Support » Allgemeine Fragen » Bild upload

  • Hallo
    ich habe ein ungelöstes Problem mit dem Bild-Upload. Aus diesem Grund habe ich WordPress von Grund auf neu hochgeladen. Der Speicherplatz ist laut Host mit 250MB gross genug.Trotzdem erhalte ich beim hochladen der Bilder nur zerbrochene Bildsymbole. Was kann das Problem sein?
    Danke für Eure Hilfe!
    Susanne

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • WordPress verschiebt Bilder beim Upload nicht nur in ein Verzeichnis, sondern erstellt außerdem auch noch verschiedene Bildgrößen. Dazu werden die Bilder Pixel für Pixel eingelesen, was bei Bildern mit einer hohen Auflösung viel Arbeitsspeicher (RAM, nicht Festplatten-Platz) verbraucht. Klappt das Einlesen nicht, werden nur zerbrochene Bildsymbole angezeigt.

    Schau mal, ob du im Kundenmenü deines Webhoster den Arbeitsspeicher hochsetzen kannst. Manchmal klappt das auch wie hier beschrieben. Unter Umständen musst du bei deinem Webhoster auch einfach ein Webhosting-Paket mit mehr Arbeitsspeicher beauftragen. Das sollte nicht so viel mehr kosten – sprich mal mit dem Support.

    Hallo Mario
    Danke für die promte Antwort. Leider nützt alles nichts. Wenn ich die Zeile bei der htaccess Datei einfüge, bekomme ich die Fehlermeldung 500 und der Host meint, ich hätte schon genügend Speicher. Ich hab auch nur kleine Bilder versucht hochzuladen, leider geht es nicht…
    beste Grüsse Susanne

    Wieviel Arbeitsspeicher soll den „genügend Speicher“ sein?
    Installiere und aktiviere doch mal das Plugin Server IP & Memory Usage und schau dann in der Fußleiste nach, wieviel du tatsächlich hast.

    Danke!
    Folgendes wird angezeigt

    <:Memory: 16 of 100 MB (16%) | WP LIMIT: 40 MB | IP 134.119.224.38 (m27s20-6-39db.ispgateway.de) | PHP 5.4.45 @32BitOS

    Kann ich daraus schliessen, dass ich für diese Site 40MB zur Verfügung habe und 16% schon gebraucht sind (habe noch nichts hochgeladen ausser ein kleines Bild)?
    Die Dame vom Host Service hat mir 250MB angegeben. Wohl für beide meiner Websits….
    Beste Grüsse Susanne

    • Diese Antwort wurde geändert vor 2 Jahre, 12 Monaten von farbkonzept.

    Computer haben Festplatten, um Dateien zu speichern. Das nennt man Festplattenspeicher. 250 MB Festplattenspeicher sind nicht viel, aber WordPress selbst braucht davon nur rund 27 MB.

    Dann haben Computer auch noch Arbeitsspeicher. Darin werden flüchtige Daten, die bei der Bearbeitung von Dateien anfallen, zwischengespeichert. Die Daten sind im Gegensatz zu Dateien auf Festplatten nicht dauerhaft gespeichert, sondern gehen beim Ausschalten des Computers verloren.

    Wenn du Bilder hochlädst, wird jedes Pixel in den Arbeitsspeicher geladen. Die 100MB Arbeitsspeicher reichen dann eben nicht. Ergebnis ist, dass die Bilder nicht in verschiedene Größen umgerechnet werden können.

    Was hast du dir denn da für einen Webhoster ausgesucht? PHP 5.4 ist reichlich veraltet, ein 32bit-Betriebssystem auch nicht ideal und 250MB sind sehr wenig Festplattenspeicher. Da bekomme ich schon für ein paar Euro im Jahr deutlich bessere Angebote.

    Herzlichen Dank für die Antwort. Ich werde mich um die nötige Anpassungen kümmern.
    Der Host ist Switchplus.ch
    Beste Grüsse Susanne

    Unterdessen konnte ich die Werte wie folgt anpassen. Die Bilder werden immer noch als zerbrochene Symbole angezeigt. Bei meiner zweiten Website klappt es jedoch seit immer, obwohl ich dort die selben Bedingungen desselben Hosts habe. Nach wie vor stehe ich vor einem Rätsel.
    | Memory: 20 of 300 MB (7%) | WP LIMIT: 40 MB | IP 134.119.224.38 (m27s20-6-39db.ispgateway.de) | PHP 7.0.13 @32BitOS Version 4.8

    Beste Grüsse Susanne

    Schau mal in der Konfigurationsdatei wp-config.php, ob da ein Wert für den zugewiesenen Speicher definiert ist:
    define( 'WP_MEMORY_LIMIT', '256M' );

    falls nicht, trag diese Zeile mal oberhalb von /* That's all, stop editing! Happy blogging. */ ein.

    Wenn das nicht hilft, prüfe bitte mal die Benutzerrechte. Sind die Benutzer, denen die Dateien zugewiesen sind, in beiden WordPress-Installationen identisch?

    Das Memory konnte ich anpassen. Welche Benutzerrechte? wo genau? Unter Benutzer? Mein Profil ist bei beiden Sites authentisch. Leider geht immer noch nichts…Schon mal vielen dank für die Mühe!!

    @farbkonzept

    Deine Frage ist jetzt als ‚gelöst‘ markiert – hast du eine Lösung gefunden? Welche?

    Die Sache ist noch nicht gelöst. Leider funktioniert der Bild upload noch nicht.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „Bild upload“ ist für neue Antworten geschlossen.