Support » Allgemeine Fragen » Bilder werden in Safari nicht angezeigt

  • Gelöst kulturproleten

    (@kulturproleten)


    Guten Tag,

    ich habe das Problem, dass in meiner WP-Installation generell Bilder in Safari nicht angezeigt werden, weder im Frontend noch im Backend. Cache löschen, Neustart etc hab ich alles schon ausprobiert. Auf einem ipad mit safari ist es dasselbe Problem.

    Ich habe mittlerweile rausgefunden, dass von irgendwo ein paar Zeichen in die Bild-Url einfügt werden und dann die URL nicht mehr stimmt. Das sieht konkret so aus:
    http://www.kulturproleten.de%09/wp-content/uploads/xxxx

    Ich nehme an, dass das WordPress da irgendwo pfuscht. Ich bin zwar interessiert aber dennoch ein Laie – kann sich irgendjemand darauf einen Reim machen?
    Vielen Dank für eure Hilfe,
    lg kulturprolet

    edit: ah, natürlich habe ich auch schon auf die Dateinamen geguckt, die sind auch in Ordnung, also ohne Sonderzeichen u.ä.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Edi

    (@psychosopher)

    Da ist ein Leerschlag dazwischengeraten, beispielsweise:

    http://www.kulturproleten.de /wp-content/uploads/2015/08/dummedeuschtesvolk-310×174.jpg

    Andere Browser sind offensichtlich nachsichtiger als Safari. Wie sieht der Code denn in den Beiträgen aus? Wie werden die Bilder eingegfügt.

    Thread-Starter kulturproleten

    (@kulturproleten)

    Das Problem besteht immer, also auch wenn man sich die Medienübersicht anzeigen will, bspw. Die Bilder sind über die „Artikelbild“-Funktion eingebunden.
    Und bei mir ist anstatt dem Leerschlag besagtes %09 zu sehen.

    Edi

    (@psychosopher)

    %09 ist ein Tab. Schau einmal, ob das irgendwo aus Versehen nach der Domain hereingerutscht ist (beispielsweise durch Kopieren und Einsetzen). Beispielsweise unter „Einstellungen“ > „Allgemein“ (was allerdings nicht sehr wahrscheinlich ist, weil dann die ganze Installation nicht mehr richtig funktionieren würde) oder bei der Domainkonfiguration.

    Thread-Starter kulturproleten

    (@kulturproleten)

    Nope, das löst das leider alles nicht.
    Was meinst du mit Domainkonfiguration? Ich habe bei meinem webserver auch nochmal die Domain und das Verzeichnis kontrolliert, da ist auch nichts zuviel..

    Thread-Starter kulturproleten

    (@kulturproleten)

    Liebe WP-Community,

    bevor ich aufgebe und alles platt mache und neu installiere würde ich gerne noch einmal nachfragen: Gibt es jemanden der eine Idee zur Lösung dieses Problems hat?

    viele Grüße
    kp

    Thread-Starter kulturproleten

    (@kulturproleten)

    Ich habs!

    Das Problem war, das mir bei der wp-config.php nach der URL-Angabe define('WP_SITEURL', 'http://www.dieseurl.de'); ein Tab reingerutscht ist. Warum alles andere außer den wp-content – Sachen funktioniert hat, wird mir trotzdem ein Rätsel bleiben – aber egal 😉

    Trotzdem danke, Edi

    Lg

    Hat Edi doch vorher schon gesagt?

    %09 ist ein Tab. Schau einmal, ob das irgendwo aus Versehen nach der Domain hereingerutscht ist (beispielsweise durch Kopieren und Einsetzen).

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Bilder werden in Safari nicht angezeigt“ ist für neue Antworten geschlossen.