Support » Allgemeine Fragen » Bilddarstellung auf mobilen Geräten mit hoher Auflösung

  • Die Darstellung der Internetseite ist einwandfrei auf Computern und iPhones. Dagegen wird die Seite auf neuen, hochauflösenden Pads nicht richtig angezeigt. Die Hintergrundbilder werden so groß dargestellt, dass sie nicht erkennbar sind. Beim runter scrollen ist ein einziges Bild richtig sichtbar, alle darüber und darunter nicht. Die Einstellungen aller Bilder sind aber gleich. Alle Hintergrundbilder sind fixiert, wodurch ich den Parallax-Effekt erreicht habe. Die Seite ist mit OceanWP (keine Pro Version) und Elementor (keine Pro Version) erstellt.

    Was kann ich tun, damit die Seite richtig dargestellt wird?

    • Dieses Thema wurde geändert vor 2 Monaten, 1 Woche von freymind.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)
  • hmm seltsam, mir wird hier aber als Theme „twentyseventeen“ angezeigt, wenn ich mir die Seite ansehe 🤔
    Oder hast du zwischenzeitlich mal das Theme gewechselt?

    Thread-Ersteller freymind

    (@freymind)

    Ja, habe ich, ich hatte mit mehreren Themen versucht den Fehler zu umgehen, leider erfolglos.

    Offensichtlich hast du mit dem aktuell verwendeten Theme die Probleme nicht und deine Beschreibung „Dagegen wird die Seite auf neuen, hochauflösenden Pads nicht richtig angezeigt.“ müsste vielmehr lauten „Dagegen würde die Seite auf neuen, hochauflösenden Pads nicht richtig angezeigt, wenn ich das Theme OceanWP nutzen würde.“

    „Hätte, hätte, Fahrradkette“ – so lässt sich das kaum nachvollziehen. Aktivier doch bitte mal wieder OceanWP, mach einen Screenshot von einer Seite die nicht richtig angezeigt wird, lad sie bei einem Bilderdienst hoch und teile hier den Link, damit wir eine Vorstellung bekommen, was du meinst. Optimal wäre, wenn wir dann noch eine URL zur betroffenen Seite bekommen, um uns selber einen Eindruck zu verschaffen.

    Hilfreiche FAQ-Beiträge dazu:

    Wie kann man hier Bilder in einen Forenbeitrag einfügen?
    Warum ein Link zu deiner Website wichtig ist

    Übrigens definieren die meisten Theme eigene Bildgrößen, um Bilder optimal einzubinden. Diese Bildgröße greift aber nur für Fotos, die du nach der Aktivierung des Themes hochlädst, während bereits vorhandene und skalierte Fotos davon unberührt bleiben. Das könnte erklären, wieso die Bilder nicht optimal zum Theme passen.

    Auf Youtube gibt es wirklich gut gemachte Tutorials, bei denen die Verwendung von OceanWP und dem Page-Builder-Plugin Elementor gezeigt wird. Mir ist klar dass sich viele Anwender/-innen daran orientieren. Das ist aber nicht der einzige Weg, mit WordPress neue Websites zu erstellen.
    Ich kann deine Kenntnisse nicht beurteilen, aber besonders Einsteigern würde ich zunächst empfehlen, eine Website ohne einen zusätzlichen Page-Builder zu erstellen. Elementor bietet zwar tolle Einstellungsmöglichkeiten, aber darin kann man sich auch ganz schön verheddern und dann lange damit aufhalten, Fehler zu suchen. Die Gefahr sehe ich beim eingebauten Block-Editor nicht so sehr.

    Thread-Ersteller freymind

    (@freymind)

    1.) Doch, genau mit diesem Thema OceanWP, wie auch mit ALLEN anderen, habe ich das gleiche Problem AKTUELL.
    2.) Ich habe nur ein einziges Thema installiert, Ocean WP, welches dem zur Folge auch aktiv ist.
    3.) Den gleichen Fehler konnte ich auf jeder neu installierten Seite, egal ob mit OceanWP oder einem anderen Thema und auch mit Gutenberg genauso wie mit Elementor nachstellen.

    Ich war im nächstgelegenen Mediamarkt meines Vertrauens und habe mir die Internetseite https://mindtuner.de auf allen dort angebotenen Geräten angesehen:

    4.) Handy hochkant, Apple, Samsung, Huawei usw.: die Seite wird einwandfrei im Handymodus angezeigt. KEIN PROBLEM
    5.) Mac, PC, ChromeBooks, Notebooks: die Seite wird einwandfrei im PC-Modus angezeigt, der Parallax Effekt funktioniert einwandfrei; es ist dabei unwichtig welcher Browser verwendet werden, alle funktionieren zuverlässig gleich. KEIN PROBLEM
    6.) Tablets und Hybride aus Tablets und PC, Apple, Samsung, Huawei, Microsoft: Viele Geräte zeigen die Seite einwandfrei im Tabletmodus an. KEIN PROBLEM
    7.) Tablets und Hybride aus Tablets und PC, Apple, Samsung, Huawei, Microsoft – ‚pro Geräte‘: die ‚pro‘ Geräte mit hoher Auflösung stellen die mobile Seite völlig falsch dar, wie oben beschrieben; wohlgemerkt, es sind gerade die Flaggschiffe der Hersteller, die die Seiten mit ihren Browsern nicht richtig darstellen. PROBLEM

    Wer ein AKTUELLES hochauflösendes Tablet hat kann sofort nachschauen, Fotostrecke folgt.

    Schön, jetzt ist OceanWP wieder aktiv. Ich weiß trotzdem nicht, auf was du dich beziehst. Aber die Screenshots sollen ja noch kommen …

    Du solltest immer zusätzlich ein (Nicht-Standard-)Theme installieren. Wenn du zumindest ein Standard-Theme („Twenty …“) installiert hast, reicht es be einem solchen Fehler, das Theme-Verzeichnis umzubenennen, um auf das Standard-Theme zurückzufallen. Das hat aber nichts mit deinem Problem zu tun.

    Thread-Ersteller freymind

    (@freymind)

    OceanWP ist seit mindestens einem Monat durchgehend aktiv. Hier mein erster Versuch Bilder in diesem Forum verlinkt dazu einzustellen.

    Dreimal die gleiche Anzeige:

    Anzeige PC richtig:

    https://www.minpic.de//o/c3hv/jz2tx/
    (zum Anzeigen anklicken)

    Anzeige iPad richtig:

    https://www.minpic.de//o/c3ht/acqeo/
    (zum Anzeigen anklicken)

    Anzeige iPad falsch:

    https://www.minpic.de//o/c3hu/195juo/
    (zum Anzeigen anklicken)

    • Diese Antwort wurde geändert vor 2 Monaten, 1 Woche von Bego Mario Garde.
    • Diese Antwort wurde geändert vor 2 Monaten, 1 Woche von Bego Mario Garde. Grund: Bilder-Links bearbeitet
    • Diese Antwort wurde geändert vor 2 Monaten, 1 Woche von Bego Mario Garde.

    Ab und zu hilft übrigens auch ein Blick in die FAQ:

    Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    Thread-Ersteller freymind

    (@freymind)

    Hab ich, aber offensichtlich verstehe ich das nicht.

    Dein ausgewählter Bilder-Dienst erlaubt scheinbar kein Hotlinking der Fotos. Ich habe jetzt nur die Links eingefügt. Wieso der Hintergrund auf bestimmten Geräten nicht angezeigt wird, kann ich dir nicht sagen – mir wird das Hintergrundbild auf einem MacBook mit retina-Display normal angezeigt. Am besten fragst du mal im Supportforum des Plugins Elementor nach.

    Thread-Ersteller freymind

    (@freymind)

    Danke für die Antwort, aber das bringt mir nichts bei Elementor nachzufragen, da das gleiche Problem wie beschrieben auch mit Gutenberg besteht. Da das Problem auch unabhängig vom Thema ist, handelt es sich um ein echtes WP-Problem, oder um ein Problem von sämtlichen mobilen Browsern bei HigEnd-Pads; ich denke, dass ich hier richtig bin.

    Thread-Ersteller freymind

    (@freymind)

    Ach, und der Bilderdienst war der erste, den ich durch Bing gefunden habe, ich würde ihn jetzt auch nicht so richtig weiterempfehlen…

    Da das Problem auch unabhängig vom Thema ist, handelt es sich um ein echtes WP-Problem …

    Das kann ich nicht beurteilen, weil ich nicht weiß, wie die gleiche Webseite bei Verwendung eines anderen Themes und ohne Elementor aussieht. Ich kann nicht einmal den genannten Fehler reproduzieren. Was meinst du mit „ein Problem von sämtlichen mobilen Browsern bei HigEnd-Pads“ – wieviele hast du auf welchen Geräten ausprobiert?

    … ich denke, dass ich hier richtig bin

    Mag sein. Schauen wir mal, wer sich mit Ideen dazu meldet?
    Mein Hinweis auf das Supportforum des Plugins war nur als freundlicher Tipp gemeint.

    Thread-Ersteller freymind

    (@freymind)

    Wie bereits beschrieben:

    1.) sieht die Seite mit jedem anderen Thema genauso aus, ich habe mindestens 8 verschiedene Themen ausprobiert
    2.) sieht die Seite mit drei verschiedenen Editoren nicht anders aus
    3.) getestete Browser Chrome, Edge, Safari, Brave

    Wie viele verschiedene Geräte je nachfolgend aufgelisteter Geräteklasse ich getestet habe kann ich nicht sagen, mindestens aber 4 MACs, 5 PCs, 5 ChromeBooks, 15 NoteBooks, 30 Handys inkl. iPhone, 15 Pads inkl. iPad, 7 Pads der ‚Pro‘-Klasse inkl. iPad Pro, 3 hybride Pad-PCs:

    4.) funktionstüchtig auf getesteten PCs, MACs, ChromeBooks und Notebooks im Saturn und älteren Geräten zu Hause und bei Freunden
    4.) funktionstüchtig mit mobiler Seite auf getesteten Handys aller im Saturn vorhandenen Hersteller
    5. funktionstüchtig auf Pads von Apple, Samsung, Huawai im unteren bis mittleren Preissegment

    6.) NICHT FUNKTIONSTÜCHTIG auf den aktuellen iPad Pro und den teuersten Pads von Microsoft, Samsung und Huawai und Microsoft.
    7.) NICHT FUNKTIONSTÜCHTIG auf den Hybriden Pad/NoteBook Modellen von Microsoft

    Ich danke auch für den Hinweis auf das Forum des Plugins, glaub aber nach wie vor, dass ich hier richtig bin. Meine Vermutung geht in Richtung WP und mobile Browser. Bei den hohen Auflösungen der teuren Pads könnte ich mir vorstellen, dass die hochauflösenden Pads gern die Desktopseite darstellen wollen; andererseits werden Funktionen der Desktopseite zum Energiesparen auf mobilen Geräten abgeschaltet; im Ergebnis stellen die Pads z.B. alle keinen Parallax Effekt dar; ich könnte mir vorstellen, dass in diesem Zusammenhang auch die Auflösung der Hintergrundbilder, die ja wesentliche Bestandteile einer parallaxen Darstellung sind, versehentlich nicht berücksichtigt werden. Mit steigender Zahl von hochauflösenden Pads würde dies in Zukunft sehr viele WP-Seiten betreffen.

    Wie bereits beschrieben:
    1.) sieht die Seite mit jedem anderen Thema genauso aus, ich habe mindestens 8 verschiedene Themen ausprobiert
    2.) sieht die Seite mit drei verschiedenen Editoren nicht anders aus

    Schon OK, mag alles sein, nur kann ich mir das eben nicht ansehen. Ich müsste die Webseite nachbauen und dann unter diesen verschiedenen Konstellationen testen. Für kostenlosen Support ist mir das zuviel Aufwand. Mag auch sein, dass es sich um einen (mir bisher nicht bekannten) Fehler in WordPress handelt … alles möglich. Und nun? 🙂

    Viel Erfolg bei der Lösung.

    Thread-Ersteller freymind

    (@freymind)

    Es ist mir gelungen mit kostenfreien Versionen von wunderbarer Software eine Internetseite mit Parallax Effekt zu erstellen die so komplex ist, dass der Aufwand zu hoch für ein Support Forum ist. Na dann erst einmal mal Danke für diesen Ritterschlag 🙂

    Auf meiner Suche nach einer Lösung habe ich in verschiedenen internationalen Foren von vergleichbaren Problemen gelesen. Immer war es die Darstellung von Hintergrundbildern auf hochauflösenden Pads. In all diesen Foren hatte aber keine eine Antwort erhalten. So beschloss ich das Problem in dem Forum zu veröffentlichen, welches am nächsten an WP dran ist – also genau hier. Auf die völlig berechtigte Frage „und nun?“ antworte ich freudig, dass ich auf dieses Forum gespannt bin. Mal schauen ob schon jemand anderes auf dasselbe Problem gestoßen ist – und es lösen konnte.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 16)