Support » WooCommerce » Bilder in Artikelübersicht haben kleinere Größe nach WooCommerce Update

  • had53

    (@had53)


    Hallo WP-Comunity,
    in unserem E-Shop mit fast 6.000 Artikeln habe ich neulich festgestellt, dass nach einem Import von neuen Artikeln die neuen Bilder in Produktübersicht kleiner sind als die bestehenden.
    Ich halte unseren Shop immer auf dem neuesten Stand (Plugins, Theme, alles Free-Versionen), vorher teste ich auf einer Parallel-Installation. Diese Problematik ist mir aber aufgefallen erst bei ‚gemischten‘ Artikeln – siehe Link.
    Die mögliche Quelle von diesem Verhalten versuchte ich auf einer Testinstallation zu identifizieren, wo noch ältere Plugins aktiv waren, die das Problem verursacht haben könnten. Nach und nach habe ich die Plugins upgedatet und dazwischen immer ein Produkt eingespielt
    1. Product Import Export for WooCommerce (WebToffee) – OK
    2. OceanWP Theme – OK
    3. Essential Addons for Elementor – OK
    4. Elementor – OK
    5. Ocean Extra – OK
    6. WooCommerce 6.8.2 – NOK (das frisch importierte Bild ist kleiner geworden)
    Mein Problem ist die Ungleichheit der Darstellung, nicht der neue Look, der gefällt mir eigentlich besser.
    Ich bin auf der Suche nach einer Möglichkeit, die bestehenden Artikel auf das neue Aussehen zu bringen, ohne den Shop mit allen Artikeln komplett neu zu bespielen (dauert ca. 1 Tag, wenn’s glatt läuft). Als Alternative ist das ‚alte‘ Verhalten für neue Artikel denkbar.
    Da ich von Google und Recherche in FAQ keine Antwort bekommen habe, erhoffe ich mir Hilfe von den Experten hier.
    Besten Dank im Voraus
    Arno

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 16 bis 19 (von insgesamt 19)
  • Thread-Starter had53

    (@had53)

    Nachtrag:
    Auf einem Testsystem, wo es unterschiedliche Darstellungen gab, habe ich Downgrade auf WooCommerce 6.3.1 durchgeführt, die Produkt-Bilder waren sofort einheitlich, und zwar ‚groß‘. Das Update zurück auf die Version 6.8.2 ergab keine Änderung, allerdings nach dem Produkt-Import sind die neuen Bilder ‚klein‘ dargestellt (URL und Bildname gekürzt):

    Original größere Darstelung:
    <img src=".../wp-content/uploads/19412414-k-267x334.jpg"
    class="woo-entry-image-main" alt="Meilenweit...2414" loading="lazy"
    itemprop="image" width="267" height="334">
    
    Neue kleinere Darstelung:
    <img src=".../wp-content/uploads/19412415-k.jpg"
    class="woo-entry-image-main" alt="Meilenweit...2415" loading="lazy"
    itemprop="image" srcset=".../wp-content/uploads/19412415-k.jpg 1280w,
    .../wp-content/uploads/19412415-k-100x100.jpg 100w,
    .../wp-content/uploads/19412415-k-503x503.jpg 503w,
    .../wp-content/uploads/19412415-k-300x300.jpg 300w,
    .../wp-content/uploads/19412415-k-1024x1024.jpg 1024w,
    .../wp-content/uploads/19412415-k-150x150.jpg 150w,
    .../wp-content/uploads/19412415-k-768x768.jpg 768w,
    .../wp-content/uploads/19412415-k-600x600.jpg 600w"
    sizes="(max-width: 1280px) 100vw, 1280px" width="1280" height="1280">

    Ist es eine mögliche Zwischenlösung bis WC-Update kommt, nach jedem Neu-Import die Version runter und wieder hoch zu setzen? Spricht etwas dagegen?

    Viele Grüße
    Arno

    Moderator espiat

    (@espiat)

    Was sofort auffällt, ist das da eben das srcset kommt, was aber gut ist.

    Aber was mich stutzig macht, ist der Teil:

    Von
    width=“267″ height=“334″
    auf
    width=“1280″ height=“1280″

    Hast du nach dem Update auch mal gecheeckt, ob die Werte in den Einstellungen noch da sind?
    Das scheint nämlich nicht der Fall.

    Scrset sind auch ganz schön viele.

    Um es einmal vorweg zu sagen:
    Das ist wirklich sehr spezifisch, vor allem wegen dem import.

    Hast du mal probiert Produkte aus dem Backend anzulegen?
    Wenn das reibungslos funktioniert, dann liegt es am Import.

    Welche Woo Version funktioniert den einwandfrei?

    Thread-Starter had53

    (@had53)

    Habe jetzt ein Produkt manuell im Backend angelegt, das Ergebnis ist wie beim Import, nämlich ‚klein‘. Srcset hat folgende Abmessungen:

    ...2417-k-100x100.jpg
    ...2417-k-1024x1024.jpg
    ...2417-k-1200x700.jpg
    ...2417-k-150x150.jpg
    ...2417-k-267x334.jpg
    ...2417-k-300x300.jpg
    ...2417-k-350x100.jpg
    ...2417-k-503x503.jpg
    ...2417-k-600x600.jpg
    ...2417-k-768x768.jpg
    ...2417-k-800x450.jpg
    ...2417-k.jpg

    Die Werte im Customizer (wenn du das meinst) sind gesetzt und vor dem Erzeugen des Testprodukts habe ich sie nochmal gespeichert.
    Ich habe mit der Woo-Version 6.3.1 getestet, nach der Installation waren die Bilder die alten. Ich hole mir noch ein paar der Vorgängerinen von 6.8.2 und werde testen, ab wann dieser Bruch kommt und melde mich.
    Vielen Dank,
    Arno

    Thread-Starter had53

    (@had53)

    So, jetzt habe ich die verfügbaren Woo-Versionen rückwerts beginnend mit 6.8.1 nach und nach installiert und jeweils ein Produkt manuell erstellt. Zwischen der 6.8.0 und 6.7.0 hat sich das Verhalten was die Bilder betrifft geändert. Nach der Installation von 6.7.0 wurden alle Bilder auf dem ‚Originalstand‘, auch bei dem dann neu erzeugten Artikel (Test-20-670).
    Für mich schaut’s nach einer Änderung in WooCommerce 6.8, die dieses Verhalten verursacht.

Ansicht von 4 Antworten - 16 bis 19 (von insgesamt 19)