Support » Allgemeine Fragen » Bilder laden nicht mehr nach update auf 5.9.3

  • Gelöst jh-photo

    (@jh-photo)


    Hallo liebe WP Gemeinde,

    nachdem ich mehrere Stunden die Suche bemüht habe, konnte ich meinen Fehler nicht finden.

    Mein Problem: Vor dem UPDATE war die Seite völlig ok, nach dem UPDATE auf 5.9.3 zeigt die Seite keine Fehler mehr an.

    Den größten Knaller den ich gelesen habe, prüfe die Internetleitung 😉

    Naja. Ich habe ein SSL Server Test gemacht. Alles Grade A.

    Unter Medien – Medienübersicht sind alle Bilder vorhanden.

    Nur sind Sie nach dem update weg. Als wenn sich der Pfad geändert hätte. Aber der ändert sich doch nicht einfach so ?

    Gebe ich die einzelne Adresse eines Fotos an, so wird dieses auch geladen.
    Link aus der Gallery. z.B. https://fotostudio-marl.de/wp-content/uploads/2019/10/Event_fotografie_Fotostudio_Marl_002.jpg

    Hier waren z.B. auch Fotos zu sehen, auf die man klicken konnte, um in die nächste Gallery des Bereichs zu kommen.

    https://fotostudio-marl.de/gallery/

    Alles Bilder und Links sind weg.

    Hat jemand einen Rat für mich ? Bin ziemlich am Ende.
    Da steckt ein halbes Jahr Arbeit in der Seite.

    Liebe Grüße und Danke
    JH

    P.S.: In meinen THEME OPTIONS ist das LOGO der Startseite z.B. sichtbar. Auf der Startseite nicht. schaue ich mir den Seitencode an, finde ich zwar das Wort LOGO, aber irgendwie Höhe Breite mit 0 angegeben und SRC unbekannt. Keine Ahnung ob das normal ist. Ich würde sagen nein. Hat das was mit diesen neuen Blöcken zu tun ?

    Auch in meinen Seiten ist alles korrekt da. Also wenn ich unter Seiten gehe, bearbeiten usw. Es wird nur nicht mehr angezeigt, egal auf welchem Geräte ich die Seiten lade 🙁

    Die Links im Seitenquelltext sind korrekt vorhanden und werden angezeigt, wenn ich sie rauskopiere und einzeln starte. Bilder sind da.

    • Dieses Thema wurde geändert vor 7 Monaten, 3 Wochen von jh-photo.
    • Dieses Thema wurde geändert vor 7 Monaten, 3 Wochen von jh-photo.
    • Dieses Thema wurde geändert vor 7 Monaten, 3 Wochen von jh-photo.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Hallo,
    die Galerie unter https://fotostudio-marl.de/gallery/ kann ich durchaus sehen. Zunächst habe ich auch die Bilder bei Klick auf dem ersten Foto gesehen. Das hat danach aber seltsamerweise nicht immer funktioniert.

    Hast du dann auch mal den Browsercache geleert und/oder einen anderen Browser zum Testen genutzt und/oder das im Inkognito-Modus z. B. von Chrome getestet? (bei Chrome oben die drei senkrechten Punkte und dann „Neues Inkognito-Fenster“) und auch mal die Cookies löschen.

    Wir können dir bei gekauften Themes (hier: Uncode) oder Plugins so gut wie gar nicht helfen, weil sie uns nicht zur Verfügung stehen. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter jh-photo

    (@jh-photo)

    Hallo Hans-Gerd,

    vielen vielen Dank erst einmal das Du Dir überhaupt die Mühe gemacht hast um reinzuschauen.

    Ich bin völlig perplex als Du heute Morgen geschrieben hast, dass bei Dir die Gallery ging.

    Ich habe es gestern Nacht noch auf Handys und anderen Browser probiert. Ohne Erfolg.
    Heute Morgen komischerweise werden wieder Bilder angezeigt, aber ebenfalls nicht korrekt !

    Die Gallery funktioniert z.B. aber das Hintergrundbild ist nur , so sieht die Qualität aus, von einem Thumbnail geladen und vergrößert. Das müsste sonst glasklar sein.

    Ja, Envato „Uncode“ habe ich schon angeschrieben.
    Kein Feedback trotz bestehender Lizenz. Ich werde kein Envato mehr erwerben.
    War halt praktisch, weil es die ersten waren, wo die Themes ohne großen Aufwand auch auf Mobilgeräten liefen und man Anpassungsmöglichkeiten hatte.

    Meine Vermutung ist, dass es an diesen neuen „Blöcken“ liegt ?

    Nach der Installation habe ich die Erneuerungen gesehen, dass jetzt alles in Blöcken gemacht wird ?

    Ich weiss, dass Ihr das kostenlos macht. Ich bin ja genauso gestrickt wie Ihr und mich haben sooo viele angeschrieben, wie es funktioniert das man Bilder als Links hat.

    Ich pflege auch ehrenamtlich weitere Webseiten wie z.B. einen Kindergarten und eine IT Firma für gemeinnützige Zwecke. Dort haben die Updates auf 5.9.3 keine Probleme bereitet.

    Den Bericht lese ich jetzt aus.

    Viele Grüße und Danke
    Jens

    
    ### wp-core ###
    
    version: 5.9.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl
    wordpress_size: 50,94 MB (53414895 bytes)
    uploads_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/uploads
    uploads_size: 104,56 MB (109642505 bytes)
    themes_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/themes
    themes_size: 53,05 MB (55622972 bytes)
    plugins_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/plugins
    plugins_size: 69,19 MB (72546583 bytes)
    database_size: 5,23 MB (5488640 bytes)
    total_size: 282,97 MB (296715595 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Uncode Child (uncode-child)
    version: 1.0.0
    author: Undsgn™
    author_website: http://www.undsgn.com
    parent_theme: Uncode (uncode)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-background, infinite-scroll, widgets
    theme_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/themes/uncode-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Uncode (uncode)
    version: 1.7.6.1
    author: Undsgn
    author_website: http://www.undsgn.com
    theme_path: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/themes/uncode
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (6) ###
    
    Twenty Nineteen: version: 1.4, author: WordPress-Team (latest version: 2.2), Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.2, author: WordPress-Team (latest version: 2.9), Automatische Aktualisierungen deaktiviert
    Twenty Sixteen: version: 2.0, author: WordPress-Team (latest version: 2.6), Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.5, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (11) ###
    
    Analytics Germanized for Google Analytics: version: 1.6.1, author: Pascal Bajorat, Automatische Aktualisierungen deaktiviert
    Breeze: version: 2.0.2, author: Cloudways, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.1.9, author: Takayuki Miyoshi (latest version: 5.5.6), Automatische Aktualisierungen deaktiviert
    Google XML Sitemaps: version: 4.1.0, author: Arne Brachhold, Automatische Aktualisierungen deaktiviert
    LayerSlider WP: version: 6.7.1, author: Kreatura Media (latest version: 7.1.4), Automatische Aktualisierungen deaktiviert
    Simply Schedule Appointments: version: 1.5.5.2, author: N Squared, Automatische Aktualisierungen deaktiviert
    Slider Revolution: version: 5.4.7.1, author: ThemePunch, Automatische Aktualisierungen deaktiviert
    Uncode Core: version: 1.5.3, author: Undsgn, Automatische Aktualisierungen deaktiviert
    Uncode Page Builder (Visual Composer): version: 5.4.7, author: Michael M - WPBakery.com (latest version: 6.8.0), Automatische Aktualisierungen deaktiviert
    Visual Composer Clipboard: version: 4.1.1, author: bitorbit, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Post SMTP: version: 2.0.25, author: Post SMTP, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-10 Q16 x86_64 2021-04-29 https://imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 4 GB
    	imagick::RESOURCETYPE_MEMORY: 2 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, APNG, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.53 (Unix)
    php_version: 7.4.28 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.82.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.36-log
    client_version: 5.6.45
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content
    WP_PLUGIN_DIR: /mnt/web414/b0/41/52216041/htdocs/Fotostudio-Marl/wp-content/plugins
    WP_MEMORY_LIMIT: 96M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Meine Vermutung ist, dass es an diesen neuen „Blöcken“ liegt ?

    Das kannst du herausfinden, indem du nochmal eine ältere WordPress-Version verwendest. Das Plugin Core Rollback ist da sehr hilfreich. Vorher aber ein Backup machen!

    Die Gallery funktioniert z.B. aber das Hintergrundbild ist nur , so sieht die Qualität aus, von einem Thumbnail geladen und vergrößert. Das müsste sonst glasklar sein.

    Kein Wunder – als Hintergrundbild wird wp-content/uploads/2019/09/Titelbild-fotostudio-m***l-uai-258x172.jpg verwendet und dann auf Bildschirmbreite (irgendwas um die 1300 Pixel bei meinem MacBook) verbreitert. Das muss unscharf aussehen. Wieso aber dieses Bild als Hintergrundbild verwendet wird und keine höhere Auflösung kann ich dir nicht sagen – das Theme steht mir für kostenlosen Support nicht zur Verfügung, aber das hast du ja schon mit Hans-Gerd besprochen.

    Hallo,
    du verwendest den Classic Editor und das Theme „beglückt“ dich mit dem WPBakery Page Builder. Wo das Problem ist, können wir wohl kaum feststellen – Gründe siehe oben.
    Bezogen auf das Bild auf der Seite „gallery“.
    Das Foto wird deshalb so unscharf dargestellt, weil es in einer Größe von 258 × 172 px verwendet wird.
    Viele Grüße
    Hans-Gerd

    Unsere Antworten haben sich mal wieder überschnitten, aber wir kommen zum gleichen Ergebnis.

    Thread-Starter jh-photo

    (@jh-photo)

    P.S.: Wenn Du auf die Startseite gehst

    https://fotostudio-marl.de/

    ist halt folgendes besonders auffällig.

    Wenn das Logo geladen wird, ist es nur eine Thumbnail Qualität. Es handelt sich aber original um ein hochwertiges PNG

    Das Bild da drunter, zwei weisse Bräute das Gleiche. Das Original ist ebenfalls glasklar.

    Da drunter das Bild, der Hintergrund, wird komischerweise zu 100% Qualität geladen.

    Thread-Starter jh-photo

    (@jh-photo)

    Das ist super,
    dass Ihr beide Euch einig seit. 🙂

    Zeigt die Professionalität mit der Ihr versucht zu helfen.

    Das ist auch ein Kern des Problems, dass die Bilder die Ihr seht nicht die ursprünglichen sind. Ihr habt ja viel mit Laien zu tun. Im CMS Bereich bin ich das sicherlich auch.

    Aber ich bin Fotograf und mit Pixelgrößen bin ich vertraut und würde niemals eine Datei mit geringerer Pixelgröße als das Anzeigefenster verwenden.

    Genau wie das Logo z.B.

    Warum auch immer scheint er auf einem Thumbs zu ziehen anstatt Originalbilder.

    Das mit dem CORE ROLLBACK werde ich zu Hause noch einmal testen.

    Und untypisch ist halt, was Hans-Gerd auch beobachtet hat, dass es mal geht und mal nicht.

    Thread-Starter jh-photo

    (@jh-photo)

    Also Uncode hat sich mittlerweile gemeldet und meinte mein Theme wäre super alt.

    Es kann sein, dass das nicht mit der aktuellen Version funktioniert.

    Entweder WordPress zurück oder Theme update.

    Das scheint aber komplexer zu sein, da man es nicht über das Dashboard aktualisieren kann. Ich halte Euch auf dem Laufenden.

    Ich finde deine Website jetzt nicht übermäßig komplex.

    Mit einem Theme wie GeneratePress (kostenlose Version) lässt sich das sicher rasch nachbauen. Eventuell kannst du bestehende Inhalte auch einfach übernehmen.

    „WordPress zurück“ wäre aus meiner Sicht der falsche Weg. Du willst auch nicht auf Windows 3.11 umsteigen, weil irgendein Programm nicht läuft?

    Thread-Starter jh-photo

    (@jh-photo)

    Läuft wieder !!!!

    Falls jemand ähnliche Probleme hat.

    Bei mir lag es daran, dass das alte Theme nicht mehr mit der aktuellsten WordPress Version läuft.

    Das alte wurde nicht auf das neue getestet.

    Ich habe eine Datei Envato Theme Check Plugin erhalten und dieses drüber laufen.
    Dort kam die Empfehlung zur Installation von 2 weiteren Plugins und jetzt ist alles wieder korrekt online.

    Viele Grüße
    und Danke an die beiden Moderatoren für die Unterstützung und das Teilen des Fachwissens.

    Dort kam die Empfehlung zur Installation von 2 weiteren Plugins …

    Welchen?

    Hallo,
    das hört sich aber alles eher wie eine Notlösung an.
    Ich würde an deiner Stelle doch mal über eine Themewechsel (GeneratePress kann ich übrigens genau wie Bego absolut empfehlen) nachdenken. Der Support von den Entwicklern (auch bei der gekauften Premium-Version) ist übrigens grandios. Wenn ich da mal nachfrage, erhalte ich innerhalb von maximal 24 Stunden eine fundierte Antwort. Aber auch die kostenfreie Version ist zu empfehlen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter jh-photo

    (@jh-photo)

    Uncode Core (meine Version lief nicht korrekt, da zu alt)
    und
    WPBakery Page Builder (Visual Composer) Clipboard

    Ich hatte vorher nicht die Visual Composer Version installiert, also eine ältere.

    • Diese Antwort wurde geändert vor 7 Monaten, 3 Wochen von jh-photo.
    Thread-Starter jh-photo

    (@jh-photo)

    Danke für den Tip. Ich werde mir GeneratePress mal anschauen.
    Für mich ist wichtig, dass es eine separate Verwaltung für Mobilgeräte gibt,
    da in meiner Branche vieles nur noch über das Handy geregelt wieder. Leider.
    Und ich möchte flexibel und einfach im Design bleiben ohne groß in den Style Sheets rumfummeln zu müssen..

    Ich habe bei einigen WordPress-Instanzen GeneratePress als Theme eingesetzt. Die Responsivität ist (nicht nur) bei GeneratePress, sondern bei vielen Themes, die du im WordPress Repository findest, in der Regel kein Problem.
    Die Durchführung des Relaunch einer WordPress-Webseite am Beispiel des Themes GeneratePress habe ich in dem folgenden Beitrag beschrieben.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Das Thema „Bilder laden nicht mehr nach update auf 5.9.3“ ist für neue Antworten geschlossen.