Support » Allgemeine Fragen » Bilder Upload funktioniert nicht

  • Gelöst platypusthb

    (@platypusthb)


    Hallo Liebe Community,

    ich habe seit ca. 2 Monaten folgendes Problem mit unserer WordPress Seite:

    Beim Hochladen von Bildern erscheint folgende Fehlermeldung:

    Der Server kann das Bild nicht verarbeiten. Dies kann vorkommen, wenn der Server beschäftigt ist oder nicht genug Ressourcen hat, um die Aufgabe abzuschließen. Es könnte helfen, ein kleineres Bild hochzuladen. Die maximale Größe sollte 2560 Pixel nicht überschreiten.

    Nach einer gewissen Zeit erscheint das Bild dann doch in der Mediathek, allerdings nur auf der deutschen Version der Seite, nicht aber in der Englischen.

    Ich habe es jetzt auch schon mit sehr kleinen Bildern und sehr kleinen Pixelzahlen versucht, es macht keinen Unterschied.

    Ich bin dankbar für jede Idee.

    Liebe Grüße,

    Armin

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo,
    leider fehlt aber noch der Bericht:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Siehe Bevor du ein neues Thema/Thread erstellst

    Thread-Starter platypusthb

    (@platypusthb)

    Hey,

    danke für den Hinweis! Hier der Bericht:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/23/d21869546/htdocs/platypus/games
    wordpress_size: 298,32 MB (312809457 bytes)
    uploads_path: /homepages/23/d21869546/htdocs/platypus/games/wp-content/uploads
    uploads_size: 69,95 MB (73346073 bytes)
    themes_path: /homepages/23/d21869546/htdocs/platypus/games/wp-content/themes
    themes_size: 11,33 MB (11884764 bytes)
    plugins_path: /homepages/23/d21869546/htdocs/platypus/games/wp-content/plugins
    plugins_size: 146,72 MB (153851403 bytes)
    database_size: 30,88 MB (32374784 bytes)
    total_size: 557,20 MB (584266481 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Platypus Theater (platypus-theater)
    version: undefined
    author: Anonymous
    author_website: (undefined)
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-formats, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, custom-background, editor-color-palette, editor-gradient-presets, responsive-embeds, custom-line-height, experimental-link-color, custom-spacing, custom-units, widgets
    theme_path: /homepages/23/d21869546/htdocs/platypus/games/wp-content/themes/platypus-theater
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (15) ###
    
    Advanced Custom Fields Multilingual: version: 1.10.3, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    Advanced Custom Fields PRO: version: 5.12.2, author: Delicious Brains (latest version: 5.12.3), Automatische Aktualisierungen deaktiviert
    Borlabs Cookie - Cookie Opt-in: version: 2.2.51, author: Borlabs GmbH (latest version: 2.2.54), Automatische Aktualisierungen deaktiviert
    CAPTCHA 4WP: version: 7.1.0, author: WP White Security, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.1, author: Takayuki Miyoshi (latest version: 5.6.2), Automatische Aktualisierungen deaktiviert
    Contact Form 7 Multilingual: version: 1.1.0, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    ImageMagick Sharpen Resized Images: version: 1.1.7, author: Hans van Eijsden,niwreg, Automatische Aktualisierungen deaktiviert
    Redirection for Contact Form 7: version: 2.7.0, author: Qube One, Automatische Aktualisierungen deaktiviert
    W3 Total Cache: version: 2.2.1, author: BoldGrid (latest version: 2.2.4), Automatische Aktualisierungen deaktiviert
    Wordfence Security: version: 7.5.10, author: Wordfence (latest version: 7.6.0), Automatische Aktualisierungen deaktiviert
    WPML Media: version: 2.7.0, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML Multilingual CMS: version: 4.5.8, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML String Translation: version: 3.2.1, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPS Hide Login: version: 1.9.6, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.5.1, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (4) ###
    
    Akismet Anti-Spam: version: 4.2.4, author: Automattic (latest version: 5.0), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4, author: Delicious Brains (latest version: 1.4.1), Automatische Aktualisierungen deaktiviert
    Enable jQuery Migrate Helper: version: 1.3.0, author: The WordPress Team, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/23/d21869546/htdocs/platypus/games/wp-content
    WP_PLUGIN_DIR: /homepages/23/d21869546/htdocs/platypus/games/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    in der developer console (Aufruf mit STRG+SHIFT+I bei Chrome) sieht man einige Fehler.

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.

    Wordfence Security und W3 Total Cache können – so weit ich das mitbekommen habe – auch schon mal Probleme bereiten, wobei in beiden Fällen die Deinstallation nicht unproblematisch ist, falls du das überhaupt machen möchtest. Ich persönlich setze beide Plugins nicht ein, sondern verwende andere Plugins.

    Es gibt noch weitere Dinge, die du versuchen kannst, um das Problem zu lösen (manche davon hast du ja bereits getestet):

    • überprüfe sicherheitshalber, ob sich die Dateien im Ordner uploads befinden
    • überprüfe die Fehlerprotokolle auf dem Server.
    • nenne die .htaccess um und prüfe dann, ob das Problem behoben ist (die Datei bitte vorher sichern).
    • starte z. B. Chrome im Inkognito Modus und prüfe dann, ob das Problem behoben ist.
    • versuche, die Bildgröße (hier geht es um die Anzahl der Pixel, nicht die Dateigröße) zu verringern,
    • beim Webhoster mehr Arbeitsspeicher (memory_limit) beauftragen.

    Viele Grüße
    Hans-Gerd

    Tritt das Problem auch auf wenn du ImageMagick Sharpen Resized Images deaktivierst?

    Thread-Starter platypusthb

    (@platypusthb)

    @michi91
    Ich habe das PlugIn mal deaktiviert und jetzt funktioniert es!

    Danke Euch!

    super – freut uns. Danke für die Rückmeldung und “Gelöst”-Markieren. 👍

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)