Support » Allgemeine Fragen » Bilder werden in Mediathek aber nicht auf Website angezeigt

  • Hallo in die Runde!

    Seit einiger Zeit habe ich auf meiner Website das Problem, dass plötzlich Bilder verschwinden. Welche Bilder nicht angezeigt werden, ist dabei von Gerät zu Gerät unterschiedlich, manchmal tauchen sie auch von selbst wieder auf. Ich habe es bereits mehrmals versucht, die besagten Bilder einfach neu hochzuladen – aber: In der Mediathek werden alle Bilder einwandfrei angezeigt und auch im Editor sind sie da. Ich benutze den Divi-Page-Builder und hoffe, dass meine Frage hier im Forum am richtigen Platz ist, denn bei all meinen anderen Websites, bei denen ich Divi benutzt (über unterschiedliche Benutzer) habe ich dieses Problem nicht.

    Vielen Dank schon mal im Voraus! Falls dieses Thema hier wie gesagt nicht richtig ist, probiere ich es nochmal bei Divi direkt. Ich nehme aber an, dass das Problem eher bei WordPress liegt.

    Hier ist der Bericht zum Website-Zustand:

    wp-core
    
    version: 6.2.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app
    wordpress_size: loading…
    uploads_path: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content/uploads
    uploads_size: loading…
    themes_path: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content/themes
    themes_size: loading…
    plugins_path: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content/plugins
    plugins_size: loading…
    database_size: loading…
    total_size: loading… wp-active-theme name: Divi (Divi)
    version: 4.21.1
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    parent_theme: none
    theme_features: core-block-patterns, block-templates, widgets-block-editor, custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, wp-block-styles, editor-style, widgets
    theme_path: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content/themes/Divi
    auto_update: Aktiviert wp-themes-inactive (1) Ashe: version: 2.215, author: WP Royal, Automatische Aktualisierungen aktiviert wp-mu-plugins (1) WordPress automation by Installatron: author: (undefined), version: (undefined) wp-plugins-active (6) CookieYes | GDPR Cookie Consent: version: 3.1.1, author: CookieYes, Automatische Aktualisierungen aktiviert
    Limit Login Attempts Reloaded: version: 2.25.20, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen aktiviert
    OMGF: version: 5.6.0, author: Daan from Daan.dev, Automatische Aktualisierungen aktiviert
    Strato Assistant: version: 7.3.0, author: Strato, Automatische Aktualisierungen aktiviert
    WP Armour - Honeypot Anti Spam: version: 2.1.4, author: Dnesscarkey, Automatische Aktualisierungen aktiviert
    WPS Hide Login: version: 1.9.8, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-60 Q16 x86_64 17403 https://legacy.imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 4 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 192
    imagick::RESOURCETYPE_MAP: 4 GB
    imagick::RESOURCETYPE_MEMORY: 2 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, APNG, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available wp-server server_architecture: Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.57 (Unix)
    php_version: 8.0.28 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.88.1 OpenSSL/1.1.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true wp-database extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.28
    max_allowed_packet: 67108864
    max_connections: 3000 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content
    WP_PLUGIN_DIR: /mnt/web112/d1/62/52288762/htdocs/STRATO-apps/wordpress_03/app/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Da schlägt der berüchtigte „Mixed Content“ zu. Deine Seite läuft über https, einige Bilder werden aber über http angesprochen und somit blockieren manche Browser das laden. Du könntest mit dem Plugin „Better Search Replace“ die Pfade in der Datenbank anpassen.

    Das sollte sogar ohne Plugin möglich sein, wenn du die URL in Einstellungen > Allgemein beide zunächst auf http umstellst und dann das Menü Werkzeuge > Website-Zustand aufrufst. Du solltest dort nach einer kurzen Pause einen Hinweis eingeblendet bekommen, dass du die Website auf https umstellen sollst. Hier reicht es, wenn du dann den Button anklickst.

    Thread-Starter iceland23

    (@iceland23)

    Vielen Dank erst einmal für die schnellen Antworten. Ich habe die http-Einstellungen wie genannt umgestellt und wurde auch aufgefordert, die Seite über den Button auf https umzustellen.

    Leider sind immer noch einige Bilder verschwunden – andere sind hingegen wieder aufgetaucht. Gibt es weitere Einstellungen, die ich vornehmen kann, um das Problem zu lösen? Hängt es jetzt vielleicht doch noch damit zusammen, dass einige Bilder über http, die Website nun aber unter https läuft?

    Viele Grüße!

    So wie ich das sehe, werden immer noch Bilder über http geladen, dann wirst du wohl mit einem Plugin die Einträge in der Datenbank korrigieren müssen.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Bilder werden in Mediathek aber nicht auf Website angezeigt“ ist für neue Antworten geschlossen.