Support » Allgemeine Fragen » Bilder werden nicht in der Medienübersicht angezeigt

  • Gelöst Tom

    (@tomschmitz)


    Mahlzeit Gemeinde,
    Ich wollte gerade eine neue Seite bzw. Beitrag erstellen und kann keine Bilder einbinden.
    Ich habe das Problem welches ich schon oben in der Überschrift angegeben ist.
    Die hochgeladenen Bilder werden nicht in der Medienübersicht angezeigt sondern sind nur grau hinterlegt. Siehe diesen Screenshot
    Seite und Plugins sind aktuell, nur die PHP Version ist die PHP (7.3.23)
    Woran kann es liegen?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 23)
  • Moderator Bego Mario Garde

    (@pixolin)

    Die PHP-Version wird nicht mehr mit Sicherheitsupdates versorgt und deshalb solltest du auf PHP 7.4 wechseln. Im Moment unterstützen noch nicht alle Plugins und Themes PHP 8.0 und deshalb sollte bis November 2022 die Version 7.4 verwendet werden, bis auch hier die Sicherheitsupdates auslaufen.

    Das hat aber mit hoher Wahrscheinlichkeit nichts mit deinem Problem beim Medienupload zu tun. Hier ist vor allem zu beachten, dass für den Upload einerseits die Dateigröße wichtig ist, damit der in der PHP-Konfiguration vorgegebene Wert upload_max_size nicht überschritten wird, andererseits ist aber auch die Bildauflösung ein wichtiger Faktor, weil jedes Bild (unabhänging vom Kompressionsfaktor der JPEG-Datei) pixelweise eingelesen wird. Da für jedes Pixel auch noch drei Farbwerte eingelesen werden, wird bei einer hohen Auflösung schnell der Arbeitsspeicher überschritten. Da das Bild nicht skaliert werden kann, erstellt WordPress zwar den Datenbankeintrag, speichert dann aber eine unbrauchbare Datei, die als graues Kästchen dargestellt wird. Lösung ist,

    • den zugewiesenen Arbeitsspeicher (memory_limit – RAM, nicht Festplatte) hochzusetzen, sofern das in den Kundeneinstellungen des Webhosters möglich ist,
    • mehr Arbeitsspeicher kostenpflichtig hinzuzubuchen oder
    • die Bilder bereits skaliert hochzuladen.

    Probier mal, ob du ein Bild mit einer niedrigen Auflösung hochladen kannst, z.B. https://s.w.org/style/images/about/WordPress-logotype-wmark.png

    Moderator Angelika Reisiger

    (@la-geek)

    Die PHP-Version wird nicht mehr mit Sicherheitsupdates versorgt

    „Offiziell“ wird sie nicht mehr mit Sicherheits-Updates versorgt, der Provider kann das durchaus machen, siehe dort.

    Nichts desto trotz ist die Empfehlung, ein Upgrade auf eine höhere PHP-Version vorzunehmen, absolut richtig (steht aber auch in dem Artikel).

    @tomschmitz
    Bei der Website liegt noch mehr im Argen, siehe diese Warnhinweise auf sucuri.net

    Falls dir die Tipps von Bego nicht weiterhelfen, dann vielleicht das Plugin Regenerate Thumbnails (vorher Datenbank-Sicherung und auch ein Backup des Update-Verzeichnisses erstellen). Aber die Bilder sind laut Screenshot alle nicht verknüpft, keine Ahnung, ob das tatsächlich helfen würde.

    Nachtrag:
    Wurden die Fotos denn über die Mediathek (WordPress-Backend) hochgeladen?

    Thread-Ersteller Tom

    (@tomschmitz)

    Danke für die schnelle Antwort.
    * PHP habe ich aktualisiert auf 7.3.23, die max_upload_size steht standardmäßig auf 8 MB.
    * Ich habe bei meinem Webhoster (df.eu) 25 GB gebucht und momentan sind 2,8 GB belegt.
    * Meine Bilder sind fürs Web optimiert mit max. 1200*800 px und max. 450kb
    * Und das wmark.png Bild habe ich auch hochgeladen, dieses wird aber ebenfalls nicht angezeigt.
    Oder habe ich das mit dem memory limit falsch verstanden?

    Moderator Bego Mario Garde

    (@pixolin)

    PHP habe ich aktualisiert auf 7.3.23,

    Das ist nachwievor nicht in Ordnung, weil (zumindest von offizieller Seite) keine Sicherheitsupdates mehr kommen. Ich bin mir ziemlich sicher, dass DomainFactory ein Update auf 7.4 zulässt.

    die max_upload_size steht standardmäßig auf 8 MB.

    Das ist wie gesagt nur ein Aspekt. Der andere ist, wieviel Arbeitspeicher dir zugewiesen wurde (memory_limit).

    Ich habe bei meinem Webhoster (df.eu) 25 GB gebucht und momentan sind 2,8 GB belegt.

    … und dann kannst du sicher auch noch E-Mail-Adressen einrichten. Alles toll, alles unerheblich für deine Frage. (Hast du meine Antwort eigentlich gelesen?)

    Meine Bilder sind fürs Web optimiert mit max. 1200*800 px und max. 450kb

    Hier kommen wir der Sache schon näher. Möglich, dass ein Plugin Probleme bereitet. Möglich, dass der Arbeitsspeicher sehr niedrig angesetzt ist oder du durch sehr viele Plugins viel Arbeitsspeicher (nochmal: RAM, nicht Festplatte) verbrauchst.

    Was helfen würde, ist ein Website-Bericht. 🙂

    Aus Wikipedia:

    Der Arbeitsspeicher oder Hauptspeicher (englisch core, main store, main memory, primary memory, RAM = Random Access Memory) eines Computers ist die Bezeichnung für den Speicher, der die gerade auszuführenden Programme oder Programmteile und die dabei benötigten Daten enthält.

    Hat also nichts mit der Festplatte/SSD zu tun, auf der du dauerhaft Dateien ablegst. Da Arbeitsspeicher begrenzt ist und du dir den Speicher bei einem Shared Hosting mit vielen anderen Kunden teilen musst, bekommst du vom Systemadministrator ein Kontigent zugewiesen, das so genannte memory_limit. Den Wert kannst du unter Umständen durch eine Einstellung im Kundenmenü hochsetzen, aber der Webhoster möchte aus verständlichen Gründen auch nicht, dass ein einzelner Kunde „Alles!“ ruft und die anderen Kunden leer ausgehen.

    Moderator Angelika Reisiger

    (@la-geek)

    PHP habe ich aktualisiert auf 7.3.23, die max_upload_size steht standardmäßig auf 8 MB.

    Sieh mal dort https://www.php.net/eol.php

    Wie von Bego angeraten, sollte es 7.4.x sein.

    8 MB ist wirklich enorm wenig.

    Moderator Bego Mario Garde

    (@pixolin)

    8MB für upload_max_filesize? Find ich OK. Wer will denn auf seinem Smartphone ein einzelnes Bild mit mehr als 8MB Größe anschauen? Wenn das 8MB memory_limit wären, … das wäre tatsächlich übel. 🙂

    Moderator Angelika Reisiger

    (@la-geek)

    Gilt ja nicht nur für Bilder, das kann schon bei einem PDF übel bremsen. Ich finde die ganze Server-Konfig bislang (nach Informations-Lage) sehr „eingeschränkt“.

    Aber ja, Problem hier ist vermutlich memory_limit

    Moderator Bego Mario Garde

    (@pixolin)

    Hochgeladen werden die Bilder offensichtlich (sonst gäbe es keinen Eintrag in der Datenbank), nur mit der Skalierung hapert es.

    Thread-Ersteller Tom

    (@tomschmitz)

    Oh Mann, jetzt gehts an eingemachte 🙁
    Eigentlich möchte ich die Seite ja nur nebenher betreiben wenn ich mal auf Fototour war und meine Bilder zeigen möchte und nicht um mit Programmierung der Webseite rum zu plagen.
    Zu Veranschaulichung füge ich noch ein paar Screenshots bei
    Laut diesem ist es jetzt PHP 7-73 Latest-standard
    https://abload.de/img/php15fk4x.jpg
    https://abload.de/img/php3bwkdc.jpg

    Die PHP.ini habe ich editiert von 100M auf 500M
    https://abload.de/img/php4iqjnd.jpg
    https://abload.de/img/php557jkh.jpg
    Und was die fehlenden Header Dateien angeht muß ich mal in Ruhe schauen.
    Danke für den Tip diesbezüglich.

    • Diese Antwort wurde geändert vor 4 Monaten von Tom.
    Thread-Ersteller Tom

    (@tomschmitz)

    Wenn ich eine der hochgeladenen Bilder über die URL auffrufen will bekomme ich die Fehlermeldung 403
    https://urbexscout.de/wp-content/uploads/2022/01/WordPress-logotype-wmark.png
    Die letzten Bilder habe ich im Sept.2021 hochgelden, da war noch alles OK
    https://urbexscout.de/wp-content/uploads/2021/09/Vergleich-Tele-105-an-Sony-Sigma.jpg
    Ich habe jetzt gerade mal meine Mediathek durchgesehen da sind alle Thumpnails und auch Bilder vorhanden.
    Ich glaube kaum das es an der Skalierung der Bilder liegt weil ich sie heute morgen auch schon in einem Fotoforum eingestellt wo es der Server sehr genau nimmt mit Bildergröße und Skalierung.

    • Diese Antwort wurde geändert vor 4 Monaten von Tom.
    Moderator Bego Mario Garde

    (@pixolin)

    Wenn dein Server nicht mehr als PHP 7.3 hergibt, sprich bitte mit dem Support des Webhosters. Ggf. muss man deine Website auf einen anderen Server umziehen.

    Ein memory_limit von 100 Megabyte ist eher niedrig angesetzt. 512 Megabyte wären schön, die Frage ist aber, ob dein Webserver das so akzeptiert. Wie gesagt: am liebsten möchte jeder Kunden den gesamten Arbeitsspeicher des Servers für sich in Anspruch nehmen. Dass das bei geteilten Ressource nicht möglich ist, erklärt sich von selbst.

    Hier nutzen uns aber auch die ganzen Screenshots nichts. Nochmal der Hinweis: ein Website-Bericht wäre hilfreich. Wenn du nicht weißt, was gemeint ist, lies dir nochmal den angehefteten Beitrag durch: Bevor du ein neues Thema (Thread) erstellst

    Was die Skalierung der Fotos in WordPress mit der Skalierung in einem Forum mit vermutlich ganz anderer Webanwendung und sicherlich auch anderer Konfiguration zu tun hat, erschließt sich mir nicht so ganz. Aber ich vermute auch nur, dass es wegen fehlendem Arbeitsspeicher oder einen Konflikt mit einem Plugin (dafür würde der 403-Fehler sprechen) zu den geschilderten Problemen kommt. Ohne Website-Bericht ist das alles Kaffeesatzleserei.

    Thread-Ersteller Tom

    (@tomschmitz)

    Das hat bei mir etwas gedauert aber ich habe es gefunden

    
    ### wp-core ###
    
    version: 5.8.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: undefined
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/57***_****/webseiten/wordpress/wordpress/wordpress
    wordpress_size: 47,29 MB (49585044 bytes)
    uploads_path: /kunden/57***_*****/webseiten/wordpress/wordpress/wordpress/wp-content/uploads
    uploads_size: 1,59 GB (1702133079 bytes)
    themes_path: /kunden/57***_*****/webseiten/wordpress/wordpress/wordpress/wp-content/themes
    themes_size: 6,50 MB (6813042 bytes)
    plugins_path: /kunden/57****_******/webseiten/wordpress/wordpress/wordpress/wp-content/plugins
    plugins_size: 61,23 MB (64202509 bytes)
    database_size: 10,52 MB (11033226 bytes)
    total_size: 1,71 GB (1833766900 bytes)
    
    ### wp-active-theme ###
    
    name: Photoflash (photoflash)
    version: 1.1.1
    author: Alexathemes
    author_website: https://alexathemes.net
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, post-thumbnails, title-tag, custom-logo, menus, custom-background, editor-style, custom-header, widgets
    theme_path: /kunden/******_********/webseiten/wordpress/wordpress/wordpress/wp-content/themes/photoflash
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Seos Photography: version: 1.3.0, author: SEOS - Tsvetomir Tsvetanov, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (6) ###
    
    Akismet Anti-Spam: version: 4.2.1, author: Automattic, Automatische Aktualisierungen aktiviert
    BST DSGVO Cookie: version: 1.2.9, author: BST Software (Autor: Arnold Margolf), Automatische Aktualisierungen aktiviert
    Envira Gallery Lite: version: 1.8.3.9, author: Envira Gallery Team, Automatische Aktualisierungen aktiviert
    GDPR Cookie Consent: version: 2.0.8, author: WebToffee, Automatische Aktualisierungen deaktiviert
    Shariff Wrapper: version: 4.6.7, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen aktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.1, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 8M
    max_effective_size: 8 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache
    php_version: 7.3.23
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 500M
    max_input_time: -1
    upload_max_filesize: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/******_********/webseiten/wordpress/wordpress/wordpress/wp-content
    WP_PLUGIN_DIR: /kunden/******_********/webseiten/wordpress/wordpress/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 500M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    • Diese Antwort wurde geändert vor 4 Monaten von Tom. Grund: Perönliche Daten entfernt
    • Diese Antwort wurde geändert vor 4 Monaten von Tom.
    Moderator Bego Mario Garde

    (@pixolin)

    Hm, beim Medien-Handling wird file_uploads: File uploads is turned off ausgegeben. Kannst du den Support deines Webhosters mal darauf ansprechen?

    Alternativ probier doch bitte mal, ob der Upload mit der GD-Library funktioniert. Dazu installierst du bitte das Plugin Code Snippets und fügst folgenden Code als neues Code-Snippet hinzu:

    add_filter( 'wp_image_editors', 'use_gd_library' );
    function use_gd_library() {
        return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
    }

    Schau dann mal, ob sich am Upload was ändert.

    Thread-Ersteller Tom

    (@tomschmitz)

    @pixolin
    Dankeschön, genau das hat geholfen.
    Die Bilder lassen sich jetzt hochladen und werden in der Medienübersicht angezeigt, ich kann sie mit der Envira Galerie verknüpfen und alles in die Seite einbinden.
    Das ganze schaut jetzt so aus >>>> https://urbexscout.de/?page_id=3239 <<<<
    Danke für die schnelle Hilfe, sorry das ich jetzt erst antworte weil ich noch ein wenig arbeiten mußte 🙁

    THX
    Tom

    Moderator Bego Mario Garde

    (@pixolin)

    Ich würde trotzdem nochmal den Support darauf ansprechen.

    Die GD Library bietet beim Bearbeiten von Bildern in WordPress nicht so viele Möglichkeiten, wie Imagemagick und die Qualität der Skalierung ist wohl auch geringfügig schlechter. Aber es gibt auch (nicht mal kleine) Webhoster, die Imagemagick gar nicht erst anbieten.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 23)