Support » Allgemeine Fragen » bilder werden nicht in mediathek geladen, aber nicht angezeigt.

  • Gelöst fbprovence

    (@fbprovence)


    Hallo.
    Ich bin keine PC Genie. Meine Seite läuft und die neuste Version ist installiert.
    Seit dem kann ich zwar Bilder hochladen, sie werden jedoch weder in der Vorschau noch in der Mediathek angezeigt. auch wenn ich sie auf die Seite einbinde, werdne sie nicht angezeigt. Gehe ich in der Mediathek jedoch bei einem Bild auf – bearbeiten -, wird es angezeigt. Ich habe keinerlei Space Problem bei meinem Provider oder irgend welche Daten Limits. Hat jemand eine Idee.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Geh mal bitte auf Werkzeuge > Website-Zustand > Bericht, warte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Den kannst du dann bitte hier als neue Antwort unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen.
    So erfahren wir ein bisschen mehr über deine Website und können den Fehler besser einschätzen.

    Thread-Ersteller fbprovence

    (@fbprovence)

    
    ### wp-core ###
    
    version: 5.4.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Paris
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/artworldweb.de/masauxaromes
    wordpress_size: 70,52 MB (73941877 bytes)
    uploads_path: /kunden/artworldweb.de/masauxaromes/wp-content/uploads
    uploads_size: 156,98 MB (164608477 bytes)
    themes_path: /kunden/artworldweb.de/masauxaromes/wp-content/themes
    themes_size: 18,08 MB (18956463 bytes)
    plugins_path: /kunden/artworldweb.de/masauxaromes/wp-content/plugins
    plugins_size: 68,83 MB (72169795 bytes)
    database_size: 10,05 MB (10534912 bytes)
    total_size: 324,45 MB (340211524 bytes)
    
    ### wp-active-theme ###
    
    name: Toko (toko)
    version: 1.9.1
    author: octagonwebstudio
    author_website: http://octagonwebstudio.com
    parent_theme: none
    theme_features: title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, menus, widgets
    theme_path: /kunden/artworldweb.de/masauxaromes/wp-content/themes/toko
    
    ### wp-themes-inactive (5) ###
    
    Sketch: version: 1.0.2, author: WordPress.com (latest version: 1.2.4)
    Twenty Nineteen: version: 1.6, author: WordPress-Team
    Twenty Seventeen: version: 2.0, author: WordPress-Team (latest version: 2.3)
    Twenty Sixteen: version: 1.8, author: WordPress-Team (latest version: 2.1)
    Twenty Twenty: version: 1.1, author: WordPress-Team (latest version: 1.4)
    
    ### wp-plugins-active (11) ###
    
    Akismet Anti-Spam: version: 4.1.5, author: Automattic (latest version: 4.1.6)
    Contact Form 7: version: 5.1.7, author: Takayuki Miyoshi (latest version: 5.2)
    Cookie Bar: version: 1.8.7, author: Brontobytes (latest version: 1.8.8)
    Easy Coming Soon: version: 2.3, author: Ankit Agarwal, Priyanshu Mittal
    Envato Market: version: 2.0.3, author: Envato
    KingComposer: version: 2.9.2, author: King-Theme (latest version: 2.9.5)
    Kirki Customizer Framework: version: 3.1.2, author: David Vongries (latest version: 3.1.4)
    Maps Widget for Google Maps: version: 4.17, author: WebFactory Ltd
    Polylang: version: 2.7.2, author: WP SYNTEX (latest version: 2.7.4)
    Slider Revolution: version: 6.1.5, author: ThemePunch
    Toko Core: version: 1.9.1, author: Octagon Web Studio
    
    ### wp-plugins-inactive (2) ###
    
    WooCommerce: version: 4.0.1, author: Automattic (latest version: 4.3.0)
    WordPress Database Backup: version: 2.3.3, author: Austin Matzko
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.18.114-pvops-xen-x64 x86_64
    httpd_software: Apache/2.4.41
    php_version: 7.2.19
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 8M
    php_post_max_size: 8M
    curl_version: 7.55.1 OpenSSL/1.0.2l
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.19-67.0-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/artworldweb.de/masauxaromes/wp-content
    WP_PLUGIN_DIR: /kunden/artworldweb.de/masauxaromes/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: false
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    Thread-Ersteller fbprovence

    (@fbprovence)

    Hallo Bego Mario Garde
    Habe alles gemäß Ihren #Anweisungen gemacht.
    Ich hoffe sie können mir helfen. Ich möchte dringend neue Bilder auf die Webseite stellen.

    Thread-Ersteller fbprovence

    (@fbprovence)

    Hallo Bego Mario Garde

    Ich habe jetzt hier sehr viel zu diesem Thema gelesen und bin auf etwas gestoßen.

    WordPress-Adresse (URL) https://le-mas-aux-aromes.com

    Kopiere ich aber die Zeile bei im Browser bei Edge, dann steht da
    http://le-mas-aux-aromes.com

    Das bedeutet das -s- fehlt bei http

    Ich habe aber eine Verschlüsselung SSL für die Webseite.

    Vorab: wir helfen hier in unserer Freizeit. Wenn du schnell Support benötigst, auch am Wochenende, solltest du vielleicht einen Dienstleister beauftragen, der gegen entsprechendes Aufgeld sicher auch 24h/7 exklusiv für dich erreichbar ist. Bitte wende dich auch nicht an einzelne Nutzer, sondern an alle ForenteilnehmerInnen.

    Wenn du deine Website von http auf https umstellst, reicht es nicht, die URL unter Einstellungen > Allgemein anzupassen, da die Bilder alle mit der absoluten URL abgelegt werden. Die werden dann bei einer verschlüsselt übertragenen Website nicht mit angezeigt, weil „gemischte Inhalte“ (unverschlüsselte Bilder in verschlüsselter Webseite) als unsicher gelten.

    Abhilfe: Installiere das Plugin Better Search Replace und ersetze damit in allen Datenbanktabellen die URL mit http mit der neuen URL mit https. (Alle Datenbanktabellen markieren und Häkchen bei Testlauf rausnehmen.)
    Vor solchen Aktionen ist es sinnvoll, ein Backup zu erstellen. Kein Backup, kein Mitleid. 🙂

    PS: Wir verwenden hier, wie in Open Source Communities üblich, das respektvoll gemeinte aber weniger förmliche „du“.

    Thread-Ersteller fbprovence

    (@fbprovence)

    Ok und Danke in die runde.
    Ich überprüfte gerade die URL der alten Bilder auf der Page.
    Die haben bereits https Beispiel
    https://le-mas-aux-aromes.com/wp-content/uploads/2020/01/bg-jardin.jpg

    URL einen neu Hochgeladenen Bildes
    https://le-mas-aux-aromes.com/wp-content/uploads/2020/07/mas_aromes11-rotated.jpg
    oder
    https://le-mas-aux-aromes.com/wp-content/uploads/2020/07/mas_aromes9-rotated-e1595148353320.jpg

    woher kommt dieser Zusatz – rotated –

    Thread-Ersteller fbprovence

    (@fbprovence)

    Gerade habe ich es nochmal mit einem Großen Bild versucht.
    Jetzt ist die URL
    https://le-mas-aux-aromes.com/wp-content/uploads/2020/07/20200605_143300065_iOS-scaled.jpg
    Da steht jetzt der Zusatz – scaled –

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn du Bilder in WordPress bearbeitest, bekommen die Dateien einen entsprechenden Zusatz. Das hat aber mit deinen gemischten Inhalten nichts zu tun.

    Thread-Ersteller fbprovence

    (@fbprovence)

    also, in die gruppe.
    alle Bilder haben die URL Https.
    Das kann es also nicht sein. Die Bilder werden weder in der Mediathek noch in der Vorschau angezeigt. Aber – sobald ich auf einem Bild – Bearbeiten – klicke, wird es ganz normal angezeigt.
    Die alten Bilder, werden sowohl in der Mediathek und auch in der Vorschau angezeigt.
    Gebe ich die URL eines alten Bildes im Browser ein, wird es normal angezeigt.
    https://le-mas-aux-aromes.com/wp-content/uploads/2020/02/le-mas-aux-aromes.jpg
    Gebe ich die URL eines neu hochgeladenen Bildes ein, wird es nicht angezeigt und ich bekomme einen Fehlercode Fehler 403 Zugriff verweigert.
    Ich denke inzwischen der Fehler liegt auf Provider Seite.
    Da ist irgend eine Freigabe nicht eingetragen oder erteilt.

    Hallo,
    es gibt mehrere Dinge, die du versuchen kannst, um das Problem zu lösen (manche davon hast du ja bereits getestet):

    • überprüfe sicherheitshalber, ob sich die Dateien im Ordner uploads befinden
    • überprüfe die Fehlerprotokolle auf dem Server.
    • nenne die .htaccess um und prüfe dann, ob das Problem behoben ist (die Datei bitte vorher sichern).
    • versuche, die Bildgröße (hier geht es um die Anzahl der Pixel, nicht die Dateigröße) zu verringern,
    • beim Webhoster mehr Arbeitsspeicher (memory_limit) beauftragen.
    • prüfe ob das Problem auch besteht, wenn du die Plugins deaktiviert UND ein Standard-Theme wie twentyseventeen aktiviert hast. Du kannst dazu auch das plugin Health Check & Troubleshooting installieren. Wenn du unter „Werkzeuge“->“Website-Zustand“ gehst, kannst du den Problembehandlungsmodus aktivieren. Danach würde ich jeweils Plugin für Plugin aktivieren und dann danach direkt testen, ob der Upload funktioniert.
      Wenn du dann irgendwann nach Aktivierung von plugin xyz bemerkst, dass das Problem wieder besteht, hast du den Übeltäter.

    Das Problem ist hier schon häufiger diskutiert worden. Hier zunächst mal ein Link auf einen älteren Beitrag oder hier, in dem das Problem auch diskutiert wurde. Ansonsten kannst du oben in der Suche auch mal upload eingeben und du erhältst dann viele Treffer dazu.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller fbprovence

    (@fbprovence)

    Hallo zusammen und Danke an alle.
    Das Problem konnte heute gelöst werden.
    Die Berechtigungen wurden nun dennoch einmal neu gesetzt vom Provider.
    Seit dem funktioniert es.
    Danke auch für den Tip mit Better Search Replace.
    Das werde ich dennoch machen, Hat auch mein Provider empfohlen.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „bilder werden nicht in mediathek geladen, aber nicht angezeigt.“ ist für neue Antworten geschlossen.