Support » Allgemeine Fragen » Blockeditor STRG-C und STRG-V geht nur im Seitentitel

  • Gelöst spandauer67

    (@spandauer67)


    Liebe Gemeine,
    ich arbeite schon lange mit WP aber so ein Problem hatte ich noch nie.

    WP Version 5.6.2 istalliert 28.02.21
    Problem: STRG-C STRG-V funktioniert nur beim Seitentitel (Seite und Beitrag)

    Gerade aufgefallen, erstelle ich einen „classic“ Block geht das Kopieren und Einfügen. Jetzt bin ich total verwirrt.

    Was habe ich getan um das Problem zu lösen:

    Alle PlugIns deaktiviert = Problem bleibt.
    Worpress nochmals über das Dashboard installiert = Problem bleibt.
    Debug Mode an = Keine Meldung
    Standard Template eingestellt = Problem bleibt.

    Bis auf das ich auch keine bestehenden Beiträge in Blöcke umwandeln kann funktioniert der Blockeditor einwandfrei. Nach 2 Tagen suchen wollte ich Euch mal um Hilfe bitten.

    Ach in der Foren Suche habe ich nichts passendes gefunden.

    Vielen Dank im Voraus

    • Dieses Thema wurde geändert vor 1 Jahr, 4 Monaten von spandauer67.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Thread-Ersteller spandauer67

    (@spandauer67)

    Guten Morgen und kurze Rückmeldung.

    Ich konnte das Problem lösen. Ich habe das Classic Editor Plugin installiert und nun geht alles 1a.

    Sorry, aber daran habe ich absolut nicht gedacht.

    Thema ist gelöst und als solches markiert.

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von spandauer67.

    Hallo,
    danke für die Info, wobei mich das wundert: Das sollte natürlich auch ohne das Plugin Classic Editor funktionieren.
    Viele Grüße
    Hans-Gerd

    Ich konnte das Problem lösen. Ich habe das Classic Editor Plugin installiert und nun geht alles 1a.

    Das ist wahrscheinlich keine Lösung, sondern ein Workaround, um einen JavaScript-Fehler zu beheben. Der Classic Editor funktioniert (als eigenständiger Editor, nicht als Block im Block-Editor) ohne JavaScript, das Problem taucht deshalb gar nicht erst auf.

    In einer Testinstallation mit WordPress 5.6.2 kann ich nicht reproduzieren, dass ein Einfügen aus der Zwischenablage nicht funktioniert. Ich würde mal mit dem Plugin Health Check testen, ob sich die Fehlerursache durch Deativieren der Plugins und Wechsel zu einem Standard-Theme eingrenzen lässt.

    Thread-Ersteller spandauer67

    (@spandauer67)

    Hallo,
    danke für die Info, wobei mich das wundert: Das sollte natürlich auch ohne das Plugin Classic Editor funktionieren.
    Viele Grüße
    Hans-Gerd

    Ja gerne und ich frag mich das ja auch. Hatte das noch nie bei WP und das ist nicht das erste was ich aufgesetzt hatte. Ganz verrückt.

    Das ist wahrscheinlich keine Lösung, sondern ein Workaround, um einen JavaScript-Fehler zu beheben. Der Classic Editor funktioniert (als eigenständiger Editor, nicht als Block im Block-Editor) ohne JavaScript, das Problem taucht deshalb gar nicht erst auf.

    In einer Testinstallation mit WordPress 5.6.2 kann ich nicht reproduzieren, dass ein Einfügen aus der Zwischenablage nicht funktioniert. Ich würde mal mit dem Plugin Health Check testen, ob sich die Fehlerursache durch Deativieren der Plugins und Wechsel zu einem Standard-Theme eingrenzen lässt.

    Danke für die Rückmeldung. Ich hänge da nicht so tief in der Materie, das ich dir darauf eine Antwort geben könnte. Was ich aber für mich als Lösung ansah, da nach der Installation des Classic Editor Plugins, STRG-V plötzlich wieder normal funktionierte.

    Ich habe nun folgendes probiert. Classic Editor Plugin deaktiviert und deinstalliert. Dann das Health Check Plugin installiert und laufen lassen.

    Alle Plugins wurden deaktiviert und der Blockeditor funktioniert einwandfrei. Das Health Plugin wieder abgeschaltet und alles geht noch immer wie sonst auch.

    Fehler wurden auch keine angezeigt, nur Empfehlungen. Nicht genutzte Templates und Plugins zu deinstallieren. Das wars auch schon.
    Templates hatte ich nur die 3 Standard mitgelieferten deaktieviert. Und Plugins nur Hello Dolly und Akismet. Jedenfalls keinerlei Fehler.

    Ich verstehe es gerade nicht, denn ausser das Classc Editor Plugin zu installieren, hatte ich nichts weiter mehr gemacht, nachdem ich hier die mein Problem gepostet hatte.

    Es ist mir ein Rätsel, denn plötzlich kann ich auch alte Beiträge wieder in Blöcke umwandeln und auch STRG-C / STRG-V normal benutzen.
    Wenn ich nicht schon ganz senil bin, habe ich mir das vorher nicht eingebildet, denn ich hatte ja 2 Tage damit zu tun den Fehler zu finden. Inkl. neu aufsetzen.

    Normalerweise repariert sich ja WordPress nicht selbst 🙂 und ich bin mir zu 100% sicher nichts anderes getan zu haben. Somit tat ich das für mich als Lösung ab. Worüber ich ja auch nicht unglücklich war.

    Jedenfalls vielen Dank für Eure Antworten.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Blockeditor STRG-C und STRG-V geht nur im Seitentitel“ ist für neue Antworten geschlossen.