Support » Allgemeine Fragen » call_user_func_array() expects parameter 1 to be a valid callback, second array

  • Hallo,

    Ich nutze das Plugin „Query Monitor“ und darin kommt seit kurzem folgende Fehlermeldung.

    call_user_func_array() expects parameter 1 to be a valid callback, second array member is not a valid method

    Hier ein Screenshot.

    Klick

    Kann mir da jemand weiterhelfen?

    Danke

    Lg
    Sakis

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Eines deiner Plugins oder dein Theme wird eine Funktion aus dem Core nicht richtig verwenden. Deshalb bekommst du einen Hinweis, dass da etwas nicht stimmt. Du könntest (z.B. mit dem Plugin Health Check) testen, ob die Meldung im verschwindet, wenn du die Plugins (im Problembehandlungsmodus des Plugins Health Check) vorübergehend deaktivierst.

    Mehr lässt sich aus diesen spärlichen Angaben wohl nicht sagen.

    Hallo,
    es könnte evtl. sein, dass das Problem durch ein Plugin oder dein Theme verursacht wird, siehe z. B hier.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann das von dir verwendete Theme und schaue mal, ob das Problem dann noch auftaucht. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem immer noch besteht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Viele Grüße,
    Hans-Gerd

    Nachtrag: Ich hatte übersehen, dass Bego schon genau das geantwortet hatte. Aber ich habe auch auf einer Testseite gerade festgestellt, dass mir Query Monitor diese Warnung zeigt.
    Ich werde wohl erst mal abwarten, ob diese Meldung noch erscheint, wenn heute oder morgen WordPress auf die Version 5.5 aktualisiert wird.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)