Support » Plugins » Classic Editor: Funktion „Neuer Artikel“ geht nicht mehr

  • Moin, ich benutze seit Jahren den Classic Editor, meist, weil ich neue Artikel „am Band“ produziere und immer nur andere Bilder einfüge (täglicher Jahreskalender). Dazu drücke ich „neuer Artikel“, füge Bild ein und konfiguriere das Wunschdatum mit „Planen“.

    Anschließend wieder „neuer Artikel“ usw usw.

    Seit dem 6.5 Update (vielleicht auch schon die Version zuvor) passiert es aber, dass ab dem zweiten „neuen“ Artikel die Artikelnummer nicht hochgezählt wird und man somit den vorigen Artikel überschreibt!

    Es gibt auch keine Möglichkeit, die Nummer manuell zu ändern! Es werden immer nur noch Revisionen des ersten Artikels angelegt und dieser somit überschrieben.

    Man kann also effektiv nur noch EINEN ARTIKEL pro Tag neu anlegen!

    (Hab Browser getauscht, Caches gelöscht/dekativiert, und sonstige Tricks durchprobiert, es hilft nix)

    Wenn man den Classic Editor deaktiviert und Gutenberg nimmt, geht wieder alles (aber Gutenberg ist für mich nicht akzeptable, einfach zuviel Tipp- und Klickarbeit für meine „Quasi-Batch-Processing“).

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • So ganz ohne Informationen zur Website lässt sich dazu nichts sagen bzw. schreiben. Bitte lies dir dazu den angehefteten Beitrag durch: Bevor du ein neues Thema (Thread) erstellst

    Thread-Starter trillian59

    (@trillian59)

    Na ja, der Link wäre homepage.meiszl.de, aber der nützt Dir nix, die Seite ist nicht öffentlich.

    Der Webseitenzustand ist „Hervorragend“

    ` wp-core
    
    version: 6.5.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: undefined
    environment_type: production
    user_count: 13
    dotorg_communication: true wp-paths-sizes wordpress_path: /usr/local/www/apache24/homepage
    wordpress_size: 546,69 MB (573244580 bytes)
    uploads_path: /usr/local/www/apache24/homepage/wp-content/uploads
    uploads_size: 1,72 GB (1849826982 bytes)
    themes_path: /usr/local/www/apache24/homepage/wp-content/themes
    themes_size: 5,70 MB (5978929 bytes)
    plugins_path: /usr/local/www/apache24/homepage/wp-content/plugins
    plugins_size: 28,79 MB (30190010 bytes)
    database_size: 27,58 MB (28917760 bytes)
    total_size: 2,32 GB (2488158261 bytes) wp-dropins (2) advanced-cache.php: true
    object-cache.php: true wp-active-theme name: MAM (mam)
    version: 2.1
    author: mam
    author_website: https://wordpress.org/
    parent_theme: Twenty Fourteen (twentyfourteen)
    theme_features: core-block-patterns, widgets-block-editor, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, automatic-feed-links, post-thumbnails, menus, html5, post-formats, custom-background, featured-content, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /usr/local/www/apache24/homepage/wp-content/themes/mam
    auto_update: Aktiviert wp-parent-theme name: Twenty Fourteen (twentyfourteen)
    version: 3.9
    author: Das WordPress-Team
    author_website: https://de.wordpress.org/
    theme_path: /usr/local/www/apache24/homepage/wp-content/themes/twentyfourteen
    auto_update: Aktiviert wp-themes-inactive (1) Twenty Twenty-Four: version: 1.1, author: Das WordPress-Team, Automatische Aktualisierungen aktiviert wp-mu-plugins (1) Autoupdate: version: 1.0, author: MAM wp-plugins-active (17) Advanced Editor Tools: version: 5.9.2, author: Automattic, Automatische Aktualisierungen aktiviert
    Cache Enabler: version: 1.8.15, author: KeyCDN, Automatische Aktualisierungen aktiviert
    Classic Editor +: version: 4.3.0, author: Pieter Bos, Greg Schoppe, Automatische Aktualisierungen aktiviert
    Classic Widgets: version: 0.3, author: WordPress Contributors, Automatische Aktualisierungen aktiviert
    Crop Thumbnails: version: 1.8.0, author: Volkmar Kantor, Automatische Aktualisierungen aktiviert
    Display Posts: version: 3.0.2, author: Bill Erickson, Automatische Aktualisierungen aktiviert
    Force Login: version: 5.6.3, author: Kevin Vess, Automatische Aktualisierungen aktiviert
    Hide Admin Notices: version: 2.1, author: PontetLabs, Automatische Aktualisierungen aktiviert
    LoginPress: version: 3.0.6, author: LoginPress, Automatische Aktualisierungen aktiviert
    Postie: version: 1.9.68, author: Wayne Allen, Automatische Aktualisierungen aktiviert
    Posts in Page: version: 1.4.4, author: IvyCat, Inc., Automatische Aktualisierungen aktiviert
    PublishPress Future: version: 3.3.1, author: PublishPress, Automatische Aktualisierungen aktiviert
    Redis Object Cache: version: 2.5.2, author: Till Krüss, Automatische Aktualisierungen aktiviert
    Remove Query Strings: version: 1.4.0, author: LittleBizzy, Automatische Aktualisierungen aktiviert
    Woody code snippets (PHP snippets | Insert PHP): version: 2.4.10, author: Creative Motion, Will Bontrager Software, LLC will@willmaster.com, Automatische Aktualisierungen aktiviert
    WP-WebAuthn: version: 1.3.1, author: Axton, Automatische Aktualisierungen aktiviert
    WP Mail SMTP: version: 4.0.1, author: WP Mail SMTP, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1808
    imagemagick_version: ImageMagick 7.1.0-62 Q16-HDRI amd64 20885 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 60
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 120 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 661128
    imagick::RESOURCETYPE_MAP: 60 GB
    imagick::RESOURCETYPE_MEMORY: 30 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, ASHLAR, AVI, AVIF, AVS, BAYER, BAYERA, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUBE, CUR, CUT, DATA, DCM, DCR, DCRAW, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FARBFELD, FAX, FF, FILE, FITS, FL32, FLV, FRACTAL, FTP, FTS, FTXT, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, HALD, HDR, HEIC, HEIF, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, JXL, K25, KDC, KERNEL, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORA, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PHM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, QOI, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGB565, RGBA, RGBO, RGF, RLA, RLE, RMF, RSVG, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, STRIMG, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TM2, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YAML, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: not available wp-server server_architecture: FreeBSD 14.0-RELEASE-p6 amd64
    httpd_software: Apache/2.4.58 (FreeBSD) OpenSSL/3.0.12 PHP/8.2.14
    php_version: 8.2.14 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 600
    memory_limit: 1024M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 8.6.0 OpenSSL/3.0.12
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2024-05-02T07:21:00+00:00
    utc-time: Thursday, 02-May-24 07:21:00 UTC
    server-time: 2024-05-02T09:20:59+02:00 wp-database extension: mysqli
    server_version: 8.0.35
    client_version: mysqlnd 8.2.14
    max_allowed_packet: 67108864
    max_connections: 151 wp-constants WP_HOME: https://homepage.meiszl.de
    WP_SITEURL: https://homepage.meiszl.de
    WP_CONTENT_DIR: /usr/local/www/apache24/homepage/wp-content
    WP_PLUGIN_DIR: /usr/local/www/apache24/homepage/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: utf8_unicode_ci wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable wp_mail_smtp version: 4.0.1
    license_key_type: lite
    debug: Keine Debug-Hinweise gefunden.
    lite_install_date: Apr 6, 2022 @ 9:03am

    Der Hinweis, dass die Website nicht zugänglich ist, erspart zumindest einen Blick in die Entwicklertools des Browsers.

    Dass der Website-Zustand „Hervorragend“ ist, bringt leider wenig zur Behebung des geschilderten Problems.

    Bei dem einen oder anderen Plugin könnte ich mir vorstellen, dass es zu einem Konflikt mit dem Classic Editor kommt. Hast du probiert, ob sich etwas ändert, wenn du bis auf den Classic Editor alle Plugins vorübergehend deaktivierst? Ziel sollte zunächst sein, die Fehlerursache einzugrenzen.

    Thread-Starter trillian59

    (@trillian59)

    Ja, hab so ziemlich alles mal abgeschaltet, auch die Caches völlig deinstalliert (das war mein erster Verdacht).

    Wenn Du unbedingt reingucken willst (ist nichts „geheimes“ nur eine private Homepage mit Bildern und Cartoons), kann ich Dir einen Benutzer anlegen.

    Wichtig wäre noch zu erwähnen, dass auch andere Zugänge (ich verwende z.B. „Postie“ um Mails vom Müllversorger zu bekommen und in Artikel einzupflegen) einwandfrei weiter funktionieren, nur der Classic Editor macht diese Zicken seit einiger Zeit.

    (noch viel lieber hätte ich es, einen Shellbefehl zu haben, um automatisch Artikel erstellen zu können, die Bilder liegen da mit Dateinamen MMTT.jpg rum, da könnte man einfach eine Batch machen, die für jedes Bild einen Artikel erzeugt und für den Tag plant, aber das sind Träume, die sich bislang nicht erfüllt haben, bleiben wir also beim Editor und viel Rumgeklicke…)

    Wenn Du unbedingt reingucken willst (ist nichts „geheimes“ nur eine private Homepage mit Bildern und Cartoons), kann ich Dir einen Benutzer anlegen.

    Danke, aber ich möchte nicht „unbedingt reingucken“ und mich auch nicht anmelden. Bitte lies dazu in den FAQ: Kannst du mich nicht anrufen oder mal schnell bei mir einloggen?

    noch viel lieber hätte ich es, einen Shellbefehl zu haben, um automatisch Artikel erstellen zu können,

    Das geht mit dem Kommandozeilen-Tool WP-CLI.

    Hast du in der Konsole der Entwickler-Tools deines Browsers nach JavaScript-Fehlern gesucht?

    Mit Aussagen wie „hab so ziemlich alles mal abgeschaltet“ ist eine Hilfe schwierig. Was sollen wir dir raten, wenn du schon „alles probiert“ hast?

    Was passiert, wenn du statt des „Classic Editor +“ den Classic Editor verwendest?

    Thread-Starter trillian59

    (@trillian59)

    oops, mir war gar nicht bewußt, dass es 2 davon gibt… aber ok, nun ohne Plus, aber leider mit demselben Fehler:

    (oops, kann man hier kein Bild einfügen? na ja, wie zuvor: Artikelnummer bleibt gleich, Revision wird eingefügt.)

    oops, kann man hier kein Bild einfügen?

    Kannst du dich bitte zuerst mit unseren FAQ vertraut machen? Dann brauche ich nicht jeden dort behandelten Punkt wiederholen:

    Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    Hast du geprüft, ob der Speicherplatz der MySQL-Datenbank erschöpft ist?

    Thread-Starter trillian59

    (@trillian59)

    Datenbankgrösse? keine Ahnung, kenne kein Limit, weis nicht, wie gucken und auf den Platten sind noch hunderte von Gb frei.

    [root@l3router ~/]# df
    Filesystem 1K-blocks Used Avail Capacity Mounted on
    /dev/nvd0p2 232371000 30316116 183465204 14% /
    devfs 1 0 1 0% /dev
    /dev/ada0p1 968783332 89904444 801376224 10% /cloud
    fdescfs 1 0 1 0% /dev/fd
    procfs 8 0 8 0% /proc
    tmpfs 4194304 44 4194260 0% /tmp

    Zu Deinem Bildchen: https://cloud.meiszl.de/index.php/s/PPEWo9YSEirEmec

    (ich verwende keinerlei externe Dienste, alle Server laufen hier lokal)

    Zur Erklärung des Bildchens: ich hab 1s vorher mit dem Editor eine neue Nachricht (mit anderem Bild und anderen Planung) eingerichtet, und dann oben auf „Neuen Artikel erstellen“ geklickt. Editor wurde geleert, anderes Bild rein, anderes Planungsdatum, aber wenn man dann „Planen“ klickt, erscheint der Link vom vorigen Artikel und unten in den Revisionen ist ein neuer Eintrag mit dem vorigen Artikel. Der ist dann nicht mehr direkt zugänglich und wird nicht mehr geplant.

    (Da ich die Kalender immer so monatsweise Einscanne und vorplane, hat es eine Zeit gedauert, bis die alten alle abgearbeitet waren und keine neuen mehr erschienen, weil sie überschrieben worden sind. Somit ist das Fehlerdatum leider nicht mehr genau ermittelbar. „Irgendwann zwischen Januar und März“ würde ich sagen)

    • Diese Antwort wurde geändert vor 2 Wochen, 2 Tage von trillian59.
    Thread-Starter trillian59

    (@trillian59)

    „Was sollen wir dir raten, wenn du schon „alles probiert“ hast?“

    Keine Ahnung, das ist vielleicht der Grund, warum ich hier frage???

    Also, aus Deinen Reaktionen entnehme ich, dass es wohl kein allgemein bekanntes Problem sein sollte. Ich wüsste zwar nicht, was ich da verwarzt haben soll (bis auf die automatischen Updates hat sich seit Jahren nichts geändert), aber vielleicht sollte ich mal alles platt machen und neu aufsetzen.

    Der Tipp mit „wp post create…“ ist schon mal sehr gut, allerdings scheitere ich dann an der eigentlich trivialen Aufgabe, den content zu definieren. Die Artikel sollen keinen Text enthalten, nur jeweils ein JPG und ich finde keinen Parameter bei dem Befehl, womit man etwas anderes als TEXT einfügen kann… (Wahrscheinlich wieder ein NOOB Problem, aber ich kenne nunmal nicht die interne Struktur von WP, finde nur, dass die Bilder alle in einem extra Pfad gesammelt werden und da wird man dann wohl einen Link zu dem Bild einbauen müssen…)

    „Was sollen wir dir raten, wenn du schon „alles probiert“ hast?“

    Keine Ahnung, das ist vielleicht der Grund, warum ich hier frage??? …

    Also, aus Deinen Reaktionen entnehme ich, dass es wohl kein allgemein bekanntes Problem sein sollte.

    Ich habe eben in einer Testinstallation die von dir beschriebenen Arbeitsschritte durchgeführt und kann das Problem nicht reproduzieren. Meine Vermutung war, dass es sich um einen Konflikt mit einem anderen Plugin handeln könnte, aber das hast du bereits kategorisch ausgeschlossen („… hab so ziemlich alles mal abgeschaltet“).

    Auf deine Fragen zu WP-CLI kann ich nicht im Detail eingehen, weil das hier den (oder zumindest meinen) zeitlichen Rahmen sprengen würde.

    Thread-Starter trillian59

    (@trillian59)

    „Auf deine Fragen zu WP-CLI kann ich nicht im Detail eingehen, weil das hier den (oder zumindest meinen) zeitlichen Rahmen sprengen würde.“

    Ok, danke erstmal ich robb mich da ran…

    Hab schonmal „wp media import“ gefunden, dass das Bild in WP reinkopiert und einen ID zurückliefert (mit –featured_image wird es sogar an der Seite angezeigt, aber das will ich ja gar nicht, sondern es soll in der Mitte sein, als einziger Content).

    Da werden dann wohl noch ein paar Schritte fehlen und die IDs muss man auch extrahieren und speichern… Na ja, ist was für den Winter…

    MAM

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)