Support » Allgemeine Fragen » Classic Editor funktioniert nicht

  • Hallo, ich hab erst im Oktober mit dem Bloggen begonnen und kenne mich deshalb noch nicht wirklich gut mit WordPress aus.

    Als ich heute einen neuen Beitrag erstellen wollte, war ich etwas erschrocken über den neuen Gutenberg Editor… (Ich muss zu meiner Schande gestehen, dass dieses Thema an mir vorbei gegangen ist.)

    Nach etwas Recherche im Internet habe ich dann das Plugin „classic editor“ installiert, um wieder wie gewohnt meine Beiträge schreiben zu können. Leider funktioniert das nicht. Ich kann nur im Feld „Überschrift“ etwas tippen. Im Textfeld tut sich überhaupt nix und die komplette Menüleiste, die immer direkt über dem Textfeld war,(fett, kursiv, Absatz, Link einfügen etc.) fehlt.
    Ansonsten sieht alles so aus wie vorher.

    Hat irgendjemand eine Idee, woran das liegen könnte? Bin am Verzweifeln.

    Vielen Dank schonmal 🙂

    Lisa

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das selbe Problem hatte ich vor Monaten mit dem Theme ‚Responsive‘. Ich hab dann das Gutenberg-Plugin installiert, und gut war es. Da ich auf der betreffenden Seite keine speziellen Funktionen des TinyMCE benötigte, bin ich dabei geblieben.

    Wenn Du funktionell beim neuen Block-Editor nix wichtiges vermisst, dann bleib dabei. Ist etwas gewöhnungsbedürftig, hat aber durchaus seine Vorteile.

    Sonst wechsle mal auf das Standardtheme ‚Twenty Nineteen‘, und versuche dann nochmals zu schreiben. Auf meiner Testumgebung kann ich das Problem nicht rekonstruieren.

    Gruß René

    Hallo Lisa,
    bitte liste doch einmal deine WordPress-Version, die Classic-Editor-Version auf und ob das Gutenberg-Plugin noch installiert ist, wenn ja auch hier die Version bitte.

    Hast du Caches geleert? Im Browser, evtl.auch von speziellen Cache-Plugins?

    Hallo und vielen Dank für eure Antworten.

    WordPress Version 5.0
    Classic editor Version 1.2

    Ich hab momentan den classic editor wieder deaktiviert und mich tatsächlich mal mit den Blöcken vertraut gemacht. So schlimm ist es eigentlich gar nicht, ich hätte aber trotzdem lieber wieder den classic editor. Der Mensch ist ein Gewohnheitstier. 😉

    Ich hab kein spezielles Gutenberg Plugin installiert, Angelika. Ich nehme an, dass das ja automatisch jetzt mit dem Update auf 5.0 kam, oder?

    LG, Lisa

    Ich hab mich recht schnell an den Block Editor gewöhnt, das wird dir bestimmt auch so gehen.

    Betreffend ‚altem Editor‘, der Classic Editor und der TinyMCE sind nicht das Selbe. Das erkennt mann alleine schon wenn man sich die Einstellungsmöglichkeiten anschaut. Da kommt der Classic sehr bescheiden daher. Ob der sich mit Erweiterungen aufpimpen lässt, ich weiss es nicht. Der MCE lässt sich pimpen. Soweit ich es ausprobiert habe funktioniert er auch mit WP5, ist darauf aber nicht vom Entwickler getestet worden. Wenn du dich mit dem Blockeditor nicht anfreunden magst, oder für dich wichtige Funktionen fehlen, dann probier mal den MCE aus, ob es damit klappt.

    Das Gutenberg-Plugin lässt sich zwar unter WP5 installieren, macht aber meines Erachtens überhaupt kein Sinn. Ich tipp mal darauf, dass es von WP5 ignoriert wird, das es ja bereits zum Standardumfang gehört.

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von radarin.

    Ich hab kein spezielles Gutenberg Plugin installiert, Angelika. Ich nehme an, dass das ja automatisch jetzt mit dem Update auf 5.0 kam, oder?

    Ja, das ist richtig. Deshalb hättest du ein eventuell vorhandenes auch wieder löschen können/müssen.

    Nachdem du den Classic Editor erneut installiert und aktiviert hast, schau bitte erst einmal in dein Benutzerprofil (Adminbereich links Benutzer -> Dein Profil) ob du dort (ganz oben) den Eintrag findest:
    Standard-Editor =>> (x) Classic Editor ||| Block-Editor, solltest du den Eintrag finden, dann „Classic Editor“ ankreuzen und speichern.

    Schritt 2: im Adminbereich links auf Einstellungen -> Schreiben klicken, dort findest du
    Standard-Editor für alle Benutzer =>> (x) Classic Editor ||| Block-Editor
    Erlaube Benutzern, den Editor zu wechseln =>> Ja ||| (x) Nein

    Hier „Classic Editor“ und „Nein“ ankreuzen, speichern bitte nicht vergessen.

    Jetzt der Test, ob alles funktioniert.

    Ich habe den Classic Editor auf *allen* Websites, meinen eigenen sowie auf von mir gemanagten Kundenwebsites installiert, Kunden, die ihre Websites selbst verwalten, habe ich es entsprechend empfohlen. Es gibt einfach momentan noch zu viele, teils gravierende Bugs im Gutenber-/Block-Editor. Der Classic Editor funktioniert auf allen installierten Websites reibungslos.

    Daher tippe ich auf Cache, oder aber ein anderes Plugin funkt dazwischen. Hier im Forum hat jemand geschrieben, dass ihm das Plugin Disable Gutenberg bei Problemen mit dem Classic Editor geholfen hat. Kannst du ja eventuell als letzte Option ausprobieren.

    Nachtrag: Wenn du das installieren solltest, kannst du den Classic Editor deinstallieren, denn „Disable Gutenberg“ ersetzt den Classic Editor.

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von Angelika Reisiger. Grund: Block-Editor geändert zu Classic Editor
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von Angelika Reisiger.
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von Angelika Reisiger.

    Den von dir genannten Eintrag finde ich leider so bei mir nicht. Hier steht nur „visueller Editor“, sonst nichts.

    Das, was du unter Schritt 2 geschrieben hast, ist genau so bei mir auch hinterlegt bzw. angekreuzt.

    Ich habe das andere Plugin (disable Gutenberg) auch schon ausprobiert, leider ebenfalls ohne Erfolg. Gleiches Problem wie beim classic editor Plugin.

    Ich kenn mich halt einfach auch zu wenig aus, um zu wissen, woran es liegen könnte bzw. Was ich noch versuchen könnte.

    Cache ist auch geleert…

    Ich fürchte, ich muss mich tatsächlich an den neuen Editor gewöhnen. Hoffe nur, dass das alles einigermaßen funktioniert und ich keine Probleme bei der Veröffentlichung von Beiträgen habe.

    Danke René, für deinen Tipp mit dem tiny mce editor. Werde ich mir auch mal anschauen.

    der Classic Editor und der TinyMCE sind nicht das Selbe

    Äh, doch.

    ok… und wo stelle ich beim Classic Editor ein, dass er meine ‚editor-styles.css‘ verwenden soll? Und wo ist das Menu mit meinen Klassen aus dieser Datei?

    Hallo,
    Ich bin langsam echt am Verzweifeln.

    Wollte heute einen Beitrag verfassen mit dem Gutenberg Editor, aber ständig hängt sich die Seite auf, sobald ich bestimmte Dinge anklicke, wie z.B einen Text fett markieren oder kursiv.
    Andauernd funktioniert etwas nicht.

    Plugins sind alle auf dem neusten Stand.

    So macht das grade wirklich keinen Spaß mehr. Ich hab keine Ahnung, was ich noch machen soll?!

    Update: Mittlerweile funktioniert gar nichts mehr. Sobald ich einen Block anklicke, schließt sich die Seite und diese Meldung kommt: „Ein Problem mit dieser Website hat bewirkt, dass Internet Explorer diese Seite geschlossen hat“

    Wie soll ich jemals wieder einen Beitrag schreiben, wenn weder der classic noch der Gutenberg funktioniert… Ich werd wahnsinnig.

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von libu14.
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von libu14.

    Was passiert, wenn Du alle Plugins mal deaktivierst? Ein Standardtheme aktivierst?

    Ich habe alle Plugins mal deaktiviert und es ging trotzdem nicht.

    Jetzt habe ich gerade den classic editor nochmal installiert und ebenfalls alle Plugins nacheinander deaktiviert. Und siehe da, hier scheint es tatsächlich an Yoast zu hängen. Wenn ich es deaktiviere, ist immerhin meine ganze Menüleiste wieder da. D.h. Ich kann jetzt im Classic editor wieder schreiben. Aber eben ohne das Yoast Plugin, was ich sehr schade finde. Gibt es da vielleicht Alternativen?

    Bin grad echt mega unzufrieden, dass das jetzt alles so kompliziert ist und nix mehr funktioniert. Bin mal gespannt, was das langfristig geben soll…

    Ich würde den schwarzen Peter jetzt eher mal Yoast als dem Editor zuschieben. Auf die Schnelle kann ich das Problem auf meiner Testumgebung mit WP5 und dem 3 Wochen alten Yoast weder mit dem Block-, noch mit dem Classic-Editor repoduzieren.

    In dem Fall musst du vorerst auf Yoast verzichten, wenn du ohne so deine Beiträge verfassen kannst. (ggf. nur zum Schreiben deaktivieren?) Wenn Yoast die Ursache ist, kannst du bei einem so beliebten Plugin davon ausgehen, dass ein Update wahrscheinlich recht zügig kommt.

    Erst wenn die breite Masse auf den Zug aufspringt zeigen sich letzte Kunderkrankheiten. Da ist natürlich nicht lustig, man verplempert doch ordentlich Zeit. Aber das wird!

    Hallo,
    nun weiß ich nicht, wie es hier weiter gegangen ist aber ich kann folgendes sagen:

    Nachdem WP 5.0 installiert war, wurde mir der Gutenberg Editor angezeigt. Sofort erhielt ich eine Warnung von Seo Yoast, dass ich den Gutenberg nicht verwenden soll, sondern den Classic Editor. Da war ich im ersten Moment auch erschrocken, weil ich fürchtete ein Backup machen zu müssen. Ich habe dann etwas recherchiert und fand die Lösung mit der Installation des Classic Editor Plugins. Das habe ich dann gezwungenermaßen gemacht. Auch habe ich das Plugin TinyMCE Advance schon lange im Betrieb, und in dessen Einstellungen ist es möglich, statt des Gutenberg, den Classic Editor als Standard Editor zu priorisieren.

    Hallo,
    sobald Du den Classic Editor installierst, wird Gutenberg quasi abgeschaltet. Allerdings kann man die Auswahl des Editors unter Einstellungen->Schreiben zusätzlich einstellen:
    a) welcher Editor soll der Standard-Editor sein und
    b) dürfen Nutzer den jeweiligen Editor bei der Erstellung auswählen.
    Nach wie vor setze ich Gutenberg nicht im Livebetrieb ein, weil der m. E. noch zu viele Macken hat.
    Viele Grüße
    Hans-Gerd

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Classic Editor funktioniert nicht“ ist für neue Antworten geschlossen.