Support » Allgemeine Fragen » Constant DISALLOW_FILE_EDIT already defined in /home/www/mg-heute.de/wp-config.

  • Gelöst Harald Wendler

    (@harald-wendler)


    Seite wird nicht mehr korrekt angezeigt.

    Das steht in der obersten Zeile: Constant DISALLOW_FILE_EDIT already defined in /home/www/mg-heute.de/wp-config.php on line 93

    In Zeile 93 steht: define('DISALLOW_FILE_EDIT', true);
    das scheint mir korrekt zu sein.

    Kann mich nicht anmelden.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Thread-Starter Harald Wendler

    (@harald-wendler)

    <?php
    
    // BEGIN iThemes Security - Diese Zeile nicht verändern oder entfernen
    // iThemes Security Config Details: 2
    define( 'DISALLOW_FILE_EDIT', true ); // Datei-Editor deaktivieren - Sicherheit > Einstellungen > WordPress-Optimierungen > Datei-Editor
    define( 'FORCE_SSL_ADMIN', true ); // Redirect All HTTP Page Requests to HTTPS - Security > Settings > Enforce SSL
    // END iThemes Security - Diese Zeile nicht verändern oder entfernen
    
    /**
     * In dieser Datei werden die Grundeinstellungen für WordPress vorgenommen.
     *
     * Zu diesen Einstellungen gehören: MySQL-Zugangsdaten, Tabellenpräfix,
     * Secret-Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es auf der {@link http://codex.wordpress.org/Editing_wp-config.php
     * wp-config.php editieren} Seite im Codex. Die Informationen für die MySQL-Datenbank bekommst du von deinem Webhoster.
     *
     * Diese Datei wird von der wp-config.php-Erzeungsroutine verwendet. Sie wird ausgeführt, wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist,
     * und die Installationsroutine (/wp-admin/install.php) aufgerufen wird.
     * Man kann aber auch direkt in dieser Datei alle Eingaben vornehmen und sie von wp-config-sample.php in wp-config.php umbenennen und die Installation starten.
     *
     * @package WordPress
     */
    
    // ** MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster** //
    /**  Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    // define('DB_NAME', '');
    define('DB_NAME', '');
    
    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    // define('DB_USER', '');
    define('DB_USER', '');
    
    /** Ersetze password_here mit deinem MySQL-Passwort */
    // define('DB_PASSWORD', '');
    define('DB_PASSWORD', '');
    
    /** Ersetze localhost mit der MySQL-Serveradresse */
    define('DB_HOST', 'localhost');
    
    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8mb4');
    
    /** Der collate type sollte nicht geändert werden */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel.
     *
     * Ändere jeden KEY in eine beliebiege, möglichst einzigartige Phrase. 
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service} kannst du dir alle KEYS generieren lassen.
     * Bitte trage für jeden KEY eine eigene Phrase ein. Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten Benutzer müssen sich danach erneut anmelden.
     *
     * @seit 2.6.0
     */
    define('AUTH_KEY',         '');
    define('SECURE_AUTH_KEY',  '');
    define('LOGGED_IN_KEY',    '');
    define('NONCE_KEY',        '');
    define('AUTH_SALT',        '');
    define('SECURE_AUTH_SALT', '');
    define('LOGGED_IN_SALT',   '');
    define('NONCE_SALT',       '');
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix.
     *
     *  Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     *  verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte!
     */
    $table_prefix  = 'wp_mg_heute1_';
    
    /**
     * WordPress Sprachdatei
     *
     * Hier kannst du einstellen, welche Sprachdatei benutzt werden soll. Die entsprechende
     * Sprachdatei muss im Ordner wp-content/languages vorhanden sein, beispielsweise de_DE.mo
     * Wenn du nichts einträgst, wird Englisch genommen.
     */
    define('WPLANG', 'de_DE');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    define('DISALLOW_FILE_EDIT', true);
    
    define( 'AUTOMATIC_UPDATER_DISABLED', true );
    
    /* Custom WordPress URL. */
    define( 'WP_SITEURL', 'https://mg-heute.de' );
    define( 'WP_HOME', 'https://mg-heute.de' );
    
    define( 'WP_CACHE', true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    Moderator Bego Mario Garde

    (@pixolin)

    Hey Harald, Grüße nach MG 👋🏻

    Constant DISALLOW_FILE_EDIT already defined … bedeutet sinngemäß „das hattest du doch schon mal!

    Tatsächlich kommt das einmal ganz oben vor (von iThemes eingetragen) und dann nochmal weiter unten unter define('WP_DEBUG', false);.

    Einmal reicht, also solltest du die Zeile unter WP_DEBUG löschen. 🙂

    Bis zum nächsten Mal. 👋🏻

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Habe wp 5.9.2 komplett (ohne wp-content-ordner) per ftp neu kopiert ausser wp-config.php
    Habe wp-config-php aus alter Sicherung per ftp kopiert.
    Habe plugins abgeschaltet.
    Habe themes abgeschaltet.

    Komme nicht weiter.

    Moderator Bego Mario Garde

    (@pixolin)

    Ähm … hast du meine Antwort gelesen? 😀

    (Bezog sich auf die wp-config.php, die du gepostet hast.)

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Herzlichen Dank Bego!

    Wieso kommt die Zeile da hinein????

    Gruß
    Harald

    Moderator Bego Mario Garde

    (@pixolin)

    Einmal von Harald, der bei einem Meetup gut aufgepasst hatte und die Zeile manuell eingetragen hat, um den Theme-/Plugin-Editor abzuschalten. Und noch einmal von Harald, der iThemes Security installiert und alles mögliche angeklickt hat und damit die Zeile nochmal in die wp-config.php geschrieben hat. Oder war es anders herum? 😉

    Wie auch immer … Konstanten kannst du nur einmal definieren.

    Moderator Bego Mario Garde

    (@pixolin)

    Deine Permalinks sind übrigens noch kaputt. .htaccess umbenannt?

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Danke, hatte leere aus neuem wordpress drüber kopiert…

    Schönes Wochenende
    Harald

    Habe übrigens seit Monaten nichts in der wp-config.php geändert…

    Sollte wohl neue Passwörter kreieren?

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn ich Hans-Gerd richtig verstanden habe, solltest du zumindest das Passwort für die MySQL-Datenbank ändern.

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Danke, hatte leere aus neuem wordpress drüber kopiert…

    Schönes Wochenende
    Harald

    Habe übrigens seit Monaten nichts in der wp-config.php geändert…

    Sollte wohl neue Passwörter kreieren?

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Habe geändert 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Prima. Dann lass dich am Wochenende nicht einschneien. ☃️

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Einmal von Harald, der bei einem Meetup gut aufgepasst hatte und die Zeile manuell eingetragen hat, um den Theme-/Plugin-Editor abzuschalten.

    Dem kann ich zustimmen, ist aber doch Monate her.
    Warum tritt das Problem erst jetzt auf?

    Bei uns regnet es leicht.

    Bis bald

    Dem kann ich zustimmen, ist aber doch Monate her.
    Warum tritt das Problem erst jetzt auf?

    Ich habe das gerade mal kurz getestet: Ich habe die Zeile bei einer lokalen Instanz zwei mal in die wp-config.php eingetragen und habe keine Probleme.

    In der Tat hätte ich auch erwartet, dass das Problem sofort auftritt.

    Danach habe ich auch spaßeshalber mal die Zeile
    define('WP_DEBUG', false);
    zwei mal eingetragen. Auch kein Problem.

    Aber nicht das jemand jetzt auf solche Ideen kommt: Das ist zur Nachahmung nicht empfohlen 😉

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn du define('WP_DEBUG', false); einträgst, werden Warnhinweise („WARNING“) auch nicht angezeigt. 🙂

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 19)
  • Das Thema „Constant DISALLOW_FILE_EDIT already defined in /home/www/mg-heute.de/wp-config.“ ist für neue Antworten geschlossen.