Support » Plugins » Contact Form 7 – Senden nur als Eingeloggter User möglich – Zeitrad läuft

  • Gelöst harsar78

    (@harsar78)


    Hallo zusammen!
    Ich brauche dringend Eure Hilfe!!
    Ich habe auf meiner Seite ein Anfrage-Formular (Contact Form 7) bei dem ich nur als angemeldeter User eine Anfrage versenden kann.
    Der eingeloggte USER benötigt keine besonderen Berechtigungen (funktioniert mit allen vorhandenen Benutzerrollen – auch mit „- Keine Benutzerrolle für diese Webseite -„).

    Wenn ich als nicht eingeloggter User eine Anfrage über das Anfrage-Formular senden möchte,
    läuft andauernd das Zeitrad (die beiden Pfeile im Kreis) und es wird nichts gesendet.

    Wenn in dem Formular Pflicht-Angaben nicht eingetragen werden und man auf „ABSENDEN“ drückt, werden die nicht ausgefüllten Felder nicht angezeigt – das Zeitrad dreht sich und es geht nichts weiter.

    Habe es mit mehreren Browsern auf unterschiedlichsten Systemen versucht – immer dasselbe Ergebnis.

    Habe ein neues Standard-Formular erstellt – auch das lässt sich nur als eingeloggter USER absenden.

    Ich hoffe es kann mir jemand helfen.

    LG

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,
    poste doch mal den Inhalt des Formulars als CODE hier (Register „Formular“).
    Dann können wir uns das ansehen (ich aber heute abend zumindest nicht mehr).
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Ich brauche dringend Eure Hilfe!!

    Wenn du „dringend“ Hilfe benötigst, wende dich bitte an einen Dienstleister, der sich gegen entsprechendes Aufgeld sicher auch gerne am Sonntagabend um dein Problem kümmert.

    Dein Kontaktformular enthält recht viele Eingabefelder, was viele Besucher bereits abschrecken dürfte. Dass fast alle davon Pflichtfelder sind (sogar Gästeanzahl?), dürfte deine Chancen auf eine Verwendung nicht unbedingt erhöhen. Das solltest du nochmal überdenken. Das Kästchen, mit dem Benutzer die Verwendung ihrer Daten bestätigen sollen, ist redundant und vermutlich rechtlich unsinnig; das solltest du aber mit einem Juristen klären.

    Wenn du selber das Formular testest, verwende doch bitte man einen neuen Browser-Tab im Incognito-Modus (oder Privat-Modus). Auf einen ersten Test scheint soweit alles zu funktionieren. (Meine Testnachricht bitte wieder löschen.)

    in der Tat funktioniert das Formular jetzt. Gestern abend hat es nicht funktioniert und ich konnte den Fehler nachvollziehen.
    Wäre schön, wenn @harsar78 schreibt, ob und was er geändert hat, so dass das Formular jetzt funktioniert.
    Meine Testnachricht bitte auch löschen.

    harsar78

    (@harsar78)

    Hallo! Danke für Eure Nachrichten!
    Das Problem war:
    In „Einstellungen“ –> „Disable REST API“ war „/contact-form-7/v1“ deaktiviert.

    Nachdem ich die checking boxes bei „/contact-form-7/v1“ aktiviert hatte, hat alles funktioniert und es konnten auch nicht User eine Anfrage senden.

    Bego Mario Garde (@pixolin):
    Danke für die Hinweise!! Ich werde das Formular nochmals Überarbeiten.

    Habe Eure Testnachrichten gelöscht!!
    GLG

    danke für die Info

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)