Support » Allgemeine Fragen » cURL Error 28

  • Hallo zusammen,

    ich habe auf einmal folgende Fehlermeldungen im Website Zustand erhalten:

    #1
    Die REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Ein Beispiel ist der Bildschirm des Block-Editors, der darauf aufbaut, deine Beiträge und Seiten anzuzeigen und zu speichern.
    #2
    Die Verbindung mit den WordPress-Servern wird verwendet, um nach neuen Versionen zu suchen und sowohl WordPress-Core, Themes oder Plugins zu installieren und zu aktualisieren.

    Außerdem erhalte ich im debug.log folgende Fehler:

    [12-Jul-2021 08:47:01 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/update.php on line 143
    [12-Jul-2021 08:49:52 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/update.php on line 175
    [12-Jul-2021 09:02:04 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-admin/includes/update.php on line 143
    [12-Jul-2021 09:11:31 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/update.php on line 175
    [12-Jul-2021 09:28:29 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/update.php on line 410
    [12-Jul-2021 09:28:42 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/update.php on line 614
    [12-Jul-2021 09:28:48 UTC] PHP Warning:  Ein unerwarteter Fehler ist aufgetreten. Es scheint etwas bei WordPress.org oder mit dieser Serverkonfiguration nicht zu stimmen. Sollte das Problem weiter bestehen, nutze bitte die <a href="https://de.wordpress.org/support/forums/">Support-Foren</a>. (WordPress konnte keine sichere Verbindung zu WordPress.org herstellen. Bitte kontaktiere deinen Server-Administrator.) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/update.php on line 175

    Fehler Deine Website kann WordPress.org nicht unter 198.143.164.251 erreichen und gab den Fehler zurück: cURL error 28: Connection timed out after 10001 millisecondsd)

    Aufgefallen sind uns die Fehler erst nachdem uns starke Performance Probleme aufgefallen sind. Die Website lädt über 20 Sekunden.

    Aktuell aktiviert ist nur Divi und ein eigen erstelltes plugin.

    Anbei der Bericht für die Seite.
    Wir lassen unsere Seite auf einer AWS EC2 Instance laufen.

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: cURL error 28: Connection timed out after 10001 milliseconds
    
    ### wp-paths-sizes ###
    
    wordpress_path: /opt/bitnami/apps/wordpress/htdocs
    wordpress_size: 54,45 MB (57099547 bytes)
    uploads_path: /opt/bitnami/apps/wordpress/htdocs/wp-content/uploads
    uploads_size: 81,38 MB (85335773 bytes)
    themes_path: /opt/bitnami/apps/wordpress/htdocs/wp-content/themes
    themes_size: 42,00 MB (44035639 bytes)
    plugins_path: /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins
    plugins_size: 126,71 MB (132864064 bytes)
    database_size: 20,13 MB (21102592 bytes)
    total_size: 324,67 MB (340437615 bytes)
    
    ### wp-active-theme ###
    
    name: Divi (Divi)
    version: 4.9.4 (latest version: 4.9.7)
    author: Elegant Themes
    author_website: http://www.elegantthemes.com
    parent_theme: none
    theme_features: core-block-patterns, custom-background, automatic-feed-links, post-thumbnails, menus, title-tag, post-formats, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, editor-style, widgets
    theme_path: /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/Divi
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.7, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (1) ###
    
    Wohnwaagen PLZ Rechner: version: 1.0, author: Techlutions, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (18) ###
    
    Akismet Anti-Spam: version: 4.1.9, author: Automattic (latest version: 4.1.10), Automatische Aktualisierungen deaktiviert
    All-in-One WP Migration: version: 7.42, author: ServMask (latest version: 7.44), Automatische Aktualisierungen deaktiviert
    All in One SEO: version: 4.1.0.2, author: All in One SEO Team (latest version: 4.1.2.1), Automatische Aktualisierungen deaktiviert
    AMP: version: 2.0.11, author: AMP Project Contributors (latest version: 2.1.3), Automatische Aktualisierungen deaktiviert
    AWS for WordPress: version: 4.3.1, author: AWS Labs, WP Engine (latest version: 4.3.2), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Duplicator: version: 1.4.0, author: Snap Creek (latest version: 1.4.2), Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 7.17.0, author: MonsterInsights, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Jetpack by WordPress.com: version: 9.6.2, author: Automattic (latest version: 9.9), Automatische Aktualisierungen deaktiviert
    ManageWP - Worker: version: 4.9.8, author: GoDaddy, Automatische Aktualisierungen deaktiviert
    Rank Math SEO: version: 1.0.63, author: Rank Math (latest version: 1.0.67), Automatische Aktualisierungen deaktiviert
    Stop Spammers: version: 2021.8, author: Trumani (latest version: 2021.16), Automatische Aktualisierungen deaktiviert
    TaxoPress: version: 3.0.4.3, author: TaxoPress (latest version: 3.0.7.2), Automatische Aktualisierungen deaktiviert
    Three Column Screen Layout: version: 4.2, author: Chad Hovell, Automatische Aktualisierungen deaktiviert
    Wordpress Uploader: author: (undefined), version: 1, Automatische Aktualisierungen deaktiviert
    WP File Manager: version: 7.1.1, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    WP Mail SMTP: version: 2.7.0, author: WPForms (latest version: 2.9.0), Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1688
    imagemagick_version: ImageMagick 6.9.8-3 Q16 x86_64 2021-04-22 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 80M
    upload_max_filesize: 80M
    max_effective_size: 80 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 2 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 49152
    	imagick::RESOURCETYPE_MAP: 2 GB
    	imagick::RESOURCETYPE_MEMORY: 988 MB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.05
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-16-cloud-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.16 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 512M
    max_input_time: 300
    upload_max_filesize: 80M
    php_post_max_size: 80M
    curl_version: 7.76.0 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.24
    client_version: mysqlnd 7.4.16
    
    ### wp-constants ###
    
    WP_HOME: https://18.196.24.253
    WP_SITEURL: https://18.196.24.253
    WP_CONTENT_DIR: /opt/bitnami/apps/wordpress/htdocs/wp-content
    WP_PLUGIN_DIR: /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: true
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Ich bin für jede Hilfe dankbar!

    • Dieses Thema wurde geändert vor 4 Monaten, 4 Wochen von jrstechl.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Wenn du statt einer Domain eine URL mit einer IP-Adresse verwendest, kann das SSL-Zertifikat nicht geprüft werden. Das führt dann zu einem Fehler.

    Wieso gibst du keine Domain an? 🙂

    Ich vermute, du hostest die Seite auf einen Computer zuhause? Dann solltest du einen DynDNS-Service verwenden, der deinen wechselnden IP-Adresse „dynamisch“ einen Domainnamen zuweist. Oder du verzichtest auf die verschlüsselte Übertragung.

    Thread-Ersteller jrstechl

    (@jrstechl)

    Vielen Dank für deine Antwort.

    Die Seite ist grade noch im Aufbau und wir haben auf die schnelle eine Instance auf AWS gestartet. Die Seite wird im Anschluss auf den Server vom Kunden umgezogen.

    Ich verstehe nicht ganz was der Auslöser war, da die Seite nun seit längerem unter diese Ip läuft und die Fehlermeldungen erst heute aufgetreten sind. Mittlerweile sind die Performance Probleme auch nicht mehr aktuell.

    Können wir sonst noch etwas für dich tun? 🙂

    Thread-Ersteller jrstechl

    (@jrstechl)

    Hey, ich hab nun die IP adresse durch eine domain getauscht. Leider immer noch kein Erfolg. Das Problem ist, dass ich mit curl keine Verbindung aufbauen kann. Egal bei welcher Adresse, ich erhalte einen Connection timed out

    define( ‚WP_MEMORY_LIMIT‘, ‚768M‘ );

    das behebt den REST API Fehler nicht!

    Hey, ich hab nun die IP adresse durch eine domain getauscht.

    Prima. Und unter welcher URL finden wir die Website jetzt? 🙂

    Geh doch mal diese Anleitung durch und schau, ob das deiner eigenen Installation entspricht: https://crunchify.com/setup-wordpress-amazon-aws-ec2/

    Thread-Ersteller jrstechl

    (@jrstechl)

    Hey,

    Prima. Und unter welcher URL finden wir die Website jetzt? 🙂

    Wenn du auf die IP adresse gehst wirst du zu der Seite weiter geleitet.

    Geh doch mal diese Anleitung durch und schau, ob das deiner eigenen Installation entspricht: https://crunchify.com/setup-wordpress-amazon-aws-ec2/

    Ich habe tatsächlich eine vorgefertigte Instance von Bitnami genommen.

    define( ‚WP_MEMORY_LIMIT‘, ‚768M‘ );

    das behebt den REST API Fehler nicht!

    Was genau soll mir das sagen?

    LG

    Wenn du auf die IP adresse gehst wirst du zu der Seite weiter geleitet.

    Nein, werde ich nicht. Ich hätte sonst auch nicht nachgefragt.

    Thread-Ersteller jrstechl

    (@jrstechl)

    Du hast in Einstellungen > Allgemein die URL einmal mit http und einmal mit https angegeben, wobei nicht einmal ein SSL-Zertifikat vorhanden ist. Schau mal, wie sich die Website verhält, wenn du das korrigierst.

    Thread-Ersteller jrstechl

    (@jrstechl)

    Hi
    bei mir werden unter Einstellung -> Allgemeine beide URL (WordPress-Adresse (URL), Website-Adresse (URL) ) mit http:// angezeigt

    Dann stimmte einfach nur die von dir angegebene URL nicht.

    Thread-Ersteller jrstechl

    (@jrstechl)

    Falsche Protokoll sorry 🙂 WP_HOME und WO_SITEURL sind definiert in wp-config

    Es ist ein wenig mühsam, wenn man jede Information einzeln abfragen muss und dann auch noch falsche Auskünfte oder Gegenfragen gestellt bekommt.

    Wieso sind die Konstanten den überhaupt in der wp-config.php definiert? Arbeitest du mit einer Staging-/Produktiv-Umgebung? Falls nicht, gehört das nicht in die wp-config.php. Ich frag auch gar nicht erst, was da eingetragen ist … 

    Thread-Ersteller jrstechl

    (@jrstechl)

    Hallo,

    vorab: ich danke dir für deine Mühen, aber ich denke dein Ton bzw. Ausdrucksart ist grade nicht angemessen.
    Anscheinend haben wir beide eine andere Ansicht von „falsche Aukünfte“.

    Du hast mich nach der URL gefragt und meine Antwort war korrekt. Die Seite ist unter dem HTTP und dem HTTPS Protokoll erreichbar.
    Genau so wenig kann ich meinerseits keine Gegenfrage erkennen, außer

    Was genau soll mir das sagen?

    Nun ja, wie soll ich auf eine unverständliche Hilfeleistung reagieren? Ignorieren? Damit die eventuelle Lösung untergeht ? 🙂

    Wenn du alle Informationen auf einmal haben möchtest, dann frag Sie doch auch auf einmal ab? Woher soll ich wissen was dir hilft oder nicht?

    Zu Anfang habe ich dir bereits gesagt, dass die Website grade in Aufbau ist und wir auf die schnelle eine EC2 Instance laufen lassen haben. Dementsprechend haben wir die Daten angepasst, da die Seite aktuell immer auf die IP umgeleitet hat.

    Es melden sich verschiedene Personen an den Support, um Hilfe zu erhalten von jemanden der sich besser damit auskennt. Daher ist es sehr Schade, dass die Personen die sich besser damit auskennen sich von oben herab benehmen.

    Ich habe mich an das Forum gewendet um Hilfe von jemanden mit mehr Erfahrung zu erhalten – wenn es dir zu nervig ist Leuten in meiner Position zu helfen, warum bist du dann hier?

    Ich hoffe ich kann jetzt auf deine neutrale Hilfe setzen 🙂

    Liebe Grüße

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)