Support » Themes » Customizer lädt nicht bei Block-basierten Themen („kritischer Fehler“)

  • Gelöst Jost

    (@vocalexpress)


    Wenn ich versuche, den Customizer bei einem Block-Basierten Thema (Twenty Twenty-Two / Three, Flat Blocks) zu laden, das nicht aktiviert ist, gibt es den „white screen of death“ („Es gab einen kritischen Fehler auf Ihrer Website. Bitte überprüfen Sie den Posteingang Ihrer Website-Administrator-E-Mail-Adresse für weitere Anweisungen.“). Eine solche E-Mail kommt natürlich nicht. Der Debugger hilft mir auch nicht (s.u.). Das Problem tritt nur auf, wenn ich den Customizer bei Block-basierten Themes aufrufen möchte, die nicht aktiviert sind. Ich kann das Theme aktivieren und dann den Customizer öffnen. Ich habe bereits alle Plugins der Reihe nach deaktiviert.

    Anbei der Output im debug.log

    [28-Sep-2023 13:35:10 UTC] PHP Deprecated: The PSR-0 Requests_... class names in the Requests library are deprecated. Switch to the PSR-4 WpOrg\Requests\... class names at your earliest convenience. in /home/www/cooldocstuff/wp-includes/class-requests.php on line 24
    [28-Sep-2023 13:35:11 UTC] PHP Deprecated: The PSR-0 Requests_... class names in the Requests library are deprecated. Switch to the PSR-4 WpOrg\Requests\... class names at your earliest convenience. in /home/www/cooldocstuff/wp-includes/class-requests.php on line 24
    [28-Sep-2023 13:35:11 UTC] PHP Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /home/www/cooldocstuff/wp-includes/capabilities.php:877
    Stack trace: 0 /home/www/cooldocstuff/wp-includes/theme-previews.php(17): current_user_can(’switch_themes‘) 1 /home/www/cooldocstuff/wp-includes/class-wp-hook.php(310): wp_get_theme_preview_path(‚envo-shopper‘) 2 /home/www/cooldocstuff/wp-includes/plugin.php(205): WP_Hook->apply_filters(‚envo-shopper‘, Array) 3 /home/www/cooldocstuff/wp-includes/theme.php(317): apply_filters(‚template‘, ‚envo-shopper‘) 4 /home/www/cooldocstuff/wp-includes/theme.php(328): get_template() 5 /home/www/cooldocstuff/wp-includes/l10n.php(1306): get_template_directory() 6 /home/www/cooldocstuff/wp-includes/l10n.php(1331): _load_textdomain_just_in_time(‚ali2woo‘) 7 /home/www/cooldocstuff/wp-includes/l10n.php(185): get_translations_for_domain(‚ali2woo‘) 8 /home/www/cooldocstuff/wp-admin/includes/plugin.php(160): translate(‚Aliexpress Drop…‘, ‚ali2woo‘) 9 /home/www/cooldocstuff/wp-admin/includes/plugin. in /home/www/cooldocstuff/wp-includes/capabilities.php on line 877

    [28-Sep-2023 13:35:11 UTC] PHP Notice: Die Funktion is_embed wurde fehlerhaft aufgerufen. Bedingte Abfragen (Conditional Tags) funktionieren nicht, wenn die Beitrags-Abfrage (query_posts) noch nicht durchgeführt wurde. Sie geben dann immer ‚false‘ zurück. Weitere Informationen: Debugging in WordPress (engl.). (Diese Meldung wurde in Version 3.1.0 hinzugefügt.) in /home/www/cooldocstuff/wp-includes/functions.php on line 5905
    [28-Sep-2023 13:35:11 UTC] PHP Notice: Die Funktion is_search wurde fehlerhaft aufgerufen. Bedingte Abfragen (Conditional Tags) funktionieren nicht, wenn die Beitrags-Abfrage (query_posts) noch nicht durchgeführt wurde. Sie geben dann immer ‚false‘ zurück. Weitere Informationen: Debugging in WordPress (engl.). (Diese Meldung wurde in Version 3.1.0 hinzugefügt.) in /home/www/cooldocstuff/wp-includes/functions.php on line 5905

    Ich bin für jede Hilfe dankbar!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Wenn ich versuche, den Customizer bei einem Block-Basierten Thema (Twenty Twenty-Two / Three, Flat Blocks) zu laden, das nicht aktiviert ist

    Was meinst du bitte damit?

    Der Customizer dient der Einstellungen eines aktuell verwendeten Themes. Bei blockbasierten Themes wird statt des Customizers der Website-Editor angezeigt, bei dem du die Inhalte durch Hinzufügen individueller Blöcke nach Belieben ändern kannst.

    Durch Aufruf von wp-admin/customize.php kann der Customizer auch für blockbasierte Themes aufgerufen werden, bietet dann aber nur einen beschränkten Handlungsspielraum.

    Für ein Theme, dass nicht aktiviert ist, kann der Customizer nicht aufgerufen werden. Für aktive, blockbasierte Themes macht der Customizer nicht so richtig Sinn.

    Eine solche E-Mail kommt natürlich nicht.

    Das ist nicht „natürlich“, sondern hängt davon ab, wie früh der Fehler beim Durchlauf diverser Skripte auftritt. Tritt der Fehler sehr frühzeitig auf, kann die Routine zum Versenden einer Fehlermeldung mit Wiederherstellungslink nicht mehr versendet werden.

    PHP Deprecated …

    Bedeutet, dass veraltete Funktionen verwendet werden. Das ist zunächst einmal ein Hinweis, könnte bei künftigen PHP-Versionen aber zu Problemen führen.

    PHP Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() …

    Hier wird – vermutlich über das Theme Envo Shopper – eine WordPress-Funktion aufgerufen, bevor sie initialisiert ist. Das führt dazu, dass PHP einen Fehler ausgibt, die Funktion gäbe es nicht. Den Fehler solltest du im Supportforum des Plugins schildern: https://wordpress.org/support/theme/envo-shopper/

    Ich bin für jede Hilfe dankbar!

    Wir auch. Deshalb freuen wir uns immer, wenn Benutzer

    • den angehefteten Beitrag lesen, bevor sie einen Thread starten: Bevor du ein neues Thema (Thread) erstellst
    • uns mit den notwendigen Informationen versorgen, damit wir den Fehler einschätzen können und nicht raten müssen. Die URL zur Website hast du genannt, der Website-Bericht steht noch aus.
    Thread-Starter Jost

    (@vocalexpress)

    Vielen Dank für die Hinweise. Ich hätte wohl präziser formulieren müssen: Wenn ein Theme installiert, aber nicht aktiviert ist, kann man ja die „Live-Vorschau“ aktivieren. Das was sich dann öffnet, sieht ziemlich genau so aus wie der Customizer (und wird auch über …customize.php?… aufgerufen), darum hatte ich das so genannt. Das ist jedenfalls, was ich meine.

    Ich hatte schon Kontakt zum Support des Themes, dass ich dafür verantwortlich gemacht hatte (Flat Blocks). Da haben wir herausgearbeitet, dass der Fehler bei allen Block-basierten Themes auftritt und hat mich an den WordPress-Support verwiesen. Da wäre ich dann.

    Und hier der Zustandsbericht:

    ` wp-core
    
    version: 6.3.1
    site_language: de_DE_formal
    user_language: de_DE_formal
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 33
    dotorg_communication: true wp-paths-sizes wordpress_path: /home/www/cooldocstuff
    wordpress_size: 58,06 MB (60877440 bytes)
    uploads_path: /home/www/cooldocstuff/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /home/www/cooldocstuff/wp-content/themes
    themes_size: 10,13 MB (10618609 bytes)
    plugins_path: /home/www/cooldocstuff/wp-content/plugins
    plugins_size: 300,31 MB (314900447 bytes)
    database_size: 248,65 MB (260731272 bytes)
    total_size: 617,15 MB (647127768 bytes) wp-dropins (3) advanced-cache.php: true
    db.php: true
    object-cache.php: true wp-active-theme name: Envo Shopper (envo-shopper)
    version: 1.1.4
    author: EnvoThemes
    author_website: https://envothemes.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, title-tag, menus, custom-background, custom-logo, automatic-feed-links, custom-header, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, html5, editor-style, recommend-plugins, widgets
    theme_path: /home/www/cooldocstuff/wp-content/themes/envo-shopper
    auto_update: Aktiviert wp-themes-inactive (4) Flat Blocks: version: 1.3.12, author: XtremelySocial, Automatische Aktualisierungen aktiviert
    Twenty Twenty-One: version: 1.8, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.2, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.4, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (26) Aliexpress Dropship for Woocommerce: version: 1.19.16, author: MA-Group, Automatische Aktualisierungen deaktiviert
    BackWPup: version: 4.0.0, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.8.1, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Envo Shopper PRO: version: 1.7.1, author: EnvoThemes, Automatische Aktualisierungen deaktiviert
    Facebook for WooCommerce: version: 3.0.33, author: Facebook, Automatische Aktualisierungen aktiviert
    Flamingo: version: 2.4, author: Takayuki Miyoshi, Automatische Aktualisierungen aktiviert
    Gelato Integration for WooCommerce: version: 1.2.1, author: Gelato, Automatische Aktualisierungen aktiviert
    Germanized for WooCommerce: version: 3.13.5, author: vendidero, Automatische Aktualisierungen aktiviert
    Germanized for WooCommerce Pro: version: 3.7.3, author: vendidero, Automatische Aktualisierungen aktiviert
    Google Listings and Ads: version: 2.5.7, author: WooCommerce, Automatische Aktualisierungen aktiviert
    Jetpack: version: 12.6.2, author: Automattic, Automatische Aktualisierungen aktiviert
    Jetpack Boost: version: 2.1.1, author: Automattic - Jetpack Site Speed team, Automatische Aktualisierungen aktiviert
    Klarna Order Management for WooCommerce: version: 1.8.2, author: klarna, krokedil, Automatische Aktualisierungen aktiviert
    Klarna Payments for WooCommerce: version: 3.2.1, author: krokedil, klarna, automattic, Automatische Aktualisierungen aktiviert
    MailPoet: version: 4.29.0, author: MailPoet, Automatische Aktualisierungen aktiviert
    MailPoet Premium: version: 4.29.0, author: MailPoet, Automatische Aktualisierungen aktiviert
    One Stop Shop for WooCommerce: version: 1.4.0, author: vendidero, Automatische Aktualisierungen aktiviert
    reCAPTCHA Jetpack: version: 0.2.2, author: bozdoz, Automatische Aktualisierungen aktiviert
    Site Kit by Google: version: 1.110.0, author: Google, Automatische Aktualisierungen aktiviert
    W3 Total Cache: version: 2.5.0, author: BoldGrid, Automatische Aktualisierungen aktiviert
    WooCommerce: version: 8.1.1, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce Payments: version: 6.5.1, author: Automattic, Automatische Aktualisierungen aktiviert
    WooCommerce PayPal Payments: version: 2.3.1, author: WooCommerce, Automatische Aktualisierungen aktiviert
    WooCommerce Shipping & Tax: version: 2.3.5, author: WooCommerce, Automatische Aktualisierungen aktiviert
    WP DSGVO Tools (GDPR): version: 3.1.31, author: legalweb, Automatische Aktualisierungen aktiviert
    YITH WooCommerce Wishlist: version: 3.25.0, author: YITH, Automatische Aktualisierungen aktiviert wp-plugins-inactive (9) Advanced Product Search For WooCommerce: version: 1.1.1, author: aThemeArt, Automatische Aktualisierungen aktiviert
    Check & Log Email: version: 1.0.7, author: WPChill, Automatische Aktualisierungen aktiviert
    Elementor: version: 3.16.4, author: Elementor.com, Automatische Aktualisierungen aktiviert
    Fraud Prevention For Woocommerce: version: 2.1.6, author: theDotstore, Automatische Aktualisierungen deaktiviert
    Pinterest for WooCommerce: version: 1.3.10, author: WooCommerce, Automatische Aktualisierungen aktiviert
    Popup Maker: version: 1.18.2, author: Popup Maker, Automatische Aktualisierungen aktiviert
    Squirrly SEO (Newton): version: 12.3.12, author: Squirrly, Automatische Aktualisierungen aktiviert
    TI WooCommerce Wishlist: version: 2.7.4, author: TemplateInvaders, Automatische Aktualisierungen deaktiviert
    vendidero Helper: version: 2.2.1, author: vendidero, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 256M
    upload_max_filesize: 150M
    max_effective_size: 150 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 251 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 768
    imagick::RESOURCETYPE_MAP: 251 GB
    imagick::RESOURCETYPE_MEMORY: 125 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3 wp-server server_architecture: Linux 5.10.0-19-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: apache2handler
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 150M
    php_post_max_size: 256M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2023-09-28T17:58:39+00:00
    utc-time: Thursday, 28-Sep-23 17:58:39 UTC
    server-time: 2023-09-28T19:58:36+02:00 wp-database extension: mysqli
    server_version: 10.11.4-MariaDB-1:10.11.4+maria~deb11-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 134217728
    max_connections: 350 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/cooldocstuff/wp-content
    WP_PLUGIN_DIR: /home/www/cooldocstuff/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable jetpack site_id: 201800936
    ssl_cert: No
    time_diff: undefined
    version_option: 12.6.2:1695841312
    old_version: 12.6.1:1695322276
    public: Public
    master_user: #2 Jost
    is_offline_mode: off
    is_offline_mode_constant: off
    current_user: #2 Jost
    tokens_set: Blog User
    blog_token: SSemTRs&Y5yoE0UL3nyl8NB@jr#OdAg user_token: L$wp#k!#XZ)GzBN1jDq%C@d1l4iZQ^@
    version: 12.6.2
    jp_plugin_dir: /home/www/cooldocstuff/wp-content/plugins/jetpack/
    plan: free
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Sun, 16 Jan 2022 11:15:02 +0000","finished":"Sun, 16 Jan 2022 11:15:05 +0000","progress":{"options":{"finished":true},"functions":{"finished":true},"constants":{"finished":true},"users":{"total":"1","sent":1,"finished":true,"last_sent":"2"},"network_options":{"finished":true}},"config":{"options":true,"functions":true,"constants":true,"users":[2],"network_options":true}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"https:\/\/www.cooldocstuff.de","siteurl":"https:\/\/www.cooldocstuff.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass. google-site-kit version: 1.110.0
    php_version: 7.4.33
    wp_version: 6.3.1
    reference_url: https://www.cooldocstuff.de
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    verification_status: verified-non-site-kit
    connected_user_count: 1
    active_modules: site-verification, search-console, analytics, analytics-4, pagespeed-insights, tagmanager
    recoverable_modules: none
    required_scopes:
    openid: ✅
    https://www.googleapis.com/auth/userinfo.profile: ✅
    https://www.googleapis.com/auth/userinfo.email: ✅
    https://www.googleapis.com/auth/siteverification: ✅
    https://www.googleapis.com/auth/webmasters: ✅
    https://www.googleapis.com/auth/analytics.readonly: ✅
    https://www.googleapis.com/auth/tagmanager.readonly: ✅
    capabilities:
    googlesitekit_authenticate: ✅
    googlesitekit_setup: ✅
    googlesitekit_view_posts_insights: ✅
    googlesitekit_view_dashboard: ✅
    googlesitekit_manage_options: ✅
    googlesitekit_update_plugins: ✅
    googlesitekit_view_splash: ✅
    googlesitekit_view_authenticated_dashboard: ✅
    googlesitekit_view_wp_dashboard_widget: ✅
    googlesitekit_view_admin_bar_menu: ✅
    googlesitekit_view_shared_dashboard: ⭕
    googlesitekit_read_shared_module_data::["search-console"]: ⭕
    googlesitekit_read_shared_module_data::["analytics"]: ⭕
    googlesitekit_read_shared_module_data::["analytics-4"]: ⭕
    googlesitekit_read_shared_module_data::["pagespeed-insights"]: ⭕
    googlesitekit_manage_module_sharing_options::["search-console"]: ✅
    googlesitekit_manage_module_sharing_options::["analytics"]: ✅
    googlesitekit_manage_module_sharing_options::["analytics-4"]: ✅
    googlesitekit_manage_module_sharing_options::["pagespeed-insights"]: ✅
    googlesitekit_delegate_module_sharing_management::["search-console"]: ✅
    googlesitekit_delegate_module_sharing_management::["analytics"]: ✅
    googlesitekit_delegate_module_sharing_management::["analytics-4"]: ✅
    googlesitekit_delegate_module_sharing_management::["pagespeed-insights"]: ⭕
    enabled_features:
    adsenseSetupV2: ✅
    enhancedMeasurement: ⭕
    ga4Reporting: ✅
    gm3Components: ⭕
    newsKeyMetrics: ⭕
    userInput: ⭕
    search-console_shared_roles: none
    search-console_management: owner
    analytics_shared_roles: none
    analytics_management: owner
    analytics-4_shared_roles: none
    analytics-4_management: owner
    pagespeed-insights_shared_roles: none
    pagespeed-insights_management: all_admins
    search_console_property: https://www.cooldocstuff.de/
    analytics_account_id: 4964••••
    analytics_property_id: UA-4964••••••
    analytics_profile_id: 2669•••••
    analytics_use_snippet: yes
    analytics_4_property_id: 3967060••
    analytics_4_web_data_stream_id: 5830••••••
    analytics_4_measurement_id: G-W4••••••••
    analytics_4_use_snippet: yes
    tagmanager_account_id: 6005••••••
    tagmanager_container_id: GTM-MHQ••••
    tagmanager_amp_container_id: none
    tagmanager_use_snippet: yes

    Ich habe versucht, das zu reproduzieren:

    • Theme Twenty Fifteen aktiviert
    • Customizer aufgerufen
    • auf Theme wechseln geklickt.

    Hier wird mir eine Live-Vorschau für klassische Themes angeboten. Bei block-basierten Themes erhalte ich den Hinweis, dass diese den Customizer nicht unterstützen.

    Screenshot
    Zum Vergrößern bitte anklicken …

    Ich kann sie direkt aktivieren, wodurch allerdings der Customizer verlassen wird.

    Wenn das bei dir anders ist, kann es an einem der genutzten Plugins liegen. Um das zu herauszufinden, kannst du vorübergehend alle Plugins deaktivieren und prüfen, ob sich im Customizer etwas ändert.

    Thread-Starter Jost

    (@vocalexpress)

    Diesen Hinweis, dass bestimmte Themes nicht den Customizer unterstützen, bekomme ich leider nicht. Die Plugins hatte ich bereits eines nach dem anderen deaktiviert und keinen Unterschied bemerkt.

    Auf einer anderen Website von mir wird die Option „Live-Vorschau“ bei den entsprechenden Themes tatsächlich auch nicht angezeigt. Da kann man nur aktivieren. Jetzt habe ich aber gerade festgestellt, dass diese Seite noch nicht auf WP 6.3.1 aktualisiert war. Nachdem ich das nachgeholt habe, habe ich jetzt auch da das Problem, dass die Option „Live-Vorschau“ angeboten wird, aber zu dem Fehler führt. Es ist also ein Problem von 6.3.1!

    Ich kann das entsprechende Theme aktivieren und dann anpassen. Aber das ist natürlich sehr ungünstig, während Besucher die Seite nutzen. Ich hätte schon gerne eine Möglichkeit, alles anzupassen, bevor ich Live gehe. Ich könnte das jetzt höchstens nachts um 3 machen oder einen Wartungsmodus aktivieren…

    Es irritiert mich, dass der Entwickler nicht darauf gekommen ist, dass sein Theme keine Live-Vorschau zulässt…

    Vielen Dank für die Hilfe, ich denke, das Problem ist zwar nicht wirklich beseitigt, aber der Grund erkannt.

    • Diese Antwort wurde geändert vor 6 Monaten, 2 Wochen von Jost.
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Customizer lädt nicht bei Block-basierten Themen („kritischer Fehler“)“ ist für neue Antworten geschlossen.