Support » Allgemeine Fragen » Customizer: Meta ausblenden beim Blog

  • Gelöst berlin20

    (@berlin20)


    Moin, ich bräuchte mal bitte Hilfe.

    Mein News-Blog wird auf der statischen Newsseite angezeigt. Alles gut soweit.

    Im Blog und in den einzelnen Einträgen soll aber NUR das Datum, kein Name, keine Kategorie und keine Kommentaranzahl angezeigt werden.

    Wenn ich dies im Customizer entsprechend einstelle, ändert mir das Backend auch die Ansicht wie es sein soll. Auch nach dem speichern bleibt die Anzeige wie gewollt. Gehe ich dann aber aus dem Customizer und rufe die Website auf, sieht alles aus wie vorher.

    Ich benutze OceanWP und Elementor.

    Danke

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 23)
  • Hallo,
    das kannst du relativ einfach unter Design > Customizer > Zusätzliches CSS ausblenden. TEste mal bitte:

    li.meta-author, li.meta-cat, li.meta-comments {
        display: none;
    }

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller berlin20

    (@berlin20)

    Nee, funktioniert leider nicht.

    Es bleibt so wie es ist.
    Ich habe allerdings den Gegentest gemacht und mit dem css versucht die Einträge im Customizer unter Blogeinträge einzublenden und das ging nicht!
    Also scheint der css Eintrag schon was zu machen.

    Florin

    (@florinschweiz)

    Hi Berlin

    Leider verstehe ich deine Aussage nicht ganz, wo siehst du dann etwas und wo nicht? Kannst du es im Customizer mal bestätigen, speichern und dann beim Anschauen mal CTRL+F5 drücken? Dann wird auch der Cache noch gelöscht. Falls es dann immer noch nicht klappt, den Code bitte drin lassen und uns nochmals schreiben, eventuell sehen wir dann, ob er überschrieben wird o.ä.

    Bei mir klappts ohne Probleme:
    07.30.2021-19.40.36

    li.meta-author, li.meta-cat, li.meta-comments, li.meta-date::after {
        display: none;
    }

    @hage
    Ich nutze da noch zusätzlich li.meta-date::after als Selektor, sonst bleibt da ein Bindestrich übrig.

    Beste Grüsse

    Florin

    Hallo @florinschweiz,

    Ich nutze da noch zusätzlich li.meta-date::after als Selektor, sonst bleibt da ein Bindestrich übrig.

    gute Idee – das hatte ich nicht getestet. Aber sonst sollte das funktionionieren.
    Cache-Plugin deaktivieren und Cache löschen ist natürlich auch noch ein guter Hinweis.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller berlin20

    (@berlin20)

    Hallo @florinschweiz,

    „Leider verstehe ich deine Aussage nicht ganz, wo siehst du dann etwas und wo nicht?“

    Ist eigentlich ganz einfach: Im Customizer ist alles gut und auf der Website ist alles zu sehen.

    Ich habe den Cache jetzt nochmal geleert (hatte ich auch schon vorher gemacht und hätte ich vielleicht erwähnen sollen, sorry) und aus drei unterschiedlichen Rechnern PC/Mac und auf unterschiedlichen Browsern Safari, FF, Edge geöffnet. Der Anzeigefehler bleibt!

    Florin

    (@florinschweiz)

    Hi @berlin20

    Ist eigentlich ganz einfach: Im Customizer ist alles gut und auf der Website ist alles zu sehen.

    Immerhin verstehe ich nun die Ausgangslage.

    Kannst du uns bitte einen Screenshot von deinem Customizer senden?

    LG Florin

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von Florin.

    mit dem css versucht die Einträge im Customizer unter Blogeinträge einzublenden und das ging nicht

    ?

    Im Customizer ist alles gut und auf der Website ist alles zu sehen.

    Wenn wir es sogar ohne Zugang ausblenden können, dann, ja weiß auch nicht…?

    Thread-Ersteller berlin20

    (@berlin20)

    Wenn wir es sogar ohne Zugang ausblenden können, dann, ja weiß auch nicht…?

    Na ja, wenn ihr das aber auch erst ausblenden müßt, dann ist das ja uch nicht richtig. Es soll ja gleich beim Aufrufen nicht angezeigt erden.

    Nächste böode Frage: Wie bindet Ihr hier die Bilder ein?

    Florin

    (@florinschweiz)

    @berlin20
    Man kann hier nicht direkt Bilder einfügen, sondern einfach mithilfe eines externen Hostingdienstes. Ich nutze z.B. Screencast, da es bei SnagIt dabei ist…

    @pezi nutzt imgur

    Na ja, wenn ihr das aber auch erst ausblenden müßt, dann ist das ja uch nicht richtig. Es soll ja gleich beim Aufrufen nicht angezeigt erden.

    Ernstgemeinte Frage?

    PS: https://de.wordpress.org/support/topic/wie-kann-man-bilder-in-einen-forenbeitrag-einfuegen/

    Thread-Ersteller berlin20

    (@berlin20)

    Ernstgemeinte Frage?

    Ähm, für mein Hobby-Website-Verständnis schon, oder? Ich meine wenn ich in meinem WP eine bestimmte Ansicht abspeicher, dann sollte sie doch erst gar nicht angezeigt werden, also dürftet Ihr die auch gar nicht erst ausblenden können.

    Wenn ich Euch aber zu doof bin und hier nur Fragen von WP Profis beantwortet werden, dann entschuldigt bitte die Störung.

    Florin

    (@florinschweiz)

    @berlin20

    Ich würde dir gerne helfen, kannst du bitte einen Screenshot hochladen von deinem Customizer?

    LG Florin

    Sorry, @berlin20 das hab ich nicht so gemeint.
    Wir, die keinen Zugriff auf deine Site, Konfiguration, Admin, … haben können das nur für uns mit den Browsertools ausblenden.
    Das zeigt aber: Es geht! Es funzt genau mit den CSS Anweisungen, die sind korrekt.
    Für mich ist es also „richtig“, die unerwünschten Bereiche so auszublenden.

    Stimmt schon, wenn alles so funzt, wie du es dir vorstellst – dann sollte keiner dies mehr so ausblenden müssen/können.
    Jedenfalls greifen die CSS Regeln theoretisch; warum aber weder deine Customizer Einstellungen noch die eigenen CSS Regeln erhalten bleiben? Wenn Cache geleert, dann müsste es ja klappen.

    Wenn die Auskenner hier nur den Profis antworten würden, hätte ich noch keine bekommen. Ich bin auch nur ein ewiger WP-Lehrling. Aber einer der sich zeitweise hier wichtig macht.

    Sorry nochmal, gell …

    Thread-Ersteller berlin20

    (@berlin20)

    @pezi Ach na ja, ist schon gut. Das war halt missverständlcih ausgedrückt und ich bin auch irgendwie angefixt, weil das nicht funkt und ich mir das mit Logik aus meinem Wissen heraus im Moment überhaupt nicht erklären kann.

    Aber dafür hast Du das jetzt alles nochmal gut zusammen gefasst:

    Jedenfalls greifen die CSS Regeln theoretisch

    Deshalb hatte ich auch den Gegentest gemacht, schon alleine um meine Einträge gegen zu checken. Und mit den css Einträgen kann ich im Customizer die Werte eben nicht über das Blog-Menü einblenden. Was ja dann richtig wäre und ist.

    warum aber weder deine Customizer Einstellungen noch die eigenen CSS Regeln erhalten bleiben?

    So ist es: Ich kann es im Customizer einstellen, die Änderung sehen und auch ganz normal abspeichern. Aber irgendwie kommt die Abspeicherung nicht vom Backend ins Frontend mit rüber oder wie auch immer.

    Stimmt schon, wenn alles so funzt, wie du es dir vorstellst – dann sollte keiner dies mehr so ausblenden müssen/können.

    Und genau so verstehe ich das!

    Hallo,

    Na ja, wenn ihr das aber auch erst ausblenden müßt, dann ist das ja uch nicht richtig. Es soll ja gleich beim Aufrufen nicht angezeigt erden.

    Über die Developer Console (Aufruf mit F12 in Chrome) kann man entsprechende Anpassungen bezogen auf CSS vornehmen, die natürlich nur auf dem lokalen Rechner zu sehen sind, d. h. wenn ich die Anpassung vornehme, dann sehe auch nur ich diese Änderung im Frontend.

    Nächste böode Frage: Wie bindet Ihr hier die Bilder ein?

    Du hast offensichtlich noch nicht in unsere FAQ geschaut. Da findest du nicht nur bezogen auf diese Frage eine Antwort (darauf hatte ja bereits @pezi hingewiesen).

    Wenn ich Euch aber zu doof bin und hier nur Fragen von WP Profis beantwortet werden, dann entschuldigt bitte die Störung.

    Darum geht es nicht: Du solltest allerdings bedenken, dass wir hier eine Handvoll Freiwilliger sind, die in unserer Freizeit Probleme von WordPress-Anwendern versuchen zu lösen. Insofern verstehe ich nicht, wieso du so verschnupft reagierst, nachdem wir dir hier schon einige Antworten gegeben haben.
    Daher noch mal mein (nett) gemeinter Hinweis: Offensichtlich hast du die von mir angegebenen CSS-Regeln mit der Ergänzung von @florinschweiz z. Zt. aus welchen Gründen auch immer momentan nicht unter Design > Customizer > Zusätzliches CSS eingegeben. Erst dann kann die CSS-Regel auch entsprechend wirken und wir können uns das dann in der developer console ansehen.
    Möglicherweise kann man das über OceanWP und/oder Elementor auch direkt einstellen. Das kann ich dir allerdings leider nicht beantworten.
    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 23)
  • Das Thema „Customizer: Meta ausblenden beim Blog“ ist für neue Antworten geschlossen.