Support » Allgemeine Fragen » Customizer Problem

  • Hallo liebe Community,

    leider habe ich ein technisches Problem mit dem Customizer. Laut der Google Pagespeed Seite kommt bei mir folgende Fehlermeldung:

    Warnungen: Ein <link>-Element zum Vorabladen wurde für „https://www.meine-domain.de/?action=kirki-styles&ver=3.0.38“ gefunden, aber nicht vom Browser verwendet. Überprüfen Sie, ob das „crossorigin“-Attribut richtig verwendet wird.

    Die Meldung erscheint bei dem Vorschlag Ressourcen mit <link rel=preload> zu priorisieren.

    Nun weiß ich leider nicht, wo ich da suchen soll. Evtl. habe ich den Fehler gemacht unter Cuszomizer bei den CSS Einstellung den Befehl einen Font mit font display: swap; anzuweisen. Trotz den Hinweis ‚unknown property‘ habe ich den veröffentlich, aber danach wieder gelöscht. Was anderes kann ich mir leider da nicht vorstellen, da ich am Customizer sonst nichts verändert habe. Über Ratschläge wäre ich sehr dankbar.

    LG Christian

    • Dieses Thema wurde geändert vor 1 Monat, 1 Woche von  namenlos.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Bego Mario Garde

    (@pixolin)

    Das hätte ich mir gerne angeschaut, leider fehlt aber ein Link zur Website.
    Vielleicht magst du den nachträglich noch angeben?

    Ansonsten wäre es sicher besser, wenn du dich direkt an den Support des Entwicklers wendest: https://wordpress.org/support/plugin/kirki/

    Sorry, hab ich nachgetragen.

    Moderator Bego Mario Garde

    (@pixolin)

    Beim Pagespeed-Hinweis geht es darum, dass ein 3,5kb großes Stylesheet geladen wird, aber eigentlich nicht zum Einsatz kommt. Wieso das überhaupt im Frontend geladen wird, kann ich nicht sagen – dafür kenne ich das Framework und seine Einstellungsmöglichkeiten zu wenig. Mit der von dir beschriebenen Änderung am Stylesheet hat das nichts zu tun.

    Man kann sich da jetzt über die Performance-Einbuße im Millisekundenbereich aufregen und auf Github einen Issue melden oder nimmt es einfach als nicht optimal hin. Ich würde mich ja erstmal auf wichtigere Dinge konzentrieren, z.B. die nicht DSGVO-konforme Verwendung von Google Fonts (bekommst du mit Selfhosted Google Fonts weg).

    Du kannst deine Website auch mal in Google Chrome öffnen, Rechtsklick auf die Startseite > Element untersuchen > Lasche „Audits“ > Run Audits, da bekommst du noch eine ganze Reihe anderer Tipps. Die Analyse von GTMetrix finde ich auch immer sehr wertvoll. Aber die ganzen Tipps müssen sich auch umsetzen lassen – wenn dein Webhoster kein HTTP/2 anbietet (nachfragen!), nützt dir auch der Tipp nichts, das zu aktivieren.

    Was verwendest du denn jetzt fürs Caching?

    HTTP/2 bietet mein Webhoster noch nicht an und soll erst nächstes Jahr kommen. Für das Caching benutze ich Pagespeed Ninja, aber auch schon länger.

    Moderator Bego Mario Garde

    (@pixolin)

    So ist das eben mit den standardisierten Empfehlungen. „Nutzen Sie HTTP/2“ steht dann da und wenn mein Webhoster das nicht kann und ich außerdem Kunde 251 auf einem Shared Hosting Server bin, nützt mir das alles nichts.

    Die Frage nach dem Cache-Plugin war mehr aus Neugierde, sicher nichts „falsch“ daran. Lazy Loading (also das nachträgliche Laden von Bildern) wird ja auch eingesetzt – alles prima. Ich empfinde die Website auch nicht als langsam. Kurz: Mach dir nicht zuviel Gedanken um die Performance, man kann es da auch übertreiben.

    Danke für deine Hilfe, laut den Support von Kirki nutzt scheinbar mein Theme eine ältere Version von Customizer. Der Hinweis mit Google Font werde ich auch in Angriff nehmen und bedanke mich recht herzlich.

    LG Christian

    Nachtrag: Das Selfhosted Plugin hat leider nicht funktioniert und wird wohl scheinbar auch nicht weiter mehr gepflegt, da schon seit 3-4 WordPressversion nicht überprüft. Gilt nur zur Info. Hab es manuell umgesetzt.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)