Support » Allgemeine Fragen » Customizer und andere Features gehen nach Update 4.9 nicht mehr

  • Gelöst stephanpierre

    (@stephanpierre)


    Hallo liebe Community, ich heiße Stephan, bin seit heute Mitglied
    und freue mich extrem das es so ein Forum gibt wo Menschen sind, die so Hilfsbereit sind! Respekt und erstmal ein großes Danke in Vorraus!

    Nun zu meinem Problem:

    Ich baue gerade eine neue Website mit den Alo Shop Theme. Im eingebauten CSS Editor habe ich einige Styles verändert. Leider wusste ich bis dato nicht das es viel besser ist vorher ein child-Theme zu erstellen wenn ich Änderungen machen will, da die Änderung bei einem Update sonst verloren gehen.

    Heute kam das WordPress Update 4.9 raus das ich natürlich sofort aktualisiert haben. Danach gibt der Customizer und alle Widgets im Backend nicht mehr…ich schätze das trifft nich auch mehr Buttons zu. Ich dachte erst es liegt an dem Custom CSS, aber der müsste ja jetzt eig gelöscht worden sein.

    Da ich ein kompletter Laie bin und nicht noch mehr „kaputt“ machen will wollte ich hier mal um Rat fragen? Was ist eure Experten Meinung, was jetzt am besten zu tun ist? Ich habe mir im Strato Paket im Kundenlogin auch mal die Error Logfiles angeschaut wo auch vieles drin stand…unter anderem Fehler in der settings.php – Die Error Files kann ich bei bedarf auch nachreichen

    Außerdem habe ich folgendes bereits getan:

    – Installation wiederholt, ohne Erfolg
    – Alle Plugins deaktiviert
    – Aufs Standard Theme gewechselt
    – Debug Mode eingestaltet aber ich wusste nicht wonach ich da genau suchen muss
    – Downgrade auf 4.8 versucht (Ich ging nach dieser Anleitung vor:http://derappelt.de/anleitung-downgrade-wordpress-bsp-version-3-6-auf-4/

    leider ging danach garnix mehr :/

    Ich hoffe ihr könnt mir helfen. Danke im Vorraus für eure Hilfe und Expertentipps

    Liebe Grüße,
    Stephan

    PS: Ich weiß es hatten bereits andere im Forum dieses Problem nur ist die Ursache in meinem Fall soweit ich es Einschätzen kann eine andere als bei den anderen. Korrigiert mich wenn ich falsch liege 🙂

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo @stephanpierre,

    das ist natürlich ärgerlich und sollte nicht so sein.

    Ein Downgrade ist immer der falsche Weg, weil Updates auch Sicherheitslücken schließen sollen, die du durch ein Downgrade wieder herstellst.

    Kannst du bitte erst einmal diesen Beitrag lesen und schauen, ob dir einer der Hinweise weiterhilft?

    Schau auch mal in den Entwickler-Tools deines Browsers nach möglichen Fehlermeldungen: Customizer öffnen > Rechtsklick auf die Webseite > Untersuchen > Tab Console, dort nach rot markierten Fehlermeldungen schauen.

    Hallo Bego Mario Garde,

    danke für die schnelle Antwort!

    Habe erst alle Plugins deaktiviert und dann den Tipp mit dem Entwickler-Tool beherzigt! Tasächlich hatte WordPress ein Problem mit der Sprache.

    Nachdem ich wie Marius L. J.(@clorith) empfahl die Benutzer Sprache umstellte, ging alles wieder!
    Ich verstehe zwar nicht warum diese Java Script Fehler aufgrund der Benutzersprache auftauchte aber bin froh das es so schnell zu lösen war.

    Viele Dank Bego Mario Garde 🙂

    @stephanpierre
    Noch ein Hinweis zu Child Themes/Custom CSS:
    Wenn du Änderungen in einem Theme selbst vornimmst, werden diese Änderungen beim nächsten Theme-Update überschrieben. Ein Child Theme kann eine (aufwändige) Lösung sein, weil nur das Parent Theme überschrieben wird. Child Themes erfordern aber zusätzliche Aufmerksamkeit, etwa wenn sich im Parent Theme ein Funktionsname ändert oder eine Sicherheitslücke in einem Template behoben wird, dass du (in seiner alten Version) vorher ins Child Theme kopiert hast.

    Der Customizer enthält ein Eingabefeld für Zusätzliches CSS, mit dem selbst CSS-Regeln in einem Child Theme überschrieben werden können. Die Einträge in diesem Feld sind in der Datenbank abgelegt und sollten eine Aktualisierung problemlos überstehen. Neu in WordPress 4.9 ist der Editor zur Bearbeitung dieser Regeln, der nun auch auf Syntax-Fehler hinweist.

    Alles klar,

    viele Dank für diese Extrainfo.

    Noch einen schönen Tag

    Ich hatte auch das Problem, dass nach dem Update auf WordPress 4.9 Funktionalitäten nicht mehr vorhanden waren (Customizer, Media-Center). Ein Änder der Spracheinstellung führte hier zum Ziel (WordPress 4.9, Theme Twenty Fourteen). Die Fehler wurden wohl durch die Datei(en) für die formale Sprachversion „Deutsch (Sie)“ verursacht. Mit Deutsch und amerikanischem Englisch funktioniert alles. Gruß Jürgen

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Die Fehler wurden wohl durch die Datei(en) für die formale Sprachversion „Deutsch (Sie)“ verursacht.

    Nein. Das Problem liegt an einem anderen Skript, welches mit der invaliden Sprachangabe „de_DE-informal“ (oder nl_NL-informal, etc.) nicht zurecht kommt. Die Übersetzungsdateien selbst sind nur ganz normale Übersetzungsdateien, die soetwas nicht anrichten können.

    Gruß, Torsten

    Der Cuszomizer kann plötzlich keine Änderungen mehr speichern. Seite dem Update ist es schon ein paar Tage her, ebenfalls andere ausgeführte Updates.

    @radarin
    … und was ist jetzt deine Frage?

    … und was ist jetzt deine Frage?

    Naja, das ist erst mal ne Feststellung 😉 Daraus resultieren mögliche Fragen wie,

    -Ein Problem von WP 4.9? (deshalb hab ich auf diesen Beitrag geantwortet)
    -Kann ich was dagegen tun?
    -Kann ich das CSS zur Not auch direkt in die DB schreiben? Tabelle? Spalte?

    Zur Sicherheit noch die Frage, kann der Fehler im Template entstanden sein? Da ich ja an der Optik rum schraube, bis zum Wochenende noch ohne Child. Beim speichern ist mir aufgefallen, wird jeweils die template-tag.php verarbeitet.

    Was mir auch gerade noch auffällt, im Backend beim Bearbeiten des Beitrags, grossen Textfeld, liegt da die Zeile danke für dein Vertrauen in WordPress mitten auf dem Feld im Weg. Stört da absolut. Und Github-URLs werden bei visuell nicht mehr so angezeigt wie später im Beitrag. Könnten Zeitlich irgendwie zusammen hängen.

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monate von  radarin.

    Kannst du diese Fragen dann bitte in einem neuen Thread stellen?
    Es hilft dem ursprünglichen Fragesteller vermutlich wenig, wenn er nach Klärung seiner Frage laufend weitere Informationen erhält, die ihn nicht betreffen.

    Eine Frage = ein Thread.
    Neue Frage? Neuer Thread!
    (siehe FAQ)

    Deshalb schließe ich jetzt den Thread hier.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Customizer und andere Features gehen nach Update 4.9 nicht mehr“ ist für neue Antworten geschlossen.