Support » Installation » Customizer und Editor Problem

  • Gelöst therat

    (@therat)


    
    ### wp-core ###
    
    version: 6.0.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: C:...glib-updater
    wordpress_size: 50,72 MB (53182497 bytes)
    uploads_path: C:...glib-updater/wp-content/uploads
    uploads_size: 14,00 B (14 bytes)
    themes_path: C:...glib-updater/wp-content/themes
    themes_size: 11,53 MB (12089471 bytes)
    plugins_path: C:...glib-updater/wp-content/plugins
    plugins_size: 17,31 MB (18154607 bytes)
    database_size: 2,44 MB (2555904 bytes)
    total_size: 82,00 MB (85982493 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Neve (neve)
    version: 3.4.3
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: core-block-patterns, hfg_support, widgets-block-editor, title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, customize-selective-refresh-widgets, custom-background, align-wide, editor-color-palette, fl-theme-builder-headers, fl-theme-builder-footers, fl-theme-builder-parts, header-footer-elementor, lifterlms-sidebars, lifterlms, service_worker, starter-content, menus, widgets
    theme_path: C:...glib-updater/wp-content/themes/neve
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (4) ###
    
    Contact Form 7: version: 5.6.3, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts Reloaded: version: 2.25.7, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.9, author: Automattic, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.8, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 5.0, author: Automattic (latest version: 5.0.1), Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 2M
    max_effective_size: 2 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Windows NT 10.0 AMD64
    httpd_software: Microsoft-IIS/10.0
    php_version: 8.0.19 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 2M
    php_post_max_size: 8M
    curl_version: 7.76.1 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.8-MariaDB
    client_version: mysqlnd 8.0.19
    max_allowed_packet: 16777216
    max_connections: 151
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: C:...glib-updater/wp-content
    WP_PLUGIN_DIR: C:...glib-updater/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### neve ###
    
    api: Ja
    child: Nein
    customizer_css: Nein
    
    

    Hallo Community,

    ich bin ein Neuzugang in WordPress und bräuchte eure Hilfe.
    Ich nutze WordPress über Hosteurope und habe es über das Plesk automatisch installiert. Die Einrichtung und alles verlief Problemlos und recht simpel.

    Leider wird bei mir im Editor, den Widgets und im Cutomizer lediglich die HTML Strucktur des Dokuments angezeigt, was ein bearbeiten eigentlich unmöglich gesaltet. (siehe Screenshot).

    Screenshot

    Was habe ich zur Lösung versucht?
    – Neve Theme Installiert
    – Javscript Einstellungen überprüft (alles an)
    – Aktivierung von Debugging Einstellungen
    – Komplettes entfernen und neu installieren der Seite
    – „Visuellen Editor nicht benutzen“ ist deaktiviert
    – anderen Browser verwendet
    – anderen Computer verwendet
    – ClassicEditor Plugin installiert (Seiten editieren zeigt dann zumindest irgendeine Art von Editor. Widget und Customizer aber nicht)
    – bis zum verderben gegooglet

    Leider gehen mir nun die Ideen aus und ich hoffe Ihr könnt mir helfen.

    Vielen Dank im vorraus.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das sieht so aus, als wenn CSS-Dateien nicht geladen werden, warum auch immer. Das könntest du mal überprüfen, in dem du in der Konsole im Browser (F12-Taste) nachsiehst.

    Hallo,
    wenn du die URL oben nennst, können wir uns das auch ansehen – oder wird die Website korrekt angezeigt?

    Vielleicht hilft es auch, wenn du die PHP-Version auf 7.4.x über den Kundenaccount des Hosters umstellst.

    Unter Dashboard > Aktualisierungen findest du unter „Du benutzt die aktuelle Version von WordPress.“ den Button „Version 6.0.2 erneut installieren“. Das wäre eine weitere Option.

    Viele Grüße
    Hans-Gerd

    CSS, ja denk ich auch.
    Was sagt der Hoster dazu?
    Könnte Plugins deaktivieren was bringen?
    Nebenbei evtl. auch zu bedenken: Apache/Nginx statt ISS? PHP 7.4 statt 8 probieren?

    Thread-Starter therat

    (@therat)

    Vielen Dank für die schnellen Antworten.

    @bscu Die .css Files in der Console können korrekt geöffnet werden. Nur bei dieser php Datei „https://softdot.studio/glib-updater/wp-admin/load-styles.php?c=1&dir=ltr&load%5Bchunk_0%5D=dashicons,admin-bar,wp-components,wp-widgets,wp-block-editor,wp-nux,wp-reusable-blocks,wp-editor,common,forms,wp-reset-editor-st&load%5Bchunk_1%5D=yles,wp-block-library,wp-editor-classic-layout-styles,wp-block-library-theme,wp-edit-blocks,wp-edit-widgets,wp-format-library,ad&load%5Bchunk_2%5D=min-menu,dashboard,list-tables,edit,revisions,media,themes,about,nav-menus,wp-pointer,widgets,site-icon,l10n,buttons,wp-auth-che&load%5Bchunk_3%5D=ck&ver=6.0.2 gibt er mir ein „Server Error 403 Forbidden“ aus. Muss ich den Zugriff auf diese Datei noch einmal explizit gewähren? Aber eigentlich sollte solch eine Freigabe (wenn erforderlich) bei der Installation gegeben sein.

    @hage Das Problem besteht nur in den Editoren. Die Seiten werden bei normalem Webseiten ganz normal und korrekt dargestellt.
    Ich habe den Server vor der 2. neuinstalltion von WordPress von 7.4 auf 8 geupdatet. Dadurch sind einige PHP Fehlermeldungen die zusätzlich noch vorhanden waren verschwunden. Leider wurde das Problem dadurch aber nicht gelöst.
    „Version 6.0.2 über Dashboard neu installieren“ hat leider auch keinen Unterschied gemacht 🙁

    @kurapika HostEurope habe ich diesbezüglich noch nicht kontaktiert. Es handelt sich um einen Virtual Server mit Plesk, von daher bin ich für das meiste selbst verantwortlich 😉
    Ich habe bereits versucht verschiedene Plugin-Paket-Versionen von WordPress zu installieren. Darunter auch die Grundversion ohne jegliche Plugins. Leider bei allen keinen Unterschied.
    „Apache/Nginx statt ISS?“: Dürfte das wirklich einen Unterschied bei WordPress machen? Ich habe auf den Domains bereits Websites laufen und würde ungern vermeiden das es mit den bestehenden zu Komplikationen kommt 😉 Wenn du aber denkst das es ausschlaggebend sein kann werde ich es mir einmal näher ansehen.

    Wie der Name der Datei (load-styles.php) schon sagt, werden damit Styles geladen. Wenn diese Datei nicht ausgeführt werden darf, dann hast du genau das Problem. Kontrolliere doch mal die Dateirechte.

    Thread-Starter therat

    (@therat)

    @bscu Super jetzt läuft es!
    Dateiberechtigungen waren korrekt gesetzt. Habe dann noch einmal explizit nach dem Problem gegooglet und dabei auf folgenden Forumsbeitrag gestoßen:

    https://wordpress.stackexchange.com/questions/163802/no-css-being-loaded-on-backend

    Wie beschrieben habe ich die Zeile: „define( ‚CONCATENATE_SCRIPTS‘, false );“ in die wp-config.php vor den require Aufruf eingebunden. Seite aktualisiert und es läuft.

    Vielen Dank für eure Hilfe 🙂

    Beste Grüße

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)