Support » Allgemeine Fragen » Customizer: veröffentlichen funktioniert nicht

  • Gelöst iriteser

    (@iriteser)


    Hallo

    ich habe mittlerweile so ziemlich alles zu dem Thema gelesen, nur leider besteht mein Problem immer noch.

    Hintergrund:
    Ich bin vor drei Wochen auf einen neuen Server umgezogen (deutlich günstigeres Paket) und nach diversen Problemen habe ich letztendlich WordPress (5.5.1) über die EasyApps (1Blu) installiert, alle meine Plugins neu installiert und natürlich auch eine neue Datenbank erzeugt. Die alten Posts etc habe ich händisch jeweils als SQL-Tabelle importiert.

    Mittlerweile funktioniert auch alles (mal abgesehen von den Umlautproblemen beim Bilder hochladen auf den FTP-Server) – nur der Customizer will nicht.

    Ich benutze das Theme Koji von Anders Noren schon länger, es gab da nie Probleme.

    Jetzt tritt folgendes auf:

    Ich kann meine Änderungenim Customizer als Entwurf speichern. Auch planen, nur leider wird die geplante Änderung nie veröffentlicht. Veröffentlichen funktioniert überhaupt nicht.

    Meine Vermutung: mein neues Paket hat keine Cronjobs – kann es damit zusammenhängen?

    Aktuell ist die Website im „Baustellenmodus“

    Sämtliche Versuche mit dem Health Check Plugin, Standardtheme (wird auch nicht veröffentlicht) etc haben nicht gefruchtet.

    Noch eine Beobachtung: wenn das Planungsdatum verstrichen ist und ich auf den Customizer klicke, bekomme ich eine Seite „Deine geplanten Änderungen wurden gerade veröffentlicht“, deklariert als WordPress Fehler. Klicke ich ein paar Mal auf den Link darunter, lande ich wieder im Customizer – veröffentlicht wurde aber nichts.

    Ich bin für jede Hilfe dankbar!!!

    LG Irit

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Mit dem eingeschalteten Wartungsmodus lässt sich wenig über die Website herausfinden. Verwendest du die neueste Version des Themes? Hast du das Plugin Enable jQuery Migrate Helper ausprobiert?

    Da nicht jeder Webhoster seinen Kunden die Einrichtung eigener Cronjobs anbietet, verwendet WordPress einen Pseudo-Cron: sobald ein Webseitenbesucher die Webseiten aufruft, wird geprüft, ob zwischenzeitlich Aufgaben anstanden. Die werden dann unmittelbar (aber unter Umständen erst eine Weile nach dem ursprünglich geplanten Termin) ausgeführt. Die Meldung „Deine geplanten Änderungen wurden gerade veröffentlicht“ soll darauf hinweisen.

    Wenn du im Customizer Änderungen vornimmst, schau doch mal in die Entwicklertools deines Browsers (Taste F12): werden in der Konsole Fehlermeldungen ausgegeben? Welche?

    Thread-Ersteller iriteser

    (@iriteser)

    Erstmal danke für die schnelle Antwort!

    Ich habe den Wartungsmodus noch an, weil ich recht viele Leserinnen habe (um die 4000-5000 Aufrufe pro Tag) und erstmal alles aufräumen wollte.

    Zu den Cronjobs: habe hier schon eifrig im Forum gelesen und überlege, ob ich mir selbst einen einrichte. Äh, ja, da muss ich dann erstmal herausbekommen wie.

    Ich habe erstmal mit F12 auf der Website geschaut, beim Reload wird ein Fehler ausgegeben:

    GET https://iriteser.de/wp-content/themes/koji/assets/svg/chevron-down.svg 404

    das scheint mir aber nicht so tragisch zu sein, ich schaue mal, wo die Datei abgeblieben ist

    Ich habe jetzt noch einen Fehler: meine geplanten Änderungen sind nicht veröffentlicht worden, sondern einfach weg, wenn ich in den Customizer gehe.

    Also nochmal die Änderungen gemacht. KLick auf „veröffentlichen“ macht nichts. Kurz eine „Eieruhr“, aber keine Änderungen sichtbar. Wenn ich auf planen gehe und etwas in der nächsten Minute einstelle, sagt er dann nach einer Minute „veröffentlicht“ – ist es aber nicht.

    Was ich auch merkwürdig finde: vor meinem Umzug hatte ich diese Planmöglichkeit nicht (oder Entwurf abspeichern). Ich hatte den Blog 2015 aufgesetzt und immer alles aktualisiert, also auch unter Version 5.5.0 hatte ich derlei nicht.

    Nun ja, lange Rede, kurzer Sinn: e gibt wohl zwei Möglichkeiten.

    1) Wartungsmodus ausschalten und mal gucken, was passiert

    2) wp-cron enablen und händisch anstoßen

    Oder 3) an der functions.php so rumspielen,d ass die von mir gewünschten Änderungen erzwungen werden. Aber das ist ja auch keine Lösung.

    Thread-Ersteller iriteser

    (@iriteser)

    noch eine neue Sache für mich: ich kann Beiträge nicht sofort veröffentlichen. Da kommt eine PLanung in der Vergangenheit, dann die fehlgeschlagen Meldung und mit etwas Glück wird der Beitrag dann über aktualisieren veröffentlicht.

    Wie gesagt ist ein Cron-Job nicht zwingend erforderlich. Wenn du ihn trotzdem einrichten willst, findest du hier eine Anleitung: https://kinsta.com/de/wissensdatenbank/wp-cron-deaktivieren/

    Du bist auf das Plugin Enable jQuery Migrate Helper nicht weiter eingegangen. Schon ausprobiert?

    Thread-Ersteller iriteser

    (@iriteser)

    Ehrlich gesagt habe ich nicht so ganz verstanden, was das Plugin macht… aber probieren werde ich es gleich mal

    kinsta hatte ich auch schon entdeckt (übrigens auch deinen sehr guten Artikel zur manuellen Installation von WordPress).

    Ich habe laut Statify diverse Aufrufe auf der Website, aber weder der letzte Beitrag von 21:39 noch die CUstomizer Änderungen sind live gegangen. Auf der Console keine Fehler.

    Melde mich noch einmal, wenn ich das Plugin installiert habe

    Thread-Ersteller iriteser

    (@iriteser)

    hm, keine Änderung. Kann weder einen Beitrag veröffentlichen noch werden die Änderungen über den Customizer veröffentlicht

    Allmählich weiß ich keinen Rat mehr

    Erst einmal Hallo,

    ich habe mich neu angemeldet, nur für dieses Thema.

    Ich bin ebenfalls bei 1blu und habe das geleiche Problem. Im Backend komme ich nicht mehr auf den Customizer. Der Fehler „Deine geplanten Änderungen wurden gerade veröffentlicht“ erscheint.

    Vorher hatte ich auch das Problem, dass Änderungen nicht veröffentlicht werden sondern nur geplant. Wenn man den Customizer verlässt, erscheint die Meldung, ob man die Seite wirklich ohne Änderungen verlassen möchte.

    Bei anderen Hosting-Anbietern, wie z.B. netcup, habe ich das Problem nicht.

    MfG

    Thread-Ersteller iriteser

    (@iriteser)

    das ist ja mal interessant – darf ich fragen, welches Paket du hast? Ich hatte vorher „Homepage Professional“ (überhaupt keine Probleme) und bin jetzt bei „Homepage A“ (eine Menge Probleme)

    Hallo,
    @yokyok2: besser ist es, wenn du ein neues Thema mit Verlinkung auf dieses Thema beginnst, siehe FAQ (A-8.).
    Insbesondere bei der Übermittlung des nachfolgend angesprochenen Berichts wird es sonst ziemlich schwierig, jeweils adäquat darauf zu antworten.

    @iriteser: Wenn das Problem bei dem speziellen Hoster auftaucht, würde ich ggfs. mal mit dem Hoster Kontakt aufnehmen.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße,
    Hans-Gerd

    Thread-Ersteller iriteser

    (@iriteser)

    Morgen Hans-Gerd, danke für die Hinweise, den Provider kontaktiere ich heute noch.

    Zum Websitezustand, den Button kannte ich noch nicht – noch ein guter Tipp 😉

    Noch eine Anmerkung: Ausnahmsweise habe ich nichts an irgendwelchen originären WP Dateien geändert, nur die .htaccess für https umgestellt

    Habe das gleich mal durchgelesen und eine Sache verstehe ich nicht: da steht
    ### wp-constants ###

    WP_HOME: undefined
    WP_SITEURL: undefined

    Das ist aber im Backend definiert. Kann das der Fehler sein?

    Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /hp/ct/ab/ys/www/iriteser
    wordpress_size: 44,40 MB (46554297 bytes)
    uploads_path: /hp/ct/ab/ys/www/iriteser/wp-content/uploads
    uploads_size: 3,65 GB (3921326013 bytes)
    themes_path: /hp/ct/ab/ys/www/iriteser/wp-content/themes
    themes_size: 2,32 MB (2433906 bytes)
    plugins_path: /hp/ct/ab/ys/www/iriteser/wp-content/plugins
    plugins_size: 25,61 MB (26852025 bytes)
    database_size: 199,45 MB (209135448 bytes)
    total_size: 3,92 GB (4206301689 bytes)
    
    ### wp-active-theme ###
    
    name: Koji (koji)
    version: 2.0.9
    author: Anders Norén
    author_website: https://www.andersnoren.se
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, custom-background, post-thumbnails, custom-logo, title-tag, menus, html5, align-wide, editor-color-palette, editor-font-sizes, widgets, editor-style
    theme_path: /hp/ct/ab/ys/www/iriteser/wp-content/themes/koji
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.5, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    
    ### wp-plugins-active (19) ###
    
    Antispam Bee: version: 2.9.2, author: pluginkollektiv
    Block Bad Queries (BBQ): version: 20200811, author: Jeff Starr
    Borlabs Cookie - Cookie Opt-in: version: 2.2.10, author: Benjamin A. Bornschein, Borlabs
    Classic Editor: version: 1.6, author: WordPress Contributors
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer
    Featured Image In Rss Feed: version: 2.2, author: Dinesh Karki
    Google XML Sitemaps: version: 4.1.1, author: Auctollo
    Health Check & Troubleshooting: version: 1.4.5, author: The WordPress.org community
    Prosodia VGW OS: version: 3.24.4, author: Prosodia – Verlag für Musik und Literatur
    Remove exif and metadata: version: 1.0, author: Edgar Kotov
    Remove noreferrer: version: 1.2.0, author: Alexander Kadyrov
    Simple Image Sizes: version: 3.2.1, author: Rahe
    SiteOrigin CSS: version: 1.2.10, author: SiteOrigin
    Statify: version: 1.8.0, author: pluginkollektiv
    Title and Nofollow For Links: version: 1.10, author: WPKube
    WordPress Editorial Calendar: version: 3.7.7, author: Colin Vernon, Justin Evans, Joachim Kudish, Mary Vogt, and Zack Grossbart
    WP GDPR Compliance: version: 1.5.4, author: Van Ons
    WP Maintenance Mode: version: 2.2.4, author: Designmodo
    WP Open Comment Links in New Window: version: 1.2, author: Dipak C. Gajjar
    
    ### wp-plugins-inactive (2) ###
    
    Better Search Replace: version: 1.3.3, author: Delicious Brains
    Broken Link Checker: version: 1.11.14, author: WPMU DEV
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-112-generic x86_64
    httpd_software: Apache
    php_version: 7.2.24-0ubuntu0.18.04.6 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_size: 2048M
    php_post_max_size: 2048M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Thu, 24 Sep 2020 06:14:55 GMT
    	server: Apache
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://iriteser.de/wp-json/>; rel="https://api.w.org/"
    	strict-transport-security: max-age=31536000
    	upgrade: h2,h2c
    	vary: Accept-Encoding
    	content-encoding: gzip
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.31-0ubuntu0.18.04.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /hp/ct/ab/ys/www/iriteser/wp-content
    WP_PLUGIN_DIR: /hp/ct/ab/ys/www/iriteser/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Die PHP-Version ist veraltet. Stell das bitte mal im Kundenmenü auf PHP 7.4 um. Ein anderer Nutzer mit Website bei 1blu hat berichtet, dass ihm das geholfen hat: https://de.wordpress.org/support/topic/aenderungen-werden-geplant-statt-veroeffentlicht-seiten-beitraege/#post-88493

    Hallo,

    Habe das gleich mal durchgelesen und eine Sache verstehe ich nicht: da steht
    ### wp-constants ###
    WP_HOME: undefined
    WP_SITEURL: undefined

    nein, das ist völlig ok und stellt in deinem Fall kein Problem dar. Weitere Infos findest du z. B. hier
    Auf den ersten Blick sehe ich hier keine Probleme.
    Viele Grüße
    Hans-Gerd

    Nachtrag: Bego war flotter 😉 und die alte PHP-Version hatte ich übersehen.

    Thread-Ersteller iriteser

    (@iriteser)

    ok, dann aktualisiere ih mal… ich werde berichten

    Ich kann es nicht oft genug sagen: DANKE für eure unkomplizierte und schnelle Hilfe!!!!!

    Thread-Ersteller iriteser

    (@iriteser)

    Kleines Update:

    PHP-Version ist auf 7.4
    Customizer sagt: es wurde veröffentlicht (auch in time, liegt vermutlich daran, dass derzeit viele auf die Website zugreifen)
    Wurde es nur leider nicht, derselbe Stand wie vorher und meine Änderungen sind weg

    Habt ihr noch Ideen?

    • Diese Antwort wurde geändert vor 1 Jahr, 7 Monaten von iriteser.
    Thread-Ersteller iriteser

    (@iriteser)

    Kommando zurück!!!

    Gerade nochmal die Änderungen eingegeben, auf „Veröffentlichen“ geklickt und siehe da: es hat funktioniert

    Ich tippe auf die PHP-Version

    Nochmal: DANKE DANKE DANKE!!!!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 26)
  • Das Thema „Customizer: veröffentlichen funktioniert nicht“ ist für neue Antworten geschlossen.