Support » Allgemeine Fragen » Customizer: veröffentlichen funktioniert nicht

  • Gelöst iriteser

    (@iriteser)


    Hallo

    ich habe mittlerweile so ziemlich alles zu dem Thema gelesen, nur leider besteht mein Problem immer noch.

    Hintergrund:
    Ich bin vor drei Wochen auf einen neuen Server umgezogen (deutlich günstigeres Paket) und nach diversen Problemen habe ich letztendlich WordPress (5.5.1) über die EasyApps (1Blu) installiert, alle meine Plugins neu installiert und natürlich auch eine neue Datenbank erzeugt. Die alten Posts etc habe ich händisch jeweils als SQL-Tabelle importiert.

    Mittlerweile funktioniert auch alles (mal abgesehen von den Umlautproblemen beim Bilder hochladen auf den FTP-Server) – nur der Customizer will nicht.

    Ich benutze das Theme Koji von Anders Noren schon länger, es gab da nie Probleme.

    Jetzt tritt folgendes auf:

    Ich kann meine Änderungenim Customizer als Entwurf speichern. Auch planen, nur leider wird die geplante Änderung nie veröffentlicht. Veröffentlichen funktioniert überhaupt nicht.

    Meine Vermutung: mein neues Paket hat keine Cronjobs – kann es damit zusammenhängen?

    Aktuell ist die Website im „Baustellenmodus“

    Sämtliche Versuche mit dem Health Check Plugin, Standardtheme (wird auch nicht veröffentlicht) etc haben nicht gefruchtet.

    Noch eine Beobachtung: wenn das Planungsdatum verstrichen ist und ich auf den Customizer klicke, bekomme ich eine Seite „Deine geplanten Änderungen wurden gerade veröffentlicht“, deklariert als WordPress Fehler. Klicke ich ein paar Mal auf den Link darunter, lande ich wieder im Customizer – veröffentlicht wurde aber nichts.

    Ich bin für jede Hilfe dankbar!!!

    LG Irit

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 16 bis 26 (von insgesamt 26)
  • Thread-Ersteller iriteser

    (@iriteser)

    es funktioniert was nicht

    Beitrag wurde veröffentlicht, Customizer funktioniert auch

    aber bei Klick auf Beitrag: kritischer Fehler auf der Website

    Ich bekomme die Krise

    Fehlermeldung auf der Konsole:
    GET https://iriteser.de/2020/09/noch-ein-test/ 500

    Websitebericht:

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    permalink: /%year%/%monthnum%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /hp/ct/ab/ys/www/iriteser
    wordpress_size: 44,40 MB (46554297 bytes)
    uploads_path: /hp/ct/ab/ys/www/iriteser/wp-content/uploads
    uploads_size: 3,65 GB (3921404447 bytes)
    themes_path: /hp/ct/ab/ys/www/iriteser/wp-content/themes
    themes_size: 2,32 MB (2433906 bytes)
    plugins_path: /hp/ct/ab/ys/www/iriteser/wp-content/plugins
    plugins_size: 25,61 MB (26852025 bytes)
    database_size: 199,45 MB (209141084 bytes)
    total_size: 3,92 GB (4206385759 bytes)
    
    ### wp-active-theme ###
    
    name: Koji (koji)
    version: 2.0.9
    author: Anders Norén
    author_website: https://www.andersnoren.se
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, custom-background, post-thumbnails, custom-logo, title-tag, menus, html5, align-wide, editor-color-palette, editor-font-sizes, widgets, editor-style
    theme_path: /hp/ct/ab/ys/www/iriteser/wp-content/themes/koji
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.5, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    
    ### wp-plugins-active (19) ###
    
    Antispam Bee: version: 2.9.2, author: pluginkollektiv
    Block Bad Queries (BBQ): version: 20200811, author: Jeff Starr
    Borlabs Cookie - Cookie Opt-in: version: 2.2.10, author: Benjamin A. Bornschein, Borlabs
    Classic Editor: version: 1.6, author: WordPress Contributors
    Disable Emojis (GDPR friendly): version: 1.7.2, author: Ryan Hellyer
    Featured Image In Rss Feed: version: 2.2, author: Dinesh Karki
    Google XML Sitemaps: version: 4.1.1, author: Auctollo
    Health Check & Troubleshooting: version: 1.4.5, author: The WordPress.org community
    Prosodia VGW OS: version: 3.24.4, author: Prosodia – Verlag für Musik und Literatur
    Remove exif and metadata: version: 1.0, author: Edgar Kotov
    Remove noreferrer: version: 1.2.0, author: Alexander Kadyrov
    Simple Image Sizes: version: 3.2.1, author: Rahe
    SiteOrigin CSS: version: 1.2.10, author: SiteOrigin
    Statify: version: 1.8.0, author: pluginkollektiv
    Title and Nofollow For Links: version: 1.10, author: WPKube
    WordPress Editorial Calendar: version: 3.7.7, author: Colin Vernon, Justin Evans, Joachim Kudish, Mary Vogt, and Zack Grossbart
    WP GDPR Compliance: version: 1.5.4, author: Van Ons
    WP Maintenance Mode: version: 2.2.4, author: Designmodo
    WP Open Comment Links in New Window: version: 1.2, author: Dipak C. Gajjar
    
    ### wp-plugins-inactive (2) ###
    
    Better Search Replace: version: 1.3.3, author: Delicious Brains
    Broken Link Checker: version: 1.11.14, author: WPMU DEV
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 16
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-112-generic x86_64
    httpd_software: Apache
    php_version: 7.4.6 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 2G
    php_post_max_size: 2G
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Thu, 24 Sep 2020 07:10:00 GMT
    	server: Apache
    	x-powered-by: PHP/7.4.6
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://iriteser.de/wp-json/>; rel="https://api.w.org/"
    	strict-transport-security: max-age=31536000
    	upgrade: h2,h2c
    	vary: Accept-Encoding
    	content-encoding: gzip
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.31-0ubuntu0.18.04.1
    client_version: 5.7.30
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /hp/ct/ab/ys/www/iriteser/wp-content
    WP_PLUGIN_DIR: /hp/ct/ab/ys/www/iriteser/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    • Diese Antwort wurde geändert vor 1 Jahr, 7 Monaten von iriteser.
    • Diese Antwort wurde geändert vor 1 Jahr, 7 Monaten von iriteser.

    Dann solltest du den Debug-Modus in der wp-config.php aktivieren, um mehr Informationen über den Fehler zu erhalten:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    

    (Quelle: Debugging in WordPress)

    Die Fehler sollten dann in /wp-content/debug.log protokolliert werden.

    Außerdem kannst du versuchen, mit dem Plugin Health Check den Fehler einzugrenzen – meistens steckt hinter dem Fehler ein Plugin oder auch das Theme.

    Thread-Ersteller iriteser

    (@iriteser)

    habe deinen zweiten Tipp gerade befolgt

    wenn ich das Standardtheme nehme: ich kann Beiträge anschauen

    nehme ich mein Theme (Koji): leere Seite, daher Vermutung, dass da der Fehler liegt

    ich kontaktiere den Themeersteller

    Und um der Frage zuvor zukommen: ich habe kein einziges Bezahltheme mit einem so schönen, cleanen, minimalistischen Design gefunden. Hatte vorher eines von Themecoder, aber das war mir zu „aufgeregt“

    nehme ich mein Theme (Koji): leere Seite, daher Vermutung, dass da der Fehler liegt

    … ist doch schon mal ein Anhaltspunkt.

    Mit eingeschaltetem Debug-Modus lässt sich das wahrscheinlich noch weiter eingrenzen.

    Und um der Frage zuvor zukommen: ich habe kein einziges Bezahltheme mit einem so schönen, cleanen, minimalistischen Design gefunden.

    Das nennt man wohl „das Kind mit dem Bad ausschütten“? 🙂
    Im Moment versuchen wir doch erst einmal, die Website wieder ans Laufen zu bekommen und Fehlerursachen einzugrenzen. Von „Theme löschen, Datenbank vernichten, Laptop zuklappen und nur noch Bücher lesen“ war bisher nicht die Rede.

    Thread-Ersteller iriteser

    (@iriteser)

    keine Bange, so schnell gebe ich nicht auf. Ich mache den Blog im Oktober 10 Jahre und beruflich IT Projekte (allerdings mehr Management als Entwicklung…) und ich bin krisenerprobt 😉 wobei ich auch gerne Bücher lese

    Ich habe den Entwickler auf der themesupport Seite angeschrieben, es gab da kürzlich erst ein Problem mit WP 5.5.0 und da hat er sehr schnell reagiert. Also abwarten.

    Bitte den Beitrag noch nicht schließen, ich gebe nochmal Rückmeldung, sobald ich mehr weiß!

    Dieses Health Check Ding ist übrigens sehr gut zum testen – mag ich!

    Bitte den Beitrag noch nicht schließen …

    Wir schließen nur Beiträge, die gegen die Forenregeln verstoßen und ändern den Status auch erst auf „gelöst“, wenn wir den Eindruck haben, dass ein Problem gelöst oder die ursprüngliche Frage zumindest hinreichend beantwortet wurde. Ansonsten freuen wir uns über deine Rückmeldung, auch wenn’s mal ein wenig länger dauert. Nur bei neuen Fragen solltest du dann bitte einen neuen Thread starten, damit sich das besser auseinanderhalten lässt.

    (And I will happily pass on the positive feedback about the Plugin Health Check to @clorith and team.)

    Thread-Ersteller iriteser

    (@iriteser)

    So, nun ist das Thema gelöst, ich hatte verbotenerweise in der content.php gebastelt (Werbehinweis) und da hatte sich ein Fehlerchen eingeschlichen

    Nun läuft alles (soweit ich es bisher gesehen habe) einwandfrei.

    Als nächstes befasse ich mich jetzt mal mit dem childtheme….

    Danke in die Runde 🙂

    oha, das konnten wir natürlich nicht ahnen.
    Insofern ist die Idee mit dem Childtheme sicherlich nervenschonender 😉
    Übrigens: An einer Liverversion zu basteln ist immer kritisch. Daher besser eine Testumgebung (entweder im Netz oder lokal) aufsetzen.
    Das schont ebenfalls die Nerven 🙂

    Thread-Ersteller iriteser

    (@iriteser)

    war aber alles in allem sehr lehrreich für mich! Und ich habe jede Menge Tipps mitgenommen, wie ich künftig besser an Fehler herangehe

    @iriteser: Ich habe diverse Pakete dort. ich werde es auch mal mit der Aktualisierung von PHP versuchen. Da hat WordPress schon eine Empfehlung ausgesprochen.

    @hage: Sorry, ich dachte, ich poste es hier, weil es zum Thema passt und ich mich mit einbringen kann.

    OK, bei 1blu kann man die PHP-Version ändern. Jetzt funktioniert das bei mir auch. Daran lag es dann wohl.

    Vielen Dank für die schnelle Hilfe!

Ansicht von 11 Antworten - 16 bis 26 (von insgesamt 26)
  • Das Thema „Customizer: veröffentlichen funktioniert nicht“ ist für neue Antworten geschlossen.