Support » Allgemeine Fragen » CustomPostType Preview defekt

  • GelöstModerator Frank Neumann-Staude

    (@fstaude)


    Hallo,

    ich habe ein sehr seltsames Problem. In einem Projekt hab ich einen CustomPostType definiert.
    Ein User hat mehrere Posts in der Liste, wenn er nun einen Editiert und dann auf die Vorschau geht, wird in der Vorschau der Content des ersten Posts der Liste angezeigt, egal aus welchem Post man die Vorschau Aufruf. In dem Aufgabetemplate behauptet WordPress immer, das er die PostID des erstens Elements hat. Offenbar wird also die URL für die Vorschau beim parsen irgendwie verworfen/falsch ausgewertet. Hat Irgendwer noch eine Idee wo ich mal schauen sollte bzw weiss wie genau die Auflösung von URL zu Post in WP funktioniert?

    Permalinks ändern und zurückändern um htaccess und rewrites in den posts neu zu schreiben -> keine Änderung
    Löschen der rewrite transients -> keine Änderung
    Die url_to_postid() aus der rewrite.php wird offenbar nicht durchlaufen.

    Gruß
    Frank

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Moderator Torsten Landsiedel

    (@zodiac1978)

    Hast du mal mit „What the file“ gecheckt ob wirklich das richtige Template genutzt wird?

    Kannst du per var_dump die ID ausgeben, um herauszufinden ob die richtige ID im Template ankommt und nur die URL-Erstellung das Problem ist?

    Kannst Du (auszugweise) den Code posten, der relevant ist? Registrierung des CPT, Ausgabe im Template …

    Das wären gerade so meine spontanen Ideen.

    Gruß, Torsten

    Moderator Frank Neumann-Staude

    (@fstaude)

    Problem Gefunden. Seiteneffekt eines posts_where Filters.

    Gruß
    Frank

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Das Thema „CustomPostType Preview defekt“ ist für neue Antworten geschlossen.