Support » Themes » Darstellung nach Migration

  • Gelöst sostberg

    (@sostberg)


    Hallo,

    ich habe per WP Clone eine Webseite auf einen neuen Server umgezogen. Nun zeigt sich ein kleines Problem, das vermutlich ein Style-Problem ist.

    Zuerst der Zustandsbericht:

    
    ### wp-core ###
    
    version: 5.8.3
    site_language: en_GB
    user_language: en_GB
    timezone: +01:00
    permalink: /{c3c4cbf05c068b42f2e2a880c5b9210f7ddc66c0177cb18b217d48728c7837d4}postname{c3c4cbf05c068b42f2e2a880c5b9210f7ddc66c0177cb18b217d48728c7837d4}
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 9
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork
    wordpress_size: 59.69 MB (62588845 bytes)
    uploads_path: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content/uploads
    uploads_size: 403.68 MB (423287672 bytes)
    themes_path: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content/themes
    themes_size: 17.09 MB (17917718 bytes)
    plugins_path: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content/plugins
    plugins_size: 129.91 MB (136224505 bytes)
    database_size: 2.98 MB (3129344 bytes)
    total_size: 613.35 MB (643148084 bytes)
    
    ### wp-active-theme ###
    
    name: Ascend (ascend)
    version: 1.4.7
    author: Kadence Themes
    author_website: https://www.kadencewp.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, menus, title-tag, post-thumbnails, woocommerce, post-formats, automatic-feed-links, editor-style, html5, custom-logo, custom-background, customize-selective-refresh-widgets, editor-color-palette, align-wide, lifterlms-sidebars, header-footer-elementor, widgets
    theme_path: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content/themes/ascend
    auto_update: Disabled
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 2.1, author: WordPress Team, Auto-updates disabled
    Twenty Twenty: version: 1.8, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-One: version: 1.4, author: the WordPress team, Auto-updates disabled
    
    ### wp-mu-plugins (1) ###
    
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    
    ### wp-plugins-active (17) ###
    
    Contact Form 7: version: 5.5.4, author: Takayuki Miyoshi, Auto-updates disabled
    EditorsKit: version: 1.33.3, author: Munir Kamal, Auto-updates disabled
    Elementor: version: 3.5.3, author: Elementor.com, Auto-updates disabled
    EU Cookie Law: version: 3.1.6, author: Alex Moss, Marco Milesi, Auto-updates disabled
    Events Manager: version: 5.12.1, author: Marcus Sykes, Auto-updates disabled
    MC4WP: Mailchimp for WordPress: version: 4.8.6, author: ibericode, Auto-updates disabled
    Permalink Manager Lite: version: 2.2.15.1, author: Maciej Bis, Auto-updates disabled
    Post Types Order: version: 1.9.7, author: Nsp Code, Auto-updates disabled
    Recent Posts Widget With Thumbnails: version: 7.1.1, author: Kybernetik Services, Auto-updates disabled
    Redirection: version: 5.2.1, author: John Godley, Auto-updates disabled
    Ultimate Carousel For Elementor: version: 2.1.7, author: Nasir Ahmad, Auto-updates disabled
    Virtue/Ascend/Pinnacle Toolkit: version: 4.9.6, author: Kadence WP, Auto-updates disabled
    Wordfence Security: version: 7.5.7, author: Wordfence, Auto-updates disabled
    WP Clone: version: 2.3.3, author: Migrate, Auto-updates disabled
    WP Media Category Management: version: 1.9.8.1, author: DeBAAT <wp-mcm@de-baat.nl>, Auto-updates disabled
    Yoast Duplicate Post: version: 4.3, author: Enrico Battocchi & Team Yoast, Auto-updates disabled
    Yoast SEO: version: 17.9, author: Team Yoast, Auto-updates disabled
    
    ### wp-plugins-inactive (4) ###
    
    BackWPup: version: 3.10.0, author: Inpsyde GmbH, Auto-updates disabled
    The Events Calendar: version: 5.12.4, author: The Events Calendar, Auto-updates disabled
    Visual Portfolio, Posts & Image Gallery: version: 2.15.5, author: nK, Auto-updates disabled
    WP Super Cache: version: 1.7.4, author: Automattic, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.284-icpu-077 x86_64
    httpd_software: Apache
    php_version: 7.4.25 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.12-MariaDB-1:10.5.12+maria~bullseye-log
    client_version: mysqlnd 7.4.25
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content
    WP_PLUGIN_DIR: /homepages/28/d898555240/htdocs/clickandbuilds/MusicFilmFestivalNetwork/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Nun zum Problem:
    Die Originalseite sieht so aus: https://mffn.org/choose-5
    Nach Migration sieht es so aus: http://s898555238.online.de/choose-5

    Ich glaube, das Problem hat mit CSS zu tun, und zwar nur in der Desktop-Ansicht. Verkleinert auf Handy-Größe ist alles richtig. Leider habe ich den Fehler nicht finden können und würde mich freuen, wenn jemand helfen könnte.

    Viele Grüße und danke!
    Simeon

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Einfach mal in die Konsole des Browser gucken, da steht nämlich:

    Source-Map-Fehler: Error: request failed with status 404
    Ressourcen-Adresse: http://s898555238.online.de/wp-content/themes/ascend/assets/css/ascend.css?ver=1.4.7

    Hast du unter Elementor > Werkzeuge die alte URL mit der neuen URL ersetzt und die Stylesheets neu erstellen lassen?

    Thread-Starter sostberg

    (@sostberg)

    Vielen Dank für die Antworten!
    @bscu
    Das habe ich übersehen, allerdings reicht mein Verständnis nicht so weit, um zu wissen, was ich daraufhin tun muss.

    @pixolin
    Ich habe auf Deinen Tipp hin die URL ersetzt, aber wie lasse ich die Stylesheets neu erstellen?

    Edit: Sorry, habe es gefunden. Das hat aber nichts geholfen leider. http://s898555238.online.de/choose-5

    • Diese Antwort wurde geändert vor 10 Monaten, 1 Woche von sostberg.

    Da stimmt irgendwas mit dem Spalten-Block wp-block-columns nicht, ich komme aber nicht drauf, was das Problem ist. Nutze ich die CSS-Regel .wp-block-columns { display: block; } wird alles richtig angezeigt. Vielleicht hat jemand mehr Geschick bei der Beurteilung des CSS.


    Nachtrag: stimmt leider so auch nicht. Zwar wird die Webseite mit der CSS-Regel immerhin lesbar angezeigt, entspricht aber nicht dem ursprünglichen Layout.
    Ich würde im Moment eher darauf tippen, dass hier das deaktivierte Plugin WP Super Cache eine Rolle spielt. Das Plugin nimmt bei der Installation diverse Änderungen vor, unter anderem auch an der .htaccess, die nicht durch Deaktivieren des Plugins alleine behoben werden. Um das Plugin vollständig zu deaktivieren sind folgende Schritte nötig:

    1. Plugin auf der Seite „Plugins“ deaktivieren.
    2. Aus der wp-config.phpdie Zeile define( 'WP_CACHE', true ); entfernen
    3. Die WP-Super-Cache-Weiterleitungs-Regeln aus der .htaccess-Datei entfernen
    4. Dateien wp-content/advanced-cache.php und wp-content/wp-cache-config.php löschen
    5. Verzeichnis wp-content/cache/ löschen
    6. Verzeichnis wp-content/plugins/wp-super-cache löschen.
    Thread-Starter sostberg

    (@sostberg)

    Hallo!

    Vielen Dank für Deine Nachricht und Deine Hilfsvorschläge!
    1. Gemacht (war gar nicht aktiviert)
    2. Da gibt es zu Supercache nur diese Zeile: define( 'WP_CACHE_KEY_SALT', '(KEY)' );
    3. Dazu gibt es nichts in der .htaccess
    4. Gibt es beide nicht
    5. Gibt es nicht
    6. Gibt es. Soll ich das löschen, wenn die anderen Sachen nicht existieren?

    Vielen Dank noch einmal!
    Simeon

    Es war eine Vermutung, dass WP Super Cache eine Rolle spielt. Wenn du die Einträge gar nicht erst findest, lag ich offensichtlich falsch – tut mir leid.

    Thread-Starter sostberg

    (@sostberg)

    Ok, kein Problem! Vielen Dank für Deine Hilfe trotzdem!

    Sollte ich deswegen nun noch einmal woanders nachfragen? Z.B. im englischsprachigen Forum?

    Viele Grüße
    Simeon

    Du kannst natürlich im internationalen Supportforum oder auch im Forum des Themes nachfragen (ein Hinweis zum Crossposting wäre nett), aber vielleicht meldet sich auch hier noch jemand zum Thema.

    @bscu Source-Map ist doch unkritisch? Ich verstehe Source-Map als eine Quellangabe, aus welchen Bestandteilen sich ein Stylesheet zusammensetzt, wenn du z.B. SASS kompilliert hast.

    @sostberg Probier mal folgende CSS-Regel als Workaround:

    @media screen and (min-width: 782px) {
    .wp-block-column[style*="flex-basis"] {
      flex-grow: 1;
    }
    }

    Hallo,
    teste mal ggfs. bitte unter Design > Customizer > Zusätzliches CSS die folgende CSS-Regel, falls die CSS-Regel von Bego nicht funktionieren sollte:

    @media (min-width: 782px){
    .wp-block-column {
        flex-grow: 1!important;
    }
    }

    Es könnte auch sein, dass die folgende CSS-Regel funktioniert:

    @media (min-width: 782px){
    .wp-block-column {
        flex-basis: inherit;
    }
    }
    Thread-Starter sostberg

    (@sostberg)

    Guten Morgen!

    @pixolin Dein Tipp war’s! Vielen vielen Dank!
    @hage Vielen Dank auch Dir!

    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

    Thread-Starter sostberg

    (@sostberg)

    Ah ok, das wusste nicht. Mache ich.

    Danke!

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Darstellung nach Migration“ ist für neue Antworten geschlossen.