Support » Themes » Das Theme meiner Webseite wird nicht mehr dargestellt – benötige dringend Hilfe!

  • Hallo zusammen,

    ich habe ein schwerwiegendes Problem mit der Darstellung meiner Webseite.

    Am letzten Wochenende ist mir aufgefallen dass meine Webseite nun noch als weißer Screen dargestellt wird.

    Meine Webseite „lief“ jedoch bisher immer einwandfrei und das bereites seit Jahren. Meine Webseite wurde damals mit dem von mir gekauften Theme „Avada“ erstellt.

    Ich habe jetzt im Backend auf das Standardtheme „Twenty Seventeen“ umgestellt.

    Nun wird oben natürlich das Standard-Bild des Themas „Twenty Seventeen“ mit dem Blumentopf dargestellt. Darunter erscheint nun ein sehr langer Code, der offensichtlich eigentlich zu meinem Theme „Avada“ gehört.

    Sicherheitshalber habe ich natürlich alle installierten Plugins deaktiviert.
    Wenn ich im Backend jedoch wieder auf das „Avada“ Theme umschalten will, dann erscheint nur ein relativ langer Fehlercode auf der Seite (siehe unten).

    Bin über jede Hilfe dankbar!

    Liebe Grüße

    Michael

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; sidebar_generator has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/plugins/multiple_sidebars.php on line 29 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Tabs_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/tabs_widget.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Tweets_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/tweets-widget.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Flickr_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/flickr-widget.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Facebook_Like_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/facebook-like-widget.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Ad_125_125_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/125_125.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Social_Links_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/social_links.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Contact_Info_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/contact_info.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Fusion_Recent_Works_Widget has a deprecated constructor in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/widgets/recent-works-widget.php on line 10 Fatal error: Cannot use „self“ when no class scope is active in /customers/e/9/4/nickel-design.de/httpd.www/Nickel/wp-content/themes/Avada/framework/plugins/importer/importer.php on line 878

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 16 bis 23 (von insgesamt 23)
  • Thread-Starter pittylabelle

    (@pittylabelle)

    Die aktuellen Fehlermeldungen auf der Seite deuten doch eher auf ein Problem mit den Plugins hin, oder?

    http://www.nickel-design.de/

    Warning: Cannot assign an empty string to a string offset in /customers/e/9/4/nickel-design.de/httpd.www/wp-content/plugins/fusion-core/fusion-slider/class-fusion-slider.php on line 1045

    Warning: Illegal string offset ’slider_indicator_color‘ in /customers/e/9/4/nickel-design.de/httpd.www/wp-content/plugins/fusion-core/fusion-slider/class-fusion-slider.php

    usw. usw.

    Hallo,
    wenn ich mir Deine Seite ansehe, dann sieht das eher so aus, als würde das theme (Avada) nicht mehr korrekt arbeiten. Der Fusion Slider wurde wohl hauptsächlich für Avada entwickelt, siehe hier.
    Hier vielleicht noch ein paar Lösungsansätze (aber erst alles sichern):

    1. das plugin Health Check & Troubleshooting installieren. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
      Einen guten Artikel dazu findest du hier
    2. den kompletten theme-Ordner von Avada löschen, ein frisches „Avada“ runterladen und dann neu per FTP hochladen. Das hat in verschiedenen Fällen bei mir auf jeden Fall schon eine Lösung gebracht, wobei ich Avada nicht kenne, weil ich in der Regel mit themes in dieser Art (Stichwort page builder) nicht arbeite.

    Nachsatz: In der developer console finden sich auch einige Fehler:

    Failed to load resource: the server responded with a status of 404 ()
    Nickel-Design-Logo-100.png:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    /Nickel/wp-content/uploads/2014/06/Michael-Nickel-3-klein.jpg:1 Failed to load resource: the server responded with a status of 404 (Not Found)
    /Nickel/wp-content/uploads/2016/05/Nickel-Design-Logo-Retina.png:1 Failed to load resource: the server responded with a status of 404 (Not Found)

    Da es sich offensichtlich um Logos etc. handelt, ist das schon seltsam, denn diese Dateien waren ja sicherlich mal auf dem Server. Ich würde daher auch noch mal die gesamte Ordnerstruktur prüfen und ggfs. ein altes Backup wiederherstellen, wenn Du sowas hast.

    Viel Erfolg
    Hans-Gerd

    Thread-Starter pittylabelle

    (@pittylabelle)

    @ hage

    also ich habe alles versucht was Du beschrieben hast. Trotzdem leider kein Erfolg. Ja, es gibt ein Backup, jedoch nur von dem „Nickel“ Ordner der als zusätzliches Verzeichnis auf dem Server liegt und auf den sich die WordPress Installation ja bezieht.

    Dennoch bin ich nach wie vor der Meinung dass es sich um ein Strukturproblem handelt.

    Das Hauptmenuü meiner Seite wird ja oben sichtbar wenn man auf der Homepage ein wenig nach oben scrollt.

    Wenn man z. B. dann auf den Menüeintrag „Gebäude“ klickt so wird dort ein Fehlercode angezeigt. Dieser besagt dass die Seite offensichtlich nicht aufgerufen bzw. geladen werden kann, weil die Pfadzuordnung dazu wohl nicht stimmmt.

    Wie kriege ich das wieder in den Griff?

    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von pittylabelle.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von pittylabelle.
    • Diese Antwort wurde geändert vor 3 Jahre, 9 Monaten von pittylabelle.

    Hol dir am besten professionelle Hilfe!
    PS: ich hab leider keine Zeit

    Übrigens: Hier werden einfach nur deine shortcodes nicht ausgeführt. Fehlt ein Plugin oder ist nicht aktiviert?

    Hallo,
    ich gehe nach wie vor davon aus, dass Du ein Problem mit dem theme hast: Die Unterseite Impressum funktioniert (wahrscheinlich hast Du diese Unterseite nicht mit einem page builder erstellt). Auf allen anderen Seiten sind die shortcodes (das was Andreas bereits geschrieben hat) zu sehen, die nicht funktionieren. Daher vermute ich, dass Du da den page builder von Avada eingesetzt hast.
    Wie gesagt, am besten Avada per FTP komplett neu kopieren (s. o.).
    Viele Grüße
    Hans-Gerd

    Thread-Starter pittylabelle

    (@pittylabelle)

    Hallo Hans-Gerd,

    danke für Deine Hilfe!

    Gestern habe ich das Avada Theme über FTP gelöscht noch einmal frisch über FTP in das Theme-Verzeichnis kopiert. Dann die beiden wichtigsten Plugin von Avada neu mit den aktuellesten Versionen installieren lassen.

    Wie gesagt, leider keine Veränderung.

    Im Backend erhalte ich diese Fehlermeldung wenn ich z.B. ein Portfolio editieren will: Your page content could not be displayed as a Fusion Builder layout.
    Most likely that means, there is some invalid markup or shortcode in it.
    Please check the contents in the text editor.

    Hallo @pittylabelle,
    dann wende Dich am besten mal an die Entwickler von Avada. Die können Dir sicher besser helfen, weil ich Avada nicht hier habe.
    Viel Erfolg
    Hans-Gerd

Ansicht von 8 Antworten - 16 bis 23 (von insgesamt 23)
  • Das Thema „Das Theme meiner Webseite wird nicht mehr dargestellt – benötige dringend Hilfe!“ ist für neue Antworten geschlossen.