Support » Themes » Dashboard öffnet sich nicht

  • Hallo und vorab schonmal danke für eventuelle Unterstützung
    nachdem mich mein Provider genötigt hatte alles neu aufzuspielen funktioniert das dashboard nicht mehr. kann mich zwar mittlerweile einloggen, wird oben rechts auch angezeigt, der Dasboardbutton funktioniert?, passieren tut nichts. Habs schon wie im Forum beschrieben mit Plugins und Themes zu deaktivieren versucht, ohne Erfolg

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 38)
  • Thread-Starter flugwerke

    (@flugwerke)

    <?php
    /**
     * Cookie holder object
     *
     * @package Requests
     * @subpackage Cookies
     */
    
    /**
     * Cookie holder object
     *
     * @package Requests
     * @subpackage Cookies
     */
    class Requests_Cookie_Jar implements ArrayAccess, IteratorAggregate {
    	/**
    	 * Actual item data
    	 *
    	 * @var array
    	 */
    	protected $cookies = array();

    Hallo,
    vielleicht gibt es ein Problem mit den Core-Dateien – schau mal hier: Probleme nach dem Update/Upgrade: Fehlerhafte oder fehlende Core-Dateien.
    Viele Grüße
    Hans-Gerd

    Thread-Starter flugwerke

    (@flugwerke)

    Guten Morgen Hans-Gerg,
    das habe ich alles schon versucht, Themes ausgetauscht, da hat sich nur eine Seite mit dem neuesten Theme aufgebaut, und mehrfach die Dateien, bis auf den Content, gelöscht und wieder hochgeladen. Habs gerade nochmal gemacht, ohne Erfolg. Seiten sind da, ohne die Möglichkeit das Dashboard zu öffnen. Button ist vorhanden und wenn man draufklickt scheint sich auch etwas zu tun, nur kommt nichts.

    Hallo @flugwerke

    In unserer Foren-FAQ findest du eine Art Troubleshooting-Guide. Teste die für dein Problem relevanten Punkte nacheinander durch, insbesondere auch den Punkt .htaccess.

    Und teste den Zugang zum Backend auch einmal in einem anderen Browser und auch im Inkognito-/privaten Fenster eines Browsers.

    Thread-Starter flugwerke

    (@flugwerke)

    Guten Morgen Angelika,
    ich habe, wie oben geschrieben alles mehrfach vor und zurück/neu getauscht, auch die themes. ich hab auch die htaccess datei umbenannt, eine Neue habe ich danach nicht gefunden

    Es geht nicht nur ums Tauschen, sondern auch ums Deaktivieren von .htaccess und dann testen, Deaktivieren von allen Plugins und dann testen, um eine debug.log-Datei (Punkt 6), um Fehlermeldungen (Punkt 5), um error.log (Punkt 7). Und auf meinen letzten Absatz oben bist du nicht eingegangen.

    Wenn das alles nichts hilft, musst du wohl leider ein Dienstleistungsunternehmen beauftragen.

    Aber eine weitere Idee habe ich noch. Bei Hosteurope gibt es zwei unterschiedliche FTP-Zugänge: wp-user und ftp-user. Möglicherweise hast du mit den ftp-user hochgeladen und über die Browser darauf keinen Zugriff.

    https://www.hosteurope.de/faq/webhosting/webpack/dateirechtestruktur

    Lade am besten alles noch einmal per FTP-Zugang wp-user hoch.

    @la-geek Angelika, nach meinen Erfahrungen mit einem anderen HostEurope-Kunden kannst du auch bei einer Installation, bei der die Dateien mit dem falschen FTP-Account hochgeladen wurden, auf das Backend zugreifen. Du bekommst dann wegen falscher Benutzerrechte unter anderem bei der Auswahl der Website-Sprache nur Englisch und Deutsch angezeigt und es ist sicher sinnvoll, den Dateiinhaber zu ändern, aber einen fehlenden Zugriff aufs Backend erklärt das nicht.

    Ich kann mit

    Seiten sind da, ohne die Möglichkeit das Dashboard zu öffnen. Button ist vorhanden und wenn man draufklickt scheint sich auch etwas zu tun, nur kommt nichts.

    nichts anfangen. Welcher Button ist damit überhaupt gemeint? Wieso nicht Login über wp-login.php? Mir fehlen da wie gesagt zu viele Informationen, um das zu beurteilen.

    @pixolin

    nach meinen Erfahrungen mit einem anderen HostEurope-Kunden kannst du auch bei einer Installation, bei der die Dateien mit dem falschen FTP-Account hochgeladen wurden, auf das Backend zugreifen.

    gilt das auch noch bei/nach einem PHP-Upgrade auf 8.x ?

    Hosteurope:

    Wenn Sie die Option für den Webserver-Benutzer deaktivieren, werden die Dateien mit dem normalen FTP-Benutzer hoch geladen. Dies kann dazu führen, dass Sie zunächst die Dateirechte der hochgeladenen Dateien ändern müssen, damit Ihre Skripte korrekt ausgeführt werden.

    Hm. Gute Frage. Kann ich nicht sagen.

    Ich hab das mal gerade in einer Testwebsite ausprobiert: alle Dateien und Verzeichnisse einem anderen Benutzer zugewiesen, PHP 8.0 → Anmeldung klappt problemlos, aber unter Einstellungen > Allgemein reichen die Benuutzerrechte nicht aus, um eine andere Sprache als Deutsch und Englisch auszuwählen. Bei der Installation eines Plugins werden (als Workaround) die FTP-Zugangsdaten abgefragt …

    Ich nehme an, dass das bei HostEurope genauso ist.

    Thread-Starter flugwerke

    (@flugwerke)

    Hallo Angelika,
    ergänzend zu deinen Empfehlungen, ich hab natürlich auch das mit der Inkognitoseite probiert, ebenso mit alternativen auf dem Rechner und vom Handy. Könnte es noch sein dass die Probleme wg. einem fehlenden SSl Zertifikat kommen?
    @mario danke für deine Bemühungen!
    würde es euch nutzen einen Account zum testen zu haben?

    würde es euch nutzen einen Account zum testen zu haben?

    Nein, siehe https://de.wordpress.org/support/topic/kannst-du-mich-nicht-anrufen-oder-mal-schnell-bei-mir-einloggen/

    @flugwerke Mit welchem Editor hast du denn die wp-config.php bearbeitet?

    @flugwerke Mit welchem Editor hast du denn die wp-config.php bearbeitet?

    @pixolin

    genau darauf zielte mein Hinweis ab, als ich schrieb:

    debug.log-Datei (Punkt 6), um Fehlermeldungen (Punkt 5), um error.log (Punkt 7)

    Punkt 5, Troubleshooting-Guide = Fehlermeldung (1 von 4): Cannot modify header

    [Wed Jan 04 17:33:22 2023] [php:warn] [pid 23962] [client 85.25.177.219] [host executive-jet.de] PHP Warning:  Cannot modify header information - headers already sent by (output started at /is/htdocs/wp12542140_33FNSDE4DI/www.flugwerke.de/wp-includes/Requests/Cookie/Jar.php:15) in /is/htdocs/wp12542140_33FNSDE4DI/www.flugwerke.de/wp-includes/pluggable.php on line 1416
    [Wed Jan 04 17:33:22 2023] [php:warn] [pid 23962] [client 85.25.177.219] [host executive-jet.de] PHP Warning:  Cannot modify header information - headers already sent by (output started at /is/htdocs/wp12542140_33FNSDE4DI/www.flugwerke.de/wp-includes/Requests/Cookie/Jar.php:15) in /is/htdocs/wp12542140_33FNSDE4DI/www.flugwerke.de/wp-includes/pluggable.php on line 1419

    ¯\_(ツ)_/¯

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 38)