Support » Allgemeine Fragen » define(‚WP_DEBUG_DISPLAY‘, false); zeigt keine Wirkung

  • Gelöst gmos

    (@gmos)


    Hallo, ich benutze das Plugin DSGVO Pro. Das Teil ist nicht sauber programmiert und gibt eine PHP-Fehlermeldung aus.

    Jetzt möchte ich diese Fehlermeldung, weil er Progger den Fehler nicht fixt, mit ‚define(‚WP_DEBUG_DISPLAY‘, false);
    define(‚WP_DEBUG‘, false);‘
    einfach ausblenden.

    Das funktioniert aber nicht und ich werde langsam verrückt.

    Dann habe ich das probiert (vor Thats all)
    ‚ini_set(‚display_errors‘,’Off‘);
    ini_set(‚error_reporting‘, E_ALL );
    define(‚WP_DEBUG‘, false);
    define(‚WP_DEBUG_DISPLAY‘, false);‘

    Dann ein php.ini

    error_reporting = E_ALL
    display_errors = OFF

    und mit einer .htaccess

    Zuletzt habe ich noch das Plugin WP Debugging getestet.

    ALLES OHNE ERFOLG

    Natürlich habe ich mehrere Browser getestet, Cache geleert, auch in WP, habe Cache Plugin deinstalliert und ein anderes….ich weiß nicht weiter.

    Jetzt liegt die WP installation bei Strato und die machen ja öfter Blödsinn.

    Kann mir jemand helfen, gibt es noch einen Tipp?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hier Daten vom Query Monitor

    Version 5.4.1
    WP_DEBUG false
    WP_DEBUG_DISPLAY false
    WP_DEBUG_LOG false
    SCRIPT_DEBUG false
    WP_CACHE true
    CONCATENATE_SCRIPTS nicht definiert
    COMPRESS_SCRIPTS nicht definiert
    COMPRESS_CSS nicht definiert
    WP_LOCAL_DEV nicht definiert

    steht alles auf aus.

    Version 7.3.18
    SAPI cgi-fcgi
    Benutzer :
    max_execution_time 240
    memory_limit 256M
    upload_max_filesize 64M
    post_max_size 76M
    display_errors 1
    In Ausführungszeit überschrieben mit Off
    log_errors 0
    Fehlerberichte 32767+
    Erweiterungen
    57

    Hallo!

    Wenn ein Plugin Probleme macht, wenn die Fehlermeldung (welche?) wirklich davon ausgeht, so würde ich es erstmal deaktivieren. (Wenn es sogar den Adminzugang blockiert, dann den Ordner des Plugins per FTP umbenennen)

    Wenn der Hersteller nichts tut, könnten weitere Probleme damit auftauchen. Und da es einen sensiblen Bereich behandelt – sollte man sich evtl. nach einem Ersatz umsehen.

    Jetzt möchte ich diese Fehlermeldung, weil er Progger den Fehler nicht fixt,

    … dann würde ich vorerst die Finger davon lassen. Geht es z.b. um das Impressum oder den Datenschutz an sich, so gibt es haufenweise kostenlose Tools zum Erstellen und das auch noch DSGVO-Konform 🙂

    Blöd ist dass ich die Pro-Version gekauft habe. Der Preis ist sehr gut aber ich habe auch viel Zeit investiert um alles einzurichten, wie YT-Videos usw.

    • Diese Antwort wurde geändert vor 2 Monaten von gmos.

    Pro-Version

    Dann muss der Support leisten, updaten, nachbessern.

    Aber wir wissen ja noch immer nicht, wie Fehlermeldung echt lautet?
    Denn in den (meist inkludierten) Pfadangaben einer solchen Meldung wird das schuldige Element schnell gefunden.

    Statt an dem ausblenden der Meldung lange herumdoktern (= nur Symptombekämpfung) solltest die mal posten. Hier gibt auch Profis, die vielleicht damit was anfangen.
    Nur: Da es ein kostenpflichtiges Plugin ist, werden die Mods hier schnell schließen.
    Weil keiner wird es kaufen, um dir zu helfen. Noch dazu wenn dessen Hersteller so ein sturer ist …

    PS: @amilak hat schon Recht: Es gibt Alternativen. Bez. Datenschutzerklärung zb mal nach Dr Schwenkes Generator googlen.
    Ok, das von dir genannte Plugin kann sicher mehr (wenn es denn funzt) wenn da soviel Zeit drin steckt ist auch klar, das du es weiter verwenden willst. Also sekkiere den Programmierer!

    OK Thema kann geschlossen werden.

    Der Progger hat jetzt schnell reagiert aber das Problem
    define(‚WP_DEBUG_DISPLAY‘, false); zeigt keine Wirkung
    tritt wohl gelegentlich auf, kannte ich vorher überhaupt nicht.

    https://de.wordpress.org/support/topic/warnings-werden-angezeigt-obwohl-wp_debug-auf-false-eingestellt-ist/

    Aber letztendlich ist der Provider….das böse Wort mit Str to schuld, weil die ihren Server im Griff haben.

    Danke für Eure Hilfe

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)