Support » Allgemeine Fragen » Deprecated: block_editor_settings ist veraltet!

  • Gelöst ricschobe

    (@ricschobe)


    Hallo zusammen,

    im Beitrags Editor bekomme ich nur noch eine weiße Seite zu sehen. Nachdem das Deaktivieren sämtlicher Plugins keine Besserung brachte – Debugging: Nun immer ein Fehler:
    Deprecated: block_editor_settings ist seit Version 5.8.0 veraltet! Benutze stattdessen block_editor_settings_all. in /home/www/mrs-hirnbirn.de/wp-includes/functions.php on line 5691

    Ich dachte mir, oh Super, das kann ich bestimmt selbst und suchte im besagten PHP Dokument die Zeile 5691 und wollte es umbenennen. Aber in Zeile 5691 steht lediglich
    E_USER_DEPRECATED

    Bevor ich alles zerstöre, wollte ich dann doch lieber mal die Profis fragen.
    Was genau muss ich tun, damit ich neue Beiträge schreiben kann?

    Leider kann ich nicht genau sagen, seit wann das Problem besteht. Mein letzter Beitrag ist 2 Monate alt :/

    Danke euch und Liebe Grüße
    Ric

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Was genau muss ich tun, damit ich neue Beiträge schreiben kann?

    Auf keinen Fall etwas in der functions.php ändern. Bei nächsten Update wären deine Änderungen sowieso wieder weg.

    Wir brauchen einige Infos von dir, siehe https://de.wordpress.org/support/topic/bevor-du-ein-neues-thema-thread-erstellst/

    Thread-Ersteller ricschobe

    (@ricschobe)

    Puh, da habe ich Glück gehabt 😉

    Link zu meiner Website https://mrs-hirnbirn.de

    Website Zustand:

    Website-Zustand
    Gut
    Status
    Bericht
    
    Hervorragende Arbeit!
    
    Hier läuft alles reibungslos.

    Die Suche habe ich bereits genutzt, jedoch leider keinen ähnlichen Fall gefunden.

    Wenn ich auf der „weißen“ Beitragsseite bin, werden mir 4 Fehler und eine Warnung angezeigt.
    In diesem Abschnitt ist eine Warnung:
    <div id=“editor“ class=“block-editor__container hide-if-no-js“></div>

    Warnung: DevTools failed to load source map: Could not load content for https://mrs-hirnbirn.de/wp-content/plugins/gutentor/assets/library/wpness-grid/assets/css/grid.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

    Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ricschobe

    (@ricschobe)

    Danke Hans-GErd,

    
    ### wp-core ###
    
    version: 5.9.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/www/mrs-hirnbirn.de
    wordpress_size: 46,42 MB (48669871 bytes)
    uploads_path: /home/www/mrs-hirnbirn.de/wp-content/uploads
    uploads_size: 2,35 MB (2465937 bytes)
    themes_path: /home/www/mrs-hirnbirn.de/wp-content/themes
    themes_size: 3,43 MB (3594720 bytes)
    plugins_path: /home/www/mrs-hirnbirn.de/wp-content/plugins
    plugins_size: 17,57 MB (18425311 bytes)
    database_size: 45,02 MB (47202304 bytes)
    total_size: 114,78 MB (120358143 bytes)
    
    ### wp-active-theme ###
    
    name: CheerUp (cheerup)
    version: 7.5.2
    author: ThemeSphere
    author_website: https://theme-sphere.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, custom-line-height, custom-units, editor-font-sizes, post-thumbnails, automatic-feed-links, html5, title-tag, post-formats, menus, custom-background, align-wide, editor-style, editor-color-palette, widgets
    theme_path: /home/www/mrs-hirnbirn.de/wp-content/themes/cheerup
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Two: version: 1.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (18) ###
    
    Antispam Bee: version: 2.11.0, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    CheerUp Core: version: 1.1.2, author: ThemeSphere, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.1.0.1, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    FooGallery: version: 2.1.33, author: FooPlugins, Automatische Aktualisierungen deaktiviert
    GDPR tools: comment ip removement: version: 1.3.2, author: fabian heinz webdesign, Automatische Aktualisierungen deaktiviert
    Gutentor - Gutenberg Blocks - Page Builder for Gutenberg Editor: version: 3.2.0, author: Gutentor, Automatische Aktualisierungen deaktiviert
    Insert Headers and Footers: version: 1.6.0, author: WPBeginner, Automatische Aktualisierungen deaktiviert
    ProfilePress: version: 3.2.8, author: ProfilePress Team, Automatische Aktualisierungen deaktiviert
    Rank Math SEO: version: 1.0.83, author: Rank Math, Automatische Aktualisierungen deaktiviert
    Regenerate Thumbnails: version: 3.1.5, author: Alex Mills (Viper007Bond), Automatische Aktualisierungen deaktiviert
    Self-Hosted Google Fonts: version: 1.0.1, author: asadkn, Automatische Aktualisierungen deaktiviert
    Sphere Core: version: 1.1.4, author: ThemeSphere, Automatische Aktualisierungen deaktiviert
    Ultimate Addons for Gutenberg: version: 1.25.4, author: Brainstorm Force, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.4, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder: version: 6.5.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    WP Fastest Cache: version: 0.9.8, author: Emre Vona, Automatische Aktualisierungen deaktiviert
    WPS Hide Login: version: 1.9.3, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen deaktiviert
    WP Statistics: version: 13.1.6, author: VeronaLabs, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: FooGallery_Thumb_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 150M
    upload_max_filesize: 150M
    max_effective_size: 150 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-14-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.22 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 150M
    php_post_max_size: 150M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.22
    client_version: mysqlnd 7.4.27
    max_allowed_packet: 134217728
    max_connections: 350
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/mrs-hirnbirn.de/wp-content
    WP_PLUGIN_DIR: /home/www/mrs-hirnbirn.de/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Ich werde mir das mit dem Plugin nun mal ansehen.

    Habs nun getestet. Leider keine Verbesserung im Problembehandlungsmodus 🙁

    Liebe Grüße
    Ricarda

    • Diese Antwort wurde geändert vor 4 Monaten, 1 Woche von ricschobe.

    Hallo,
    ich vermute, dass der Fehler mit deinem Browsercache zusammenhängt.
    Teste das doch mal in einem privaten Fenster (Firefox) und/oder im Inkognitomodus (Chrome). Die Option findest du oben rechts bei den drei senkrechten Punkten in Chrome.
    Ggfs. auch mal den Browsercache komplett löschen.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller ricschobe

    (@ricschobe)

    Leider bringt auch das keine Besserung. Meinst du, es würde helfen, die neuste WordPress Version (5.9.1) nochmal zu installieren?

    Du kannst das natürlich versuchen: Dashboard > Aktualisierungen > Button „Version 5.9.1 … erneut installieren“
    Evtl. ist es auch sinnvoll, wenn du debug aktivierst. Wie du das machen kannst, habe ich in meinem Beitrag Debug-Modus auf WordPress-Seiten mit und ohne Plugins erklärt.

    Thread-Ersteller ricschobe

    (@ricschobe)

    Leider hat das erneute Aktualisieren auch nichts gebracht.

    Aber ….

    ich habe mal den alten „classic Editor“ Installiert. Et Voila.. Ich kann damit wieder Beiträge erstellen.

    Mir wird oberhalb diese Meldung angezeigt:
    Ultimate Addons für Gutenberg erfordert den Block Editor. Du kannst deine Editor-Einstellungen in Block-Editor von hier ändern. Das Plugin wird derzeit NICHT AUSGEFÜHRT.

    Scheint ja doch irgendwie mit einem Plugin in Verbindung zu stehen. Gibt es noch eine Möglichkeit das herauszufinden?

    hmmm, so ganz will mir das nicht in den Kopf und ich vermute nach wie vor, dass das Problem mit dem Theme zusammenhängen könnte.
    Sorry, aber da das ein kostenpflichtiges Theme ist, kann ich das selbst nicht testen.
    Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ II, 1b zu diesem Thema.
    Logisch, dass nach Aktivierung vom Classic Editor Ultimate Addons nicht mehr ausgeführt wird.
    Du kannst natürlich auch noch mal ohne den Problembehandlungsmodus zu nutzen, mal ein anderes Theme aktivieren, dann mal testen, ob es funktioniert. Wenn es bei einem Standardtheme wie Twenty Twenty-One funktioniert, dann liegt es eindeutig am Theme.
    Wenn nicht, kannst du anschließend Plugin für Plugin aktivieren und jeweils nach der Aktivierung testen, ob das Problem behoben ist.

    Warnung: DevTools failed to load source map: Could not load content for https://mrs-hirnbirn.de/wp-content/plugins/gutentor/assets/library/wpness-grid/assets/css/grid.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

    Vielleicht ist auch das Plugin Gutentor der Übeltäter.

    WP Fastest Cache würde ich auf jeden Fall solange deaktivieren bis der Fehler gefunden ist.

    Thread-Ersteller ricschobe

    (@ricschobe)

    Guten Morgen 🙂

    Danke dir Hans-Gerd.
    Das Problem habe ich lösen können.

    Es lag tatsächlich am Theme. Habe das Neuste Update aufgespielt und nun sieht alles wieder gut aus.

    Merci für eure tatkräftige Unterstützung.

    Liebe Grüße und ein schönes Wochenende
    Ricarda

    Guten Morgen,
    super – freut mich 😊
    … und danke für die Rückmeldung 👍
    Viele Grüße und ein schönes Wochenende
    Hans-Gerd

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)