Support » Installation » Design>Widgets: Im Editor ist ein unerwarteter Fehler aufgetreten.

  • Gelöst flugzeug

    (@flugzeug)


    Seit kurzem tritt der genannte Fehler auf. Woran kann das liegen?
    Der Fehler bleibt auch nach Widerherstellung von Sicherungen mit updraftplus bestehen. Ich kann es nicht 100% sicher sagen, aber habe das Gefühl, dass der Fehler vorher (also zur Zeit der Sicherung) noch nicht da war.
    Hänge unten den Bericht aus Werkzeuge>Website-Zustand an.
    Bin absoluter wordpress-Anfänger. Bitte sagen, falls ich noch weitere Infos hier bereitstellen kann.

    
    ### wp-core ###
    
    version: 5.9.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: undefined
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web014/b2/18/511387018/htdocs
    wordpress_size: 512,47 MB (537364634 bytes)
    uploads_path: /mnt/web014/b2/18/511387018/htdocs/wp-content/uploads
    uploads_size: 7,51 MB (7876571 bytes)
    themes_path: /mnt/web014/b2/18/511387018/htdocs/wp-content/themes
    themes_size: 19,81 MB (20770267 bytes)
    plugins_path: /mnt/web014/b2/18/511387018/htdocs/wp-content/plugins
    plugins_size: 92,62 MB (97118539 bytes)
    database_size: 5,38 MB (5636096 bytes)
    total_size: 637,79 MB (668766107 bytes)
    
    ### wp-active-theme ###
    
    name: Shop Isle (shop-isle)
    version: 1.1.60
    author: Themeisle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, starter-content, fl-theme-builder-headers, fl-theme-builder-footers, automatic-feed-links, menus, html5, custom-background, woocommerce, title-tag, custom-header, customize-selective-refresh-widgets, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, custom-logo, infinite-scroll, widgets
    theme_path: /mnt/web014/b2/18/511387018/htdocs/wp-content/themes/shop-isle
    auto_update: Deaktiviert
    
    ### wp-plugins-active (2) ###
    
    UpdraftPlus - Backup/Restore: version: 1.22.11, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 6.3.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (3) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Automatische Aktualisierungen deaktiviert
    Germanized for WooCommerce: version: 3.8.4, author: vendidero, Automatische Aktualisierungen deaktiviert
    Jetpack: version: 10.7, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-10 Q16 x86_64 2021-04-29 https://imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 4 GB
    	imagick::RESOURCETYPE_MEMORY: 2 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, APNG, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.36.2.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.52 (Unix)
    php_version: 7.4.27 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.80.0 OpenSSL/1.1.1l
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.36-log
    client_version: 5.6.45
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web014/b2/18/511387018/htdocs/wp-content
    WP_PLUGIN_DIR: /mnt/web014/b2/18/511387018/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    evtl. kannst du das Problem bei Nutzung des Plugins Classic Widgets lösen.
    Das wäre aber nach meiner Ansicht nur eine vorübergehende Lösung. Die aktuell von dir genutzten Widgets werden im Block-Editor unter Design Widgets als Legacy Widgets gelistet oder es erscheint sogar im oberen Bereich eine blassrote Meldung mit einer Fehlermeldung zu einem Widget.
    Auf Dauer solltest du aber (wenn das Problem bei Nutzung des genannten Plugins behoben sein sollte) die Widgets überarbeiten. Das ist je nach genutzten Widgets an sich kein Hexenwerk. Zum Beispiel kann es sein, dass ein bisher als Text-Widget mit dem Inhalt „das ist ein Text“ genutztes Widget bei Nutzung des Block-Editors als „Legacy Widget“ dargestellt wird. Wenn man dann auf dieses Widget im Block-Editor unter Design > Widgets klickt, wird auch schon die Option „In Blöcke umwandeln“ angeboten. Nach Klick auf diese Option wird aus dem Legacy Widget ein Absatz-Block und damit ist das Problem behoben. Das sollte man natürlich erst nach einer Sicherung machen bzw. (noch besser) auf einer Entwicklungsumgebung.
    Viele Grüße
    Hans-Gerd

    WordPress verwendet seit WordPress Version 5.8 für Widgets den Block-Editor. Dieser Block-Editor kommt allerdings etwas aus dem Takt, wenn er Widgets einlesen soll, die vorher angelegt wurden. Am einfachsten ist es, die Widgets neu anzulegen. Ein Workaround wäre, das Plugin Classic Widgets zu installieren, dass WordPress auf die klassische Bearbeitung der Widgets zurücksetzt.

    Bei deiner Website fällt mir auf, dass du keine Permalinks gesetzt hat. Beitrags-URLs werden also nach dem Schema https://example.com/?p=42 gebildet, was weder für Menschen noch für Suchmaschinen besonders gut zu lesen ist. Auch für die Verwendung des Block-Editors ist das nicht ideal – gut möglich, dass sich das auch auf die Widgets auswirkt.

    Die Zeitzone ist bei dir nicht richtig eingestellt. Änderst du die Zeitzone in Einstellungen > Allgemein auf „Berlin“, klappt es auch mit der anstehenden Umstellung auf Sommerzeit.

    Ansonsten ist der Website-Bericht unauffällig.

    Deine Startseite wird im Browser als „unsicher“ angezeigt, weil gemischte Inhalte (https und http) verwendet werden. Kontrolliere dazu bitte die Einstellung der URL in Einstellungen > Allgemein – fangen beide mit https an? Danach kannst du das Plugin Better Search Replace verwenden, um in der Datenbank die eigene URL mit http in allen Datenbank-Tabellen mit der URL mit https zu ersetzen.


    Nachtrag: Hans-Gerd war wiedermal schneller – ich werd‘ alt. 👴🏼

    • Diese Antwort wurde geändert vor 2 Monaten, 1 Woche von Bego Mario Garde. Grund: Nachtrag
    Thread-Ersteller flugzeug

    (@flugzeug)

    Habe die Zeitzone angepasst; mit Better Search Replace alle http durch https ersetzt; und die permalinks auf Beitragsnamen umgestellt.

    Nun zu den widgets:
    Wenn ich classic widgets installiere, dann verschwindet die Fehlermeldung. Aber ohne dieses Plugin wird es komisch:

    Ich kann mit dem Customizer alle widgets aus der Seitenleiste (Beispielbeitrag hier: https://auf-kante.de/2022/03/18/klamotten-klima/) löschen. Aber wenn ich dann auf Design>Widgets clicke, dann kommt die Fehlermeldung, und alle widgets, die ich zuvor gelöscht hatte, sind wieder da!

    Ich habe den Verdacht, dass das mit meinem Theme (Shopisle) zu tun hat. Muss ich evtl das Theme austauschen? Hier noch die Fehlermeldung aus Design>Widgets:

    metaBoxFix/<@https://auf-kante.de/wp-content/themes/shop-isle/inc/compatibility/wordpress-editor/wp-editor-scripts.js?ver=1.1.60:20:18
    pfJ3/$/n/<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:17360
    n@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:17349
    emit@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:17494
    i@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:17681
    pfJ3/Z/p/t.subscribe/o<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:18690
    pfJ3/q/instantiate/v</<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:16310
    b@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:8590
    pfJ3/q/instantiate/</</<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:13584
    +ekt/s/</</<@https://auf-kante.de/wp-includes/js/dist/redux-routine.min.js?ver=6c3ab278bc9641b6f62731e018a4449e:2:1797
    pfJ3/L/</<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:10824
    pfJ3/x/</</<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:11136
    pfJ3/q/instantiate/f</<@https://auf-kante.de/wp-includes/js/dist/data.min.js?ver=c5f9378263e5eea9d870764c8fc1dd1b:2:14301
    /QNa/t.a</<@https://auf-kante.de/wp-includes/js/dist/block-editor.min.js?ver=54657317be78fb1c246c72b38dc2ed0e:2:25219
    Tj@https://auf-kante.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:179:399
    unstable_runWithPriority@https://auf-kante.de/wp-includes/js/dist/vendor/react.min.js?ver=17.0.1:24:26
    Za@https://auf-kante.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:73:8
    Ra@https://auf-kante.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:178:368
    Rj/<@https://auf-kante.de/wp-includes/js/dist/vendor/react-dom.min.js?ver=17.0.1:178:275
    R@https://auf-kante.de/wp-includes/js/dist/vendor/react.min.js?ver=17.0.1:16:299
    ua.port1.onmessage@https://auf-kante.de/wp-includes/js/dist/vendor/react.min.js?ver=17.0.1:22:361

    Habe die Zeitzone angepasst; mit Better Search Replace alle http durch https ersetzt; und die permalinks auf Beitragsnamen umgestellt.

    Prima. Jetzt wird die Seite auch nicht mehr als „unsicher“ angezeigt.

    Wenn ich classic widgets installiere, dann verschwindet die Fehlermeldung. Aber ohne dieses Plugin wird es komisch …

    Hm, dann … 💡 nutz doch einfach das Plugin? 😀

    Muss ich evtl das Theme austauschen?

    Es gab wohl eine neuere Version 1.1.62, bevor das Theme komplett aus dem WordPress-Verzeichnis genommen wurde – was generell kein gutes Zeichen ist. 🙂

    Hier noch die Fehlermeldung aus Design>Widgets: metaBoxFix …

    Hm, komisch – die Zeichenkette metaBoxFix kommt in WordPress gar nicht vor und wenn ich in Google danach suche, finde ich nur Beiträge zu „Nulled Themes“ (kostenpflichtige Themes, bei denen die Lizenzabfrage „mit Nullen überschrieben“ wurde, auch Raubkopie genannt und meistens mit Malware versehen). Aber damit hast du doch sicher nichts zu tun?

    Thread-Ersteller flugzeug

    (@flugzeug)

    Hm, ich habe mir das Theme einfach direkt aus Design>Themes in WordPress rausgesucht und installiert. Da kann es ja sicher keine Raubkopie sein!?

    So oder so scheint es mir aber Sinn zu machen, ein anderes Theme zu wählen, das auch weiter gepflegt wird.

    Mein Plan ist darum, jetzt erstmal eine Staging-Seite (falls das der richtige Begriff ist) anzulegen und dann ein neues Theme zu installieren.

    Hm, ich habe mir das Theme einfach direkt aus Design>Themes in WordPress rausgesucht und installiert. Da kann es ja sicher keine Raubkopie sein!?

    naja, kommt darauf an, wo du das rausgesucht hast. 😉

    Eine (lokale) Entwicklungsumgebung wie z. B. Laragon, bitnami oder Local by Flywheel aufzusetzen, ist sicher hilfreich, um ein entsprechendes Theme zu testen.

    Thread-Ersteller flugzeug

    (@flugzeug)

    Habe mir jetzt mit Duplicator (nach dieser Anleitung: https://www.wpbeginner.com/wp-tutorials/how-to-create-staging-environment-for-a-wordpress-site/#stagingplugin) einen Klon der Website erstellt. Da habe ich das Theme ausgetauscht und das Aussehen der Seite unter dem neuen Theme wieder zurechtgepuzzelt.

    Die Tools für eine lokale Entwicklungsumgebung merke ich mir auf jeden Fall. Im Moment habe ich das Gefühl, noch ein bisschen mehr Erfahrung sammeln zu wollen, bevor ich mich auf eines davon festlege (genauso wie bei den verschiedenen kostenpflichtigen Tools, wie zB wp staging).

    Beide Lösungen (Classic widgets und Theme-Austausch) haben funktioniert, der Fehler ist weg; außerdem noch viel mehr tolle Hilfestellung hier, vielen Dank!

    alles klar – danke für die Rückmeldung und „Gelöst“-Markieren 👍

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)