Support » Allgemeine Fragen » Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst marliesb82

    (@marliesb82)


    Hallo zusammen,

    ich hab zwar schon den ein oder anderen Beitrag zu dem Thema gelesen, aber ich hab keine Lösung gefunden.
    Ich kann meine Seiten nicht mehr bearbieten, es kommt immer die Fehlermeldung „Die Antwort ist keine gültige JSON-Antwort“.

    WordPress ist aktuell auf 5.3.2 ich verwende das Theme Radiant Pro mit ein paar wenigen PlugIns.
    Health Check & Troubleshooting habe ich schon runtergeladen. Es wird hauptsächlich angemerkt, dass php zu alt ist, ich habe auf php 7.0 aktualisiert, aber es geht immer noch nicht. Wenn ich auf php 7.2. oder höher aktualisiere geht die Seite gar nicht mehr und es kommt ein php Fehler.
    Die Seite liegt bei IONOS (1und1).
    Dem „Problembehebungsmodus“ habe ich auch schon ausprobiert, aber das gleiche Problem tritt auf!

    Ich hoffe sehr, es kann mir jemand weiterhelfen!!
    (Mitte Oktober 2019 hat noch alles problemlos funktioniert.)

    Vielen Dank und Grüße
    Marlies

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo,
    auch wenn du schon das plugin Health Check & Troubleshooting installiert hast, scheint mir, dass du noch nicht alle Möglichkeiten ausgeschöpft hast.
    Im Problembehandlungsmodus ist als theme (falls vorhanden) twenty nineteen aktiviert und alle plugins sind deaktiviert. Dann kannst Du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembenhandlungsmodus und schaue anschließend, ob das Problem noch besteht. Auf diese Weise kannst Du möglicherweise das Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies Dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Du findest unter „Info“ einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, wo das Problem liegt.
    Ein weiterer Aspekt zeigt sich bezogen auf die Umstellung der PHP-Version: Wenn nach er Umstellung auf PHP 7.2 „die Seite gar nicht mehr“ geht, dann deutet das auf ein Problem bei einem Plugin oder theme hin. Es kann dann z. B. sein, dass das plugin oder theme nicht unter PHP 7.2 funktioniert.
    Letztendlich bleiben aber auch einige Fragen, weil die Beschreibung von dir nicht eindeutig ist, um dir helfen zu können:

    1. Was heißt genau "es geht immer noch nicht"? – Wie äußert sich das?
    2. Welcher "PHP – Fehler" kommt nach Einstellung von PHP 7.2?

    Wenn es am theme liegen sollte, können wir dir kaum weiterhelfen, weil das theme uns nicht zur Verfügung steht. Wir müssten sonst bei jeder Frage erst einmal das passende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast. Du solltest dich in dem Fall an den Entwickler wenden. Lies bitte auch mal in der FAQ (B 5.) zu diesem Thema.
    Viele Grüße
    Hans-Gerd

    Was ist denn unter Einstellungen > Allgemein als Website- und WordPress-URL eingetragen? Die Website läuft zwar unter http://reisebuero-schoefmann.de/, verweist dann aber an vielen Stellen auf http://toelzerautoreisen.apps-1and1.net/ – ich nehme an, dass WordPress damit „durcheinander kommt“.

    Hallo Hans-Gerd,

    Vielen Dank für die ausführliche Antwort, hier der Health-Check Bericht:

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2
    wordpress_size: 418,24 MB (438552796 bytes)
    uploads_path: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/uploads
    uploads_size: 80,85 MB (84775054 bytes)
    themes_path: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes
    themes_size: 7,31 MB (7669362 bytes)
    plugins_path: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/plugins
    plugins_size: 5,01 MB (5254123 bytes)
    database_size: 190,99 MB (200265728 bytes)
    total_size: 702,40 MB (736517063 bytes)
    
    ### wp-active-theme ###
    
    name: Radiant Pro (radiantpro-yXlW4z)
    version: 1.0.1.2
    author: CyberChimps
    author_website: http://cyberchimps.com/
    parent_theme: none
    theme_features: woocommerce, post-formats, automatic-feed-links, post-thumbnails, custom-background, menus, widgets
    theme_path: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes/radiantpro-yXlW4z
    
    ### wp-themes-inactive (1) ###
    
    Twenty Nineteen: version: 1.4, author: WordPress-Team
    
    ### wp-mu-plugins (3) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    Product Subdomain: author: (undefined), version: (undefined)
    Safe mode: author: (undefined), version: (undefined)
    
    ### wp-plugins-active (5) ###
    
    Antispam Bee: version: 2.9.1, author: pluginkollektiv
    EU Cookie Law: version: 3.1, author: Alex Moss, Marco Milesi
    FooBox Image Lightbox: version: 2.7.8, author: FooPlugins
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    Limit Login Attempts: version: 1.7.1, author: Johan Eenfeldt
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
    httpd_software: Apache
    php_version: 7.0.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 2M
    php_post_max_size: 8M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: false
    server-headers: 
    	content-type: text/html; charset=UTF-8
    	date: Mon, 06 Jan 2020 08:48:18 GMT
    	server: Apache
    	x-powered-by: PHP/7.0.33
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	x-ua-compatible: IE=edge,chrome=1
    	link: <http://reisebuero-schoefmann.de/wp-json/>; rel="https://api.w.org/", <http://reisebuero-schoefmann.de/>; rel=shortlink
    	content-encoding: gzip
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.60-0+deb7u1-log
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content
    WP_PLUGIN_DIR: /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Wenn ich im Problemmodus bin und die Seite bearbeiten möchte, auch in dem Standard Thene, kommt weiterhin beim Speichern, die Fehlermeldung: „Die Antwort ist keine gültige JSON-Antwort“.

    Wenn ich auf php 7.2. update kommt folgendes beim Aufruf der Seite:

    Fatal error: Uncaught Error: [] operator not supported for strings in /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes/radiantpro-yXlW4z/cyberchimps/options/options-sanitize.php:192 Stack trace: #0 /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-includes/class-wp-hook.php(288): cyberchimps_sanitize_section_order(Array, Array) #1 /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #2 /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes/radiantpro-yXlW4z/cyberchimps/options/options-init.php(1265): apply_filters(‚cyberchimps_san…‘, Array, Array) #3 /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes/radiantpro-yXlW4z/cyberchimps/init.php(91): cyberchimps_get_default_values() #4 /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-includes/class-wp-hook.php(288): cyberchimps_core_setup_theme(“) #5 /homepages/29/d28858546/htdocs/c in /homepages/29/d28858546/htdocs/clickandbuilds/WordPress/MyCMS2/wp-content/themes/radiantpro-yXlW4z/cyberchimps/options/options-sanitize.php on line 192

    Vielleicht fällt dir noch eine Lösung ein, das wäre super?

    Vielen Dank!!

    Viele Grüße
    Marlies

    Hallo Bego Mario,

    auch vielen Dank für deine Antwort.

    Es ist folgendes eingestellt:
    WordPress-Adresse (URL): http://toelzerautoreisen.apps-1and1.net
    Website-Adresse (URL): http://reisebuero-schoefmann.de

    http://toelzerautoreisen.apps-1and1.net ist wordpress, wie kann ich das ändern?

    Viele Grüße
    Marlies

    Hallo,
    zunächst ist mir aufgefallen, dass das Plugin „Limit Login Attempts“ sehr alt ist, siehe hier.
    Das könnte problematisch sein, muss aber nicht. So weit ich das gesehen habe, ist das Plugin „Limit Login Attempts Reloaded“ sozusagen der „Nachfolger“ des Plugins.
    Das könnte eine Ursache sein.
    Daher würde ich das Plugin mal deaktivieren.
    Aufgrund der Fehlermeldungen gehe ich aber eher davon aus, dass das theme die Probleme verursacht. Du hast allerdings geschrieben, dass du bereits das Standardtheme (welches?) getestet hast und die gleichen Fehlermeldungen kamen.
    Das solltest du noch mal prüfen.
    Viele Grüße
    Hans-Gerd

    Hallo zusammen,

    ich habe nun einfach mal auch bei der
    WordPress-Adresse (URL): http://reisebuero-schoefmann.de hinterlegt!
    Jetzt gehts wieder!!
    Muss ich da bei 1und1/IONOS auch noch was ändern?

    Das Login Attempts Reloaded Plugin werde ich auch aktualisieren!

    Vielen Dank!
    Viele Grüße
    Marlies

    Hallo,

    Muss ich da bei 1und1/IONOS auch noch was ändern?

    kann ich dir leider nicht sagen. Aber es scheint ja zu funktionieren. Sonst einfach mal beim Hoster anrufen.
    Außerdem ist es in vielerlei Hinsicht hilfreich, wenn du ein SSL-Zertifikat einrichtest. Auf der folgenden Seite findest du eine Anleitung, wie du Deine Webseite korrekt umstellst.
    Wenn das damit erledigt ist, bitte als „gelöst“ markieren.
    Viele Grüße
    Hans-Gerd

    Vielen Dank!

    Hallo, ich habe das gleiche Problem.
    “ Aktualisierung fehlgeschlagen. Fehlermeldung: Die Antwort ist keine gültige JSON-Antwort“

    Vielleicht könnt Ihr mir weiterhelfen.

    Das Problem tritt massiv auf wen ich einen neuen Beitrag erstellen will.( Blog )
    bzw.da geht nichts mehr.

    Ich bin bei 1und1 Ionos gehostet.

    Meine Addi: http://www.koos-interior-design.de

    Den Tipp vom Marliesb82 kann ich nicht nachvollziehen.
    Die wordpress adr.und Webadresse sind bei mir eingetragen in den allgemeinen Einstellungen aber grau hinterlegt. Die kann ich aktuell gar nicht bearbeiten bzw. ändern.

    Vielen dank für euer Feedback

    Andras

    Moderator Bego Mario Garde

    (@pixolin)

    @androsimus Bitte beachte unsere Forenregeln und häng deine Frage nicht an einen bereits gelösten Thread an, sondern starte einen neuen Thread.

    Ich schließe diesen Thread für weitere Antworten.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Die Antwort ist keine gültige JSON-Antwort.“ ist für neue Antworten geschlossen.