Support » Allgemeine Fragen » die Funktion „planen“ bei der Veröffentlichung eines Artikels

  • Gelöst Harald Wendler

    (@harald-wendler)


    in den letzten Tagen (vorher ab und zu ) funktioniert die Planung nach Zeit und Uhrzeit nicht.
    Wo kann ich mit der Ursachenforschung beginnen?

    Gruß
    Harald

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Hallo Harald,

    du kannst mit WP Crontrol prüfen, welche Aufgaben geplant sind.

    WordPress verwendet keine echten Cron-Jobs, weil nicht jedes Webhosting die Einrichtung von Cron-Jobs erlaubt. Soweit ich mich erinnere, kannst du bei deinem Webhoster aber Cron-Jobs einstellen. Dieser Beitrag geht etwas detaillierter auf das Thema ein: So deaktivierst du WP-Cron (wp-cron.php) für schnellere Leistung

    Was heisst funktioniert nicht? Werden die Artikel verzögert veröffentlicht oder garnicht?
    Setzt du ein caching plugin ein?
    Wieviele Besucher hat deine Webseite am Tag?

    An den Besucherzahlen wird es nicht liegen. Harald betreibt ein rege besuchtes Narichtenportal für Mönchengladbach mit einigen tausend Zugriffen am Tag. (Wir kennen uns schon eine Weile.)

    Ein Cache-Plugin könnte ich mir eher als Ursache vorstellen.

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Habe mir erstmal WP Control eingerichtet und muss jetzt erstmal lesen und verstehen, das dauert.
    Die vielen Infos in der Datei muss ich serst verstehen, dann melde ich mich wieder.

    Bis hierhin schon mal Danke Bego

    Und ja, ich benutze WP Fastest Cache.

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Hi Bego,

    habe jetzt WP-Cron deaktiviert wie beschrieben.
    Werde weiter testen was nun passiert.
    Melde mich wieder sobald ich ein Ergebnis habe, egal welches.

    Schönen Abend
    Harald

    Hallo Harald,
    ich habe das Problem mit einer Website auch bei mir vor langer Zeit gehabt und habe WP-Cron über wp-config.php mit
    define('DISABLE_WP_CRON', true);
    deaktiviert und über WP Crontrol die Zeitpläne eingestellt. Danach hat das auf dieser WordPress-Instanz bis heute funktioniert.

    Auf einer anderen fast baugleichen WordPress-Instanz musste ich das nicht machen.

    Melde dich noch mal hier, wenn das bei dir nicht klappen sollte.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Hallo Hans-Gerd,

    genau so habe ich es gemacht, Bego hatte mir die Anleitungs.doc geschickt.

    Die Zeitpläne muss ich jetzt erst noch „lernen“ und dann einstellen.
    Gruß nach Nederland
    Harald

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Hi, hier bin ich wieder.

    cronjobs sind beim Hoster eingerichtet, nach etlichen Versuchen hat es geklappt.
    Mit einem externen Link: https://mg-heute.de/wp-cron.php?_nonce=ebfcb37d&backwpup_run=runext&jobid=2

    Danke an alle für die Hilfe

    Bleibt für mich die Frage offen: Warum werden Artikel nicht zur eingestellten Zeit veröffentlicht?
    Muß ich für jeden geplanten Artikel einen cron-Auftrag schreiben/anlegen?

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, „nonce“ ist eigentlich die Abkürzung für eine „Number used once“ – also eine einmalige Nummer. Diese Nummer dient zur Bestätigung dass eine Berechtigung vorliegt, den Link aufzurufen.

    Eigentlich richtest du einen Cron-Job auf, um https://mg***te.de/wp-cron.php aufzurufen. Damit wird dann die Liste aller anstehenden Aufträge abgearbeitet – auch geplante Beiträge.

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Kopiere den Link für einen externen Auftragsstart. Diese Option muss erst aktiviert werden, damit der Link funktioniert.

    Obiges schreibt backwpup in der Auftragsplanung.

    Ich teste mal Deinen Vorschlag oben, bis bald

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Hi Bego,

    es klappt mit Deinem Vorschlag, sowohl das backup als auch die Artikelveröffentlichung, nachdem ich mein cache.plugin deaktiviert habe.

    Muß mir wohl ein anderes suchen.

    Nochmals herzlichen Dank
    Harald

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo Harald,
    schön, dass es jetzt mit Hilfe von Begos Vorschlag funktioniert. Ich markiere den Thread dann als gelöst.

    Viele Grüße
    Hans-Gerd

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Hallo zusammen,
    muß doch nochmal nachfragen
    die backups der Datenbank und das Dateienbackup laufen einwandfrei.
    Habe dazu beim Provider jeweils einen Cronjob mit täglicher Wiederholung gemacht.
    Dadurch wurden automatisch in WP-Control ein Zeitplan kreiert, funktioniert.

    Artikel werden jedoch nicht veröffentlicht.
    Habe ich etwas falsch verstanden?
    Muß ich je Artikel in WP-Kontrol einen Zeitplan einstellen?
    Das Cach-Plugin ist deaktiviert.

    Gruß
    Harald

    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von Harald Wendler.

    Habe dazu beim Provider jeweils einen Cronjob mit täglicher Wiederholung gemacht.

    du solltest einen cron anlegen der minutlich die https://mg***te.de/wp-cron.php aufruft 🙂

    Thread-Starter Harald Wendler

    (@harald-wendler)

    Lieber support,
    ist es sinnvoll minütliche cronjobs anzustoßen um 1 (einen) Artikel zu veröffentlichen?
    Mir ist nicht klar was ich damit anstelle.
    Eine 2. Meinung könnte mir helfen (wie in der Medizin).

    Gruß
    Harald

    • Diese Antwort wurde geändert vor 1 Woche, 3 Tage von Harald Wendler.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)