Support » Allgemeine Fragen » Die REST-API kam zu einem unerwarteten Ergebnis

  • 
    
    Die REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Ein Beispiel ist der Bildschirm des Block-Editors, der darauf aufbaut, deine Beiträge und Seiten anzuzeigen und zu speichern.
    
    Der Aufruf der REST-API führte zu folgendem unerwarteten Ergebnis: (404) <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en"> <head> <title>Object not found!</title> <link rev="made" href="mailto:mail@joelmueller.ch" /> <style type="text/css"><!--/*--><![CDATA[/*><!--*/ body { color: #000000; background-color: #FFFFFF; } a:link { color: #0000CC; } p, address {margin-left: 3em;} span {font-size: smaller;} /*]]>*/--></style> </head> <body> <h1>Object not found!</h1> <p> The requested URL was not found on this server. The link on the <a href="https://joelmueller.ch/wp-json/wp/v2/types/post%3fcontext=edit">referring page</a> seems to be wrong or outdated. Please inform the author of <a href="https://joelmueller.ch/wp-json/wp/v2/types/post%3fcontext=edit">that page</a> about the error. </p> <p> If you think this is a server error, please contact the <a href="mailto:mail@joelmueller.ch">webmaster</a>. </p> <h2>Error 404</h2> <address> <a href="/">joelmueller.ch</a><br /> <span>Apache</span> </address> </body> </html> .
    

    Rewite ist aktiviert.

    vhost sieht so aus:

    <VirtualHost *:80>
         ServerAdmin mail@joelmueller.ch
         ServerName joelmueller.ch
         ServerAlias www.joelmueller.ch
         DocumentRoot /usr/share/webapps/blog/
         DirectoryIndex index.php
    
         <Directory /usr/share/webapps/blog>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    
        <FilesMatch \.php$>
          # For Apache version 2.4.10 and above, use SetHandler to run PHP as a fastCGI process server
          SetHandler "proxy:unix:/run/php-fpm/php-fpm.sock|fcgi://localhost"
        </FilesMatch>
        <Files "*.php">
          MultiviewsMatch Any
        </Files>
        </Directory>
         ErrorLog /var/log/httpd/blog_error.log
         CustomLog /var/log/httpd/blog_access.log combined
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =joelmueller.ch
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </VirtualHost>
    <VirtualHost *:443>
         ServerAdmin mail@joelmueller.ch
         ServerName joelmueller.ch
         ServerAlias www.joelmueller.ch   
         DocumentRoot /usr/share/webapps/blog
         DirectoryIndex index.php
    
         <Directory /usr/share/webapps/blog>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Order allow,deny
            allow from all
    
        <FilesMatch \.php$>
          # For Apache version 2.4.10 and above, use SetHandler to run PHP as a fastCGI process server
          SetHandler "proxy:unix:/run/php-fpm/php-fpm.sock|fcgi://localhost"
        </FilesMatch>
    
        <Files "*.php">
         MultiviewsMatch Any
        </Files>
    	
        </Directory>
         ErrorLog /var/log/httpd/blog_error.log
         CustomLog /var/log/httpd/blog_access.log combined
    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/joelmueller.ch/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/joelmueller.ch/privkey.pem
    </VirtualHost>
    [morta@5erver vhosts]$ 
    
    

    Was ist falsch?

    Das einzige was mir vorstellen kann ist eine Theme das ich editiert habe. Aber das sollte doch keinen Einfluss haben.

    Wenn ich einen Beitrag veröffentlichen will kommt immer diese Fehlermeldung:
    Veröffentlichung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Problem kann unterschiedliche Ursachen haben. Über die Suche hier im Forum findest du schon einige Hinweise zur Lösung des Problems, z. B. folgender Beitrag

    Thread-Starter morta1985

    (@morta1985)

    Ich habe gesucht und verschiedene Lösungen probiert und nichts hat geholfen, am Schluss war es ganz einfach.

    Die Permalinks mussten geupdated werden und danach ging es wieder!

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von morta1985.

    Freut mich, dass es geklappt hat.
    Diese Empfehlung hat Bego ja auch in dem von mir verlinkten Thread als erste Antwort gegeben.
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von Hans-Gerd Gerhards. Grund: Korrektur (Tippfehler)
Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Die REST-API kam zu einem unerwarteten Ergebnis“ ist für neue Antworten geschlossen.