Support » Themes » Die Verarbeitung des Bildes ist fehlgeschlagen.

  • Guten Abend zusammen ich habe schon viel im Forum gelesen und auch im Internet nachgeschaut ob ich irgend eine Lösung für mein Problem finde. Bin aber bis jetzt nicht zu einer Lösung gekommen.
    Obwohl ich viel zu meinem Problem finde sehe ich keine Möglichkeit mein Problem zu lösen, deswegen wende ich mich auf diesem Weg an Benutzer von WordPress die mir eventuell helfen könnten.

    meine Eckdaten:

    Ich habe mir einen eigenen Webserver aufgebaut, also meine Beschränkungen sind mein eigener Server.

    der Server besitzt aktuell:

    16 CPU
    64 GB RAM
    186 GB freien HDD Platz.

    beim Hochladen von Medien bekomme ich folgende Fehlermeldung:

    Die Verarbeitung des Bildes ist fehlgeschlagen. Der Server ist möglicherweise ausgelastet oder hat nicht genügend Ressourcen zur Verfügung. Eventuell hilft es, wenn Sie ein kleineres Bild hochladen. Die vorgeschlagene Maximalgrösse ist 2500 Pixel.

    Maximale Dateigrösse für Uploads: 128 MB.

    Ich möchte eine Date Hochladen welche folgende Grösse hat:
    Typ JPG Grösse 299KB

    hat mir da jemand einen gangbaren weg.

    Meine WordPress Version:
    5.6.1
    Themes:
    OceanWP

    Plugins:
    Elementor Version 3.1.1
    Ocean Extra Version 1.7.2

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller gery63

    (@gery63)

    #
    ### wp-core ###
    
    version: 5.6.1
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: undefined
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: U:\Go2Dive
    wordpress_size: 50,96 MB (53434285 bytes)
    uploads_path: U:\Go2Dive/wp-content/uploads
    uploads_size: 3,80 MB (3982319 bytes)
    themes_path: U:\Go2Dive/wp-content/themes
    themes_size: 19,66 MB (20611239 bytes)
    plugins_path: U:\Go2Dive/wp-content/plugins
    plugins_size: 45,81 MB (48030839 bytes)
    database_size: 2,66 MB (2785280 bytes)
    total_size: 122,88 MB (128843962 bytes)
    
    ### wp-active-theme ###
    
    name: OceanWP (oceanwp)
    version: 2.0.2
    author: Nick
    author_website: https://oceanwp.org/about-me/
    parent_theme: none
    theme_features: core-block-patterns, align-wide, wp-block-styles, responsive-embeds, editor-styles, editor-style, menus, post-formats, title-tag, automatic-feed-links, post-thumbnails, custom-header, custom-logo, html5, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, customize-selective-refresh-widgets, widgets
    theme_path: U:\Go2Dive/wp-content/themes/oceanwp
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.9, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.1, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (2) ###
    
    Elementor: version: 3.1.1, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Ocean Extra: version: 1.7.2, author: OceanWP, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: false
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: not available
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Windows NT 10.0 AMD64
    httpd_software: Microsoft-IIS/10.0
    php_version: 7.4.12 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 32768M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: not available
    suhosin: false
    imagick_availability: false
    pretty_permalinks: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 8.0.23
    client_version: mysqlnd 7.4.12
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: U:\Go2Dive/wp-content
    WP_PLUGIN_DIR: U:\Go2Dive/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 32768M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    #

    Hallo,
    viel habe ich nicht gefunden:
    Ich gehe mal davon aus, dass das Problem mit dem Windows NT Server zusammenhängt. @pixolin hatte dazu vor einiger Zeit in diesem Thread den folgenden Hinweis gegeben: „Die Nutzung von WordPress auf einem Windows Server ist wohl nicht ganz unproblematisch. Schau mal, ob du aus diesem (etwas polemischen) Beitrag etwas hilfreiches erfährst: https://www.soupbowl.io/2020/01/the-complete-guide-to-running-wordpress-on-windows-iis/“
    Vielleicht hilft es, wenn du andere Werte für WP_MAX_MEMORY_LIMIT und WP_MEMORY_LIMIT in der wp-config.php definierst (vermutlich aber eher nicht)
    Als Zeitzone solltest du unter Einstellungen > Allgemein „Berlin“ eintragen.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Ein PS-starkes Auto nutzt dir nichts, wenn es keine Reifen hat. 🙂

    Dein Server ist überdimensioniert, aber Imagemagick nicht installiert. WordPress kann dann aber auf die Grafikbibliothek GD zurückfallen, wenn sie vorhanden ist. Prüf bitte mal über die Konsole, ob GD installiert ist: php -i | grep 'GD' – du solltest dann eine Rückmeldung GD Support => enabled bekommen.

    Was für eine Bilddatei möchtest du hochladen? Die Dateigröße ist hier irrelevant, da das Bild zur Skalierung pixelweise eingelesen werden muss. Bitte probier mal, ob du diese Datei hochladen kannst: https://s.w.org/style/images/about/WordPress-logotype-standard.png

    Auch ein fehlendes Verzeichnis zum Ablegen temporärer Dateien könnte eine Ursache sein. Du kannst im Verzeichnis wp-content ein Unterverzeichnis temp anlegen und dem Verzeichnis mit chmod 755 /var/www/html/wp-content/temp (Pfad bitte anpassen) passende Benutzerrechte einräumen. Dann bearbeitest du die wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code, kostenlos für alle Betriebssysteme erhältlich) und fügst oberhalb von /* That's all, stop editing! Happy blogging. */ die Zeile

    define('WP_TEMP_DIR', dirname(__FILE__) . '/wp-content/temp/');

    ein.

    Übrigens können auch Dateinamen mit Sonderzeichen (in diesem Fall gehören dazu auch Umlaute) Probleme bereiten.

    Thread-Ersteller gery63

    (@gery63)

    Hallo Bego Mario Garde
    danke für den Tipp.
    Habe leider vergessen mitzuteilen das es sich um einen Windows Server 2019 und eine IIS handelt.
    die Berechtigungen haben wir auf diesem Ordner auf Vollzugriff gesetzt. keine Veränderung.

    Moderator Bego Mario Garde

    (@pixolin)

    Zum Window Server hat dir Hans-Gerd doch schon was geschrieben – das müssen wir doch nicht nochmal wiederholen.

    Für Außenstehende ist die Fehlermeldung „Die Verarbeitung des Bildes ist fehlgeschlagen. Der Server ist möglicherweise ausgelastet oder hat nicht genügend Ressourcen zur Verfügung.“ noch schlechter nachzuvollziehen. Du könntest mit den Entwickler-Tools des Browsers die Antwort-Header auslesen. Vielleicht ergibt auch der Error-Log einen Hinweis. Wir können uns weder Antwort-Header anschauen, noch haben wir Zugriff auf den Error-Log und auf meine anderen Anmerkungen (Dateiname, Bildabmessungen, Imagemagick- und GD-Bibliothek) bist du nicht eingegangen. Ich kann dir da wenig weiterhelfen, wünsche aber viel Erfolg bei der Lösung des Problems.

    Guten Abend Zusammen

    Wir konnten das Problem und dessen Ursache lösen. Der Fehler lag im php.ini File. Die Option ;upload_tmp_dir = war ausgeklammert und ohne Pfad hinterlegt. Nachdem wir auf diesem einen Pfad festgesetzt hatten, konnten wir nun Bilder auf die Webseite uploaden. Nun haben wir das Problem, das wir auf diesem IIS mehrere Webseiten gleichzeitig laufen lassen wollen und daher diesen Pfad pro Seite definieren wollen und nicht per PHP File auf allen den selben.

    Kann uns jemand Sagen wo wir diesen spezifisch anpassen können. Wir möchten euch noch für die Vielen Rückmeldungen danken.

    PS. Ich arbeite mit Gery zusammen an seiner Webseite und kümmere mich hauptsächlich um den Betrieb dieser.

    Hallo,
    das ist dann eher kein WordPress-Problem. Insofern solltest du dich mit der Frage besser an Foren wenden, die sich mit dieser Thematik befassen.
    Ich glaube kaum, dass du in diesem Forum Hilfe dazu erhältst.
    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)