Support » Allgemeine Fragen » Domain Adresse anstatt Weiterleitung

  • Hallo aktuell habe ich eine Homepage und unter dieser sind auch mehrere verschiedene Projekte untergegliedert. Das heißt das jedes Projekt seine eigene WordPress Anwendung hat.

    Ungefähr so aufgegliedert:
    Homepage WordPress Anwendung
    Projekt A WordPress Anwendung
    Projekt B WordPress Anwendung
    usw.

    Meine Frage diesbezüglich, ob ich alle Projekte auch unter einer WordPress Anwendung laufen lassen kann aber jedes Projekt seine eigene Domain beibehält.

    Ungefähr so: Beispiel
    Homepage (Homepage.de)
    Projekt A (ProjektA.de)
    Projekt B (ProjektB.de)
    usw.

    Noch eine Info am Rande, alle Projekte sind über die Homepage erreichbar, allerdings hat jedes Projekt seine eigene Webseite und WordPress Anwendung. Eine Interne-Weiterleitung also.

    Eine Interne-Weiterleitung würde ja so aussehen:
    Homepage+Projekt A (Homepage.de/ProjektA)
    So soll es aber nicht sein, denn für den User soll es so aussehen, ob es eine eigene Webseite unter der Domain (ProjektA.de) ist, nachdem man unter (Homepage.de/projekte) ein Projekt angeklickt hat.

    Wer sich die Webseite angesehen hat, weiß ich mein mit der Intern-Weiterleitung und dabei auf die URL in der Adresszeile achtet.

    Ich vermute auch das dies wohl eher mit der Domain zutun haben wird, anstatt mit WordPress. Ich hoffe das Ihr mir dennoch helfen könnt.

    Mit freundlichem Gruß
    Michael

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 31 bis 42 (von insgesamt 42)
  • Thread-Starter Michael

    (@shelby0815)

    Auch das verstehe ich nicht. Du postest einen Screenshot vom Backend und fragst, wie du dich im Backend anmelden kannst?

    Du solltest über den Link „Meine Websites“ ganz oben auch einen Link zur eingerichteten Website sehen und dort wiederum einen Link zum Dashboard der zusätzlich angelegten Website.

    Das war ein Bild vom Dashboard des Netzwerks aber wenn über das Netzwerk ein Dashboard einer anderen Webseite öffnen möchte, die zum Netzwerk gehört, kommt Fehler 404.


    (zum Vergrößerern anklicken)

    Wenn ich wie im Bild zu sehen auf das Dashboard der Webseite zugreifen möchte, erhalte ich den Fehler 404.

    (zum Vergrößerern anklicken)


    Moderationshinweis: Unser Forum kann BBCode nicht umsetzen. Bitte verwende HTML oder platziere einfach einen Link zum Bild.

    • Diese Antwort wurde geändert vor 1 Jahr, 5 Monaten von Michael.
    • Diese Antwort wurde geändert vor 1 Jahr, 5 Monaten von Michael.
    • Diese Antwort wurde geändert vor 1 Jahr, 5 Monaten von Bego Mario Garde.

    Schaust du bitte mal beim Kundenmenü von Strato, ob unter Sicherheit der Gästebuchfilter aktiv ist? Falls ja, bitte deaktivieren.

    Thread-Starter Michael

    (@shelby0815)

    Schaust du bitte mal beim Kundenmenü von Strato, ob unter Sicherheit der Gästebuchfilter aktiv ist? Falls ja, bitte deaktivieren.

    Okay habe ich ausgeschaltet. Leider keine Änderung.

    Dann müsstest du Einträge im Error-Log finden.
    Was steht da?

    https://www.strato.de/faq/hosting/wo-finde-ich-meine-logfiles/#bereitstellung_errorlogs

    Poste bitte auch mal den Inhalt der wp-config.php (aus der Antwort vor dem Absenden bitte Zugangsdaten zur Datenbank und SALT-Keys löschen) und der .htaccess.

    Thread-Starter Michael

    (@shelby0815)

    Logfile Strato:
    29.12.2022 11:58:02 simulationmaiki0815.de [client 139.59.121.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    29.12.2022 11:58:02 simulationmaiki0815.de [client 139.59.121.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    30.12.2022 01:24:25 simulationmaiki0815.de [client 198.20.67.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    30.12.2022 01:24:25 simulationmaiki0815.de [client 198.20.67.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    30.12.2022 01:24:25 simulationmaiki0815.de [client 198.20.67.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    30.12.2022 01:24:25 simulationmaiki0815.de [client 198.20.67.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    02.01.2023 07:08:25 simulationmaiki0815.de [client 167.99.69.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.
    02.01.2023 07:08:25 simulationmaiki0815.de [client 167.99.69.0] AH00124: Request exceeded the limit of 4 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.

    wp-config:

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the installation.
     * You don't have to use the web site, you can copy this file to "wp-config.php"
     * and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * Database settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** Database settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    
    VON MODERATOR: Datenbankzugangsdaten entfernt.
    
    /** Database charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The database collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication unique keys and salts.
     *
     * Change these to different unique phrases! You can generate these using
     * the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}.
     *
     * You can change these at any point in time to invalidate all existing cookies.
     * This will force all users to have to log in again.
    
    VON MODERATOR: Salt keys entfernt.
    
    /**
     * Other customizations.
     */
    define('FS_METHOD','direct');
    define('FS_CHMOD_DIR',0755);
    define('FS_CHMOD_FILE',0644);
    define('WP_TEMP_DIR',dirname(__FILE__).'/wp-content/uploads');
    
    /**#@-*/
    
    /**
     * WordPress database table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = '';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the documentation.
     *
     * @link https://wordpress.org/support/article/debugging-in-wordpress/
     */
    define( 'WP_DEBUG', false );
    
    /* Add any custom values between this line and the "stop editing" line. */
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    define( 'DOMAIN_CURRENT_SITE', 'simulationmaiki0815.de' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', __DIR__ . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    
    define( 'WP_AUTO_UPDATE_CORE', true );
    ?>

    Datenbankzugang: Von Moderator entfernt

    htaccess:

    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    SALT-Keys löschen? Weiß ich nicht was damit gemeint ist!

    @shelby0815

    Ohne den Thread jetzt näher gelesen zu haben und somit auch ohne mögliche Antwort auf das Problem:

    Du hattest die Zugangsdaten zur Datenbank hier veröffentlicht, diese habe ich soeben entfernt. Leider hat das vom Moderatorenteam wohl niemand zuvor entdeckt.

    Bitte ändere umgehend die Zugangsdaten zu deiner Datenbank (mindestens das Passwort) bei deinem Provider/Webspace, denn durch die Veröffentlichung ist eine latente Sicherheitslücke entstanden.

    Soviel zu „aus der Antwort vor dem Absenden bitte Zugangsdaten zur Datenbank und SALT-Keys löschen“ …

    In der wp-config.php stehen zwei Zeilen:

    /* Add any custom values between this line and the "stop editing" line. */

    und

    /* That's all, stop editing! Happy publishing. */

    (auf Deutsch sinngemäß: Nimm eigene Ergänzungen zwischen diesen beiden Zeilen vor.)

    Was machst du? Hängst ganz unten noch ein

    define( 'WP_AUTO_UPDATE_CORE', true );
    ?>

    an. Die Zeile define( 'WP_AUTO_UPDATE_CORE', true ); gehört also zwischen die beiden oben genannten Zeilen, nicht ans Ende. Außerdem soll die Datei nicht mit ?> enden.

    Das hat aber nichts mit dem eigentlichen Problem zu tun. Laut Fehlermeldung erzeugst du mit Weiterleitungen eine Endlosschleife, die nach vier Versuchen abgebrochen wird. Da in der .htaccess nichts eingetragen ist, stimmt vermutlich eine Einstellung im Kundenmenü des Webhosters nicht. Wahrscheinlich ein Fehler bei der Domain-Verwaltung.

    Aber wir Angelika schon richtig geschrieben hast, solltest du jetzt erstmal die Zugangsdaten zur Datenbank im Kundenmenü und anschließend in der wp-config.php ändern.

    Thread-Starter Michael

    (@shelby0815)

    Habe das Passwort geändert.

    stimmt vermutlich eine Einstellung im Kundenmenü des Webhosters nicht. Wahrscheinlich ein Fehler bei der Domain-Verwaltung

    Ich weiß leider nicht, was da Jetzt in der Domain Einstellern soll, ich benötige schon einem Lösungsweg mit genauer Beschreibung.

    Bisher haben alle genannten Lösungen, das Problem nicht gelöst.

    Bisher haben alle genannten Lösungen, das Problem nicht gelöst.

    Du möchtest einen „Lösungsweg mit genauer Beschreibung“, ignorierst aber z.B. meine letzte Antwort völlig – wie soll das funktionieren? Deine Rückmeldungen sind ungenau, auf Rückfragen gehst du nicht oder nur teilweise ein und den Vorschlag, einen Dienstleister zu beauftragen lehnst du auch ab. Wie auch immer – wir möchten hier keine Befindlichkeiten diskutieren und schulden dir auch keine kostenlose Dienstleistung.

    Ich drücke die Daumen, dass du noch eine Lösung für dein Problem findest. Vielleicht meldet sich noch jemand.

    Thread-Starter Michael

    (@shelby0815)

    In der wp-config.php stehen zwei Zeilen:

    /* Add any custom values between this line and the „stop editing“ line. */

    und

    /* That’s all, stop editing! Happy publishing. */

    (auf Deutsch sinngemäß: Nimm eigene Ergänzungen zwischen diesen beiden Zeilen vor.)

    Was machst du? Hängst ganz unten noch ein

    define( ‚WP_AUTO_UPDATE_CORE‘, true );
    ?>
    an. Die Zeile define( ‚WP_AUTO_UPDATE_CORE‘, true ); gehört also zwischen die beiden oben genannten Zeilen, nicht ans Ende. Außerdem soll die Datei nicht mit ?> enden.

    Das hat aber nichts mit dem eigentlichen Problem zu tun. Laut Fehlermeldung erzeugst du mit Weiterleitungen eine Endlosschleife

    Dies habe ich nicht umgesetzt weil du geschrieben hast, das dies mit dem Problem nicht zu tun hatte. Wie bereits geschrieben, weiß ich leider nicht, was da Jetzt genau in meiner Domain einstellen soll, damit das Problem behoben wird.

    Also wenn der Support hier mir keine genaue Lösung nennen wird, wird das wohl nichts, mit einer Lösung. Oder denkst du das ich mich darüber freue das dieses Problem besteht? Nein natürlich nicht. Ich würde mich freuen, wenn wir gemeinsam zu einer Lösung kommen werden.

    Also wenn der Support hier mir keine genaue Lösung nennen wird, …

    Wir können dir keine „genaue Lösung“ nennen, weil uns dazu Informationen fehlen.

    Du kannst vermutlich die nötigen Informationen (z.B.: sind im Kundenmenü des Webhosters für die Domains Weiterleitungen eingetragen?) nicht beitragen, weil dir das Wissen fehlt, wo du sie herbekommst.

    … wird das wohl nichts, mit einer Lösung.

    Deshalb hatte ich vorgeschlagen, dass du einen Dienstleister beauftragst.

    … wenn wir gemeinsam zu einer Lösung kommen werden

    Wie gesagt: vielleicht meldet sich noch jemand.

    @shelby0815
    Du solltest bedenken, dass wir hier eine Handvoll Freiwilliger sind, die in unserer Freizeit Probleme von WordPress-Anwendern versuchen zu lösen.
    Solche Äußerungen von dir motivieren nicht unbedingt, sich weiter mit dem Problem zu beschäftigen und da haben @pixolin und @la-geek schon viel Zeit investiert.

    Es gibt eben Probleme, da kann man von außen nur noch schwerlich helfen. In solchen Fällen ist ein Dienstleister sinnvoll, der sich so etwas genauer ansehen kann.
    Sicherheitshalber: Jobangebote sind hier im Forum ausdrücklich unerwünscht.

Ansicht von 12 Antworten - 31 bis 42 (von insgesamt 42)
  • Das Thema „Domain Adresse anstatt Weiterleitung“ ist für neue Antworten geschlossen.