Support » Installation » Domain auf „www“ ändern schlägt fehlt

  • Gelöst webman20

    (@webman20)


    Hallo zusammen,

    ich bin Neuling in WP und habe ein kleines Problem. Ich habe eine Website erstellt, jedoch in den Einstellugnen den Domainnamen ohne „www“ eingegeben. Wenn ich nun das „www“ hinzufüge, dann sehe ich weder Bilder auf meiner Seite, noch wird meine korrekte Schriftart angezeigt. Wie kann ich die Domain so abändenr, dass das „www“ davor steht und am Ende auch immer (auch ohne Eingabe von „www“) aufgerufen wird?

    Ich hoffe ich habe nicht gleich am Anfang einen fatalen Fehler gemacht der nunmehr für Probleme sorgt…

    Wäre dankbar für Eure Mithilfe!

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Bego Mario Garde

    (@pixolin)

    Als ich in den 90er Jahren Einsteigerkurse fürs Internet gegeben habe, haben wir noch darauf hingewiesen, dass das Internet nicht nur aus Webseiten besteht, sondern auch andere Dienste wie E-Mail-Server, Telnet, FTP und einiges mehr beinhaltet. Zu diesem Zeitpunkt war die Unterscheidung durch eine Voranstellung von www didaktisch sinnvoll und half auch Einsteigern zu unterscheiden, dass ihre E-Mail-Adresse nicht mit www beginnt. Heute wird die Eingabe dieser drei Buchstaben (die immer noch ein gewisses Risiko für Tippfehler beinhaltet) meistens als lästig angesehen und entfällt bei den meisten Webseiten. Wer trotzdem www eingibt, wird üblicherweise auf die Adresse ohne www weitergeleitet. Das hat unter anderem auch damit zu tun, dass eine Webseite zur Suchmaschinenoptimierung nur unter einer einzigen URL vorkommen sollte, nicht sowohl unter www also auch unter der Domain ohne www.

    Hat dein Webhoster eine solche Weiterleitung bereits vorgesehen, ist es wenig hilfreich, die URL in WordPress trotzdem auf www zu ändern. Ich würde also erst einmal prüfen, ob der Webhoster vielleicht im Kundenmenü einen Punkt anbietet, bei dem die Weiterleitung bereits aktviert ist (z.B. im Domain-Menü).

    Natürlich ist auch der umgekehrte Weg möglich, URLs ohne www automatisch auf die Adresse mit www umzuleiten – Hauptsache, die Seiten kommen nur einmal vor, weil das für Suchmaschi… siehen oben! Auch das ist eher eine Frage der Serverkonfiguration, die wir (vor allem ohne Angabe der URL oder des Webhosters) hier nicht weiter vertiefen können.

    Solltest du durch die Eingabe einer falschen URL deine Website unzugänglich gemacht haben, ist natürlich nicht alles verloren. Über die Datenbankverwaltung im Kundenmenü deines Webhosters kannst du auf die Datenbanktabellen zugreifen, in denen WordPress seine Zugangsdaten speichert. Hier rufst du die Tabelle wp_options auf, suchst nach dem Feld siteurl, blätterst ein wenig in der Tabelle und findest dann auch noch home und korrigierst für beide Felder die angegebene URL, um wieder Zugriff auf die Website zu bekommen.

    Thread-Ersteller webman20

    (@webman20)

    Danke für deine Infos @pixolin.

    Eine autopamtische Weiterleitung auf „www“ ist eim Hoster nicht eingestellt. Muss wirklich nur in der „options“ Tabelle etwas geändert werden? Es werden ja wie gesagt auch scheinbar die gesamten Pfade der Bilde rbenötigt, bzw. auch der Text wird ja nicht mehr korrekt dargestellt sondenr eine andere Schriftart …

    Thread-Ersteller webman20

    (@webman20)

    Hat sich erledigt, HP wurde bei „ohne www“ belassen.

    Gute Entscheidung.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)