Support » Allgemeine Fragen » Domain geändert, Login und Zugriff nicht mehr möglich

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Hallo,
    in dem Fall passen die Einstellungen für siteurl und home bei Einstellungen nicht mehr. Zur Korrektur gibt es mehrere Möglichkeiten:

    • entweder gehst du im Kundenmenü deines Webhosters in die Datenbankverwaltung (üblicherweise phpMyAdmin) und überprüfst dort in der für WordPress genutzten Datenbank in der Tabelle wp_options für die Felder siteurl und home die URL
    • oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einfügst. Danach solltest du dich über wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Vorsichtshalber sollte danach noch die in der wp-config.php eingefügte Zeile wieder entfernt oder die Konstante auf false gesetzt werden: define( 'RELOCATE', false);. Den FTP-Zugang kannst du über den Kundenbereich in der Regel neu einrichten.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von Hans-Gerd Gerhards. Grund: Ergänzung
    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von Hans-Gerd Gerhards. Grund: Tippfehler

    Warum hast du denn die URL geändert?
    Möchtest du die Website unter der neuen URL betreiben und unter der alten Adresse nicht mehr? Dann müsstest du im Kundenmenü des Webhosters die URL auf das Verzeichnis verweisen, in dem die WordPress-Dateien liegen.

    Thread-Starter fabirille

    (@fabirille)

    Vielen Dank für die schnelle Rückmeldung!

    Die URL habe ich geändert, weil sich der Name der Marke geändert hat. – Und ja, die Website möchte ich unter der neuen URL betreiben und unter der alten nicht mehr.

    Habe ich richtig verstanden, dass phpymadmin der Webhoster ist?

    Phpmyadmin habe ich installiert, jedoch habe ich hier nur einen zib-komprimierten Ordner mit Dokumenten enthalten, die ich nicht öffnen kann. Screenshot kann ich hier leider nicht einfügen.

    – Wie komme ich in dieses Kundenmenü?

    Danke & Liebe Grüße

    Wir sollten bei Gelegenheit mal in den FAQ ein Glossar einfügen. 🙂

    Mit Webhoster ist eine Firma gemeint, die dir mit einem Webhostingvertrag einen Webserver zur Verfügung stellt, über den du deine Website im Internet zugänglich machen kannst.

    Der Webhoster bietet dir zur Verwaltung des Webservers ein Kundenmenü mit bei Vertragsabschluß mitgeteilten Zugangsdaten an. Oft kannst du diese Zugangsdaten auch dazu verwenden, um dich mit einem FTP-Programm (z.B. FileZilla) mit dem Server zu verbinden und Dateien hochzuladen.

    In diesem Kundenmenü findest du üblicherweise ein Menü zur Domainverwaltung. Hier stellst du ein, in welchem Verzeichnis die PHP- oder HTML-Dateien liegen, die bei Aufruf der Domain im Browser geöffnet werden sollen. Registrierst du beim Webhoster eine neue Domain, musst du auch angeben, welches Verzeichnis die Dateien enthält, die im Browser geöffnet werden sollen.

    Im Kundenmenü findest du außerdem ein Menü zur Verwaltung der Datenbank. Die meisten Webhoster bieten dazu die Webanwendung phpMyAdmin an, weil damit die Datenbankverwaltung vergleichsweise einfach ist, die Webanwendung weit verbreitet ist und als sicher gilt. phpMyAdmin ist dann aber vorinstalliert – du brauchst selber nichts zu installieren.

    Solltest du (warum auch immer) keinen Zugriff auf eine Datenbankverwaltung haben, aber mit einem FTP-Client auf den Webserver zugreifen können, kannst du als Alternative zu phpMyAdmin die Datei https://github.com/vrana/adminer/releases/download/v4.8.1/adminer-4.8.1-mysql-de.php herunterladen, in adminer.php umbenennen, in das Verzeichnis mit den WordPress-Dateien hochladen und dann im Browser mit https://example.com/adminer.php (natürlich mit deiner Domain) aufrufen. Du wirst dann nach den Zugangsdaten zur MySQL-Datenbank gefragt, die du aus der wp-config.php auslesen kannst.

    Thread-Starter fabirille

    (@fabirille)

    Jetzt versteh ich’s halbwegs 😉

    Habe es geschafft FTP Zugang zu bekommen und define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einzufügen.

    (Nur steht da bei mir nicht „Happy blogging“ sondern „Happy publishing“ – hoffe das macht keinen Unterschied.

    Nun habe ich versucht den Link http://www.eonia-desinfektion.at/wp-login.php in meinen Browser einzutippen, doch hier kommt nur folgende Rückmeldung:“

    Parse error: syntax error, unexpected end of file in /home/customer/www/eonia-desinfektion.at/public_html/wp-config.php on line 87″

    Welchen Fehler habe ich gemacht?

    LG

    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von Bego Mario Garde. Grund: Code formatiert

    Welchen Fehler habe ich gemacht?

    Vermutlich hast du einen unbrauchbaren Editor benutzt. Manche Editoren setzen falsche Anführungszeichen, und dann streikt PHP. Nutze z.B. Notepad++ als Editor, damit sollte das kein Problem sein. Lösche die Zeile und schreibe sie nochmal neu und achte darauf, dass du entweder normale oder einfache Anführungszeichen benutzt. Es kann natürlich auch sein, dass du noch einen anderen Fehler eingebaut hast, das können wir so nicht beurteilen.

    So muss die Zeile aussehen:
    define('RELOCATE', true );

    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von bscu.
    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von bscu.
    • Diese Antwort wurde geändert vor 4 Monaten, 2 Wochen von bscu.

    Parse error: syntax error, unexpected end of file

    Hast du ein ?> eingefügt?
    Was steht in Zeile 87 der wp-config.php?

    Hmm, was mich jetzt noch verwundert, warum Zeile 87? Bei mir ist jede wp-config.php länger als 87 Zeilen. Diese Fehlermeldung erscheint in der Regel, wenn irgendwelche Klammerebenen nicht geschlossen werden.

    Thread-Starter fabirille

    (@fabirille)

    Hallo zusammen,

    vielen Dank für die Tipps!

    @bscu Ich habe bereits beim ersten Mal das Dokument mit Notepad++ editiert. Klammern habe ich auch grad gecheckt, die passen. Anscheinend habe ich einen Fehler, den ich nicht finde

    @pixolin </blockquote?>

    habe ich nicht eingefügt. in der Zeile 87 stand gar nichts. Habe jetzt oben einen Absatz gemacht, jetzt sagt mir der Browser „Parse error: syntax error, unexpected end of file in /home/customer/www/eonia-desinfektion.at/public_html/wp-config.php on line 88„.

    Sind wir somit dem Problem näher gekommen?

    Liebe Grüße und vielen Dank für die Hilfe!

    Ich verstehe immer noch nicht, warum deine wp-config.php nur so wenige Zeilen hat. Poste diese mal komplett, mache aber vorher Benutzername, Passwort und „Authentication Unique Keys and Salts“ unkenntlich.

    Hallo,

    Alternative:

    • Sichere zuerst die wp-config.php deiner WordPress-Instanz auf deinem Rechner.
    • Dann lädst du dasWordPress-Paket auf den eigenen Rechner runter und entpackst das Paket.
    • Enthalten ist da die Datei wp-config-sample.php. Hier trägst du die Daten von deiner Datenbank und die Salts aus der wp-config.php ein.
    • Dann benennst du die Datei wp-config-sample.php in wp-config.php um und lädst die Datei wieder hoch.

    Sollte das nicht funktionieren, dann kannst du immer noch die gesicherte Datei wp-config.php wieder hochladen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter fabirille

    (@fabirille)

    @bscu

    
    <?php
    
    //Begin Really Simple SSL session cookie settings
    @ini_set('session.cookie_httponly', true);
    @ini_set('session.cookie_secure', true);
    @ini_set('session.use_only_cookies', true);
    //END Really Simple SSL
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://wordpress.org/support/article/editing-wp-config-php/
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', 'x' );
    
    /** MySQL database username */
    define( 'DB_USER', 'x' );
    
    /** MySQL database password */
    define( 'DB_PASSWORD', 'x' );
    
    /** MySQL hostname */
    define( 'DB_HOST', 'x' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'x' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define( 'AUTH_KEY',          'xxx' );
    define( 'SECURE_AUTH_KEY',   'xxx' );
    define( 'LOGGED_IN_KEY',     'xxx' );
    define( 'NONCE_KEY',         'xxx' );
    define( 'AUTH_SALT',         'xxx' );
    define( 'SECURE_AUTH_SALT',  'xxx' );
    define( 'LOGGED_IN_SALT',    'xxx' );
    define( 'NONCE_SALT',        'xxx' );
    define( 'WP_CACHE_KEY_SALT', 'xxx' );
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'itj_';
    
    define( 'WC_GZD_ENCRYPTION_KEY', '687d5f2d457264beb3a3c2eaecfac095ade1f2e31deb2430d6a029b94b29be99' );
    define('RELOCATE', true );
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    
    /** Sets up WordPress vars and included files. */
    require_once ABSPATH . 'wp-settings.php';
    @include_once('/var/lib/sec/wp-settings.php'); // Added by SiteGround WordPress management system

    @fabirille
    Du musst den PHP-Code zwischen Code-Tags setzen, sonst zerdrischt dieses Forum Anführungs- und Sonderzeichen.

    Michi91

    (@michi91)

    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    } 

    Bei dir fehlt die letzte klammer..

    @fabirille
    ich habe jetzt erst mal die SALT-Keys entfernt (die waren noch drin und daher gab es auch das Problem mit der Formatierung).

    Vor der Zeile
    @include_once('/var/lib/sec/wp-settings.php'); // Added by SiteGround WordPress management system

    muss noch eine geschweifte Klammer geschlossen werden.
    So wäre es vermutlich ok:

    }
    @include_once('/var/lib/sec/wp-settings.php'); // Added by SiteGround WordPress management system

    Viele Grüße
    Hans-Gerd

    Nachtrag: @michi91 war flotter 🚀

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)