Support » Installation » Domainumleitung bei Strato

  • Hallo zusammen,

    ich habe die Suche genutzt und ganz viele Antworten, die ähnlich sind, gesehen. Allerdings bin ich jetzt noch verwirrter und ich bitte um kurze Hilfe.

    Ich habe meine WordPress-Seite im Unterverzeichnis /wordpress erstellt. Läuft auch alles. Dann habe ich bei Strato versucht, eine Domainumleitung einzurichten. Dazu müssen laut Strato die Werte für SITEURL und HOME in der Datenbanktabelle OPTIONS sowie den Pfad für RewriteBase und RewriteRule in der .htaccess angepasst werden. Habe ich gemacht. Die Umleitung funktioniert. ABER: Es werden keine Bilder angezeigt. Kein Logo, nix. Irgendetwas habe ich wohl falsch gemacht. Weiß jemand Rat?

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • … müssen laut Strato die Werte für SITEURL und HOME in der Datenbanktabelle OPTIONS sowie den Pfad für RewriteBase und RewriteRule in der .htaccess angepasst werden.

    Manuell? Oh weh.

    Kannst du das wieder zurücksetzen? Also sowohl die Änderungen in der Datenbank und .htaccess, als auch die Domainumleitung?

    Danach ist es eigentlich ganz einfach:

    1. Du kopierst* die index.php und (sofern vorhanden) die .htaccess aus dem Verzeichnis wordpress in das höher gelegene Web-Stammverzeichnis (web root, wird häufig vom Webhoster www oder htdocs genannt).
    2. Du passt in dieser Datei die letzte Zeile so an, dass sie auf das WordPress-Verzeichnis verweist:
      require( dirname( __FILE__ ) . '/wordpress/wp-blog-header.php' );
    3. Du verschiebst* die Datei wp-config.php aus dem Verzeichnis wordpress in das höher gelegene Web-Stammverzeichnis.
    4. Nun meldest du dich über http://deinedomain.de/wordpress/wp-login.php im Backend an und änderst unter Einstellungen > Allgemein die URLs. Die WordPress-URL bleibt unverändert http://deinedomain.de/wordpress/, die Website-URL änderst du auf http://deinedomain.de/.
    5. Unter Einstellungen > Permalinks wählst du die gewünschte Linkstruktur und achtest beim Speichern darauf, ob es irgendwelche Fehlermeldungen gibt. Ggf. musst du die vorgeschlagenen Änderungen dann manuell in die Datei übertragen.
    6. Wenn du ein benutzerdefiniertes Menü angelegt hast, musst die Links korrigieren (/wordpress löschen).
      Wenn das sehr viele Korrekturen sind, kannst du auch ein Plugin wie Better Search Replace verwenden, um im ersten Schritt alle Links zu bereinigen (ersetze http://deinedomain.de/wordpress/ mit http://deinedomain.de/). Da aber dein Theme und deine Mediendateien weiterhin im Unterverzeichnis wordpress liegen, musst du anschließend noch http://deinedomain.de/wp-content/ in http://deinedomain.de/wordpress/wp-content umbenennen.

    *oft verwechseln Anwender hier kopieren und verschieben, was zu Fehlern führt. Also bitte darauf achten.

    Das Ergebnis ist, dass WordPress weiterhin in einem eigenen Verzeichnis liegt, die Webseiten aber ohne Eingabe des Verzeichnisses (also über http://deindomain.de, statt http://deinedomain.de/wordpress) erreichbar sind. Vorteil ist, dass du parallel andere PHP-Anwendungen (z.B. PIWIK für eine statistische Auswertung) installieren kannst.

    Direkte Änderungen in der Datenbank solltest du künftig nach Möglichkeit vermeiden, weil sich hier zu schnell Fehler einschleichen.

    Übrigens solltest du vor solchen Aktionen immer ein Backup von Dateien und Datenbank machen. Hast du auch sicher, oder?

    Ja, ich hab ein Backup gemacht, Gott sei Dank. Mittlerweile ist auch alles wieder in den Ursprung zurück versetzt, sodass ich das mit deiner tollen Anleitung jetzt mal versuchen kann. Ganz lieben Dank für die ausführlichen Infos. Ich sag Bescheid, ob alles geklappt hat.

    Top! Jetzt funktioniert alles. Perfekt, Dankeschön!

    Du musst allerdings Punkt 4 nochmal bearbeiten. Es heißt nicht wp-login, sondern wp-admin. Nicht dass jemand, der das selbe Problem hat, deshalb Schwierigkeiten hat.

    Viele Grüße
    Alex

    Das stimmt nicht. 🙂

    wp-admin ist der Link zum Backend. Bei Aufruf dieser Webseite wird aber geprüft, ob der Anwender angemeldet ist. Falls nicht, wird er üblicherweise auf die Seite mit dem Login-Formular wp-login.php weitergeleitet. Genau diese Weiterleitung wollte ich aber vermeiden – deshalb der Vorschlag, die Login-Seite direkt aufzurufen.

    Achso, okay. Bei wp-login kam bei mir allerdings ne Fehlermeldung, dass die Seite nicht gefunden werden konnte. Mit wp-admin ging’s. Sei’s drum, jetzt geht ja alles.

    Genau lesen 😉

    /wp-admin ist eine Weiterleitung (genau wie login und admin – funktioniert alles). Aber am Ende landet man bei der Datei wp-login.php – wenn du also wp-login ohne das PHP eingibst, dann gibt es weder eine Weiterleitung dazu noch die Datei, also kommt der 404-Fehler.

    Gruß, Torsten

    Aha, wusste ich nicht.

    Ein kleines Problem habe ich aber doch noch. Wenn man auf die Links zum Impressum und zur Datenschutzerklärung klickt, landet man auf der Startseite.

    Ich nutze das BeTheme und habe unter „Design“ > „BeTheme Optionen“ > „Fußzeile“ > „Allgemein“ bei „Copyright“ folgenden Code eingegeben:

    ImpressumDatenschutz

    Wenn ich „/wordpress“ entferne, findet er die Seite nicht. Lasse ich es drin, lande ich auf der Startseite. Kann es sein, dass das an der Änderung der Permalinks liegt? Muss ich da noch was ändern?

    Edit: Mist, ich weiß nicht, wie ich den Code posten kann, ohne dass er gleich als Link angezeigt wird.

    • Diese Antwort wurde geändert vor 3 Jahre, 6 Monaten von echoohce.
    • Diese Antwort wurde geändert vor 3 Jahre, 6 Monaten von echoohce.

    Die Links zu den beiden Seiten sollten kein wordpress enthalten.
    Hast du nach den Änderungen die Parmalink-Einstellungen nochmal gespeichert?
    Welche URL bekommst du angezeigt, wenn du im Backend die Seiten aufrufst und dann auch „Seite ansehen“ klickst?

    Die page_id wird angezeigt. Klar, denn so habe ich es ja auch eingestellt. Den Link habe ich jetzt geändert und jetzt geht auch alles. Vielen Dank, Ihr seid echt toll!

    Die page_id wird angezeigt.

    Was meinst du damit? Hast du die Permalinks jetzt auf „Einfach“ (http://deinedomain.de/?p=123) gesetzt? „Sprechende“ Permalinks (z.B. Beitragsname http://deinedomain.de/beispielbeitrag/) sind für SEO besser.

    Ja, so habe ich das gemacht. Die Permalinks stehen auf „Einfach“.

    Mein gesamter Inhalt ist auf einer Seite. So viel ist es (noch) nicht. Mir geht es nur darum, mit einem ordentlichen Auftritt präsent zu sein. Ne Visitenkarte quasi. Nur Impressum und Dateschutzerklärung sind auf eigenen Seiten.

    Hallo,

    bei mir läuft die Umleitung auf dem Hauptverzeichnis leider etwas anders. Wenn ich versuche die Website URL (von http://meinedomain.de/dev/, auf http://meinedomain.de/) zu ändern und speichern will, bekomme ich die Datei Option.php zum Herunterladen angezeigt.

    Weißt zufällig jemand woran es liegen kann?

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Domainumleitung bei Strato“ ist für neue Antworten geschlossen.