Support » Allgemeine Fragen » .dot Datei kann nicht hochgeladen werden

  • Hallo,

    ich habe nun schon alle Foren durch und kann leider keine Lösung finden.

    Ich versuche bei einem Kunden eine .dot Datei in die Mediathek hochzuladen.
    Dabei bekomme ich folgende Fehlermeldung:
    „Faxvorlage.dot: Sorry, this file type is not permitted for security reasons.“

    Daraufhin habe ich in der wp-config.php die Filterung ausgeschaltet mit dem Befehl „define(ALLOW_UNFILTERED_UPLOADS=true);“
    Jedoch half dies nichts. Ich habe auch schon verschiedene MIME Type Plugins ausprobiert sowie Plugins für extra Datei Typen.
    Nichts hilft.

    Die Webseite läuft aktuell auf einem IIS unter Windows Server 2016, jedoch habe ich das gleiche Problem auf einem Test System unter XAMPP.
    Dort habe ich auch die gleichen Anpassungen vorgenommen.

    Kann mir hier jemand helfen?

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Ich habe auch schon verschiedene MIME Type Plugins ausprobiert sowie Plugins für extra Datei Typen.

    Das ist eigentlich der richtige Weg.
    Was hast du da ausprobiert?

    Hm, komisch – ich hab jetzt mal das erste Plugin https://de.wordpress.org/plugins/wp-add-mime-types/ installiert und unter Einstellungen > Mime Type Settings im Feld Add Values folgendes eingetragen:

    dot = application/msword

    Damit kann ich dann .dot-Dateien hochladen.

    Das .dot-Format ist schon ein wenig älter und durch .dotx bzw. .dotm abgelöst worden, was auch erklärt, wieso das nachträglich eingetragen werden muss.

    WordPress lässt aus Sicherheitsüberlegungen nur bestimmte Dateitypen zu. Mit define(ALLOW_UNFILTERED_UPLOADS=true); in der wp-config.php solltest du das umgehen können, wenn du als Administrator angemeldet bist. Alternativ kannst du ein eigenes Code Snippets nur für diesen einen Dateityp hinzufügen:

    function edit_upload_types($existing_mimes = array()) {
        // allow .dot
        $existing_mimes['dot'] = 'application/msword';
     
        return $existing_mimes;
    }
    add_filter('upload_mimes', 'edit_upload_types');

    (Quelle: https://www.isitwp.com/modify-allowed-upload-mime-types/)

    So viele Möglichkeiten. 🙂

    Danke für deine Antwort.

    Habe den Snippet gerade hinzugefügt, das hat aber leider auch nicht geholfen.
    Was bei mir gerade aktiv ist:
    1. Ich habe define(ALLOW_UNFILTERED_UPLOADS=true); in der wp-config.php eingetragen.
    2. Ich habe das Plugin WP Add MIME Types installiert und die Dot Datei hier eingetragen
    3. Ich habe deinen Code Snippet hinzugefügt
    Ergebnis:
    Immernoch kommt die Fehlermeldung.

    Langsam bin ich ratlos.

    Ich habe auch im IIS überprüft ob dort dot Dateien erlaubt sind, aber dies ist der Fall. Also daran kann es auch nicht liegen.

    Ich habe define(ALLOW_UNFILTERED_UPLOADS=true); in der wp-config.php eingetragen.

    Wo hast du das eingetragen?
    Oberhalb von /* That's all, stop editing! Happy blogging. */?
    Bist du als Administrator angemeldet?

    Ich habe das Plugin WP Add MIME Types installiert und die Dot Datei hier eingetragen

    Sieht das dann so aus?
    Screenshot WP Add MIME Types

    Ich habe deinen Code Snippet hinzugefügt

    Auch „Nur im Administrationsbereich ausführen“ angeklickt und aktiviert?

    Bei mir funktionieren alle drei Methoden – bei dir keine einzige. Woran kann das liegen? Gib uns doch mal ein paar Informationen zu deiner Website:
    Werkzeuge > Website-Zustand > Bericht > per Button in die Zwischenablage kopieren, dann hier unverändert in eine Antwort einfügen.

    Ja habe alles genau so eingetragen.
    Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.4
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: /index.php/%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 6
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: C:\inetpub\wwwroot
    wordpress_size: 41,73 MB (43751897 bytes)
    uploads_path: C:\inetpub\wwwroot/wp-content/uploads
    uploads_size: 192,60 MB (201959264 bytes)
    themes_path: C:\inetpub\wwwroot/wp-content/themes
    themes_size: 5,16 MB (5411648 bytes)
    plugins_path: C:\inetpub\wwwroot/wp-content/plugins
    plugins_size: 119,96 MB (125791158 bytes)
    database_size: 1,89 MB (1982464 bytes)
    total_size: 361,34 MB (378896431 bytes)
    
    ### wp-active-theme ###
    
    name: Baskerville (baskerville)
    version: 2.1.0 (latest version: 2.1.1)
    author: Anders Norén
    author_website: https://www.andersnoren.se
    parent_theme: none
    theme_features: automatic-feed-links, post-thumbnails, post-formats, custom-background, custom-header, custom-logo, title-tag, menus, align-wide, editor-color-palette, editor-font-sizes, widgets, editor-style
    theme_path: C:\inetpub\wwwroot/wp-content/themes/baskerville
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 1.4, author: the WordPress team (latest version: 1.5)
    Twenty Seventeen: version: 2.2, author: the WordPress team (latest version: 2.3)
    Twenty Sixteen: version: 2.0, author: the WordPress team (latest version: 2.1)
    Twenty Twenty: version: 1.1, author: the WordPress team (latest version: 1.2)
    
    ### wp-plugins-active (6) ###
    
    Active Directory Integration for Intranet sites: version: 3.5.3, author: miniorange
    Awesome Support: version: 5.8.2, author: Awesome Support Team
    BackWPup: version: 3.7.1, author: Inpsyde GmbH
    Code Snippets: version: 2.14.0, author: Code Snippets Pro
    WP Add Mime Types: version: 2.5.4, author: Kimiya Kitani
    WPFront User Role Editor: version: 2.14.3, author: Syam Mohan
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Windows NT 10.0 i586
    httpd_software: Microsoft-IIS/10.0
    php_version: 7.1.29
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 2M
    php_post_max_size: 8M
    curl_version: 7.64.0 OpenSSL/1.0.2r
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.1.73-community
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: C:\inetpub\wwwroot/wp-content
    WP_PLUGIN_DIR: C:\inetpub\wwwroot/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    WPFront User Role Editor – kann es sein, dass deine Benutzerrechte eingeschränkt sind? Deaktviere das Plugin doch mal und schau, ob sich dadurch etwas ändert.

    Die PHP-Version ist veraltet.

    Sonst sehe ich nichts auffälliges. Poste doch bitte noch den Inhalt deiner wp-config.php (die Zeilen mit den Datenbank-Zugangsdaten und SALT-Keys bitte vor dem Absenden löschen).

    Hier die Config.php

    
    <?php
    
    /**
    
     * The base configuration for WordPress
    
     *
    
     * The wp-config.php creation script uses this file during the
    
     * installation. You don't have to use the web site, you can
    
     * copy this file to "wp-config.php" and fill in the values.
    
     *
    
     * This file contains the following configurations:
    
     *
    
     * * MySQL settings
    
     * * Secret keys
    
     * * Database table prefix
    
     * * ABSPATH
    
     *
    
     * @link https://codex.wordpress.org/Editing_wp-config.php
    
     *
    
     * @package WordPress
    
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    
    /** The name of the database for WordPress */
    
    define( 'DB_NAME', "wordpress215" );
    
    /** MySQL database username */
    
    /** MySQL database password */
    
    /** MySQL hostname */
    
    define( 'DB_HOST', "localhost" );
    
    /** Database Charset to use in creating database tables. */
    
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    
    define( 'DB_COLLATE', '' );
    
    /**#@+
    
     * Authentication Unique Keys and Salts.
    
     *
    
     * Change these to different unique phrases!
    
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    
     *
    
     * @since 2.6.0
    
     */
    
    /**#@-*/
    
    /**
    
     * WordPress Database Table prefix.
    
     *
    
     * You can have multiple installations in one database if you give each
    
     * a unique prefix. Only numbers, letters, and underscores please!
    
     */
    
    $table_prefix = 'wp_';
    
    /**
    
     * For developers: WordPress debugging mode.
    
     *
    
     * Change this to true to enable the display of notices during development.
    
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
    
     * in their development environments.
    
     *
    
     * For information on other constants that can be used for debugging,
    
     * visit the Codex.
    
     *
    
     * @link https://codex.wordpress.org/Debugging_in_WordPress
    
     */
    
    define( 'WP_DEBUG', false );
    
    define( 'ALLOW_UNFILTERED_UPLOADS', true );
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    
    if ( ! defined( 'ABSPATH' ) ) {
    
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    
    }
    
    /** Sets up WordPress vars and included files. */
    
    require_once( ABSPATH . 'wp-settings.php' );
    
    define('WP_PROXY_HOST', '192.168.5.164');
    
    define('WP_PROXY_PORT', '3128');
    
    define('WP_PROXY_USERNAME', '');
    
    define('WP_PROXY_PASSWORD', '');
    
    define('WP_PROXY_BYPASS_HOSTS', 'localhost, www.example.com');
    
    • Diese Antwort wurde geändert vor 4 Monaten, 1 Woche von louis2906.

    Mir ist gerade auch aufgefallen das ich nichtmal doc Dateien hochladen kann. Langsam denke ich das der Server an sich nen Schuss hat…

    Unter der Zeile
    /* That's all, stop editing! Happy publishing. */

    sollte eigentlich nichts mehr angefügt werden (deshalb steht das da) – die Zeilen

    define('WP_PROXY_HOST', '192.168.5.164');
    define('WP_PROXY_PORT', '3128');
    define('WP_PROXY_USERNAME', '');
    define('WP_PROXY_PASSWORD', '');
    define('WP_PROXY_BYPASS_HOSTS', 'localhost, www.example.com');

    sollten also über dieser Zeile stehen. Aber das hat nichts mit dem Problem zu tun, dass nach Anpassung der erlaubten Dateitypen der Upload nicht funktioniert. Hattest du mal versucht, das Plugin zu deaktivieren? Ansonsten fällt mir dazu im Moment wenig ein.

    Du hast den Dateityp auch ohne anführenden Punkt eingegeben?
    Also dot (und nicht .dot)?

    Mir ist gerade auch aufgefallen das ich nichtmal doc Dateien hochladen kann.

    Klappt denn der Upload anderer Dateien?
    Deine Word-Vorlage ist auch nicht größer als 2MB?

    Ja ich habe den Dateityp ohne Anführenden Punkt angegeben. Ich habe auch schon das Role Plugin deaktiviert aber hat nichts gebracht. Die Vorlage ist 66kb Groß und txt Dateien kann ich ohne Probleme hochladen.

    Ich versuche gerade den Server manuel komplett neu zu installieren. falls das nicht geht hab ich einen Snapshot auf den ich zurück gehe. Melde mich dann nochmal.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)