• pmov

    (@pmov)


    Hallo,
    ich arbeite gerade an einer Seite auf Basis des Ample-Themes. Das klappt auch alles ganz wunderbar, jedoch mit einer Einschränkung:

    Ich habe ein Dropdown Menü erstellt und wünsche mir, dass man „ganz normal“ mit dem Mauszeiger auf einen der Menüpunkte zeigt, sich dabei das jeweilige Untermenü öffnet und man den Unterpunkt auswählen kann. Jedoch macht mein bisheriges Menü das genaue Gegenteil: Man muss auf den Ober-Menüpunkt klicken, damit das Ausklappmenü darunter auch geöffnet bleibt und kann dieses einmal geöffnete Untermenü dann auch nicht mehr schließen. D.h. nacheinander die Menüpunkte durchklicken führt zu 5 geöffneten, „unschließbaren“ Ausklappmenüs. Fährt man nur mit dem Mauszeiger über die Oberpunkte, schließt sich das Ausklappmenü beim Weiterziehen des Mauszeigers sofort wieder…

    In den Einstellungen des Themes habe ich nichts gefunden, womit sich dieses Problem beheben ließe. Hat jemand hier eine Idee? Vielen Dank!

    • Dieses Thema wurde geändert vor 7 Jahren von pmov.
Ansicht von 6 Antworten – 1 bis 6 (von insgesamt 6)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ich habe ein Dropdown Menü erstellt …

    Wie und wo hast du das erstellt?

    Jedoch macht mein bisheriges Menü das genaue Gegenteil: Man muss auf den Ober-Menüpunkt klicken, damit das Ausklappmenü darunter auch geöffnet bleibt und kann dieses einmal geöffnete Untermenü dann auch nicht mehr schließen.

    Kann ich nicht nachvollziehen. Verwendest du zusätzlich vielleicht Plugins, die das Verhalten der Navigation beeinflussen könnten?

    Können wir uns das von dir beschriebene Verhalten irgendwo ansehen? (URL?)

    Thread-Starter pmov

    (@pmov)

    Naja, ich habe das Menü im Customizer des Themes erstellt…und nutze auch keine weiteren Plug-Ins, die sich auf Navigation beziehen.

    Die Seite, wo der Fehler auftritt, kann man sich hier anschauen (work in progress):
    http://iwit.info/versuch2/

    Moderator Bego Mario Garde

    (@pixolin)

    …und nutze auch keine weiteren Plug-Ins, die sich auf Navigation beziehen.

    Sicher? Deaktiviere mal die Plugins und schau dir dir Navigation dann an. Ich vermute, dass hier Elementor dazwischenfunkt.

    Thread-Starter pmov

    (@pmov)

    Hmm ich habe Elementor deaktiviert, das hat aber leider nicht geholfen. Ich wusste aber nicht, dass dieses Plug-In für die Navigation genutzt werden kann? Verwende das eigentlich nur für die Erstellung der Seiten…

    Merkwürdig ist auch, dass in Chrome das oben beschriebene Phänomen auftaucht (Menüs verschwinden sofort wieder bzw. schließen sich), in Firefox sind dagegen immer alle (!) Untermenüs aufgeklappt.

    Dabei habe ich für das Menü tatsächlich nur den Customizer verwendet, und der bietet (leider) gar nicht so viele Einstellungsmöglichkeiten :/

    Thread-Starter pmov

    (@pmov)

    Noch ein Nachtrag: Den Fehler in Firefox konnte ich beheben: In der style.css habe unter main navigation zweimal display:block durch display:none ersetzt, nun zeigt der Brwoser zumindest dasselbe Verhalten wie Chrome. Aber wirklich gut ist das natürlich trotzdem nicht…
    Hier der entsprechende Auszug:

    .main-navigation ul li ul,
    .main-navigation ul li:hover ul ul,
    .main-navigation ul ul li:hover ul ul,
    .main-navigation ul ul ul li:hover ul ul,
    .main-navigation ul ul ul ul li:hover ul ul {
    display:none;
    z-index: 9999;
    }
    .main-navigation ul li:hover ul,
    .main-navigation ul ul li:hover ul,
    .main-navigation ul ul ul li:hover ul,
    .main-navigation ul ul ul ul li:hover ul,
    .main-navigation ul ul ul ul ul li:hover ul {
    display:none;

    Moderator Bego Mario Garde

    (@pixolin)

    Ich wusste aber nicht, dass dieses Plug-In für die Navigation genutzt werden kann?
    Darum geht es auch nicht. Das Theme verwendet aber für die Navigation JavaScript (wp-content/themes/ample/js/navigation.js). Es könnte sein, dass dieses Script mit einem anderen Script eines Plugins nicht klarkommt. Es ist aber auch nicht sehr kompliziert, die Plugins mal für einen Moment zu deaktivieren, oder? Wenn der Fehler dann immer noch besteht, liegt es wohl am Theme.

    Wenn du Änderungen direkt im Theme vornimmst, ist das schwierig nachzuvollziehen (und wird beim nächsten Update ohnehin überschrieben). Ohne Änderungen klappt es mit der Navigation.

Ansicht von 6 Antworten – 1 bis 6 (von insgesamt 6)
  • Das Thema „Dropdown-Menü beim Ample-Theme“ ist für neue Antworten geschlossen.