Support » Allgemeine Fragen » Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.

  • Hallo,
    ich habe ein neues Plugin (Car Rental System) installiert und nach kurzer Zeit wieder gelöscht. Danach komme ich nicht mehr in dem WordPress Admin-Bereich ‚rein.
    Es erscheint die berühmte Zeile: „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“
    Ich habe inzwischen die „gefühlte 100“ Problemlösungen aus den Foren ausprobiert – leider ohne Erfolg.
    Inklusive per FTP die einzelnen Plugins nacheinander deaktiviert, auf Standard Theme zurückgesetzt, die Datenbank auf „Reste“ des Plugins überprüft, die wp_ Präfixe überprüft, die ht_access Datei deaktiviert, mein WP-Admin Passwort geändert, etc., etc.
    Es passiert leider nichts, ich habe nachwievor keine Berechtigung auf die Seite zurückzugreifen.
    Kennen Sie noch eine Lösung? Vielen Dank für eine Hilfestellung.
    Beste Grüße
    Hans

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Wenn du ein Plugin installierst, wird häufig ein weiterer Menüeintrag hinzugefügt. Rufst du diesen Menüeintrag nach der Löschung des Plugins erneut auf, bekommst du ebenfalls den Hinweis, du wärst nich berechtigt, auf diese Seite zuzugreifen. Besser wäre ein „hey, das Menü gibt es hier nicht mehr“.

    Eine Anmeldung über https://call***e.de/wordpress/wp-login.php sollte aber funktionieren und dich nach Prüfung der Zugangsdaten zum Dashboard weiterleiten. Falls nicht, schau mal in den Entwickler-Tools des Browsers im Tab Netzwerk, was da im Hintergrund aufgerufen wird.

    Im Moment fallen mir nur folgende Möglichkeiten ein:

    • du rufst eine nicht mehr existierende Menüseite auf
    • du verwendest einen serverseitigen Cache, der geleert werden muss oder
    • dein Browser-Cache spielt dir einen Streich.

    Für den ersten Punkt reicht es eigentlich, wenn du dich ganz normal wieder anmeldest.
    Zum zweiten Punkt müsstest du beim Webhoster nachfragen, ob sie Opcache/Memcache löschen können.
    Beim letzten Punkt hilft es, den Browser-Cache zu leeren oder über ein privates Browserfenster eine Anmeldung vorzunehmen.

    Noch ganz kurz: „Kennen Sie noch eine Lösung?“ ist zwar sehr höflich formuliert, aber wir verwenden hier ganz unkompliziert das weniger förmliche „du“ (und beleiben trotzdem respektvoll).

    Thread-Ersteller hz50

    (@hz50)

    Hallo Bego Mario Garde,
    vielen Dank erstmal für deine Antwort und den netten Hinweis, das respektvolle „du“ zu verwenden…sehr gut.
    Also, gleich eine der Hinweise hat „so halbwegs“ geklappt…und zwar beim Entwickler-Tool des Browsers im Tab Netzwerk erscheint diese Meldung:
    „GET https://call-a-duke.de/wordpress/wp-admin/“ und „[HTTP/2 403 Forbidden 1103ms]“
    d.h. wenn ich es richtig verstehe, der Pfad soll um „wp-admin“ ergänzt werden, oder?
    Wenn ich das mache, komme ich wenigstens auf der Seite mit den schwarzen Bearbeitungsbalken oben. Wenn ich dann aber linksoben auf „Zur Webseite“ klicke, passiert nichts. Wenn ich dann aber auf „Seite bearbeiten“ klicke komme ich sofort auf die Bearbeitungsseite im Admin-Bereich mit der Admin-Leiste auch links.
    In den Einstellungen und Permalinks ist aber alles so eingestellt wie immer.
    (Ich installiere WP immer mit einer Website-Adresse ohne Unterverzeichnis und eine WordPress-Adresse mit Unterverzeichnis wordpress).
    Übersehe ich da etwas? Vielen Dank für deine Hilfe!
    Hans

    im Tab Netzwerk erscheint diese Meldung:
    GET https://call-a-duke.de/wordpress/wp-admin/ und [HTTP/2 403 Forbidden 1103ms]

    403 Forbidden („Verboten“) bedeutet, dass dein Browser etwas abrufen möchte, was er nicht darf. Das kann z.B. passieren, wenn ein Verzeichnis aufgerufen wird (wp-admin), aber keine index.php oder index.html gefunden wird. Der Browser versucht dann, statt dessen eine Inhaltsangabe der vorhandenen Dateien auszugeben, was aus Sicherheitsgründen nicht erlaubt ist. Und was nicht erlaubt ist … 

    Ich weiß nicht, was du beim Entfernen des Plugins wirklich gelöscht hast. Schau doch mal per FTP-Programm, ob das Verzeichnis überhaupt noch vorhanden ist.

    Thread-Ersteller hz50

    (@hz50)

    Ich habe nur das Plugin erst deaktiviert und dann gelöscht.
    Und ja, das Verzeichnis wp-admin ist in FileZilla vorhanden und das Verzeichnis index.php ist auch da drin.

    Versuch doch mal, das Plugin-Verzeichnis wordpress/wp-content/plugins in sowas wie wordpress/wp-content/no.plugins umzubenennen. Damit werden dann erst einmal alle Plugins deaktiviert, um sie als mögliche Fehlerquelle auszuschließen. Danach solltest du dich im Backend anmelden können. Wenn das geklappt hat, benennst du das Verzeichnis wieder in wordpress/wp-content/plugins und aktivierst einzeln die Plugins über das Plugin-Menü. Tritt der Fehler erneut um, benennst du nur das Verzeichnis des zuletzt aktivierten Plugins um.

    Thread-Ersteller hz50

    (@hz50)

    Das hatte ich Heute Morgen schon gemacht… Jetzt gerade nochmal alles wiederholt, es klappt aber nach wie vor nicht.

    Du verwendest ein Coming-Soon-Plugin. Wenn du die Plugins wie beschrieben deaktivierst, läuft auch das Coming-Soon-Plugin nicht mehr. Tut es aber. Das wäre nur möglich, wenn du das Plugin wieder aktiviert hast. Das wiederum geht nur nach erfolgreicher Anmeldung im Backend. Irgendwas an deiner Aussage stimmt dann wohl nicht – oder übersehe ich etwas?

    Thread-Ersteller hz50

    (@hz50)

    ??? Ich habe nach dem Versuch, mit „ausgeschaltete“ Plugins rein zu kommen, wieder „no.“ gelöscht. Vielleicht hast du da gerade probiert.
    Ich habe jetzt nochmal die Plugins ausgeschaltet und die Webseite ist zwar erreichbar unter der normale Website-Adresse (ohne Plugins), aber mit WordPress Adresse um ins Admin zu kommen, kommt nachwievor die Fehlermeldung „Sie haben keine Berechtigung…“ usw.

    Thread-Ersteller hz50

    (@hz50)

    „Das wiederum geht nur nach erfolgreicher Anmeldung im Backend. Irgendwas an deiner Aussage stimmt dann wohl nicht – oder übersehe ich etwas?“</

    blockquote>

    Nein, ein Plugin aktivieren geht auch, wenn mann im ftp die deaktivierte Plugins wieder aktiviert…

    Ich habe nach dem Versuch, mit „ausgeschaltete“ Plugins rein zu kommen, wieder „no.“ gelöscht. Vielleicht hast du da gerade probiert.

    Die Plugins aktivieren sich nicht von selbst.

    Wenn du das Verzeichnis wp-content/plugins (bei der richtigen WordPress-Installation) umbenennst und mit umbenanntem Verzeichnis versuchst, dich anzumelden, prüft WordPress, welche Plugins ausgeführt werden müssen, stellt fest dass das Verzeichnis verschwunden ist und deaktiviert die Plugins. Du solltest dich dann im Backend wieder anmelden können.

    Solange du das Verzeichnis nicht wieder umbenennst und die Plugins aktivierst, sollte auch ein „Coming Soon“-Plugin nicht funktionieren. Da aber aktuell „Hier erscheint in Kürze unsere neue Website“ angezeigt wird, scheint das Plugin weiterhin aktiv zu sein – und war folglich zwischenzeitlich nicht deaktiviert worden, es sei denn du warst im Backend und hast es manuell wieder aktiviert.

    Nein, ein Plugin aktivieren geht auch, wenn mann im ftp die deaktivierte Plugins wieder aktiviert…

    Stimmt nicht. Du kannst das Verzeichnis wieder in wp-content/plugins umbenennen, aber WordPress fängt dann nicht an, wahlfrei alles zu aktivieren, was dort im Verzeichnis liegt.

    Thread-Ersteller hz50

    (@hz50)

    Ich habe bereits 2 mal das Verzeichnis plugins umbenannt in no.plugins, und dann versucht in das Backend reinzukommen. Jedesmal hat es nicht geklappt, weil dieser berühmte Fehlermeldung kommt „Sie haben keine Berechtigung…“.
    Danach habe ich das Verzeichnis no.plugins wieder umbenannt in plugins.
    Während der Phase, dass das Verzeichnis no.plugins heisst, sieht man natürlich die Coming soon-Seite nicht. Wenn das Verzeichnis wieder plugins heisst, sieht man die Coming soon-Seite wieder. Was im Moment der Fall ist, denn ich lasse ja nicht die ganze Zeit das so stehen.
    Fakt ist, mit diese Problemlösung komme ich NICHT im Backend. Vielleicht soll ich einige „Beweisfotos“ mitschicken.
    Aber, Spaß beiseite, ist es wirklich dein Ernst, jetzt diese Tatsachen in Zweifel zu ziehen? Ich schreibe hier bestimmt keine Unwahrheiten, nur weil ich mich am heutigen Sonntag langweile. Und ich fühle mich etwas angegriffen, mit deiner Tonalität.
    Ich versuche, ernsthaft unter Expertenhilfe ein Problem zu lösen, nur das scheint nicht möglich zu sein…???

    Und ich fühle mich etwas angegriffen, mit deiner Tonalität.

    Nein, es gibt da keine Tonalität. Eher Unverständnis, wieso ein Plugin trotz einer Deaktivierung weiterhin aktiv sein soll. Wenn du das als übergriffig empfunden hast, bedauere ich das und entschuldige mich.

    Ich versuche, ernsthaft unter Expertenhilfe ein Problem zu lösen …

    Dann hoffe ich, dass du dazu von einem Experten Hilfe bekommst.
    Ich kann dir offensichtlich nicht weiterhelfen.

    Thread-Ersteller hz50

    (@hz50)

    Ach, Bego Mario Garde, was sind Sie ein schrecklicher Mensch…

    Hallo @hz50
    wir empfehlen die Prozedur, wie sie Bego ausführlich beschrieben hat, fast täglich und testen selbstverständlich auch die Dinge, die wir empfehlen.
    Bego investiert hier im Support-Forum und auch wieder bei diesem Thread sehr viel Zeit, um Benutzern zu helfen. Hast du dir schon mal Gedanken darüber gemacht, dass wir hier in unserer Freizeit diese Hilfe anbieten, wobei Bego mit Abstand der aktivste Supporter ist?
    Es ist schon (sehr dezent formuliert) seltsam, wenn das bei dir nicht klappt und bei tausenden Anwendern funktioniert. Du kannst diese Lösungsmöglichkeit übrigens auch in unserer FAQ nachlesen
    Die Aussage von dir empfinde ich nach Lesen des Threads in der Tat als Frechheit.
    Thread geschlossen.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“ ist für neue Antworten geschlossen.