Support » Allgemeine Fragen » Duplicator Backup ohne Inhalte

  • Hallo zusammen,
    ich habe von einem ehemaligen Webentwickler ein Backup einer Website bekommen, die er uns früher erstellt hat. Er hat sich beruflich umorientiert und steht mir deshalb nicht mehr zur Verfügung. Ich habe die Sicherung auch nach etwas hin und her eingespielt bekommen. Zuerst neues WordPress installiert, Duplicator Plugin installiert und importiert – tat aber nicht, also alles gelöscht, entpacktes Archiv und installer.php hochgeladen und eine leere Datenbank angelegt.

    Die ursprünglichen Plugins und Themes werden unter Aktualisierungen angezeigt und ich habe alles installiert/aktualisiert, aber hier ist aber mein Problem: die Website ist leer. Keine Start- oder Unterseiten, keine Bilder unter Medien und so weiter.

    Mit dem File Manager sehe ich allerdings die alten Bilder als Uploads, drin sind sie also.

    Habe WordPress bislang im Backend eher redaktionell und grafisch angepasst, allerdings kaum Übung in Datenbanken. Ich könnte mir vorstellen, dass der Fehler ggf. dadurch entsteht, dass die Sicherung auf einer neuen Domain liegt, aber komme leider nicht weiter. Für eure Hilfe tausend Dank!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Hallo @mamue90
    Ein Duplicator „Backup“ ist (wenn es richtig eingestellt und erstellt wurde) eine vollständige, lauffähige Kopie der Website.
    Jene Kopie kann auf jeden anderen Server wieder neu installiert werden. Die dort anderen Pfade werden eigentlich automatisch vom Duplicator Installer angepasst.

    Also: Bitte kein WP installieren und irgendwas importieren! Das macht alles Duplicator alleine. Eine Datenbank muss natürlich angelegt werden und die Zugangsdaten sollte man parat haben.
    s. https://snapcreek.com/duplicator/docs/quick-start/

    Also: Duplicator Archiv + installer.php auf den neuen Webspace hochladen und die installer.php per Browser aufrufen. Dann den Anweisungen folgen (DB Zugang eintragen, Test Verbindung, usw.). Normalerweise muss man keine der vielen angebotenen Extra-Optionen anrühren.

    Thread-Ersteller mamue90

    (@mamue90)

    Hey @pezi,

    vielen Dank für Deine schnelle Antwort. Also die Domain zeigt direkt auf „/“, habe die .zip und den Archiv-Ordner sowie die installer.php per File Manager dorthin geschoben. Wenn ich jetzt /installer aufrufe kommt folgende Meldung:

    Setup Notice:
    An error has occurred. In order to load the full installer please resolve the issue below.
    Archive not found! The ‚Required File‘ below should be present in the ‚Extraction Path‘. The archive file name must be the exact name of the archive file placed in the extraction path character for character.

    If the file does not have the correct name then rename it to the ‚Required File‘ below. When downloading the package files make sure both files are from the same package line in the packages view. If the archive is not finished downloading please wait for it to complete.

    If this message continues even with a valid archive file, consider clearing your browsers cache and refreshing, trying another browser or change the browsers URL from http to https or vice versa.

    Extraction Path: /kunden/634883_49811/

    Nachtrag: der entpackte Ordner ist da auch, weil lt. Aussage des Hosters (DF) keine zips entpackt werden können und deshalb gleich der Ordner dort sein muss.

    • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von mamue90.
    • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von mamue90.

    lt. Aussage des Hosters (DF) keine zips entpackt werden können

    echt?
    Ich wills gar nicht wissen, wer „DF“ ist …

    Hast es überhaupt auch mit dem nicht entpackten *.zip getestet?

    Immerhin basieren eine Menge moderner Web Installationsvorgänge per entpacken von z.B. *.zip. Etwa WP Themes oder Plugins werden eigentlich immer als zip angeboten und werden standardmäßig auch so installiert. Nicht schon entpackt, nein, als Archiv, andernfalls ein Fehler kommt.
    Würde diese Meinung des Hosters echt stimmen, würde auch eine herkömmlich installierte WP-Website spätestens beim installieren des ersten Themes streiken.

    Also bitte den Hoster darum, diesen längst etablierten Standard (Archive entpacken) zu ermöglichen. Wenn der sich blöd stellt, gleich mit Wechsel zu anderen winken.

    PS: Ich schau dann mal nach, wie es auch mit dem entpackten Ordner funktionieren könnte. Kann aber nix versprechen …

    Nachtrag zT. Installation mit manuellen Entpacken: Guckst du hier: https://snapcreek.com/duplicator/docs/faqs-tech/?load#faq-installer-015-q

    • Diese Antwort wurde geändert vor 2 Monaten, 4 Wochen von pezi. Grund: Nachtrag zT. Installation mit manuellen Entpacken

    Hallo,

    habe die .zip und den Archiv-Ordner

    Eine Sicherung mit dem Duplicator besteht aus einer (!) ZIP-Datei und der installer.php.
    Da scheint bei dir mit der Sicherung irgendwas nicht in Ordnung zu sein.
    Viele Grüße
    Hans-Gerd

    Ups, übersehen. Stimmt: Eine einzige ZIP und eine installer.php – nicht mehrm nicht weniger!
    Nur: Wenn der Host kein entpacken ermöglicht, ist eher das Schuld als der überzählige „Archiv“Ordner …

    Thread-Ersteller mamue90

    (@mamue90)

    Hallo @pezi, hallo @hage,

    danke, dass ihr euch so einbringt! Der Hoster ist Domainfactory. Ich habe natürlich eine .zip und eine Installer.php. Wenn ich beide per File Manager hochlade und die installer.php aufrufe kommt folgendes:

    Setup Notice:
    An error has occurred. In order to load the full installer please resolve the issue below.
    Archive not found! The ‚Required File‘ below should be present in the ‚Extraction Path‘. The archive file name must be the exact name of the archive file placed in the extraction path character for character.

    If the file does not have the correct name then rename it to the ‚Required File‘ below. When downloading the package files make sure both files are from the same package line in the packages view. If the archive is not finished downloading please wait for it to complete.

    If this message continues even with a valid archive file, consider clearing your browsers cache and refreshing, trying another browser or change the browsers URL from http to https or vice versa.

    Extraction Path: /home/customer/www/DOMAIN.com/public_html/

    Server Settings:
    ZipArchive: Enabled
    ShellExec Unzip: Enabled
    Extraction Path: /home/customer/www/DOMAIN.com/public_html
    Installer Path: /home/customer/www/DOMAIN/public_html/dup-installer
    Archive Name: [HASH]_archive.zip or [HASH]_archive.daf
    This is based on the format used to build the archive
    Archive Size: Expected Size: 101.38MB Actual Size: 0B
    Boot Log dup-installer-bootlog__[HASH].txt

    Please Note: Either ZipArchive or Shell Exec will need to be enabled for the installer to run automatically otherwise a manual extraction will need to be performed. In order to run the installer manually follow the instructions to manually extract before running the installer.

    Ich habe mittlerweile noch einen Account bei siteground erstellt und es dort probiert, aber exakt dasselbe. Wenn ich mit Workarounds arbeite, die mir DF genannt hat, dann wird nur WordPress mit den Plugins aber ohne Inhalte installiert (keine Medien oder Seiten). Wenn ich den Workaround nutze, zeigt er mir auch den alten Namen der Website bei der Installation, aber nach Step 2 lande ich nicht in Step 3, in dem ich die permanent Links ändern kann, sondern auf der Admin Seite für die Ersteinrichtung für WordPress. Schritt 3 und Schritt 4 werden nicht ausgeführt und ich habe ein leeres WordPress inclusive Plugins der alten Seite.

    Wenn ich versuche eine WordPress Seite neu aufzusetzen und das Backup über das Duplicator Plugin (egal ob Pro oder Standard) kommt folgender Fehler:

    Package version too old, 4.0.0-alpha 2 version or higher is required. If you want install this package then please use the „classic installer.php“

    Also, egal ob Domainfactory oder Siteground, die Installation will einfach nicht. Gibt es eine Möglichkeit die Datenbank einzeln hochzuladen und die Dateien dann per File Manager, sodass die Website läuft? Ich hatte schon versucht die sql-Datei aus dem Ordner dup-installer einzeln als Datenbank zu importieren und die Ordnerstruktur einzeln hochzuladen, aber auch das hat mir nicht geholfen.

    Ich sitze jetzt schon zwei Tage an einer Lösung und bin mittlerweile wirklich verzweifelt..

    Hallo,
    wenn ich das richtig sehe und das Duplicator-Backup tatsächlich ok ist, dann sollte

    • die ZIP-Datei alle Ordner enthalten und
    • im Ordner dup-installer eine SQL-Datei sein

    Also könnte (ohne dass ich das getestet habe) funktionieren, wenn du die ZIP-Datei lokal entpackst und alle Ordner per FTP in den Ordner auf deinem Webspace hochlädst.
    Die (entpackte) SQL-Datei müsstest du über phpMyAdmin importieren können.
    Wenn du hier nicht weiterkommst, wäre es wahrscheinlich besser, wenn du dich direkt an das Support-Forum der Entwickler wendest.
    Viele Grüße
    Hans-Gerd

    Sorry, aber jetzt weiß ich auch nicht mehr weiter …

    Wenn bei 2 Hosts nix geht, hat wahrscheinlich Hans Recht.

    Archive not found!

    kann aber auch sein, das der Archiv-Dateiname nicht mit dem Eintrag im Installer übereinstimmt.
    So müsste in der installer.php (oder wie auch immer die heißt) in Zeile 92 der Dateiname des (hoffentlich im gleichen Ordner befindlichen) Archivs sein.
    ZB.: const ARCHIVE_FILENAME = '00000000_blablub_0000000000_archive.zip';
    Wenn das passt, muss der ja was finden …

    mit Workarounds arbeite, die mir DF genannt hat,

    Diese kennen wir ja nicht.

    eine WordPress Seite neu aufzusetzen und das Backup über das Duplicator Plugin

    Das machte ich noch nie, sondern immer nur den normalen Weg, Duplicator die gesamte Site neu aufsetzen zu lassen.

    Files hochladen und DB importieren sollte auch klappen, ja. Nur musst dann die Pfade in der DB manuell umbiegen. Was Duplicator eigentlich eh macht, machen sollte.

    Thread-Ersteller mamue90

    (@mamue90)

    Hallo @pezi und @hage

    Danke für eure so späte Hilfe! Ihr werdet es nicht glauben. Zum tausendsten Mal bin ich jetzt durch die installer.php und habe mir den Archivnamen nochmal Buchstabe für Buchstabe angesehen – und da wars:

    20201021_DOMAIN_bakup_71c5bb79cace01d69197_20201021145932

    Das Archiv heißt aber 20201021_DOMAIN_backup_71c5bb79cace01d69197_20201021145932

    Ich kann es mir nur so vorstellen, dass mein alter Webdesigner sich verschrieben hat als er das Archiv erstellt hat und ihm es zu blöd war, dass er Backup falsch geschrieben hat. Also hat er die .zip umbenannt, ohne daran zu denken, dass die installer.php auf den alten Namen verweist.

    Da kann man sich aber auch einen Wolf suchen 😀 Der Installer klappt schon besser, auch das Entpacken der Zip wird endlich angeboten. Aber nach Schritt 1 kommt jetzt:

    Please try again an issue has occurred.

    Server Code: 500
    Status: Internal Server Error
    Response:
    Error establishing a database connection
    Recommendation:
    See this FAQ item for possible resolutions.

    Ich mach mein Webpaket nochmal komplett platt, entferne die alte Datenbank und alle Files und versuche dann nochmal sauber von vorn anzufangen. Halte euch auf dem Laufenden 🙂

    PS: @hage @pezi Der Workaround von DF war übrigens genau der Vorschlag von @hage.

    Einen schönen Abend für euch beide und ganz vielen Dank!

    nochmal sauber von vorn anzufangen

    Gute Idee.

    Also dann bis morgen – und möge die Nacht mit euch sein!

    dann mal viel Erfolg

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)