Support » Plugins » Durch Google Fonts in eingebettetem iframe ist Seite nicht DSGVO-konform

  • Gelöst sonnila1986

    (@sonnila1986)


    Hallo zusammen,

    ich bin eigentlich Grafikerin und im neuen Unternehmen an ein Problem gesetzt worden, das ich nicht durch googeln lösen kann. WordPress und Programmieren generell ist neu für mich.

    Es gibt bei der Webseite https://rothen-haustechnik.de/, die hier von meiner Vorgängerin aufgebaut wurde, eine Klage, da Google Fonts nicht DSGVO-konform verwendet wurden. Bei einer anderen Webseite hatte ich das Plugin „OMGF“ genutzt und das hat auch gut geklappt. Hier genauso. Leider bekomme ich unter „Einstellungen > Optimize Google Fonts“ im Aufgabenmanager den Hinweis:

    1 potential conflict found in your configuration.

    Recaptcha is loading an embedded iframe on your site. OMGF (Pro) can’t process Google Fonts inside iframes. Click here to find out why and what you can do about it.

    Ich habe bereits die Kontaktformulare von der Seite gelöscht, da ich dachte, dass das Problem daran läge. Ich weiß nicht, wie ich herausfinden soll, welches iframe gemeint ist und wie ich das löschen bzw. das Problem beheben kann.

    Über diese Seite bekomme ich leider immer noch den Hinweis, dass die Google Fonts nicht DSGVO-konform eingebunden sind:
    https://www.e-recht24.de/google-fonts-scanner

    Ich hoffe sehr, mir kann jemand helfen.
    (Ich hoffe, dass ich zeitnah antworten kann, da ich nur 3 Tage/Woche im Unternehmen bin)

    Allen, die eine Idee haben, vorab vielen Dank!

    Sonja

    Hier der Bericht:

    
    ### wp-core ###
    
    version: 6.0.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /usr/www/users/rothenef
    wordpress_size: 127,54 MB (133737146 bytes)
    uploads_path: /usr/www/users/rothenef/wp-content/uploads
    uploads_size: 10,98 MB (11511395 bytes)
    themes_path: /usr/www/users/rothenef/wp-content/themes
    themes_size: 17,41 MB (18260491 bytes)
    plugins_path: /usr/www/users/rothenef/wp-content/plugins
    plugins_size: 104,74 MB (109828707 bytes)
    database_size: 6,11 MB (6406144 bytes)
    total_size: 266,78 MB (279743883 bytes)
    
    ### wp-active-theme ###
    
    name: XTRA (xtra)
    version: 4.4.13 (latest version: 4.4.17)
    author: Codevz
    author_website: https://codevz.com/
    parent_theme: none
    theme_features: core-block-patterns, menus, html5, title-tag, automatic-feed-links, post-thumbnails, post-formats, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, responsive-embeds, jetpack-responsive-videos, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, bbpress, widgets
    theme_path: /usr/www/users/rothenef/wp-content/themes/xtra
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 2.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (14) ###
    
    Autoptimize: version: 3.1.2, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4.1, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Codevz Plus: version: 4.4.17, author: Codevz, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.3.4, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Disable Recaptcha - CF7: version: 1.2, author: Faiyaz Vaid, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Duplicator: version: 1.5.0, author: Snap Creek, Automatische Aktualisierungen deaktiviert
    EWWW Image Optimizer: version: 6.9.1, author: Exactly WWW, Automatische Aktualisierungen deaktiviert
    Invisible reCaptcha: version: 1.2.3, author: Mihai Chelaru, Automatische Aktualisierungen aktiviert
    OMGF: version: 5.4.2, author: Daan from Daan.dev, Automatische Aktualisierungen aktiviert
    OMGF Pro: version: 3.7.1, author: Daan from Daan.dev, Automatische Aktualisierungen deaktiviert
    Slider Revolution: version: 6.5.24, author: ThemePunch (latest version: 6.6.4), Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder: version: 6.10.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 5.0.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: EWWWIO_GD_Editor
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.0-17-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.15-MariaDB-0+deb11u1
    client_version: mysqlnd 7.4.32
    max_allowed_packet: 1073741824
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /usr/www/users/rothenef/wp-content
    WP_PLUGIN_DIR: /usr/www/users/rothenef/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von sonnila1986.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Das kommt mit ziemlicher Sicherheit vom reCaptcha.

    Nachtrag:
    Deaktiviere (besser lösche es komplett) mal das Plugin
    Invisible reCaptcha: version: 1.2.3, author: Mihai Chelaru

    Thread-Starter sonnila1986

    (@sonnila1986)

    Vielen Dank, Angelika. Ich teste es morgen direkt und melde mich, ob es geklappt hat.

    Hallo,
    zumindest auf einer Unterseite habe ich (zusätzlich) noch Google Fonts trotz des eingesetzten Plugins OMGF gefunden. Evtl. solltest du da die Einstellungen bei OMGF noch mal überprüfen.

    Ich hatte heute auch solch einen Fall, dass auf einer Unterseite Google Fonts eingebunden waren. Lösen konnte ich das in dem Fall mit dem Plugin Local Google Fonts.
    Zunächst „fand“ das Plugin die Schriften nicht. Ich habe dann bei dem Plugin “Schriften automatisch laden” bei den Eigenschaften eingeschaltet. Danach wurden die Google Fonts gefunden und lokal eingerichtet.

    Das ist in der Tat mühsam, weil man ja wohl kaum alle vorhandenen Seiten manuell durchklicken kann.

    Es gibt dazu zwar Webseiten, die eine Prüfung bezogen auf Google Fonts vornehmen. Das geschieht aber leider in der Regel nur auf der Hauptseite.

    Viele Grüße
    Hans-Gerd

    OMGF entfernt keine Google Fonts, die durch iFrames eingebunden wurden und auch die anderen von dir genannten werden das nicht tun @hage

    @la-geek
    Stimmt – ich hatte übersehen, dass auf der Seite, die ich mir angesehen habe, Google Fonts durch reCaptcha eingebunden wurden.

    @sonnila1986

    Abgesehen von den Google Fonts: Mit dem Badplaner wäre ich auch vorsichtig. Man sieht dort zwar einen Cookie-Banner, aber es werden direkt beim Aufrufen der Seite 8 Cookies geladen. Ich würde ein Popup davor schalten, wo darauf hingewiesen wird. Hab ich z. B. auf dieser Website so gemacht, oben auf den roten Button „Online buchen“ klicken.

    Thread-Starter sonnila1986

    (@sonnila1986)

    @la-geek:
    Hatte jetzt beim ersten Versuch das Plugin erst deaktiviert, dann gelöscht und bekomme noch immer die Fehlermeldung. Heißt aber ja nicht, dass das jetzt nichts gemacht hat.

    Ich gehe dann die nächsten Schritte erstmal durch.

    Thread-Starter sonnila1986

    (@sonnila1986)

    Danke @hage für deine Antwort. Darf ich fragen, wie du auf einer Unterseite noch GoogleFonts gefunden hast?
    Ich habe im Seitenquelltext der HOME-Seite nach „fonts.googleapis.com“ und „fonts.gstatic.com“ gesucht und er hatte nichts mehr gefunden. Muss man da alle Unterseiten einzeln durchschauen?

    Thread-Starter sonnila1986

    (@sonnila1986)

    Ich verstehe auch nicht, was das für ein iFrame ist, in dem die GoogleFonts eingespielt werden sollen.

    @sonnila1986
    vermutlich musst du den Cache von Autoptimize noch löschen Info

    Und das Plugin „Disable Recaptcha“ kannst du auch löschen, immer danach Cache leeren, von Autoptimize und Browser.

    Thread-Starter sonnila1986

    (@sonnila1986)

    @la-geek
    Gerade gemacht. Immernoch die Fehlermeldung bei e-Recht 24
    Den Hinweis mit dem Badplaner gebe ich mal intern weiter.

    BTW:
    Hatte die Webseiten alle nicht erstellt. Bin noch relativ neu in der Firma und hatte bislang kaum mit WordPress zu tun außer mal nen Text aktualisieren oder ein Bild einpflegen. Tu mir gerade echt schwer 🙁

    Thread-Starter sonnila1986

    (@sonnila1986)

    Weiß nicht, ob das interessant ist. Hier nochmal ein aktueller Bericht:

    
    ### wp-core ###
    
    version: 6.0.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /usr/www/users/rothenef
    wordpress_size: 127,54 MB (133737146 bytes)
    uploads_path: /usr/www/users/rothenef/wp-content/uploads
    uploads_size: 10,98 MB (11511395 bytes)
    themes_path: /usr/www/users/rothenef/wp-content/themes
    themes_size: 17,41 MB (18260491 bytes)
    plugins_path: /usr/www/users/rothenef/wp-content/plugins
    plugins_size: 104,74 MB (109828707 bytes)
    database_size: 6,14 MB (6438912 bytes)
    total_size: 266,82 MB (279776651 bytes)
    
    ### wp-active-theme ###
    
    name: XTRA (xtra)
    version: 4.4.13 (latest version: 4.4.17)
    author: Codevz
    author_website: https://codevz.com/
    parent_theme: none
    theme_features: core-block-patterns, menus, html5, title-tag, automatic-feed-links, post-thumbnails, post-formats, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, responsive-embeds, jetpack-responsive-videos, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, bbpress, widgets
    theme_path: /usr/www/users/rothenef/wp-content/themes/xtra
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (4) ###
    
    Twenty Nineteen: version: 2.3, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 2.0, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.6, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (14) ###
    
    Akismet Anti-Spam: version: 5.0.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 3.1.2, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.4.1, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Codevz Plus: version: 4.4.17, author: Codevz, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.3.4, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.6.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Duplicator: version: 1.5.0, author: Snap Creek, Automatische Aktualisierungen deaktiviert
    EWWW Image Optimizer: version: 6.9.1, author: Exactly WWW, Automatische Aktualisierungen deaktiviert
    Local Google Fonts: version: 0.18, author: EverPress, Automatische Aktualisierungen deaktiviert
    OMGF: version: 5.4.2, author: Daan from Daan.dev, Automatische Aktualisierungen aktiviert
    OMGF Pro: version: 3.7.1, author: Daan from Daan.dev, Automatische Aktualisierungen deaktiviert
    Slider Revolution: version: 6.5.24, author: ThemePunch (latest version: 6.6.4), Automatische Aktualisierungen deaktiviert
    WPBakery Page Builder: version: 6.10.0, author: Michael M - WPBakery.com, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: EWWWIO_GD_Editor
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.53.3
    
    ### wp-server ###
    
    server_architecture: Linux 5.10.0-19-amd64 x86_64
    httpd_software: Apache
    php_version: 7.4.32 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 60
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.15-MariaDB-0+deb11u1
    client_version: mysqlnd 7.4.32
    max_allowed_packet: 1073741824
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /usr/www/users/rothenef/wp-content
    WP_PLUGIN_DIR: /usr/www/users/rothenef/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    
    • Diese Antwort wurde geändert vor 1 Monat, 2 Wochen von sonnila1986.

    Auf der Website ist noch Contact Form 7 aktiv. Auch wenn du Formulare im Frontend gelöscht hast, im Backend ist das Plugin noch aktiv.

    Ist dort reCaptcha aktiviert?
    siehe
    https://contactform7.com/recaptcha/

    @sonnila1986
    vermutlich reicht es schon, wenn du unter Formulare > Integration > ReCAPTCHA und Button „Integration“ den Website-Schlüssel für reCAPTCHA entfernst und dann den Cache leerst.

    Thread-Starter sonnila1986

    (@sonnila1986)

    @hage
    Ich habe das als erstes versucht, weil das einfacher ausgesehen hat und es hat tatsächlich funktioniert. Ich bekomme keine Fehlermeldung mehr.

    Ganz ganz herzlichen Dank an @la-geek und @hage für die wundervolle Hilfe!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)