Support » Allgemeine Fragen » Einbindung von MP4-Video verursacht RSS-Fehler

  • Gelöst Regenpfeifer

    (@regenpfeifer)


    Hallo,

    ich habe auf meiner Seite in einen der Beiträge mittels des entsprechenden Gutenberg-Blocks „Video“ ein MP4-Video eingebunden. Die Datei wurde dazu in die Mediathek hochgeladen. Es handelt sich also nicht um eine Einbettung einer anderswo gespeicherten Datei, sondern um eine lokale Datei.

    Das funktioniert tadellos und ich bekomme auch alles ordentlich angezeigt. Allerdings verursacht das eingebundene MP4-Video einen Fehler im RSS-Feed meiner Seite.

    Der Fehler ist hier im Validator zu sehen: https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fregenpfeifer.net%2Ffeed

    Leider bleibt das auch nicht folgenlos, sondern führt dazu, dass der RSS-Feed meiner Seite zumindest bei einigen Feedreadern nicht aufgerufen werden kann.

    Irgendwie scheint das ein WordPress-interner Fehler zu sein, weil hier ja nur Bordmittel verwendet werden und der Gutenberg-Video-Block offenbar den RSS-Feed killt.

    Hat jemand einen Tipp, wie man dieses Verhalten beheben könnte?

    Danke und beste Grüße!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Michi91

    (@michi91)

    Moin,
    Verwendest du irgendwelche Plugins um den Rss Feed anzupassen? Oder custom code?

    Ich vermute dass das Problem von deinem Theme oder einem Plugin verursacht wird… Wenn es von WordPress intern käme, gäbe es sicher schon viel mehr Beschwerden.

    Grüße Michael

    Thread-Starter Regenpfeifer

    (@regenpfeifer)

    Vielen Dank für deine Hinweise, Michael!

    Ich hatte gedacht, dass ich Plugins als Ursache ausgeschlossen hätte, habe aber jetzt bei nochmaliger Prüfung festgestellt, dass es das Plugin RankMath PRO ist, das den Fehler verursacht; genauer das Schema-Modul der Pro-Version des Plugins.

    Werde mich an den Support von RankMath wenden, da wird es sicher durch das Setzen bestimmter Einstellungen eine Abhilfe geben.

    Kann dann gerne hier nochmals berichten.

    Herzliche Grüße,
    Hermann Josef

    Thread-Starter Regenpfeifer

    (@regenpfeifer)

    Hier die Rückmeldung vom RankMath-Support. Das Problem wird tatsächlich durch die Schema-Einstellungen von RankMath Pro verursacht.

    Abhilfe schafft diese Einstellung:

    RankMath -> Allgemeine Einstellungen -> Andere
    Dort die Option „Remove Media Data from RSS feed“ aktivieren.

    Dann funktioniert der RSS-Feed wieder tadellos.

    Danke für die Info 👍

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Einbindung von MP4-Video verursacht RSS-Fehler“ ist für neue Antworten geschlossen.