Support » Allgemeine Fragen » Eingebettete Videos werden nicht angezeigt

  • Gelöst derschleifer

    (@derschleifer)


    Hallo zusammen,

    ich bin gerade ein wenig am Verzweifeln. Ich nutze WordPress 5.8.2 mit dem Theme OceanWP v3.1.2. Als Editor nutze ich Gutenberg.

    Jetzt habe ich plötzlich das Problem, dass eingebettete YouTube Videos nicht mehr angezeigt werden. Egal ob ich im Editor eine URL oder das YouTube Video direkt einbette. Im jeweiligen Blog-Artikel wird dann nur noch die YouTube URL angezeigt und das wars.

    Ich weiß nicht genau seit wann das Problem besteht. Ich betreibe die Seite jetzt seit eineinhalb Jahren und bisher hat es immer funktioniert.

    Hier mal ein Beispiel Code:

    <!-- wp:embed {"url":"https://www.youtube.com/watch?v=A0Ls1drB4MU","type":"video","providerNameSlug":"youtube","responsive":true,"className":"wp-embed-aspect-16-9 wp-has-aspect-ratio"} -->
    <figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
    
    </div></figure>
    <!-- /wp:embed -->

    Hat jemand eine Idee?

    Schonmal danke im Voraus.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Hallo,

    Als Editor nutze ich Gutenberg.

    … nutzt du denn auch den Youtube-Block vom Block-Editor? – dann ist eine Anpassung des Quellcodes gar nicht notwendig, weil du da direkt die URL des Videos erfassen kannst, siehe hier:
    Youtube.

    Ergebnis siehe hier:
    Youtube.

    Anmerkung: das Plugin „Gutenberg“ solltest du nicht installieren. Leider gibt es allgemein ein wenig Verwirrung: In der Regel wird der Block-Editor auch als Gutenberg bezeichnet. Das ist so nicht ganz korrekt, weil es zusätzlich ein Gutenberg-Plugin gibt. Dieses Plugin bietet bestimmte Funktionen an, die man als experimentell betrachten kann. Daher sollte man das Plugin nicht auf Produktivseiten einsetzen. Der Block-Editor ist dagegen der Standard-Editor von WordPress und steht ab der Version 5.0 automatisch als Editor zur Verfügung. Das war nicht immer klar und (nicht nur) deswegen gibt es so viele negative Bewertungen für das Gutenberg-Plugin.
    Solltest du also das Gutenberg-Plugin installiert haben, deaktiviere das Plugin bitte und teste dann, ob es wieder funktioniert.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 10 Monaten, 4 Wochen von Hans-Gerd Gerhards. Grund: Ergänzung
    • Diese Antwort wurde geändert vor 10 Monaten, 4 Wochen von Hans-Gerd Gerhards. Grund: Ergänzung
    Thread-Starter derschleifer

    (@derschleifer)

    Ja, genau den nutze ich. Das ist der Code vom Block Editor den ich genutzt habe. Ich hab sowohl URL einbetten, als auch den YouTube Block benutzt. Funktioniert beides nicht.

    Und ich habe nichts zusätzlich installiert, also nutze ich scheinbar nur den standard Blockeditor. Gutenberg ist jedenfalls nicht als Plugin installiert.

    • Diese Antwort wurde geändert vor 10 Monaten, 4 Wochen von derschleifer.

    Scheinbar wird das Embed nicht korrekt umgewandelt.

    Setze ich in OceanWP eine Seite auf und füge den gleichen Videolink in einen Youtube-Block ein, bekomme ich folgenden Code im Frontend ausgegeben:

    <figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
     <p class="responsive-video-wrap clr">
    <iframe title="Gedanken zum Jahresbeginn | Kant, die Aufklärung und ein wenig Social Media Kritik" src="https://www.youtube.com/embed/A0Ls1drB4MU?feature=oembed" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen="" width="1200" height="675" frameborder="0">
    </iframe>
    </p>
    </div>
    </figure>

    Bei deiner Website sieht das etwas anders aus:

    <figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio">
    <div class="wp-block-embed__wrapper">
    https:// www.youtube.com/watch?v=A0Ls1drB4MU
    </div>
    </figure>

    (den Leerschritt habe ich eingefügt, weil unsere Forensoftware so gerne Youtube-Videos zeigt …)

    … also kein iFrame? ¯\_(ツ)_/¯

    Ich vermute dass es hier einen Konflikt mit einem Plugin gibt. Hast du mal versucht, die Plugins zum Testen zu deaktivieren (geht recht komfortabel mit dem Plugin Health Check – dann schimpft auch kein Webseitenbesucher, weil die von deinen Tests nichts mitbekommen).

    • Diese Antwort wurde geändert vor 10 Monaten, 4 Wochen von Bego Mario Garde. Grund: Video-URL verhunzt
    Thread-Starter derschleifer

    (@derschleifer)

    Hab das Plugin installiert. Zeigt mir aber keine Konflikte an. Und da ich kaum Plugins installiert hab, hab ich die paar mal nach der Reihe ausgeschaltet. Kein Effekt.

    Wenn ich zum Standard Theme wechsle geht es. Nur mit OceanWP nicht.

    Ich bin mir nicht ganz sicher, ob wir uns da richtig verstehen. Das Plugin Health Check bietet dir unter Werkzeuge > Website-Zustand einen „Problembehandlungsmodus“, mit dem du die Plugins deaktivieren und ein Standardtheme aktivieren kannst.

    Wenn du allerdings schreibst, dass das Video in einem anderen Theme korrekt eingebunden wird, liegt der Fehler sehr wahrscheinlich am Theme OceanWP. Versuch doch mal, das Theme zu deinstallieren und neu installieren. (Es wäre sinnvoll, vorher rasch ein Backup der Datenbank zu machen.)

    Auf meiner Testumgebung konnte ich mit der aktuellen Version von OceanWP das Video korrekt einbinden. Welche PHP-Version verwendest du?

    Noch eine andere Idee: mit dem Plugin WP Rollback kannst du mal versuchen, eine ältere Version von OceanWP zu installieren. Das ist natürlich nur eine Übergangslösung, hilft aber vielleicht bei der Suche nach der Fehlerursache.

    Thread-Starter derschleifer

    (@derschleifer)

    Eine ältere Verison hat leider auch keine Besserung gebracht. Gleiches Problem.

    Ich nutze die PHP Version 7.4.24

    Irgendwie macht es keinen Sinn, dass das Einbinden bisher ging und nun nicht mehr. Ich konnte das Video auch in einer Testumgebung (PHP 8.0, OceanWP aktuelle Version) problemlos einbinden. Wenn du sonst keine Einstellungen z.B. in der wp-config.php oder functions.php des Themes vorgenommen hast, kann ich mir da im Moment keinen Reim drauf machen.

    Thread-Starter derschleifer

    (@derschleifer)

    Jetzt wird es richtig schräg. Ich hab eben mal rumgespielt und wenn ich in den jeweiligen Beitrag gehe, mir einfach mal die Seite als Vorschau in einem neuen Tab anzeigen lassen und danach aktualisiere, funktioniert es wieder. Aber eben halt nur auf dem Blogbeitrag wo ich dieses Spiel so gespielt habe.

    das hört sich aber schwer nach einem Problem mit dem Cache an.
    Hast du ein Cache-Plugin (welches?) installiert? – Lösche doch in dem Fall den Cache bei den Einstellungen des Plugins.

    Die Videos in den ersten Beiträgen werden jetzt alle korrekt eingebunden.

    off topic: Das Video zum grünen Tee war prima. O-Cha … Wenn zu mir bisher jemand O-ha gesagt hat, habe ich das nicht als besondere Wertschätzung empfunden. 🤔

    Thread-Starter derschleifer

    (@derschleifer)

    @hage
    Nein, hab keins installiert. Von daher kann es da nicht dran liegen.

    @pixolin
    Ich hab die ersten Beiträge jetzt auch alle durchgeklickt, so das es wieder geht. Die Videos weiter hinten gehen auch. Allerdings weiß ich jetzt nicht, ob diese die ganze Zeit auch nicht gingen und die paar Klicks jetzt alles behoben haben, oder ob es nur die Videos auf der ersten Seite betroffen hat.

    off topic: Danke! Und im Japanischen ist das mit O halt ein wenig anders als im Deutschen XD

    @derschleifer
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Hallo zusammen!

    Also ich hatte das selbe Problem heute auch, jedenfalls mit den Videos welche ich von Vimeo über die normale URL eingebettet hatte.

    Die Lösung war relativ einfach. Ich habe im Block-Editor den Block entfernt in dem man nur die Einbettungs-URL eingeben muss und einen HTML-Block erstellt in dem ich den (ich glaube es heißt iframe) Einbettungscode eingefügt habe.

    Somit habe ich das Problem behoben und es funktioniert alles wieder einwandfrei.
    In Zukunft werde ich daher alle Videos ausschließlich nur noch mit dem Einbettungscode einfügen.

    Hoffe der Tipp hilft dem Ein oder Anderen weiter.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Eingebettete Videos werden nicht angezeigt“ ist für neue Antworten geschlossen.