• Hallo, mein Hoster hat zum 14.11.22 PHP 7.3/7.4 abgeschaltet und auf PHP 8.1 gesetzt. Meine Seite wurde noch mit dem Theme „ElegantEstate“ im Jahr 2012 erstellt und seither ist keine Aktualisierung gemacht worden. Mein Hoster hat „twenty twenty-three“ aktiviert damit ich ins Backend kommen kann. WP ist sonst aktuell. Was kann ich tun ??

    • Dieses Thema wurde geändert vor 1 Jahr, 7 Monaten von rdwhannover.
Ansicht von 6 Antworten – 1 bis 6 (von insgesamt 6)
  • Manchmal hakt es nur an einfachen Programierfehlern, die leicht zu beseitigen sind. Dazu bräuchten wir aber den Error-Log des Servers. Ich finde das Theme auch nicht im WordPress-Theme-Verzeichnis. Wenn es sich um ein gekauftes Theme handelt, können wir dir ohnehin hier nicht weiterhelfen, weil uns das Theme dann für kostenlosen Support nicht zur Verfügung steht.

    Die Inhalte sind durch einen Theme-Wechsel nicht weg – es sieht nur anders aus. Ich würde im Zweifelsfall ein einfaches Theme verwenden und soweit möglich gestalterisch an die ursprüngliche Website anpassen. Um eine Überarbeitung wirst du bei einem Theme-Wechsel nicht herum kommen.

    Thread-Starter rdwhannover

    (@rdwhannover)

    okay, verstehe.. wo steht der Error-Log des Server ? Das Theme war soweit ich weiß kostenlos.., ich hab dafür jedenfalls nicht bezahlt.., ich weiss das mein Spezie das 2012 in den Staaten gebucht hat…

    Thread-Starter rdwhannover

    (@rdwhannover)

    die letzten 10 ganz aktuell:

    [Wed Dec 07 10:29:04 2022] [ssl:warn] [pid 28619] [client [host AH01909: mw-immobilien-hannover.de:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Dec 07 11:22:27 2022] [ssl:warn] [pid 28619] [client [host AH01909: mw-immobilien-hannover.de:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Dec 07 12:26:23 2022] [ssl:warn] [pid 28619] [client [host AH01909: mw-immobilien-hannover.de:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Dec 07 12:36:05 2022] [php:error] [pid 30264] [client 84.171.86.166] [host mw-immobilien-hannover.de] PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function WP_Widget::__construct(), 0 passed in /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-widget-factory.php on line 62 and at least 2 expected in /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-widget.php:163\nStack trace:\n#0 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-widget-factory.php(62): WP_Widget-]__construct()\n#1 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/widgets.php(115): WP_Widget_Factory-]register('AboutMeWidget')\n#2 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-content/themes/ElegantEstate/includes/widgets/widget-about.php(58): register_widget('AboutMeWidget')\n#3 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-hook.php(308): AboutMeWidgetInit('')\n#4 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-hook.php(332): WP_Hook-]apply_filters(NULL, Array)\n#5 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/plugin.php(517): WP_Hook-]do_action(Array)\n#6 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/widgets.php(1854): do_action('widgets_init')\n#7 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-hook.php(308): wp_widgets_init('')\n#8 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-hook.php(332): WP_Hook-]apply_filters(NULL, Array)\n#9 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/plugin.php(517): WP_Hook-]do_action(Array)\n#10 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-settings.php(617): do_action('init')\n#11 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-config.php(80): require_once('/is/htdocs/wp10...')\n#12 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-load.php(50): require_once('/is/htdocs/wp10...')\n#13 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-admin/admin.php(34): require_once('/is/htdocs/wp10...')\n#14 /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-admin/customize.php(13): require_once('/is/htdocs/wp10...')\n#15 {main}\n  thrown in /is/htdocs/wp10960332_ACRV91XFNZ/www/wp-includes/class-wp-widget.php on line 163
    [Wed Dec 07 13:10:21 2022] [ssl:warn] [pid 28619] [client [host AH01909: mw-immobilien-hannover.de:443:0 server certificate does NOT include an ID which matches the server name
    Thread-Starter rdwhannover

    (@rdwhannover)

    ich habe ja eine FTP-Datei-Sicherung und SQL-Datei Sicherung.., kann man das nicht einbauen und vorher den Hoster wechseln (z.b.Raidboxes) die können noch auf PHP7.3 umstellen.., dann müßte doch erstmal alles wieder laufen..

    Da alle älteren Versionen als PHP 8 nicht mehr mit Sicherheitsupdates versorgt werden, halte ich das für keine gute Idee – auch wenn es funktionieren sollte.

    Hier scheint vor allem ein Widget Probleme zu bereiten. Das sollte sich mal ein Freelancer ansehen.

    Hallo,

    Hoster wechseln (z.b.Raidboxes) die können noch auf PHP7.3 umstellen.., dann müßte doch erstmal alles wieder laufen..

    das wäre grundsätzlich möglich und Raidoboxes bietet den Service sogar kostenlos an, aber damit wird das Problem erst mal nur verlagert.
    Um einen Themewechsel wirst du mit Sicherheit nicht rum kommen.
    Ziemlich sicher hat dich auch dein jetziger Hoster vorher über die Änderung bezüglich PHP informiert. Da hättest du an sich schon reagieren müssen.

    Wenn jetzt TT3 (Twenty Twenty-Three) aktiviert ist, dann kannst du doch auch durchaus auf ein klassisches Theme umstellen, so dass du vermutlich zumindest eine bessere Ausgangsbasis für einen Relaunch hast.

    Viele Grüße
    Hans-Gerd

Ansicht von 6 Antworten – 1 bis 6 (von insgesamt 6)
  • Das Thema „ElegantEstate ersetzen läuft nichtmit PHP 8.1“ ist für neue Antworten geschlossen.