Support » Allgemeine Fragen » Error – PHP Deprecated: Directive ‚allow_url_include‘ is deprecated in Unknown

  • Gelöst steindialog

    (@steindialog)


    Hallo liebes Forum,

    hat jemand eine Ahnung wie ich die Fehlermeldung gelöst bekomme die ich in meinem error.log finde:

    PHP Deprecated: Directive ‚allow_url_include‘ is deprecated in Unknown on line 0

    LG, Alex

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Deprecated heißt auf Deutsch Veraltet – du wirst als darauf hingewiesen, dass eine verwendete Funktion veraltet oder unbekannt ist.

    Eigentlich sollten solche Hinweise nur angezeigt werden, wenn das Debugging aktiviert ist. Schau mal, ob du in der wp-config.php die Zeile define( 'WP_DEBUG', true ); auf false ändern kannst.

    Da du nur einen Teil der Fehlermeldung angegeben hast und wir keine URL zu deiner Website haben, kann ich nicht beurteilen, was den Fehler auslöst.
    Bitte prüf auch im Kundenmenü deines Webhosters, welche PHP-Version verwendet wird. PHP 7.4 wäre optimal, 7.3 OK, alles ältere schlecht und für 8.0 ist es noch zu früh (nicht alle Plugins wurden darauf umgestellt).

    Thread-Ersteller steindialog

    (@steindialog)

    Hallo Mario,

    danke für dein Feedback.

    Was den Fehler betrifft das war die komplette Zeile gewesen.
    „PHP Deprecated: Directive ‚allow_url_include‘ is deprecated in Unknown on line 0“

    Ja – debug ist aktiviert gewesen, da ich ein Problem zu lösen hatte was diesen Fehler oben verursacht hatte. Es ging dabei darum dass in meinem woocommerce shop die Bilder sich bei variablen Produkten nicht nach Auswahl geändert haben und dann keine Auswahl möglich war.

    Nun wurde das Problem lösen können. Alles hing mit der Umstellung auf PHP v.7.4 zusammen. Dort wird die oben genannte Directive nicht mehr unterstützt. Daher kam es zu der Fehlermeldung die weiterhin auch mein Problem mit dem Shop auslöste.

    Zur Lösung habe ich folgende musste ich die Directive „allow_url_include = Off“ in den PHP Einstellungen der Seite ändern.

    Gemäß dieser Anleitung:

    To fix this 
    1.	Log in to your control panel
    2.	Select Advanced from the menu on the left
    3.	Scroll down to the SOFTWARE group and select MultiPHP INI Editor
    4.	Select location Home Directory
    5.	Set PHP Directive allow_url_include to Disabled
    6.	Set PHP Directive display_errors to Disabled
    7.	Hit the Apply button at the bottom of the page
    8.	Repeat steps 4-7 for each of your sites in the location menu

    Gruß Alex

    Freut mich, dass du eine Lösung gefunden hast und Danke fürs Teilen.
    Sicher spricht dann nichts dagegen, dass wir den Thread als „gelöst“ markieren? 🙂

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)