Support » Allgemeine Fragen » Es gab einen kritischen Fehler auf deiner Website

  • Hallo,

    Ich habe gefühlt seit sehr lange „nichts mehr an“ der aufgeführten Webseite gmacht, ausser: automatische Updates der Themes und Plugins.

    Nun stelle ich fest, dass die Seite ein schwerwiegendes Problem hat.
    Beispiele:

    • Ich kann im Event-Manager keine neuen Events mehr erfassen
    • Ich kann keine neue Seite mehr erstellen

    Solche Versuche enden immer mit „Es gab einen kritischen Fehler auf deiner Website“

    Allerdings: ich erhalte auf meine E-Mail keine Nachricht, wie das angedeutet wird.

    Ich bin mir sicher (hoffe), dass dies ein Standard-Problem ist, welches andere auch kennen? Ich habe FAQ und ungelöste Themen gesichtet und so nichts gefunden – was natürlich nicht bedeutet, dass es noch keinen Lösungsvorschlag gibt.

    Herzlichen Dank schon vorab für eure Hilfe!

    —-

    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/post.php on line 7580
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/post.php on line 7581
    
    Warning: Attempt to read property "ID" on null in /home/web/195365/htdocs/wp-includes/post.php on line 7585
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/post.php on line 7840
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/theme.php on line 3636
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/theme.php on line 3862
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/post.php on line 5516
    
    Warning: Attempt to read property "ID" on null in /home/web/195365/htdocs/wp-includes/post.php on line 5516
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-includes/post.php on line 4817
    
    Warning: Attempt to read property "post_type" on null in /home/web/195365/htdocs/wp-admin/includes/post.php on line 769
    
    Fatal error: Uncaught Error: Attempt to assign property "post_content" on null in /home/web/195365/htdocs/wp-admin/includes/post.php:808 Stack trace: #0 /home/web/195365/htdocs/wp-admin/post-new.php(66): get_default_post_to_edit() #1 {main} thrown in /home/web/195365/htdocs/wp-admin/includes/post.php on line 808
    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Hallo,
    schau doch mal bitte, ob du mit den beiden folgenden Beiträgen aus unserer FAQ weiterkommst:
    https://de.wordpress.org/support/topic/speichern-o-aktualisieren-o-schreiben-o-anmeldung-im-backend-geht-nicht-mehr/ und https://de.wordpress.org/support/topic/wie-deaktiviert-man-alle-plugins-ohne-adminzugang/
    Das könnte an Plugins oder deinem Theme liegen.

    Viele Grüße
    Hans-Gerd

    Moderator La Geek

    (@la-geek)

    @rsbmechatronik

    Ich habe FAQ und ungelöste Themen gesichtet und so nichts gefunden

    Dabei ist dir vermutlich dieser Beitrag aus der FAQ entgangen:

    Speichern o. Aktualisieren o. Schreiben o. Anmeldung im Backend geht nicht mehr

    Hast du davon etwas ausprobiert, falls ja, was? Außerdem: 2. d) Website-Bericht, Punkt 6. debug.log, 7. error.log.

    Thread-Starter rsbmechatronik

    (@rsbmechatronik)

    @la-geek

    Danke für deine Unterstützung.

    Ich bin deine Link „Schritt für Schritt“ durchgegangen.
    Bisher ohne Erfolg.

    • alle Plugins deaktiviert – keine Wirkung
    • Theme auf „WordPress Twenty Twentyfour“ gewechselt – keine Wirkung
    • Webseiten Bericht –> siehe unten
    • debug.log: das File kann ICH nicht finden. Ich weiss wo es sein sollte, es existiert / entsteht aber nicht.
    • error.log: Fehler provoziert, jedoch kein Eintrag mit dem Zeitstempel von JETZT, darum Code hier nicht angefügt.

    Debug Aktiviert, jedoch kein File debug.log findbar:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    define( 'WP_DEBUG_LOG', true );

    Hier der Webseiten Bericht:

    `
    ### wp-core ###
    
    version: 6.5
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%year%_%monthnum%_%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/web/195365/htdocs
    wordpress_size: 114,22 MB (119764301 bytes)
    uploads_path: /home/web/195365/htdocs/wp-content/uploads
    uploads_size: 134,15 MB (140663418 bytes)
    themes_path: /home/web/195365/htdocs/wp-content/themes
    themes_size: 13,02 MB (13653345 bytes)
    plugins_path: /home/web/195365/htdocs/wp-content/plugins
    plugins_size: 79,62 MB (83482622 bytes)
    database_size: 13,39 MB (14041088 bytes)
    total_size: 354,39 MB (371604774 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Sydney (sydney)
    version: 2.36
    author: aThemes
    author_website: https://athemes.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-background, align-wide, block-templates, custom-header, infinite-scroll, widgets
    theme_path: /home/web/195365/htdocs/wp-content/themes/sydney
    auto_update: Aktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Four: version: 1.1, author: Das WordPress-Team, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-active (3) ###
    
    Error Log Viewer by BestWebSoft: version: 1.1.4, author: BestWebSoft, Automatische Aktualisierungen deaktiviert
    Events Manager: version: 6.4.7.2, author: Pixelite, Automatische Aktualisierungen aktiviert
    WP File Manager: version: 7.2.6, author: mndpsingh287, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-inactive (8) ###
    
    Advanced Editor Tools: version: 5.9.2, author: Automattic, Automatische Aktualisierungen aktiviert
    IP Location Block: version: 1.3.1, author: IP Location Block, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts Reloaded: version: 2.26.8, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen aktiviert
    NextGEN Gallery: version: 3.59.1, author: Imagely, Automatische Aktualisierungen aktiviert
    Simple History: version: 4.13.0, author: Pär Thernström, Automatische Aktualisierungen aktiviert
    WPS Cleaner: version: 1.6.9, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen aktiviert
    WPS Hide Login: version: 1.9.13.2, author: WPServeur, NicolasKulka, wpformation, Automatische Aktualisierungen aktiviert
    WP Visitor Statistics (Real Time Traffic): version: 6.9.5, author: osamaesh, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 2 GB
    	imagick::RESOURCETYPE_MEMORY: 1 GB
    	imagick::RESOURCETYPE_THREAD: 1
    	imagick::RESOURCETYPE_TIME: 1.844674407371E+19
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-26-amd64 x86_64
    httpd_software: Apache
    php_version: 8.0.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1500
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    current: 2024-04-04T13:10:48+00:00
    utc-time: Thursday, 04-Apr-24 13:10:48 UTC
    server-time: 2024-04-04T13:10:47+00:00
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 11.0.5-MariaDB-1:11.0.5+maria~deb11
    client_version: mysqlnd 8.0.30
    max_allowed_packet: 16777216
    max_connections: 1000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/web/195365/htdocs/wp-content
    WP_PLUGIN_DIR: /home/web/195365/htdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    `

    Hallo,
    vermutlich wird das Problem mit der eMail beim Versand per SMTP statt über die PHP mail() function gelöst. Wenn du eine Mail erhältst, wäre eine Analyse zumindest einfacher.

    Dazu gibt es einige Plugins. Wie das zum Beispiel bei dem Plugin Easy WP SMTP funktioniert, habe ich in diesem älteren Beitrag beschrieben.

    Viele Grüße
    Hans-Gerd

    Moderator La Geek

    (@la-geek)

    @rsbmechatronik

    Da sehr wahrscheinlich die Plugins und das Theme als Ursache wegfallen (das hast du ja bereits getestet), schränkt es die mögliche Ursache ein, auf

    .htaccess-Datei? (laut Website-Bericht sollte dieser allerdings keine zusätzlichen Regeln enthalten htaccess_extra_rules: false) – also eher nicht, dann

    Cache? es ist kein Cache-Plugin installiert, soweit ich das sehe, eventuell hat der Events Manager eine Cache-Option (falls ja, bitte leeren). Bleiben

    WordPress? Hast du die WordPress-Dateien schon überschrieben? Falls nein, dann teste das: entweder über Dashboard –> Aktualisierungen –> Version 6.5 neu installieren, oder per FTP (siehe Artikel)

    Datenbank?

    PHP-Version: Kannst du die PHP-Version erhöhen auf 8.1 oder 8.2? und

    Permalinks, speichere die einmal neu (Adminbereich –> Einstellungen –> Permalinks), wähle vielleicht statt /%year%_%monthnum%_%day%/%postname%/ mal Beitragsname = /%postname%/ und teste das.

    Zur debug.log –> entferne define( 'WP_DEBUG_LOG', true );, reproduziere den Fehler und sieh, ob dir eine Fehlermeldung angezeigt wird. Anschließend ändere den Eintrag in der wp-config.php sofort wieder von

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    define( 'WP_DEBUG_LOG', true );

    bzw. von

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', true );

    auf
    define( 'WP_DEBUG', false );

    Außerdem ist der File Manager noch so ein Kandidat, möglicherweise wurden darüber Dateien hochgeladen und die Berechtigungen (sieht man in einem FTP-Client-Programm) sind verändert, bzw der FTP-User.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Hey @rsbmechatronik hast Du Zugriff auf die Datenbank?

    Vielleicht über phpMyAdmin? Wenn du in die Posts-Tabelle schaust, sieht das da alles korrekt aus? Vielleicht ist die Posts-Tabelle locked oder korrupt. Sind die IDs korrekt?

    Abgesehen davon ein kleiner Hinweis zur Website:
    In dem Slider sind die Bilder etwas zu groß (Pixelmaße z.T. über 2560 und über 1 MB pro Bild). Die Startseite ist so fast 12 MB groß! Außerdem sind 6 Bilder via http statt https eingebunden, weshalb mein Browser eine „Mixed Content“ Warnung ausgibt. Die Bilder werden korrekt auf https weitergeleitet, aber die Warnung irritiert ja doch …

    Thread-Starter rsbmechatronik

    (@rsbmechatronik)

    @la-geek

    WordPress
    Ich habe letzte Wochwe deinen sehr hoffnungsvollen Beitrag entdeckt und getestet = alle WordPress-Basis-Files entfernt und durch die aktuellste Version ersetzt.
    … Resultat❌ Kein Erfolg bei mir. Derselbe Fehler besteht weiter.

    Permalink?
    Getestet gemäss deinem Hinweis
    … Resultat ❌keiner Erfolg. Derselbe Fehler besteht weiter.

    Nur zur Präzisierung meines Problems: Ich kann auch keine neue Seite in Worpress erstellen. Es hängt aus meiner Sicht also nicht am Event-Manager, sonder ist „fundamentaler“ – da denke ich dann eher an die Datenbank oder die PHP Version. Ich gehe dem mal nach.

    ———————————————————————————–
    @zodiac1978

    Auch deinen Hinweisen werde ich gerne nachgehen. Danke

    ———————————————————————————–

    Mein Fehler (= der Ursprung meiner Frage):

    Fatal error: Uncaught Error: Attempt to assign property "post_content" on null in /home/web/195365/htdocs/wp-admin/includes/post.php:808 Stack trace: #0 /home/web/195365/htdocs/wp-admin/post-new.php(66): get_default_post_to_edit() #1 {main} thrown in /home/web/195365/htdocs/wp-admin/includes/post.php on line 808
    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von rsbmechatronik.
    • Diese Antwort wurde geändert vor 2 Wochen, 3 Tage von rsbmechatronik.
    Moderator La Geek

    (@la-geek)

    @rsbmechatronik
    ist das Problem nun gelöst, hast du die Posts-Tabelle überprüft?

    Den Hinweis von @hage, die E-Mail per SMTP zu erhalten, ausprobiert? Die Fehlermeldung in der automatisch von WordPress verschickten E-Mail liefert i. d. R. entscheidende Hinweise, wodurch der Fehler verursacht wurde.

    Debug-Fehlermeldung produziert (s. meinen vorherigen Post)?

    PHP-Version geändert?

    Wurden beim Hochladen der WordPress-Core-Dateien alle Dateien überschrieben (Anzeige in FTP-Client okay)?

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)