Support » Allgemeine Fragen » Es gab einen kritischen Fehler auf deiner Website

  • Gelöst wuestenblumesamy

    (@wuestenblumesamy)


    Hallo Zusammen,
    ich verzweifle ein wenig. Meine Website lässt sich ganz normal aufrufen, ich komme auch ins Backend. Alle Seiten kann ich bearbeiten, nur die Startseite nicht, bzw. in den Pagebuilder Elementor komme ich, aber kann ihn nicht mehr verlassen, ohne dass die Meldung erscheint: „„Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang……“

    Die Tipps, die unter >>Speichern o. Aktualisieren o. Schreiben o. Anmeldung im Backend geht nicht mehr<< vorgeschlagen werden, habe ich befolgt.
    Ohne Erfolg!

    Hier mal der Bericht vom Plugin „Health Check & Troubleshooting“:

    
    ### wp-core ###
    
    version: 5.8.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: undefined
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/619056_47058/webseiten/WordPress_02
    wordpress_size: 423,32 MB (443881184 bytes)
    uploads_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/uploads
    uploads_size: 36,83 MB (38613978 bytes)
    themes_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/themes
    themes_size: 22,92 MB (24031610 bytes)
    plugins_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/plugins
    plugins_size: 107,93 MB (113170329 bytes)
    database_size: 178,78 MB (187465728 bytes)
    total_size: 769,77 MB (807162829 bytes)
    
    ### wp-active-theme ###
    
    name: Astra-Child (astra-child)
    version: 1.0.0
    author: Peter von wpwissen.com
    author_website: https://wpwissen.com
    parent_theme: Astra (astra)
    theme_features: core-block-patterns, astra_hooks, widgets-block-editor, align-wide, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-logo, customize-selective-refresh-widgets, editor-style, woocommerce, rank-math-breadcrumbs, amp, editor-color-palette, widgets, menus
    theme_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/themes/astra-child
    
    ### wp-parent-theme ###
    
    name: Astra (astra)
    version: 3.7.6
    author: Brainstorm Force
    author_website: https://wpastra.com/about/?utm_source=theme_preview&utm_medium=author_link&utm_campaign=astra_theme
    theme_path: /kunden/619056_47058/webseiten/WordPress_02/wp-content/themes/astra
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.8, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    
    ### wp-plugins-active (19) ###
    
    Astra Pro: version: 3.6.5, author: Brainstorm Force
    Astra Widgets: version: 1.2.9, author: Brainstorm Force
    Contact Form 7: version: 5.5.3, author: Takayuki Miyoshi
    Cookie Notice & Compliance for GDPR / CCPA: version: 2.2.1, author: Hu-manity.co
    Custom Fonts: version: 1.3.3, author: Brainstorm Force
    Disable Emojis (GDPR friendly): version: 1.7.3, author: Ryan Hellyer
    Easy Social Icons: version: 3.1.3, author: cybernetikz
    Easy WP SMTP: version: 1.4.7, author: wpecommerce, alexanderfoxc
    Elementor: version: 3.5.3, author: Elementor.com
    Elementor Pro: version: 3.5.2, author: Elementor.com
    Health Check & Troubleshooting: version: 1.4.5, author: The WordPress.org community
    Honeypot for Contact Form 7: version: 2.1, author: Nocean
    Login Designer: version: 1.2.5, author: wpexpertsio
    Starter Templates: version: 3.0.22, author: Brainstorm Force
    Tawk.to Live Chat: version: 0.6.0, author: Tawkto
    UpdraftPlus - Backup/Restore: version: 1.16.69, author: UpdraftPlus.Com, DavidAnderson
    WP Fastest Cache: version: 0.9.7, author: Emre Vona
    Yoast Duplicate Post: version: 4.3, author: Enrico Battocchi & Team Yoast
    Yoast SEO: version: 17.8, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-28 Q16 x86_64 2021-10-29 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 59 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 59 GB
    	imagick::RESOURCETYPE_MEMORY: 29 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.45.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 8.0.12 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1500
    time_limit: 60
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 50M
    php_post_max_size: 75M
    curl_version: 7.61.1 OpenSSL/1.1.1g
    suhosin: false
    imagick_availability: true
    server-headers: 
    	server: nginx
    	date: Tue, 04 Jan 2022 17:09:25 GMT
    	content-type: text/html; charset=UTF-8
    	content-length: 28566
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://samy-design.de/wp-json/>; rel="https://api.w.org/", <https://samy-design.de/wp-json/wp/v2/pages/607>; rel="alternate"; type="application/json", <https://samy-design.de/>; rel=shortlink
    	vary: Accept-Encoding
    	content-encoding: gzip
    	x-cache-status: MISS
    	accept-ranges: bytes
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.22-MariaDB
    client_version: mysqlnd 8.0.12
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/619056_47058/webseiten/WordPress_02/wp-content
    WP_PLUGIN_DIR: /kunden/619056_47058/webseiten/WordPress_02/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Könnt Ihr mir bitte helfen?
    LG,
    Samy

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 27)
  • Evtl. auf eine PHP Version < 8, also auf 7.4.x zurückschalten?

    Wenn das nix hilft:
    Trotz dass du das Backend noch aufrufen kannst, könnte doch auch Pkt. 1 des von dir genannten FAQ Tipp helfen. Also etwa die Plugins deaktivieren.
    Wobei dieses deaktivieren der Plugins wahrscheinlich eh auch beim Pkt. 2 unter dem Abschnitt „Installiere das Plugin Health Check & Troubleshooting und …“ gemacht wurde?

    Nachtrag: Wenn es nur? beim verlassen vom Elementor auftritt – hast den mal deaktiviert? Leider kenne ich mich mit dem Ding nicht aus. Aber tests mal.

    • Diese Antwort wurde geändert vor 2 Wochen, 6 Tage von pezi. Grund: Nachtrag zu Elementor

    Hallo,
    ergänzend zu dem, was @pezi schreibt, wäre es günstig zu erfahren, ob der Fehler auch nach Aktivierung eines Standardthemes wie z. B. Twenty Twenty erscheint, wenn du den Problembehandlungsmodus bei Health Check & Troubleshooting aktiviert hast. Sollte das Problem dann nicht erscheinen, dann liegt es wohl an dem Child Theme von Astra. Wenn das Problem allerdings weiter besteht, dann aktiviere Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und Plugins sehen, während nur für dich alle Plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.

    Wenn das Problem im Zusammenhang mit dem gekauften Theme Astra Pro und/oder dem Plugin Elementor Pro auftritt, dann wende dich bitte an die jeweiligen Entwickler, weil wir dir bei gekauften Themes oder Plugins nicht helfen können. Wir müssten sonst bei jeder Frage erst einmal das entsprechende Theme oder Plugin kaufen, uns dort einarbeiten und dann kostenlos den Support anbieten, für den du beim Kauf eigentlich bezahlt hast.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Hallo,

    zunächst danke für die Antworten.
    Bin leider keinen Schritt weitergekommen. Ich habe alles ausprobiert:

    – PHP Version auf 7.4 >> keine Veränderung
    – Theme gewechselt auf Standard >> keine Veränderung
    – jedes Plugin im Problembehandlungsmodus geprüft.

    Hierbei gab es Auffälligkeiten bei den Plugins
    Disable Emojis (GDPR friendly),
    Tawk.to Live Chat,
    WP Fastest Cache,
    d.h. ich konnte mal auf die Bearbeitungsfunktion der Startseite zugreifen, allerdings unregelmäßig, einmal ja, dann wieder nicht mehr.
    Habe diese Plugins dann im Normalmodus deaktiviert, hat aber auch nichts gebracht.
    Dann habe ich die Plugins im Problembehandlungsmodus nochmal gecheckt, keine Veränderung. Ich weiß also nicht, woran es liegt.

    Ich könnte Euch den WP Zugang senden!?

    Viele Grüße,
    Samy

    Hallo,

    Ich könnte Euch den WP Zugang senden!?

    Das ist hier Forum nicht vorgesehen, siehe hier: Kannst du mich nicht anrufen oder mal schnell bei mir einloggen?
    Schau mal bitte in die error.log beim Hoster, ob da Einträge sind und ob das Problem zu einem bestimmten Zeitpunkt entstanden ist. Prüfe doch dann bitte, was du davor gemacht hast (Plugin, Theme aktualisiert, etc.).
    Evtl. ist es auch sinnvoll, wenn du debug aktivierst. Wie du das machen kannst, habe ich in meinem Beitrag Debug-Modus auf WordPress-Seiten mit und ohne Plugins erklärt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Hallo Hans-Gerhard,

    ich habe parallel meinen Hoster angeschrieben.
    Dort meinen sie, dass es am Arbeitsspeicher liegt. Elementor verlangt immer sehr viel Speicher

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Bevor ich meinen Vertrag ändere, werde ich Deinen Vorschlag in Angriff nehmen und versuchen debug zu aktivieren.

    Dein anderer Rat: „Schau mal bitte in die error.log beim Hoster, ob da Einträge sind …“ – wie mache ich das?

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Hallo Hallo Hans-Gerhard,

    ich habe jetzt debug aktiviert, indem ich die angegebenen 3 Zeilen in die wp-config.php Datei eingesetzt habe. Aber mir ist nicht klar, wo nun Fehlermeldungen auftauchen sollen und was ich nun machen muss?

    VG,
    Samy

    Aus der verlinkten Seite:

    Mit den o. g. Codezeilen kann man den Debug-Modus bei einer WordPress-Webseite aktivieren. Die Fehlermeldungen sollen aber nicht direkt angezeigt werden, sondern in die Datei /wp-content/debug.log geschrieben werden. Daher ist WP_DEBUG_DISPLAY auf false gesetzt.

    Hallo,
    vielleicht reicht auch schon, wenn du WP_MEMORY_LIMIT erhöhst. Ob du mehr Arbeitsspeicher zuweisen kannst, hängt vom Vertrag und Hoster ab:
    Trag doch bitte mal mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++) in der wp-config.php oberhalb von /* That's all, stop editing! Happy blogging. */ folgende Zeile ein:
    define( 'WP_MEMORY_LIMIT', '512M' );
    Sollte die Zeile bereits existieren, dann musst du den Wert entsprechend ändern.
    Vorher aber bitte die Datei lokal sichern.
    Die Fehlermeldungen werden in die Datei /wp-content/debug.log geschrieben.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Ich habe jetzt erst mal nach debug Aktivierung folgende Fehlermeldung in der debug.log Datei:

    [05-Jan-2022 10:46:49 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 135168 bytes) in /kunden/619056_47058/webseiten/WordPress_02/wp-includes/wp-db.php on line 2022
    [05-Jan-2022 11:02:53 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 98304 bytes) in /kunden/619056_47058/webseiten/WordPress_02/wp-includes/wp-db.php on line 2022

    Allowed memory size of 268435456 bytes exhausted

    oder

    Erlaubte Speichergröße von 268435456 Bytes ausgeschöpft

    Isr eigentlich eindeutig, oder? Dein WordPress benötigt zu viel Arbeitsspeicher. Da hast du zwei Möglichkeiten: entweder bei dem Hoster mehr Speicher beantragen oder checken, welches Plugin da so ein Speicherfresser ist und es deaktivieren.

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Ja, so ist es leider!

    Trotzdem herzlichen Dank für Eure Tips und Unterstützung!
    Schön, dass es das Forum gibt – Ihr seid immer wieder eine große Hilfe!

    VG,
    Samy

    Hallo,
    hast du denn mal geprüft, ob du das Speicherlimit (Stichwort WP_MEMORY_LIMIT) hochsetzen bzw. ob du mehr Speicher beim Hoster buchen kannst?

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller wuestenblumesamy

    (@wuestenblumesamy)

    Ja, das ist möglich mit einem Vertragsupgrade, was dann natürlich auch direkt teurer ist.
    Laut Hoster hängt das nicht mit dem verfügbaren Speicherplatz zusammen, sondern mit dem Arbeitsspeicher, der die Ausführung von Scripten ermöglicht. Mehr Arbeitsspeicher erhalte ich nur mit einem höheren Tarif.

    VG,
    Samy

    Hallo,

    Laut Hoster hängt das nicht mit dem verfügbaren Speicherplatz zusammen, sondern mit dem Arbeitsspeicher, der die Ausführung von Scripten ermöglicht.

    Genau das hatte ich oben ja auch geschrieben 😉

    Dann können wir dir hier wohl erst mal nicht mehr weiterhelfen, denn die Ursache hängt ja dann offensichtlich mit dem Vertrag beim Hoster zusammen.
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich so weit behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.
    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 27)