Support » Allgemeine Fragen » Es ist eine Aktualisierung der Datenbank notwendig

  • Hi, ich bekomme in unregelmäßigen Abständen, beim Anmelden im Dashboard die Mitteilung: Es ist eine Aktualisierung der Datenbank notwendig.
    Dies bestätige ich mit OK und erhalte direkt die Nachricht die Datenbank ist Aktuell. Nach ein paar Stunden kommt die Meldung jedoch erneut.

    Wordpress und Plugins sind alle auf dem aktuellen Stand.
    Regelmäßige Backups sowohl der Datenbank als auch der WP Dateien wurde angelegt.
    PHP Version 7.2.34
    Wordpress 5.6 wurde bereits erneut installiert.
    Datenbank wurde aktualisiert.

    Wordpress Version ist 5.6

Ansicht von 1 Antwort (von insgesamt 1)
  • Die PHP-Version wird nicht mehr gepflegt und du solltest zumindest auf PHP7.3 (besser 7.4) umsteigen.

    Der Hinweis, dass die Datenbank aktualisiert werden soll, kommt dann, wenn im Rahmen eines Updates neue Funktionalität die Erweiterung der Datenbank notwendig macht.

    Wieso das bei dir in einer Dauerschleife kommt, kann verschiedene Gründe haben. Ein möglicher Grund ist, dass die Datenbank repariert werden muss. Dazu fügst du per FTP mit einem geeigneten Code-Editor (z.B. VS Code, kostenlos für alle Betriebssysteme erhältlich) oberhalb von /* That's all, stop editing! Happy blogging. */ die folgende Zeile ein:

    define ('WP_ALLOW_REPAIR', 'true');

    Danach rufst du im Browser http://example.com/wp-admin/maint/repair.php (mit deiner Domain) auf und klickst auf Repair and Optimize Data.
    (Es ist sinnvoll, vorher über die Datenbankverwaltung im Kundenmenü deines Webhosters – meistens phpMyAdmin – eine Sicherung der Datenbank vorzunehmen.)

    Hilft das nicht, könnte eine Ursache sein, dass der vorgegebene Speicherplatz erschöpft ist oder die Berechtigungen nicht stimmen.

Ansicht von 1 Antwort (von insgesamt 1)
  • Das Thema „Es ist eine Aktualisierung der Datenbank notwendig“ ist für neue Antworten geschlossen.